You are not logged in.

#1 2005-08-09 00:39:45

arjun
Member
Registered: 2005-07-09
Posts: 28

qt 4.0 will not configure properly

Hello:

I'm trying to install open source Qt 4.0 but when i type in "./configure" i get this error at the end and no make file is made:

make: *** [qfsfileengine_unix.o]] Error 1

I'm using the current Arch gcc.

Offline

#2 2005-08-09 00:56:24

T-Dawg
Forum Fellow
From: Wilmington, NC
Registered: 2005-01-29
Posts: 2,734

Re: qt 4.0 will not configure properly

*I think* that requires gcc 4.0. Try installing it (gcc 4.0) from testing repo and give it another shot.

Offline

#3 2005-08-09 13:04:57

IceRAM
Member
From: Bucharest, Romania
Registered: 2004-03-04
Posts: 772
Website

Re: qt 4.0 will not configure properly

Nope, it doesn't.
I've successfully built Qt4 with GCC 3.4.3-2.

I haven't installed it yet.. that's a totally different conversation (not because it doesn't work, but because I didn't have time to play with it).

Offline

#4 2005-08-09 16:14:48

elahav
Member
From: Ottawa, ON
Registered: 2005-04-18
Posts: 90

Re: qt 4.0 will not configure properly

Can you specify the exact command line you have used? Just ./configure doesn't do the job. I had to specify the architecture with -platform to make it work.

Offline

#5 2005-08-09 17:10:42

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: qt 4.0 will not configure properly

Offline

#6 2005-08-09 19:28:20

arjun
Member
Registered: 2005-07-09
Posts: 28

Re: qt 4.0 will not configure properly

Thanks everyone.  My only configure line wa "./configure" I'll try out the package in the AUR.

Offline

#7 2005-08-10 12:42:13

IceRAM
Member
From: Bucharest, Romania
Registered: 2004-03-04
Posts: 772
Website

Re: qt 4.0 will not configure properly

Err.. indeed. I assumed you were using Qt in AUR, as I have.

Offline

Board footer

Powered by FluxBB