You are not logged in.

#1251 2012-03-01 18:38:50

frankieboy
Member
Registered: 2009-04-12
Posts: 53

Re: systemd: Yet Another Init Replacement

Blµb wrote:
frankieboy wrote:

(...)

http://pastebin.com/NccT8NGw

Thank you for your help

Frankieboy

I just hate how systemd-journalctl cuts off lines even when piping to a file, could you use `systemd-journalctl -a` please?

Here it is:

http://pastebin.com/NSr5ShFu

Thank you.

Frankieboy

Offline

#1252 2012-03-01 19:57:15

Blµb
Member
Registered: 2008-02-10
Posts: 223

Re: systemd: Yet Another Init Replacement

I don't see any errors there hmm
I have only just started using systemd, and already figured out that debugging the bootprocess with systemd can be really annoying.
I can't even see which target/service it is that is actually hanging for so long.
You could try disabling "everything" that's not actually required to boot (network, cron, syslog...), and reboot to make sure it's not related to anything else.
And have you made the .mount files for *all* partitions of the imsm raid you have configured in /etc/fstab?

I can't do much more than guess there, sorry hmm

Maybe someone else can help?

Last edited by Blµb (2012-03-01 19:57:38)


You know you're paranoid when you start thinking random letters while typing a password.
A good post about vim
Python has no multithreading.

Offline

#1253 2012-03-02 06:45:06

frankieboy
Member
Registered: 2009-04-12
Posts: 53

Re: systemd: Yet Another Init Replacement

Blµb wrote:

I don't see any errors there hmm
I have only just started using systemd, and already figured out that debugging the bootprocess with systemd can be really annoying.
I can't even see which target/service it is that is actually hanging for so long.
You could try disabling "everything" that's not actually required to boot (network, cron, syslog...), and reboot to make sure it's not related to anything else.
And have you made the .mount files for *all* partitions of the imsm raid you have configured in /etc/fstab?

I can't do much more than guess there, sorry hmm

Maybe someone else can help?

ssd dmraid has /boot, /, /home and swap, I created /boot and /home, it's interesting that  swap partition is not enabled, how can I write a service file to enable swap during boot? I have also a laptop with lvm, I'm using arch and systemd on it, and everything is working during boot (swap is enabled).

Thanx

Frankieboy

Offline

#1254 2012-03-02 09:20:06

Blµb
Member
Registered: 2008-02-10
Posts: 223

Re: systemd: Yet Another Init Replacement

man 5 systemd.swap big_smile

You can make a service file named something.swap and in the [Swap] section add What=/dev/...
Much like a .mount but without all the additional options like DirectoryMode or Where.


You know you're paranoid when you start thinking random letters while typing a password.
A good post about vim
Python has no multithreading.

Offline

#1255 2012-03-06 21:42:56

litemotiv
Forum Fellow
Registered: 2008-08-01
Posts: 5,026

Re: systemd: Yet Another Init Replacement

I did a reinstall of systemd on another machine and was a little confused by:

# systemctl enable acpid.service
Warning: unit files do not carry install information.

It's mentioned earlier in this thread, but not on the wiki page. Should it be reported as a 'bug' in systemd-arch-units, or would it be better to inform users about this scenario in the wiki (or both)?


ᶘ ᵒᴥᵒᶅ

Offline

#1256 2012-03-06 22:07:46

falconindy
Developer
From: New York, USA
Registered: 2009-10-22
Posts: 4,092
Website

Re: systemd: Yet Another Init Replacement

litemotiv wrote:

I did a reinstall of systemd on another machine and was a little confused by:

# systemctl enable acpid.service
Warning: unit files do not carry install information.

It's mentioned earlier in this thread, but not on the wiki page. Should it be reported as a 'bug' in systemd-arch-units, or would it be better to inform users about this scenario in the wiki (or both)?

Working as intended. Enable the socket, not the service.

Offline

#1257 2012-03-07 17:39:19

litemotiv
Forum Fellow
Registered: 2008-08-01
Posts: 5,026

Re: systemd: Yet Another Init Replacement

falconindy wrote:
litemotiv wrote:

I did a reinstall of systemd on another machine and was a little confused by:

# systemctl enable acpid.service
Warning: unit files do not carry install information.

It's mentioned earlier in this thread, but not on the wiki page. Should it be reported as a 'bug' in systemd-arch-units, or would it be better to inform users about this scenario in the wiki (or both)?

Working as intended. Enable the socket, not the service.

Is acpid an exception to the rule in this regard? Since other services which use sockets do seem to have an [Install] section?


ᶘ ᵒᴥᵒᶅ

Offline

#1258 2012-03-07 17:49:20

falconindy
Developer
From: New York, USA
Registered: 2009-10-22
Posts: 4,092
Website

Re: systemd: Yet Another Init Replacement

No, but for now it's somewhat irregular. acpid implements proper socket activation, so any requests to /run/acpid.socket will cause the daemon to start up. Notice that there's no Accept=yes, meaning that only the first request will cause a handoff from systemd to acpid (meaning only a single session is spawned, unlike sshd.socket).

Ideally, things like cups, rpcbind, mysql, etc (realistically, anything that listens on a socket) could follow this in the future.

Offline

#1259 2012-03-07 17:49:59

tomegun
Developer
From: France
Registered: 2010-05-28
Posts: 661

Re: systemd: Yet Another Init Replacement

litemotiv wrote:

Is acpid an exception to the rule in this regard? Since other services which use sockets do seem to have an [Install] section?

The purpose of the [Install] in socket activated services, is to be able to enable stuff unconditionally rather than having it start on demand. This might make sense for services that are slow to start, and that you know will be eventually accessed and started on demand.

Whether or not this makes sense for acpid, I don't know. If you have a reason to do it, I see nothing wrong with it. On the other hand it is not something that all services SHOULD implement.

Offline

#1260 2012-03-09 11:28:03

eworm
Trusted User (TU)
From: Oberhausen, Germany
Registered: 2010-01-30
Posts: 95
Website

Re: systemd: Yet Another Init Replacement

lucke wrote:
Wey wrote:

Anyone else having locale issues with systemd-43-3? Since the upgrade, my locale is not set and defaults to english. Downgrading to systemd-43-2 makes it work again. Any hints on how to debug this problem?

I have just noticed a problem with locale, but I don't know if it's systemd's fault. I got rid of initscripts, I have "LANG=en_US.UTF-8" in /etc/locale.conf, after boot I have proper locale in vc, but in KDE I get POSIX, and exporting proper locale doesn't really let me use UTF-8 characters in the konsole (they used to work). Downgrading systemd to 43-2 doesn't change anything.

Any news on this? I have the same problem with my Xfce session. Terminal does not accept any utf8 characters, even typing a German Umlaut (ä, ö, ü, ß & Co) just shows a question mark. Pane borders drawn by tmux are ugly and sometimes break the terminal when a single character is printed as two.
Would be great to have this sorted out...


ArchLinux - make it simple & lightweight

Offline

#1261 2012-03-09 12:37:55

crabman
Member
Registered: 2010-08-12
Posts: 30

Re: systemd: Yet Another Init Replacement

@ eworm:
look at post #1224, page 49

this is probably material for the wiki though...

EDIT: ive added this info to the wiki under "Running DEs under systemd". Not sure about formatting and language. Could somebody please revise that section?

crabman

Last edited by crabman (2012-03-09 13:02:31)

Offline

#1262 2012-03-09 14:24:57

lucke
Member
From: Poland
Registered: 2004-11-30
Posts: 4,018

Re: systemd: Yet Another Init Replacement

Even with locale exported manually/through /etc/profile and then set through pam_env, I still had broken characters in KDE, while in GNOME, on a different PC, I didn't have such problems and didn't have to put anything in /etc/environment or export the locale. My KDE problems fixed themselves at some point, though - I have no idea how.

Last edited by lucke (2012-03-09 14:31:00)

Offline

#1263 2012-03-09 15:11:03

Zom
Member
From: Sweden
Registered: 2007-10-27
Posts: 406

Re: systemd: Yet Another Init Replacement

lucke wrote:

Even with locale exported manually/through /etc/profile and then set through pam_env, I still had broken characters in KDE, while in GNOME, on a different PC, I didn't have such problems and didn't have to put anything in /etc/environment or export the locale. My KDE problems fixed themselves at some point, though - I have no idea how.

I simply downloaded the PKGBUILD for initscripts and removed the dependency for sysvinit. That fixed it for me.

Offline

#1264 2012-03-09 15:17:28

eworm
Trusted User (TU)
From: Oberhausen, Germany
Registered: 2010-01-30
Posts: 95
Website

Re: systemd: Yet Another Init Replacement

As /etc/environment only allows simple "KEY=VAL" pairs and I did not want to have redundant config in /etc/{environment,locale.conf} I decided to add this to my pam configuration:

auth            required        pam_env.so              envfile=/etc/locale.conf

Not the "sane way", but it works.


ArchLinux - make it simple & lightweight

Offline

#1265 2012-03-12 13:43:23

Weegee
Member
Registered: 2010-08-06
Posts: 62

Re: systemd: Yet Another Init Replacement

Today I switched to systemd (instant boot, hurray!), however it seems like my /etc/crypttab keeps getting ignored by it. I've already searched a solution within this thread, and it seems like some people managed to solve the crypttab-problem (by using keyfiles), however I have no idea how to accomplish this neutral

Do I just have to add a keyfile for the encrypted partition and then replace the password in the crypttab with the path to the keyfile? Or is there more voodoo needed to solve this? Eventually my system should just boot without me having to enter the password every time ...


~

Offline

#1266 2012-03-12 14:07:39

tomegun
Developer
From: France
Registered: 2010-05-28
Posts: 661

Re: systemd: Yet Another Init Replacement

Weegee wrote:

Today I switched to systemd (instant boot, hurray!), however it seems like my /etc/crypttab keeps getting ignored by it. I've already searched a solution within this thread, and it seems like some people managed to solve the crypttab-problem (by using keyfiles), however I have no idea how to accomplish this neutral

Do I just have to add a keyfile for the encrypted partition and then replace the password in the crypttab with the path to the keyfile? Or is there more voodoo needed to solve this? Eventually my system should just boot without me having to enter the password every time ...

Sadly, the /etc/crypttab formats in systemd and initscripts are not compatible.

Also, systemd does not ship with a manpage for crypttab, so that makes things more difficult. Luckily, systemd's format is shared (mostly) with most other distros. This is a rough overview:

name: as expected
device: as expceted
password: '-' or 'none' to ask for password on boot, otherwise absolute path to a file containing the password (could be a device node such as /dev/urandom).
options: noauto, cipher=,size=,hash=,tries=,readonly,verify,luks,plain,swap,tmp,timeout,none

For more details see e.g. http://manpages.ubuntu.com/manpages/jau … tab.5.html. However, note that systemd does not support all the options that ubuntu does, only the ones I listed above.

Someone should put this in our wiki, or better yet a systemd manpage ;-)

Offline

#1267 2012-03-12 14:39:24

Weegee
Member
Registered: 2010-08-06
Posts: 62

Re: systemd: Yet Another Init Replacement

tomegun wrote:

password: '-' or 'none' to ask for password on boot, otherwise absolute path to a file containing the password (could be a device node such as /dev/urandom).

Hm, systemd refuses to boot if I just put my password in a file and then put the file path in the crypttab hmm So, what's wrong here?

tomegun wrote:

Someone should put this in our wiki, or better yet a systemd manpage ;-)

Indeed.


~

Offline

#1268 2012-03-12 15:12:23

tomegun
Developer
From: France
Registered: 2010-05-28
Posts: 661

Re: systemd: Yet Another Init Replacement

Weegee wrote:

Hm, systemd refuses to boot if I just put my password in a file and then put the file path in the crypttab hmm So, what's wrong here?

Dunno. Something... I would need more info.

My first guess would be to add or remove a trailing newline from the file you saved your password in. If you wait for the timeout (2 min?) and are able to somehow boot anyway (depending on which partition failed, this should be possible), then have a look at "systemd-journalctl" to see if you get any error messages from cryptsetup. If not, up the error logging (in /etc/systemd/system.conf) and try again.

Offline

#1269 2012-03-12 15:40:41

Weegee
Member
Registered: 2010-08-06
Posts: 62

Re: systemd: Yet Another Init Replacement

Problem: There is no timeout, systemd just asks me for the root password (for maintenance tasks). And even if I enter emergency mode, systemd-journalctl doesn't show me any errors ...


~

Offline

#1270 2012-03-13 22:30:33

ron9
Member
From: Norway
Registered: 2011-02-02
Posts: 103

Re: systemd: Yet Another Init Replacement

After todays system upgrade I get the following errors.

systemd-tmpfiles-clean.service         loaded failed failed        Cleanup of Temporary Directories
systemd-tmpfiles-setup.service         loaded failed failed        Recreate Volatile Files and Directories

Journal show this:

[ronny@me ~]$ sudo systemd-journalctl -a | grep tmpfiles
Mar 13 21:59:38 me systemd-tmpfile[118]: [/usr/lib/tmpfiles.d/clamav.conf:1] Unknown user '64'.
Mar 13 21:59:39 me systemd[1]: systemd-tmpfiles-setup.service: main process exited, code=exited, status=1
Mar 13 21:59:39 me systemd[1]: Unit systemd-tmpfiles-setup.service entered failed state.
Mar 13 22:14:30 me systemd-tmpfile[439]: [/usr/lib/tmpfiles.d/clamav.conf:1] Unknown user '64'.
Mar 13 22:14:31 me systemd[1]: systemd-tmpfiles-clean.service: main process exited, code=exited, status=1
Mar 13 22:14:31 me systemd[1]: Unit systemd-tmpfiles-clean.service entered failed state.

archlinux x86_64 | openbox | urxvt | zsh | xfe | qupzilla

Offline

#1271 2012-03-14 06:01:44

Avant-texte
Member
Registered: 2012-02-13
Posts: 136

Re: systemd: Yet Another Init Replacement

I need help.

How do I switch agetty with qingy? Obviously, custom unit(s) need to be made, but what else needs to be done. The most common instuctions focus on graphical and (text) multiuser targets. Looking at the more complex setup of the getty files, I assume I can't just throw in a qingy service file and enable it like gdm, kdm, or slim in graphical.

I could have swarn I saw some mention of switching the loging for text mode in the past... This is what I get for not bookmarking. :'(

Offline

#1272 2012-03-14 12:20:16

tomegun
Developer
From: France
Registered: 2010-05-28
Posts: 661

Re: systemd: Yet Another Init Replacement

Avant-texte wrote:

How do I switch agetty with qingy? Obviously, custom unit(s) need to be made, but what else needs to be done.

Copy getty@.service to /etc/systemd/system and adjust ExecStart.

Offline

#1273 2012-03-14 13:30:11

falconindy
Developer
From: New York, USA
Registered: 2009-10-22
Posts: 4,092
Website

Re: systemd: Yet Another Init Replacement

tomegun wrote:
Avant-texte wrote:

How do I switch agetty with qingy? Obviously, custom unit(s) need to be made, but what else needs to be done.

Copy getty@.service to /etc/systemd/system and adjust ExecStart.

...and disable/enable getty@tty1.service to force it to relink to the new qingy unit.

Offline

#1274 2012-03-14 13:30:54

falconindy
Developer
From: New York, USA
Registered: 2009-10-22
Posts: 4,092
Website

Re: systemd: Yet Another Init Replacement

ron9 wrote:

After todays system upgrade I get the following errors.

systemd-tmpfiles-clean.service         loaded failed failed        Cleanup of Temporary Directories
systemd-tmpfiles-setup.service         loaded failed failed        Recreate Volatile Files and Directories

Journal show this:

[ronny@me ~]$ sudo systemd-journalctl -a | grep tmpfiles
Mar 13 21:59:38 me systemd-tmpfile[118]: [/usr/lib/tmpfiles.d/clamav.conf:1] Unknown user '64'.
Mar 13 21:59:39 me systemd[1]: systemd-tmpfiles-setup.service: main process exited, code=exited, status=1
Mar 13 21:59:39 me systemd[1]: Unit systemd-tmpfiles-setup.service entered failed state.
Mar 13 22:14:30 me systemd-tmpfile[439]: [/usr/lib/tmpfiles.d/clamav.conf:1] Unknown user '64'.
Mar 13 22:14:31 me systemd[1]: systemd-tmpfiles-clean.service: main process exited, code=exited, status=1
Mar 13 22:14:31 me systemd[1]: Unit systemd-tmpfiles-clean.service entered failed state.

You can ignore these errors. I'll fix this in the next day or two.

Offline

#1275 2012-03-14 21:28:52

ron9
Member
From: Norway
Registered: 2011-02-02
Posts: 103

Re: systemd: Yet Another Init Replacement

falconindy wrote:

You can ignore these errors. I'll fix this in the next day or two.

Thank you! Keep up the good work q:-)


archlinux x86_64 | openbox | urxvt | zsh | xfe | qupzilla

Offline

Board footer

Powered by FluxBB