You are not logged in.

#1 2011-12-21 20:56:05

Carlinhos
Member
Registered: 2011-07-08
Posts: 41

[Solved] Skype doesn't follow my GTK theme

Hi,
I'm trying to get Skype to follow my GTK theme with no luck. I have set my theme in .gtkrc-2.0 and added export GTK2_RC_FILES="$HOME/.gtkrc-2.0" to my .xinitrc but Skype refuses to follow my theme even though other Qt applications do without problem.
Launching Skype with commands

$ export GTK2_RC_FILES="/etc/gtk-2.0/gtkrc:$HOME/.gtkrc-2.0"
$ skype

in the same terminal does the trick but this isn't a very convenient solution. The Skype wiki suggests starting Skype with a script containing those two commands but is there a way to make my Skype entry in the Xfce menu start that script?
Has anybody had the same issue?

Last edited by Carlinhos (2012-03-29 23:42:09)

Offline

#2 2011-12-21 21:22:47

Starfall
Member
From: /home/
Registered: 2011-05-24
Posts: 209
Website

Re: [Solved] Skype doesn't follow my GTK theme

Just a guess here; but you can change the 'Exec' line in Skype's desktop file? smile

Edit the skype.desktop file in /usr/share/applications (make sure to back it up just in case)

It's pretty straight forward, just put in the command you want to execute it with. Let me know how you get on or if you need me to clarify any points big_smile

Last edited by Starfall (2011-12-21 21:23:39)


Visit my blog and my DeviatArt page

Offline

#3 2011-12-21 21:25:40

Carlinhos
Member
Registered: 2011-07-08
Posts: 41

Re: [Solved] Skype doesn't follow my GTK theme

Starfall wrote:

Just a guess here; but you can change the 'Exec' line in Skype's desktop file? smile

Edit the skype.desktop file in /usr/share/applications (make sure to back it up just in case)

It's pretty straight forward, just put in the command you want to execute it with. Let me know how you get on or if you need me to clarify any points big_smile

I thought about it but in this case I would need it to execute with those two different commands I mentioned, is this possible through editing the desktop file? If yes, how exactly?

Offline

#4 2011-12-21 21:28:59

Starfall
Member
From: /home/
Registered: 2011-05-24
Posts: 209
Website

Re: [Solved] Skype doesn't follow my GTK theme

Ermmmm, okay, so what two commands are these? You could set the 'Exec' line to launch a script? Or possibly use '&&' ?

Example:

*first command* && *second command*

Last edited by Starfall (2011-12-21 21:29:19)


Visit my blog and my DeviatArt page

Offline

#5 2011-12-21 21:29:02

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: [Solved] Skype doesn't follow my GTK theme

are you on x86_64 and you are missing lib32-gtk2?


Give what you have. To someone, it may be better than you dare to think.
Blog

Offline

#6 2011-12-21 21:35:00

Carlinhos
Member
Registered: 2011-07-08
Posts: 41

Re: [Solved] Skype doesn't follow my GTK theme

Starfall wrote:

Ermmmm, okay, so what two commands are these? You could set the 'Exec' line to launch a script? Or possibly use '&&' ?

Example:

*first command* && *second command*

First I need to run export GTK2_RC_FILES="/etc/gtk-2.0/gtkrc:$HOME/.gtkrc-2.0" and then skype. I tried using && between those two in the desktop file but it would give me an error.

wonder wrote:

are you on x86_64 and you are missing lib32-gtk2?

I am on x86_64 and I do have lib32-gtk2. Other Qt applications work just fine, only Skype refuses to follow my theme.

Offline

#7 2011-12-21 21:50:19

Starfall
Member
From: /home/
Registered: 2011-05-24
Posts: 209
Website

Re: [Solved] Skype doesn't follow my GTK theme

Carlinhos wrote:

First I need to run export GTK2_RC_FILES="/etc/gtk-2.0/gtkrc:$HOME/.gtkrc-2.0" and then skype. I tried using && between those two in the desktop file but it would give me an error.

Ah, okay, how about a script?


Visit my blog and my DeviatArt page

Offline

#8 2011-12-21 21:54:26

Carlinhos
Member
Registered: 2011-07-08
Posts: 41

Re: [Solved] Skype doesn't follow my GTK theme

Starfall wrote:
Carlinhos wrote:

First I need to run export GTK2_RC_FILES="/etc/gtk-2.0/gtkrc:$HOME/.gtkrc-2.0" and then skype. I tried using && between those two in the desktop file but it would give me an error.

Ah, okay, how about a script?

A script worked! I'm so glad Skype doesn't look horrendous anymore. Thanks a lot!

Offline

#9 2011-12-21 21:54:27

Gusar
Member
Registered: 2009-08-25
Posts: 3,466

Re: [Solved] Skype doesn't follow my GTK theme

Export the variable in ~/.bashrc, that way you don't need to care about individual apps, it'll always be available.

Offline

#10 2011-12-21 21:55:21

Starfall
Member
From: /home/
Registered: 2011-05-24
Posts: 209
Website

Re: [Solved] Skype doesn't follow my GTK theme

Excellent! Glad it fixed it smile Don't forget to mark the thread as solved ;D


Visit my blog and my DeviatArt page

Offline

#11 2011-12-21 21:57:28

Carlinhos
Member
Registered: 2011-07-08
Posts: 41

Re: [Solved] Skype doesn't follow my GTK theme

Gusar wrote:

Export the variable in ~/.bashrc, that way you don't need to care about individual apps, it'll always be available.

I tried this but Skype would keep being stubborn.

Last edited by Carlinhos (2011-12-21 21:58:01)

Offline

#12 2011-12-22 01:02:13

franck
Member
Registered: 2011-12-20
Posts: 3

Re: [Solved] Skype doesn't follow my GTK theme

A little precision: .bashrc is only executed by interactive shells like terminal for XFCE or gnome-terminal for GNOME.
The variable exported in .bashrc will be visible only in these interactive shells.

When you launch an application by clicking it in the Applications Menu, the .desktop is executed by xdg-open outside an interactive shell, so the exported variable is not visible wink

Offline

#13 2012-02-09 08:05:42

robegrassi
Member
Registered: 2011-11-19
Posts: 13

Re: [Solved] Skype doesn't follow my GTK theme

It does not work anymore for me after latest updates. I am on x86_64 and I am using the Adwaita theme. I have both lib32-gtk2 and lib32-gtk-engines. Acroread is correctly themed instead. Any idea?

Offline

#14 2012-02-09 10:51:49

X-Stranger
Member
Registered: 2007-01-30
Posts: 2

Re: [Solved] Skype doesn't follow my GTK theme

robegrassi wrote:

It does not work anymore for me after latest updates. I am on x86_64 and I am using the Adwaita theme. I have both lib32-gtk2 and lib32-gtk-engines. Acroread is correctly themed instead. Any idea?

The same to me sad Tried to install lib32-gconf - did not help. Thoughts?

Offline

#15 2012-02-09 10:55:52

kolombo
Member
From: Ukraine
Registered: 2011-12-14
Posts: 31

Re: [Solved] Skype doesn't follow my GTK theme

The same problem sad after recent update

Offline

#16 2012-02-10 02:49:50

Carlinhos
Member
Registered: 2011-07-08
Posts: 41

Re: [Solved] Skype doesn't follow my GTK theme

Not working for me any more either. I can no longer choose GTK as the style in Skype options. Guess I can remove the [Solved] from the title for now.

Last edited by Carlinhos (2012-02-10 02:52:04)

Offline

#17 2012-02-12 14:59:41

emmanuelux
Member
Registered: 2012-02-12
Posts: 7

Re: [Solved] Skype doesn't follow my GTK theme

i confirm no gtk+ theme in skype anymore on arch64 (may be i delete a 32 bits package in aur) but not in multilib

Offline

#18 2012-03-16 10:27:49

ekzotech
Member
Registered: 2011-05-17
Posts: 3

Re: [Solved] Skype doesn't follow my GTK theme

emmanuelux wrote:

i confirm no gtk+ theme in skype anymore on arch64 (may be i delete a 32 bits package in aur) but not in multilib

What does it mean?

I installed skype a few days ago, but there is no GTK+ style anymore. I'm running arch64 with multilib. Is there a way to launch skype with GTK+ theme now?

Offline

#19 2012-03-16 18:58:14

tydell
Member
From: actually: Hannover, DE
Registered: 2009-07-26
Posts: 102
Website

Re: [Solved] Skype doesn't follow my GTK theme

Run qtconfig and choose GTK+ as theme for qt applications, then skype will follow your gtk theme with no problem

Offline

#20 2012-03-16 20:00:09

brebs
Member
Registered: 2007-04-03
Posts: 3,439

Re: [Solved] Skype doesn't follow my GTK theme

This seems to kick qtconfig and skype into using the font I want, at least:

In ~/.gtkrc-2.0

style "font"
{
    font_name = "Liberation Sans 9"
}
widget_class "*" style "font"
gtk-font-name = "Liberation Sans 9"

From old Ubuntu thread.

Offline

#21 2012-03-18 02:50:48

Carlinhos
Member
Registered: 2011-07-08
Posts: 41

Re: [Solved] Skype doesn't follow my GTK theme

tydell wrote:

Run qtconfig and choose GTK+ as theme for qt applications, then skype will follow your gtk theme with no problem

Does this actually work for you? We wouldn't still be trying to figure it out if it was that simple.

Offline

#22 2012-03-18 09:25:45

tydell
Member
From: actually: Hannover, DE
Registered: 2009-07-26
Posts: 102
Website

Re: [Solved] Skype doesn't follow my GTK theme

Yes, it works for me.

Offline

#23 2012-03-18 09:26:26

gnomeye
Member
From: Switzerland
Registered: 2010-08-04
Posts: 178

Re: [Solved] Skype doesn't follow my GTK theme

Carlinhos wrote:
tydell wrote:

Run qtconfig and choose GTK+ as theme for qt applications, then skype will follow your gtk theme with no problem

Does this actually work for you? We wouldn't still be trying to figure it out if it was that simple.

I can confirm this worked for me. Without any of those lib32 pkgs.

The strange thing was, qtconfig was already set to GTK2. Once I resaved it, it worked.

14cs7pg_th.png

Offline

#24 2012-03-18 12:49:49

vjjustin
Member
Registered: 2012-02-22
Posts: 20

Re: [Solved] Skype doesn't follow my GTK theme

How to install qtconfig (gnome 3)? Does it come with lot of dependencies?

Can someone please update the wiki page (https://wiki.archlinux.org/index.php/Un … plications)?

Last edited by vjjustin (2012-03-18 12:50:56)

Offline

#25 2012-03-19 05:25:20

Carlinhos
Member
Registered: 2011-07-08
Posts: 41

Re: [Solved] Skype doesn't follow my GTK theme

gnomeye wrote:
Carlinhos wrote:
tydell wrote:

Run qtconfig and choose GTK+ as theme for qt applications, then skype will follow your gtk theme with no problem

Does this actually work for you? We wouldn't still be trying to figure it out if it was that simple.

I can confirm this worked for me. Without any of those lib32 pkgs.

The strange thing was, qtconfig was already set to GTK2. Once I resaved it, it worked.

http://i43.tinypic.com/14cs7pg_th.png

Strange, that does not work for me. Which style is your Skype set to in the settings? Are you starting it normally?

Offline

Board footer

Powered by FluxBB