You are not logged in.

#26 2012-03-19 18:16:38

gnomeye
Member
From: Switzerland
Registered: 2010-08-04
Posts: 178

Re: [Solved] Skype doesn't follow my GTK theme

Hi

I'ts definitely working for me, after I saved the settings in qtconfig. Today after a reboot, I just started skype normally (> command skype) and the Design was there.

In the Skype Settings I set "Desktopsettings".

Oh I also exported GTK2_RC_FILES in my .bash_profile:

.bash_profile:export GTK2_RC_FILES="/etc/gtk-2.0/gtkrc:$HOME/.gtkrc-2.0"

@vjjustin:

eye@tharsis | ~ :
> pacman -Qo qtconfig
/usr/bin/qtconfig ist in qt 4.8.0-6 enthalten
eye@tharsis | ~ :
> pacman -Qi qt
Name           : qt
Version              : 4.8.0-6
URL                  : http://qt-project.org/
Lizenzen             : GPL3  LGPL
Gruppen              : Nichts
Stellt bereit        : Nichts
Hängt ab von         : libtiff  libpng  libmng  sqlite3  ca-certificates  glib2
                       dbus  fontconfig  libgl  libsm  libxrandr  libxv  libxi
                       alsa-lib  xdg-utils  hicolor-icon-theme  desktop-file-utils
Optionale Abhängigkeiten: postgresql-libs: PostgreSQL driver
                          libmysqlclient: MySQL driver
                          unixodbc: ODBC driver
                          libxinerama: Xinerama support
                          libxcursor: Xcursor support
                          libxfixes: Xfixes support
Benötigt von         : lib32-qt  qtwebkit  unetbootin
Konflikt mit         : Nichts
Ersetzt              : Nichts
Installationsgröße   : 92672.00 KiB
Packer               : Andrea Scarpino <andrea@archlinux.org>
Architektur          : x86_64
Erstellt am          : Don 08 Mär 2012 10:29:10 CET
Installiert am       : Die 13 Mär 2012 20:26:26 CET
Installationsgrund   : Installiert als Abhängigkeit für ein anderes Paket
Installations-Skript : Ja
Beschreibung         : A cross-platform application and UI framework

Offline

#27 2012-03-20 00:38:38

emmanuelux
Member
Registered: 2012-02-12
Posts: 7

Re: [Solved] Skype doesn't follow my GTK theme

tydell wrote:

Run qtconfig and choose GTK+ as theme for qt applications, then skype will follow your gtk theme with no problem

nice one, it's working

Offline

#28 2012-03-20 02:22:02

Carlinhos
Member
Registered: 2011-07-08
Posts: 41

Re: [Solved] Skype doesn't follow my GTK theme

It's not working for me. I'm doing export GTK2_RC_FILES="/etc/gtk-2.0/gtkrc:$HOME/.gtkrc-2.0" and have also set my style to Desktop Settings but it does not display my theme correctly. I tried setting a diferent theme in .gtkrc-2.0 but no luck.

It looks like a Windows application. In fact, it looks the same as it does when I chose "Windows" as the style.

Last edited by Carlinhos (2012-03-20 02:25:24)

Offline

#29 2012-03-28 19:05:09

TheImmortalPhoenix
Member
From: 127.0.0.1
Registered: 2011-08-13
Posts: 436

Re: [Solved] Skype doesn't follow my GTK theme

Same problem here, i follow the hint of gnomeeye but nothing works....i remember that in the past i could select "GTK+ Style" in the style options of skype, but now it's disappeared ...

Offline

#30 2012-03-28 19:11:22

brebs
Member
Registered: 2007-04-03
Posts: 3,645

Re: [Solved] Skype doesn't follow my GTK theme

Here's how I fix/force it:

In ~/bin/skype:

#!/bin/bash

export GTK2_RC_FILES="$HOME/.gtkrc-2.0-qt"

exec /usr/bin/skype

And in ~/.gtkrc-2.0-qt

gtk-menu-popup-delay = 0

style "font"
{
    font_name = "Arial 10"
}
widget_class "*" style "font"
gtk-font-name = "Arial 10"

I'm still using qt 4.7.4, so this isn't an issue caused by 4.8

Offline

#31 2012-03-29 18:21:21

robegrassi
Member
Registered: 2011-11-19
Posts: 13

Re: [Solved] Skype doesn't follow my GTK theme

Solved for me by latest update of lib32-qt (4.8.0-2 -> 4.8.1-1).

Offline

#32 2012-03-29 23:41:48

Carlinhos
Member
Registered: 2011-07-08
Posts: 41

Re: [Solved] Skype doesn't follow my GTK theme

Yes, it seems to be working for me as well using the original solution. I'm marking this as solved again.

Offline

#33 2012-08-17 21:24:55

StR@ng3r
Member
Registered: 2011-11-12
Posts: 65

Re: [Solved] Skype doesn't follow my GTK theme

Where can i put

export GTK2_RC_FILES="$HOME/.gtkrc-2.0-qt"

so that it gets exported automatically at startup? .xinitrc does not work since I am using lightdm with i3.

Adding exec export GTK2_RC_FILES="$HOME/.gtkrc-2.0-qt" to my i3conf does not help, nor does exporting it from my bash_profile or bashrc.

If I enter it into a terminal and then run skype from that same terminal, it works. However, that isn't rly a practical solution. Thanks.

Offline

#34 2012-11-15 17:14:56

cirrus
Member
From: Glasgow Scotland
Registered: 2012-08-24
Posts: 199
Website

Re: [Solved] Skype doesn't follow my GTK theme

for me on 64bit  editing the window palate colour in qtconfig worked a treat ,  without any 32 bit libs ,good stuff.


Registered Linux User #544546
   Time you enjoyed wasting was not wasted. --John Lennon.

Offline

Board footer

Powered by FluxBB