You are not logged in.

#1 2012-03-26 08:20:27

thms
Member
Registered: 2010-02-01
Posts: 117

[solved] Hebrew spell checker as dependency for enchant?

Hi, on a fresh installation I noticed that the only dictionary Evolution shows is for Hebrew.

$ pacman -Qs hebrew
local/hspell 1.1-2
    Hebrew spell-checker

I then tried to remove this but pacman says enchant needs it which is needed by a lot of packages:

checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: gedit: requires enchant
:: gtkhtml4: requires enchant
:: kdelibs: requires enchant
:: libwebkit3: requires enchant

I just ask myself why is a dictionary a depemdency for such a package?

Last edited by thms (2012-03-28 07:16:28)

Offline

#2 2012-03-28 02:43:23

MOPSTER
Member
From: Aruba
Registered: 2012-03-26
Posts: 15

Re: [solved] Hebrew spell checker as dependency for enchant?

To fix the problem of the Hebrew dictionary being the only one Evolution sees, you need to install any other dictionary. Typically you would want packages like aspell-[LANGUAGE]

Also regarding why enchant actually depends on hspell: http://projects.archlinux.org/svntogit/ … dcdb8dc519

Offline

#3 2012-03-28 07:16:12

thms
Member
Registered: 2010-02-01
Posts: 117

Re: [solved] Hebrew spell checker as dependency for enchant?

Thanks for the link. I was just wondering that there's a dictionary of a not so often spoken language installed by default. Didn't seem so KISS for me ;b

Offline

#4 2013-07-31 20:07:08

sbmomeni
Member
Registered: 2013-07-26
Posts: 22

Re: [solved] Hebrew spell checker as dependency for enchant?

If you want to remove the 'hspell' package, you can install 'enchant-pure' package from <https://aur.archlinux.org/packages/enchant-pure/> which provides 'enchant'.

Offline

Board footer

Powered by FluxBB