You are not logged in.

#1 2012-04-02 21:09:09

dustykhan
Member
Registered: 2012-01-12
Posts: 21

obmenugen - Invalid output from pipe-menu "obmenugen --pipe"

Hi all I have searched up and down to try and fix this but after running obmenugen i get:

i18n msg (not even a warning): No translations loaded for your current locale.
Information (Core): Setting 'menu.xml' for dinamic menus (auto-updating menus).

A dialogue box pops up after reconfiguring openbox when trying to access the menu that states 'Invalid output from pipe-menu "obmenugen --pipe"'

Any help or a push in the right direction would be realy helpful as it used to work when i last used it about 4months ago!

Thanks in advance!
DK

Last edited by dustykhan (2012-04-03 07:44:02)

Offline

#2 2012-04-04 11:39:04

shefla
Member
From: France
Registered: 2010-03-05
Posts: 19

Re: obmenugen - Invalid output from pipe-menu "obmenugen --pipe"

Hi dustykhan,

Maybe a problem with locale-gen.
What is the content of the /etc/locale.gen file ?

Maybe a "locale-gen" command as root could help.

Regards

Offline

#3 2012-04-04 13:41:33

NeOnsKuLL
Member
From: Havana, Cuba
Registered: 2005-03-29
Posts: 117

Re: obmenugen - Invalid output from pipe-menu "obmenugen --pipe"

I'll reproduce here my comment on AUR's package page:

The message you got are expected, it's just information. The error when running obmenugen --pipe means that the generated menu.xml is not in the format of Openbox Menus, or have some ilegal character for a well-formed XML file.

When you run obmenugen --help, near the end is my contact email. Could you send me your generated menu.xml to see if I can find what's the problem?

You could put it on pastebin instead.

See you


Intel Core 2 Duo E8400 3.0 GHz | 2x1GB 667MHz | 250+750GB Seageate SATAII | Samsung 19" TFT 1440x900
Openbox + obmenugen + PyTyle | bmpanel2 | oblogout | conky | pyBgSetter (with Esetroot as backend)
Projects: obmenugen, pyBgSetter

Offline

#4 2012-04-04 18:28:28

dustykhan
Member
Registered: 2012-01-12
Posts: 21

Re: obmenugen - Invalid output from pipe-menu "obmenugen --pipe"

Hi shefla and NeOnsKuLL thanks for the responses.

The output of my menu.xml is found here  http://pastebin.com/tUYsdfUT  and also below:

<?xml version="1.0" encoding="UTF-8"?>
<openbox_menu xmlns="http://openbox.org/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://openbox.org/ file:///usr/X11R6/share/openbox/menu.xsd">
<menu id="root-menu" label="openbox3" execute="obmenugen --pipe" />
</openbox_menu>

Thanks for your help smile

Offline

#5 2012-04-04 18:33:19

NeOnsKuLL
Member
From: Havana, Cuba
Registered: 2005-03-29
Posts: 117

Re: obmenugen - Invalid output from pipe-menu "obmenugen --pipe"

No problem there, now try:

obmenugen --pipe > output.txt

And paste output.txt content on pastebin or send it to me. There is where the problem is. Should be something wrong in a .desktop file which makes XML invalid. I'll will try to help you to find it.

See you


Intel Core 2 Duo E8400 3.0 GHz | 2x1GB 667MHz | 250+750GB Seageate SATAII | Samsung 19" TFT 1440x900
Openbox + obmenugen + PyTyle | bmpanel2 | oblogout | conky | pyBgSetter (with Esetroot as backend)
Projects: obmenugen, pyBgSetter

Offline

#6 2012-04-04 19:38:31

dustykhan
Member
Registered: 2012-01-12
Posts: 21

Re: obmenugen - Invalid output from pipe-menu "obmenugen --pipe"

it just gives me a blank file in /home/user...?

Thanks again

Offline

#7 2012-06-03 12:26:01

dustykhan
Member
Registered: 2012-01-12
Posts: 21

Re: obmenugen - Invalid output from pipe-menu "obmenugen --pipe"

I know this is an older thread, But I still havent managed to sort this out I was using a menu created by mmaker but I prefer the obmenugen generated menu.
Still same problem as above any help..?

Offline

#8 2012-10-03 17:38:12

Fallback
Member
Registered: 2009-12-26
Posts: 20

Re: obmenugen - Invalid output from pipe-menu "obmenugen --pipe"

I have exactly the same problem.
No output

obmenugen --pipe > menu.xml

I tryed openbox-menu but there is also a problem:

openbox-menu 

** (openbox-menu:8199): WARNING **: Cannot create menu, check if the .menu file is correct

Offline

#9 2012-10-03 19:11:20

Fallback
Member
Registered: 2009-12-26
Posts: 20

Re: obmenugen - Invalid output from pipe-menu "obmenugen --pipe"

I found the problem with obmenugen:
Basically an empty .desktop file from a AUR install was the initiator. (zotero.desktop@)

https://answers.launchpad.net/obmenugen … ion/151269


rm -rf $HOME/.config/obmenugen/ 
rm -rf /home/user/.local/share/applications

and uninstall obmenugen

install gdc-bin and obmenugen from AUR

obmenugen 
Information (Core): Setting 'menu.xml' for dinamic menus (auto-updating menus).
openbox --reconfigure

________________________
For openbox-menu try this:
http://bbs.archbang.org/viewtopic.php?id=2312

Offline

#10 2012-10-11 19:20:59

ackt1c
Member
From: Visalia, California
Registered: 2012-10-10
Posts: 215

Re: obmenugen - Invalid output from pipe-menu "obmenugen --pipe"

From my ~/.config/openbox/menu.xml

<menu label="Applications" id="xdg-apps" execute="openbox-menu /etc/xdg/menus/lxde-applications.menu"/>
packer -S openbox-menu openbox-xdgmenu

This still gives me pipe output warnings once in a while, also would like to fix this.

Last edited by ackt1c (2012-10-11 19:34:59)

Offline

Board footer

Powered by FluxBB