You are not logged in.

#76 2012-04-05 00:47:40

demizer
Member
From: Santa Clara
Registered: 2010-03-03
Posts: 108
Website

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

My solution to this problem is to un-install flash. I don't use it on anything other than youtube and porn, but there are other ways to get that content.

Offline

#77 2012-04-05 19:31:23

Fuzzo
Member
Registered: 2010-11-07
Posts: 27

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

I think I agree with demizer here. The right solution for me is to uninstall anything adobe has ever made and avoid anything they have made like the plague.


.....####...................####........####
....#*#*##...............##*#*#.....#*#*##
.....#~##...................##~#.......#~##
I'm not as fuzzy as these creatures but I'm close

Offline

#78 2012-04-05 21:08:29

Darksoul71
Member
Registered: 2010-04-12
Posts: 319

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

With all respect:
IMO The more smarter approach is to use the available Flash replacements such as:
http://linterna-magica.nongnu.org/
https://addons.mozilla.org/en-US/firefo … oreplacer/
http://www.gnu.org/software/gnash/

Most of those work fine with flash content. At least for the main video sites (e.g. Vimeo, Youtube).

But similar to other propritary software essentially Flash is a bad thing and free open source alternatives are much better.


My archlinux x86_64 host:
AMD E350 (2x1.6GHz) / 8GB DDR3 RAM / GeForce 9500GT (passive) / Arch running from 16GB USB Stick

Offline

#79 2012-04-06 01:29:34

fast_rizwaan
Member
Registered: 2010-04-01
Posts: 65

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

this fixed my blue flash video problem on x64 arch and no crashes on youtube:

To fix blue color

cat /etc/adobe/mms.cfg 
#Hardware video decoding
EnableLinuxHWVideoDecode=1
OverrideGPUValidation=true

And to fix crashes after setting the above add "export VDPAU_NVIDIA_NO_OVERLAY=1" to ~/.xinitrc

cat ~/.xinitrc 
#!/bin/sh
#
# ~/.xinitrc
#
# Executed by startx (run your window manager from here)
export VDPAU_NVIDIA_NO_OVERLAY=1

if [ -d /etc/X11/xinit/xinitrc.d ]; then
  for f in /etc/X11/xinit/xinitrc.d/*; do
    [ -x "$f" ] && . "$f"
  done
  unset f
fi

# exec gnome-session
# exec startkde
# exec startxfce4
# ...or the Window Manager of your choice

I'm having flashplugin 11.2.202.228-1
thanks.

Offline

#80 2012-04-06 09:52:16

Earnestly
Member
Registered: 2011-08-18
Posts: 804

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

Adding OverrideGPUValidation=true has made the flashplugin stable enough to use. There are still random crashes now and then the first few times and typically when you press the big play button in the centre (Youtube's player works pretty flawlessly). Not sure why that is, but there you go.

This stuff might be worth a wiki entry; come to think of it especially since Adobe is not planning to ever fix this.

Offline

#81 2012-04-06 21:07:35

twilight0
Member
From: Greece
Registered: 2011-05-01
Posts: 227
Website

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

Hi everyone, although I did applied the workaround, I told myself, why not give gnash a try? All I have to say is that it works really nice on youtube and off course uncluttered HD content. Farewell Adobe.


Proud Arch Linux user since 2007.

Offline

#82 2012-04-07 00:53:40

cobalt45xy
Member
From: WA - USA
Registered: 2012-04-02
Posts: 9

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

I had the same blue tint problem. I fixed mine by simply editing /etc/adobe/mms.cfg and allowing hardware video decoding. I've never had problems with flash crashing before and I can confirm that I can go full screen and back without crashing. Thanks for the tips on how to fix it, it worked for me.

Offline

#83 2012-04-07 01:12:36

Kaurin
Member
From: Ireland
Registered: 2011-12-11
Posts: 66

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

cobalt45xy: give it a few days and you will see smile

please report if you still don't have crashes

Offline

#84 2012-04-07 01:34:30

kingkong
Member
Registered: 2011-11-21
Posts: 4

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

I can confirm that adding EnableLinuxHWVideoDecode=1 to mss.cfg and exporting VDPAU_NVIDIA_NO_OVERLAY=1 resolved both issues. People aren't blue and a running flash video does not remain visible across desktops. I did not need to add OverrideGPUValidation=true. I have had no stability problems.

Offline

#85 2012-04-07 01:35:17

Kaurin
Member
From: Ireland
Registered: 2011-12-11
Posts: 66

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

Thank you for the update. I will try it without OverrideGPUValidation=true

Offline

#86 2012-04-07 10:48:30

Kaurin
Member
From: Ireland
Registered: 2011-12-11
Posts: 66

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

Sorry for the dobulepost. kingkong: your solution does not work for me. I still get Flash plugin crashes sad

Offline

#87 2012-04-07 12:06:57

cian1500ww
Member
Registered: 2011-09-12
Posts: 5

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

I've been able to resolve it by reinstalling the flashplugin but I doubt that it's going to last.

Offline

#88 2012-04-07 12:57:27

longstaffkj
Member
Registered: 2012-02-15
Posts: 3

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

Kaustic wrote:

linux-ck-corex: 3.2.14-2
nvidia: 295.33-1

# /etc/adobe/mms.cfg 
EnableLinuxHWVideoDecode=1

Flash's hardware acceleration option checked
export VDPAU_NVIDIA_NO_OVERLAY=1 added to my ~/.xinitrc (The only way I know to export Nvidia settings. Doing it via the terminal or profile seems to do nothing.)

Big thanks to Gusar, or should it be distain? For now we get to use the steaming pile of crap that is flashplayer tongue.
Shame HTML5 isn't there yet.

Edit: It's still not as stable, but that's asking too much from the poor folks over at Adobe.







Did the trick for me. Simple solution. Thanks.

Offline

#89 2012-04-07 18:13:25

fatino
Member
Registered: 2012-04-07
Posts: 9

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

I tried everything from this thread. Nothing works. If it does it randomly crashes (too often to be bearable).

Last edited by fatino (2012-04-07 18:20:41)

Offline

#90 2012-04-07 21:56:26

Earnestly
Member
Registered: 2011-08-18
Posts: 804

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

fatino wrote:

I tried everything from this thread. Nothing works. If it does it randomly crashes (too often to be bearable).

That's the impetus for calling it unstable. The best solution seems to be downgrading to 11.1 and hoping Linux never implements ActiveX.

Last edited by Earnestly (2012-04-07 22:13:13)

Offline

#91 2012-04-07 22:01:50

Gusar
Member
Registered: 2009-08-25
Posts: 3,446

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

Kaustic wrote:

The best solution seems to be downgrading to 11.1

11.1 has security vulnerabilities. 11.2 doesn't and 10.3.183.18 doesn't either.

security bulletin

Offline

#92 2012-04-07 22:23:12

Earnestly
Member
Registered: 2011-08-18
Posts: 804

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

Gusar wrote:
Kaustic wrote:

The best solution seems to be downgrading to 11.1

11.1 has security vulnerabilities. 11.2 doesn't and 10.3.183.18 doesn't either.

security bulletin

Ah, when I read the reports they all seemed to be talking about memory corruption on Vista/Windows 7 due to ActiveX. However, there's a load of new CVE's on their report which weren't when I looked.

This update resolves a memory corruption vulnerability in the NetStream class that could lead to code execution (CVE-2012-0773).

HTML5, save me!

Offline

#93 2012-04-07 22:44:39

fatino
Member
Registered: 2012-04-07
Posts: 9

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

On youtube using html5 and webm it freezes sometimes... I have no idea why.
EDIT: Funny thing downgrading to 11.1 doesnt help. Hardware decoding doesnt work. It lags in fullscreen and doesnt scale video as it scale on 11.2.
I hate Flash.

Last edited by fatino (2012-04-07 22:51:34)

Offline

#94 2012-04-07 22:55:15

Psykorgasm
Member
From: England, UK
Registered: 2011-11-24
Posts: 158

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

fatino wrote:

On youtube using html5 and webm it freezes sometimes... I have no idea why.

I get the same thing, usually about half way through it starts to freeze, or it only the image will freeze repeatedly for 5 seconds at a time while the audio plays, then again html video issues are a whole other story, hope for improvement! I ended up just leaving the test after a few days.

twilight0 wrote:

Hi everyone, although I did applied the workaround, I told myself, why not give gnash a try? All I have to say is that it works really nice on youtube and off course uncluttered HD content. Farewell Adobe.

I wish I had such a good experience with gnash cause I'd love to use it, cant expand, it takes about 5 seconds to show the play button then my CPU starts to **** itself for another 5 seconds before playing the video. Like I said in the thread about linux flash supporting dropping apart from chrome a few weeks ago, hopefully gnash will get some some more drive behind and become a really good alternative.

Offline

#95 2012-04-08 06:05:28

akspecs
Member
Registered: 2012-02-11
Posts: 169

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

Hey - I just want to clarify a few things.  I am having this problem, and by disabling hardware acceleration and reloading the page I no longer see blue people (only youtube has this problem).  I am running the nvidia propietary drivers.

Does anyone have this on other web sites and with other types of graphics?  Someone claimed this happened with their radeon card on open source drivers.

I am also really interested to here if this happens with the nouveau driver for anyone.

Offline

#96 2012-04-08 23:23:22

gerald82
Member
From: The known universe
Registered: 2011-03-25
Posts: 60

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

cobalt45xy wrote:

I had the same blue tint problem. I fixed mine by simply editing /etc/adobe/mms.cfg and allowing hardware video decoding. I've never had problems with flash crashing before and I can confirm that I can go full screen and back without crashing. Thanks for the tips on how to fix it, it worked for me.

Yeah did the same here.
Works fine for YouTube.
Many other video sites frequently crash, though.
It's not a solution.

I agree with akspecs - this topic is falsely marked "solved". There are only bad workarounds, but there is no solution.

Offline

#97 2012-04-08 23:30:25

Earnestly
Member
Registered: 2011-08-18
Posts: 804

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

Just chiming in to say the vdpau trace hack solved all my problems. (Using the PKGBUILD on one of the first pages of this thread)

Offline

#98 2012-04-09 23:41:31

cobalt45xy
Member
From: WA - USA
Registered: 2012-04-02
Posts: 9

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

I did have a couple of crashes but I haven't really been able to put it to a full test yet. I didn't add the VDPAU_NVIDIA_NO_OVERLAY=1 to my .xinitrc though. There was another nvidia update that came through last night so I'll see if that does anything.

Offline

#99 2012-04-10 09:11:41

mr.wizrd
Member
From: Hull, UK
Registered: 2012-03-31
Posts: 8

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

Just in case any of you are interested, here's a more technical explanation of the problems with the older version.

Last edited by mr.wizrd (2012-04-10 09:12:01)

Offline

#100 2012-04-10 11:29:27

lenk
Member
Registered: 2009-01-27
Posts: 27

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

It would be great if someone can make an AUR for flashplugin 10.3.183.18 for i686 and x86_64

Safe and Stable.

Offline

Board footer

Powered by FluxBB