You are not logged in.

#1 2012-04-05 09:13:15

lgolebio
Member
From: Poland / Wroclaw
Registered: 2008-07-28
Posts: 101

[solved] Problem making package nvidia

Hi
I need to downgrade xorg-server and nvidia driver, because it is buggy as hell. I'm trying to compile nvidia package 290.10 but all I get is this.

[lukasz@lukaszdell nvidia]$ LC_ALL=C  makepkg -d
==> Making package: nvidia 290.10-3 (Thu Apr  5 11:12:49 CEST 2012)
==> WARNING: Skipping dependency checks.
==> Retrieving Sources...
  -> Found NVIDIA-Linux-x86-290.10.run
==> Validating source files with md5sums...
    NVIDIA-Linux-x86-290.10.run ... Passed
==> Extracting Sources...
==> Starting build()...
Creating directory NVIDIA-Linux-x86-290.10
Verifying archive integrity... OK
Uncompressing NVIDIA Accelerated Graphics Driver for Linux-x86 290.10........................................................................................................................................
NVIDIA: calling KBUILD...
test -e include/generated/autoconf.h -a -e include/config/auto.conf || (    \
echo;                                \
echo "  ERROR: Kernel configuration is invalid.";        \
echo "         include/generated/autoconf.h or include/config/auto.conf are missing.";\
echo "         Run 'make oldconfig && make prepare' on kernel src to fix it.";    \
echo;                                \
/bin/false)
make[2]: *** No rule to make target `+'.  Stop.
NVIDIA: left KBUILD.
nvidia.ko failed to build!
make[1]: *** [module] Error 1
make: *** [module] Error 2
==> ERROR: A failure occurred in build().
    Aborting...
[lukasz@lukaszdell nvidia]$

Here is the PKGBUILD

# $Id: PKGBUILD 149468 2012-02-08 09:34:11Z ibiru $
# Maintainer : Thomas Baechler <thomas@archlinux.org>

pkgname=nvidia
pkgver=290.10
_extramodules=extramodules-3.2-ARCH
_kernver="$(cat /lib/modules/${_extramodules}/version)"
pkgrel=3
pkgdesc="NVIDIA drivers for linux."
arch=('i686' 'x86_64')
url="http://www.nvidia.com/"
depends=('linux>=3.2' 'linux<3.3' "nvidia-utils=${pkgver}")
makedepends=('linux-headers>=3.2' 'linux-headers<3.3')
conflicts=('nvidia-96xx' 'nvidia-173xx')
license=('custom')
install=nvidia.install
options=(!strip)

if [ "$CARCH" = "i686" ]; then
    _arch='x86'
    _pkg="NVIDIA-Linux-${_arch}-${pkgver}"
    source=("ftp://download.nvidia.com/XFree86/Linux-${_arch}/${pkgver}/${_pkg}.run")
    md5sums=('50319a4b3818c12c9c7243525e0e6316')
elif [ "$CARCH" = "x86_64" ]; then
    _arch='x86_64'
    _pkg="NVIDIA-Linux-${_arch}-${pkgver}-no-compat32"
    source=("ftp://download.nvidia.com/XFree86/Linux-${_arch}/${pkgver}/${_pkg}.run")
    md5sums=('cebfba9a7e91716a06c66bb5b38d9661')
fi

build() {
    cd "${srcdir}"
    sh "${_pkg}.run" --extract-only
    cd "${_pkg}/kernel"
    make SYSSRC=/lib/modules/"${_kernver}/build" module
}

package() {
    install -D -m644 "${srcdir}/${_pkg}/kernel/nvidia.ko" \
        "${pkgdir}/lib/modules/${_extramodules}/nvidia.ko"
    install -d -m755 "${pkgdir}/lib/modprobe.d"
    echo "blacklist nouveau" >> "${pkgdir}/lib/modprobe.d/nvidia.conf"
    echo "blacklist nvidiafb" >> "${pkgdir}/lib/modprobe.d/nvidia.conf"
    sed -i -e "s/EXTRAMODULES='.*'/EXTRAMODULES='${_extramodules}'/" "${startdir}/nvidia.install"
    gzip "${pkgdir}/lib/modules/${_extramodules}/nvidia.ko"
}

Last edited by lgolebio (2012-04-07 16:55:15)

Offline

#2 2012-04-05 09:59:09

Gusar
Member
Registered: 2009-08-25
Posts: 3,408

Re: [solved] Problem making package nvidia

You need a patch to compile this version with newer kernels: http://www.nvnews.net/vbulletin/showthread.php?t=173612

Also, note that this version doesn't work with xorg-server-1.12

Offline

#3 2012-04-06 12:20:25

lgolebio
Member
From: Poland / Wroclaw
Registered: 2008-07-28
Posts: 101

Re: [solved] Problem making package nvidia

Well I don't know what am I doing wrong, but I still can't compile this package. Can anyone help me with creating proper PKGBUILD?

It looks like this patch works only on 3.3.1-rc1 http://weltall.heliohost.org/wordpress/ … a-drivers/

Last edited by lgolebio (2012-04-06 12:22:06)

Offline

#4 2012-04-06 12:37:25

Gusar
Member
Registered: 2009-08-25
Posts: 3,408

Re: [solved] Problem making package nvidia

The patch isn't for one specific kernel, it's a general fix for the nvidia's compile script. It's actually wrong, but you don't need to know that smile, it works on Arch.

Offline

#5 2012-04-06 13:25:55

lgolebio
Member
From: Poland / Wroclaw
Registered: 2008-07-28
Posts: 101

Re: [solved] Problem making package nvidia

@Gusar, can you post a working modified PKGBUILD ? Here are the source files http://dl.dropbox.com/u/412776/nvidia%2 … ls.tar.bz2


EDIT
Problem was solved. I forgot to delete the "space" in the name of the package folder. Linux doesn't like spaces smile There is no need to apply any patch. So what @gusar said is not necessary.

Last edited by lgolebio (2012-04-07 16:57:24)

Offline

Board footer

Powered by FluxBB