You are not logged in.

#1 2012-04-08 14:19:56

Micah89
Member
Registered: 2011-05-01
Posts: 29

DBUS failed to load after upgrade kernel to 3.3.1

After upgrading the system to kernel 3.3.1, during boot the dbus fails to load.

I dont know if its related, but my wireless also stopped working, in the sense that it obtains the wireless
networks available, but isn't able to connect (the wireless router is like an inch away from the laptop =P).

Anywho, i still have the old kernel in cache, how can i downgrade in the meantime? there are still some packages
related with the kernel which should i use to downgrade?

Thanks!

Offline

#2 2012-04-08 14:27:06

Into the Pit
Member
Registered: 2010-09-04
Posts: 36

Re: DBUS failed to load after upgrade kernel to 3.3.1

Micah89 wrote:

Anywho, i still have the old kernel in cache, how can i downgrade in the meantime? there are still some packages
related with the kernel which should i use to downgrade?

Read here how to downgrade a package: https://wiki.archlinux.org/index.php/Do … _a_package

Offline

#3 2012-04-08 14:35:37

Micah89
Member
Registered: 2011-05-01
Posts: 29

Re: DBUS failed to load after upgrade kernel to 3.3.1

Ah okay, thanks, already have virtualbox modules messing with me =P, but ill deal with that, but im just wondering
if anyone had also this problem, and if can be related with the wireless issue.

Thanks!

Offline

#4 2012-04-08 16:12:46

Into the Pit
Member
Registered: 2010-09-04
Posts: 36

Re: DBUS failed to load after upgrade kernel to 3.3.1

Micah89 wrote:

but im just wondering if anyone had also this problem, and if can be related with the wireless issue.

After updating the Kernel my wireless also didn't work, using Atheros AR9285.

Offline

#5 2012-04-08 16:21:49

nirvanix
Member
From: Saskatoon
Registered: 2005-01-31
Posts: 193

Re: DBUS failed to load after upgrade kernel to 3.3.1

I've got the same wireless problem on my netbook after upgrading to kernel 3.3. The netbook uses the ath9k modules, which still load with the new kernel. Running a 'iwlist wlan0 scanning' command does produce a list of available networks, but I don't seem to be able to connect with them. Cannot ping my own router.

I've also upgraded the kernel on my desktop which uses a different wireless card and it's working fine. Seems to be specific to the atheros hardware.

Dbus loads fine on both machines.

Downgrading the kernel fixes it.

Last edited by nirvanix (2012-04-08 16:44:45)


I've got a lovely bunch of coconuts...

Offline

#6 2012-04-08 16:29:40

Micah89
Member
Registered: 2011-05-01
Posts: 29

Re: DBUS failed to load after upgrade kernel to 3.3.1

Right, also atheros here, but seems that i'm alone on the DBus problem.

I did a downgrade to the previous kernel in the meantime, which solves both problems.

Offline

#7 2012-04-08 20:08:30

rps63ifid
Member
From: Idaho, US
Registered: 2008-08-02
Posts: 39
Website

Re: DBUS failed to load after upgrade kernel to 3.3.1

I have this same problem: netbook apparently with an Atheros-based network interface, no longer working after updating to the new kernel.

I guess I will downgrade the kernel and see if that solves it, and then hold off updating that box until this gets resolved... which raises the following question for me: how will I know when we can move to the new kernel for these Atheros-based systems?

Edit: Downgraded the kernel, and box is functional again.

--
/ron

Last edited by rps63ifid (2012-04-08 20:17:22)

Offline

#8 2012-04-09 01:22:45

temp1
Member
Registered: 2010-08-23
Posts: 4

Re: DBUS failed to load after upgrade kernel to 3.3.1

linux 3.3.1 seems to have broken my ath9k hardware too. I am able to scan for networks but am unable to connect to my (previously working) wpa2 network.

If anyone else is curious it looks like a bug report has been filed FS#29340.

Last edited by temp1 (2012-04-20 10:36:15)

Offline

Board footer

Powered by FluxBB