You are not logged in.

#26 2012-04-09 02:04:58

Registered: 2008-10-23
Posts: 28

Re: Suspend doesn't resume

tocer wrote:
tocer wrote:

same hear on my desktop.

Note: I use the uswsusp-git package for suspend. I notice that error when resuming:

/usr/lib/suspend/resume: error while loading shared libraries: cannot open  shared object file: No such file or directory

I reinstall uswsusp and lzo2, but errer message display again.

I inspired from old bug(, and found that don't included when build kernel.

rebuild kenel detail:
my mkinitcpio.conf
my suspend.conf

any help?

Solved. The solution is removing compile option 'upx' in the makepkg.conf.  resume come back again.


#27 2012-06-23 03:09:38

Registered: 2012-06-17
Posts: 15

Re: Suspend doesn't resume

I just recently started using arch from fedora/centos, although I used ubunto for some time.  The suspend/hibernate is a problem for all the distros that I used and arch for my current machine. As I tried so many proposed "fixes" with blinking cursor/black screen when resuming, I think it is very likely a kernel bug to the problem I have.

however, I have to say first: symptom of "blinking cursor/black screen when resuming" problem may not be the same cause -- it has various causes.  My problem is with Marvell 88SE6480 host controller (using mvsas driver) along with SATA II disks. I remember in Fedora with kernel 3.0.x or 3.1.x, if I hook the disks to IDE controller from Intel, I don't see problem in suspend/hibernate.  Thus I believe the problem is in Marvell controller driver or sata/scsi driver.  I also come to see, during extensive search, some ASUS computers also use Marvell controller.  If this is the case to you, we may be on a same boat.  so if you reveal a bit your hardware info, it may help each other.  I have nvidia video card and use nouveau driver is fine.

I debug the resume process by initiating hibernate/suspend command in tty1 (gui is in tty7 or 8).  I know I can access to my disk very brief when prompt just comes back during resume (at this short window). Then when the process to resume disks, it has problem. The disk is operational already, however the resume process is trying hard to "resume" the disks.  I don't know how the system get there.  but I can tell this is the real problem in my system.  I saw only one other report of same machine that has exact the same problem to mine.

I tried in latest kernel 3.5-rc3.  I hope further kernel development/improvement will solve my problem.


Board footer

Powered by FluxBB