You are not logged in.

#1 2012-04-12 22:51:26

sliposk
Member
Registered: 2010-08-19
Posts: 45

Nvidia 295.40 Problems Using XBMC Assaultcube or anything with(SOLVED)

The title pretty much sums it up , Ever since I updated to 295.40 . The previous driver 295.33 was working fine .  Problems Using XBMC , Wine , Assaultcube or anything with uses Open GL .  The two machines that are affected have the same hardware ( Nvidia 6200 pci) . Let me know if any of you are having similar issues . I will continue to work on this for a couple of hours .  Thanks .

Last edited by sliposk (2012-05-03 18:47:26)

Offline

#2 2012-04-12 23:24:08

evilgnome
Member
Registered: 2009-02-20
Posts: 54

Re: Nvidia 295.40 Problems Using XBMC Assaultcube or anything with(SOLVED)

I'm also having xbmc trouble after upgrading, with a GeForce GTX 560. It closes shortly after launching.

Offline

#3 2012-04-13 04:17:04

gsg
Member
Registered: 2008-02-08
Posts: 14

Re: Nvidia 295.40 Problems Using XBMC Assaultcube or anything with(SOLVED)

I have NVIDIA GeForce 6100 integrated on motherboard graphics and since 295.40 update the mame emulator for linux - sdlmame (which uses Open GL) works extremely slowly. I downgraded Nvidia drivers to 295.33 ind it works fine now.

Last edited by gsg (2012-04-13 04:26:00)

Offline

#4 2012-04-13 14:23:33

sliposk
Member
Registered: 2010-08-19
Posts: 45

Re: Nvidia 295.40 Problems Using XBMC Assaultcube or anything with(SOLVED)

Yeah , I had to downgrade to 295.33 , now everything is working great . I hope this gets fixed soon . Nvidia Bug report .

Offline

#5 2012-04-13 15:16:52

sliposk
Member
Registered: 2010-08-19
Posts: 45

Re: Nvidia 295.40 Problems Using XBMC Assaultcube or anything with(SOLVED)

It looks like there are others that are having the same issue with 295.40   .....  http://forum.xbmc.org/showthread.php?tid=128705

Offline

#6 2012-04-13 21:41:41

berbae
Member
From: France
Registered: 2007-02-12
Posts: 1,125

Re: Nvidia 295.40 Problems Using XBMC Assaultcube or anything with(SOLVED)

I have the same problem with the same chipset as preceding posts.
I had also to downgrade to 295.33 driver.
Can someone signals the regression in performance to Nvidia.
I cannot presently, I'm not at home for some days.
Thanks.

Offline

#7 2012-04-14 00:25:28

quiquex
Member
Registered: 2011-01-25
Posts: 34

Re: Nvidia 295.40 Problems Using XBMC Assaultcube or anything with(SOLVED)

Yep 295.40-2 broke my gnome too, I had to downgrade to 295.33 luckily it was still in cache. This means downgrading kernel too...

On a laptop with a 6150.

Offline

#8 2012-04-14 08:16:28

berbae
Member
From: France
Registered: 2007-02-12
Posts: 1,125

Re: Nvidia 295.40 Problems Using XBMC Assaultcube or anything with(SOLVED)

quiquex wrote:

This means downgrading kernel too...

No the 295.33 nvidia driver was built for current linux 3.3.1.1 kernel and still works with it.
But it requires to reboot before using it; or to run under root:

modprobe -r nvidia && modprobe nvidia
before launching the GUI.

Offline

#9 2012-04-14 10:15:51

twau
Member
Registered: 2012-03-02
Posts: 4

Re: Nvidia 295.40 Problems Using XBMC Assaultcube or anything with(SOLVED)

Also have problem with 295.40, fixed by downgrading to 295.33 as everyone else. Got really bad performance with the new drivers, running 8800GTS 640MB.

Offline

#10 2012-04-14 10:33:54

Rokixz
Member
From: Šiauliai, Lithuania
Registered: 2007-04-21
Posts: 251
Website

Re: Nvidia 295.40 Problems Using XBMC Assaultcube or anything with(SOLVED)

Same issue Geforce 8800GTS, should be driver related problem smile Thanks for tip smile


http://ispconfig.lt - ISPConfig 3 based hosting. Coming Soon!

Offline

#11 2012-04-14 12:35:42

Gusar
Member
Registered: 2009-08-25
Posts: 3,466

Re: Nvidia 295.40 Problems Using XBMC Assaultcube or anything with(SOLVED)

As I wrote in the other thread, the main point of 295.40 is to fix security vulnerabilities. So if you want to use older versions, at least patch them: http://www.nvnews.net/vbulletin/showthread.php?t=178006

Offline

#12 2012-04-14 13:56:37

sliposk
Member
Registered: 2010-08-19
Posts: 45

Re: Nvidia 295.40 Problems Using XBMC Assaultcube or anything with(SOLVED)

Gusar wrote:

As I wrote in the other thread, the main point of 295.40 is to fix security vulnerabilities. So if you want to use older versions, at least patch them: http://www.nvnews.net/vbulletin/showthread.php?t=178006

 

  I have tried to patch 295.33 , Using the instructions over at Nvidia . However I have been unsuccessful so far .

Last edited by sliposk (2012-04-14 13:57:33)

Offline

#13 2012-04-15 05:41:00

quiquex
Member
Registered: 2011-01-25
Posts: 34

Re: Nvidia 295.40 Problems Using XBMC Assaultcube or anything with(SOLVED)

berbae wrote:
quiquex wrote:

This means downgrading kernel too...

No the 295.33 nvidia driver was built for current linux 3.3.1.1 kernel and still works with it.
But it requires to reboot before using it; or to run under root:

modprobe -r nvidia && modprobe nvidia
before launching the GUI.

Yeah sorry, it was virtualbox that was complaining.

Offline

#14 2012-04-15 20:36:57

Dieter
Member
From: Germany
Registered: 2005-10-13
Posts: 120

Re: Nvidia 295.40 Problems Using XBMC Assaultcube or anything with(SOLVED)

If I have 295.33 installed and run "pacman -Sy linux" I get an error response "nvidia requires linux<3.3". So this nvidia driver doesn't seem to be built for kernel 3.3 - or am I wrong?

Offline

#15 2012-04-15 20:47:07

Gusar
Member
Registered: 2009-08-25
Posts: 3,466

Re: Nvidia 295.40 Problems Using XBMC Assaultcube or anything with(SOLVED)

Create your own nvidia package. And patch it!

Offline

#16 2012-04-15 21:18:45

berbae
Member
From: France
Registered: 2007-02-12
Posts: 1,125

Re: Nvidia 295.40 Problems Using XBMC Assaultcube or anything with(SOLVED)

@Dieter: You need the rebuilt 295.33-2 package version which has:
depends=('linux>=3.3' 'linux<3.4' "nvidia-utils=${pkgver}")
as dependencies line in PKGBUILD.

not the 295.33-1 version with:
depends=('linux>=3.2' 'linux<3.3' "nvidia-utils=${pkgver}")

Concerning the available patch, I don't think this is a good solution to need to keep an older version from now on.
I think there is a bug in the new driver release for the chipsets which are supposed to work with the current nvidia driver and don't now with unusable opengl performances. I think a bug has to be opened in nvidia bug tracker for them to correct that.

Offline

#17 2012-04-16 05:00:52

AxGS
Member
From: Mexico
Registered: 2011-11-06
Posts: 12
Website

Re: Nvidia 295.40 Problems Using XBMC Assaultcube or anything with(SOLVED)

Same here...
glxgears runs very slow, no direct rendering?


Amateur game developer, who needs help with pixel art or a team for make games as a hobby.

Offline

#18 2012-04-16 06:57:58

amatriain
Member
Registered: 2011-06-02
Posts: 49

Re: Nvidia 295.40 Problems Using XBMC Assaultcube or anything with(SOLVED)

Same here. I updated my htpc from nvidia-290.10-2 to nvidia-295.40 and I'm currently experiencing choppy video playback in xmbc.

Offline

#19 2012-04-16 10:16:56

twau
Member
Registered: 2012-03-02
Posts: 4

Re: Nvidia 295.40 Problems Using XBMC Assaultcube or anything with(SOLVED)

My issued was solved by upgrading to kernel linux 3.3.2-1, Nvidia 295.40 now working fine on my system.

Edit, ignore my previous statement, now my games launch, but the FPS/overall performance is terrible.

Last edited by twau (2012-04-16 20:50:35)

Offline

#20 2012-04-16 14:52:43

SataMaxx
Member
Registered: 2011-08-07
Posts: 18

Re: Nvidia 295.40 Problems Using XBMC Assaultcube or anything with(SOLVED)

Tried upgrading the nvidia package after upgrading linux to 3.3.2 but with no success, it still freezes…

Gusar wrote:

As I wrote in the other thread, the main point of 295.40 is to fix security vulnerabilities. So if you want to use older versions, at least patch them: http://www.nvnews.net/vbulletin/showthread.php?t=178006

Tried to patch 295.33, successfully (making a 295.33-3 package to stay clean), but had the same failures and freezes. Looks like the problem we are experiencing is caused by the security fix…

Offline

#21 2012-04-16 15:30:25

Gusar
Member
Registered: 2009-08-25
Posts: 3,466

Re: Nvidia 295.40 Problems Using XBMC Assaultcube or anything with(SOLVED)

SataMaxx wrote:

Looks like the problem we are experiencing is caused by the security fix…

That's just awesome... cool

You speak of freezes though, that's new. All other people have performance issues, not freezes. Do you by any chance use pcie_aspm=force?

Offline

#22 2012-04-16 16:11:01

SataMaxx
Member
Registered: 2011-08-07
Posts: 18

Re: Nvidia 295.40 Problems Using XBMC Assaultcube or anything with(SOLVED)

I'm running compiz 0.8 standalone, with all packages up to date (except for the nvidia driver), on a 8800 GTS.
I'm calling them freezes, but it's the system hanging, then I can resume activities, although everything is still slow. It could be very important performance issues (as my compiz desktop uses a lot of effects with shaders etc…).
I have a stack trace for xorg showing issues with glx.
I don't use pcie_aspm=force, only ro, fastboot and quiet.

Last edited by SataMaxx (2012-04-16 16:13:00)

Offline

#23 2012-04-17 08:41:10

masteryod
Member
Registered: 2010-05-19
Posts: 433

Re: Nvidia 295.40 Problems Using XBMC Assaultcube or anything with(SOLVED)

Same here. With 295.40 Kwin compositing is unusable on GeForce 7100/nForce 630i.

this thread is also related: https://bbs.archlinux.org/viewtopic.php?id=139553

Offline

#24 2012-04-17 09:27:33

Gusar
Member
Registered: 2009-08-25
Posts: 3,466

Re: Nvidia 295.40 Problems Using XBMC Assaultcube or anything with(SOLVED)

Nvidia responds: http://www.nvnews.net/vbulletin/showthr … ost2546510

PS. Do we really need multiple threads for this? Perhaps mods should lock the other threads, it'd make things simpler if all info is contained in one thread.

Offline

#25 2012-04-17 11:21:17

zebulon
Member
Registered: 2008-10-20
Posts: 235

Re: Nvidia 295.40 Problems Using XBMC Assaultcube or anything with(SOLVED)

Phoronix has been covering the issue:

Did The NVIDIA 295.40 Linux Driver Fall Off A Cliff?: http://www.phoronix.com/scan.php?page=n … px=MTA4ODQ
NVIDIA Confirms Linux Driver Problems: http://www.phoronix.com/scan.php?page=n … px=MTA4ODc

Hopefully we will see a new version soon.

Offline

Board footer

Powered by FluxBB