You are not logged in.

#1 2005-08-03 17:06:20

Alexo
Member
From: near a cup of coffee
Registered: 2005-06-27
Posts: 90

problem installing nvidia

pacman -S nvidia
...
INSTALLATION FAILED!
==>you have to shutdown Xserver to finish installation!
...
modprobe:can't locate module nvidia
...

Even though I run pacman before startx...

Offline

#2 2005-08-03 17:11:39

phrakture
Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879
Website

Re: problem installing nvidia

well, just because installation failed doesn't mean that it's because X was running - it's just the most common case

The next common case is that you have a different compiler installed than the one your kernel was compiled with... is that possibly the case?

Offline

#3 2005-08-03 18:00:06

Alexo
Member
From: near a cup of coffee
Registered: 2005-06-27
Posts: 90

Re: problem installing nvidia

The next common case is that you have a different compiler installed than the one your kernel was compiled with... is that possibly the case?

I guess not... already installed xorg, firefox, mutt,links and other packages and it's the first time I get this error. Anyway, I didn't install any compiler since kernel compilation.

Offline

#4 2005-08-03 19:39:09

Kern
Member
From: UK
Registered: 2005-02-09
Posts: 464

Re: problem installing nvidia

su - first
then telinit 3 to be sure.

then run the pacman -S nvidia thingy

no implied insult if you're console competent. just to be sure of a common starting point.

next thing to check is the error logs

Offline

#5 2005-08-03 20:07:11

Alexo
Member
From: near a cup of coffee
Registered: 2005-06-27
Posts: 90

Re: problem installing nvidia

su - first
then telinit 3 to be sure.
then run the pacman -S nvidia thingy

Done.
Same result.

no implied insult if you're console competent.

none taken, kern. a couple of months ago I didn't even know what a console is. Moreover I still don't know how to copy/paste from my xterm to this post in order to show nvidia-installer.log...

Cheers

Offline

#6 2005-08-03 20:22:37

Moo-Crumpus
Member
From: Hessen / Germany
Registered: 2003-12-01
Posts: 1,444

Re: problem installing nvidia

so your X is running? You are inside a desktop environment?


Frumpus addict
[mu'.krum.pus], [frum.pus]

Offline

#7 2005-08-03 20:29:48

phrakture
Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879
Website

Re: problem installing nvidia

Alexo wrote:

Moreover I still don't know how to copy/paste from my xterm to this post in order to show nvidia-installer.log...

open it in gvim/gedit/kate/nedit or something like that - the log is very important

Offline

#8 2005-08-04 11:38:07

Alexo
Member
From: near a cup of coffee
Registered: 2005-06-27
Posts: 90

Re: problem installing nvidia

X and windowlab are running.
Can't do copy/paste from nedit to firefox. When I rightclick firefox the paste option is not available.

Offline

#9 2005-08-04 18:03:48

Kern
Member
From: UK
Registered: 2005-02-09
Posts: 464

Re: problem installing nvidia

i too find nedit is buggy like that. gedit / gvim etc should work tho

Offline

#10 2005-08-04 18:59:22

FUBAR
Member
From: Belgium
Registered: 2004-12-08
Posts: 1,029
Website

Re: problem installing nvidia

Do you have the hotplug package installed?


A bus station is where a bus stops.
A train station is where a train stops.
On my desk I have a workstation.

Offline

#11 2005-08-04 22:24:54

Alexo
Member
From: near a cup of coffee
Registered: 2005-06-27
Posts: 90

Re: problem installing nvidia

nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Wed Aug  3 20:51:09 2005

option status:
  license pre-accepted    : true
  update                  : false
  force update            : false
  expert                  : false
  uninstall               : false
  driver info             : false
  no precompiled interface: true
  no ncurses color        : false
  query latest driver ver : false
  OpenGL header files     : false
  no questions            : true
  silent                  : false
  no backup               : false
  kernel module only      : false
  sanity                  : false
  add this kernel         : false
  no runlevel check       : false
  no network              : true
  no ABI note             : false
  no RPMs                 : false
  force tls               : (not specified)
  force compat32 tls      : (not specified)
  X install prefix        : /usr/X11R6
  OpenGL install prefix   : /usr
  compat32 install prefix : (not specified)
  installer install prefix: /usr
  utility install prefix  : /usr
  kernel name             : (not specified)
  kernel include path     : (not specified)
  kernel source path      : (not specified)
  kernel output path      : (not specified)
  kernel install path     : (not specified)
  proc mount point        : /proc
  ui                      : none
  tmpdir                  : /tmp
  ftp mirror              : ftp://download.nvidia.com
  RPM file list           : (not specified)

Using built-in stream user interface
-> The file '/tmp/.X0-lock' exists... an X server appears to be running
ERROR: You appear to be running an X server; please exit X before installing. 
       For further details, please see the section INSTALLING THE NVIDIA DRIVER
       in the README available on the Linux driver download page at
       www.nvidia.com.
ERROR: Installation has failed.  Please see the file
       '/var/log/nvidia-installer.log' for details.  You may find suggestions
       on fixing installation problems in the README available on the Linux
       driver download page at www.nvidia.com.

Here's the log. Notice that I tried to install nvidia from bash, no X, despite the complains in the log file...

Do you have the hotplug package installed?

Here:

# whereis hotplug
hotplug: /bin/hotplug /sbin/hotplug /etc/hotplug /etc/hotplug.d /usr/man/man8/hotplug.8.gz

Offline

#12 2005-08-04 22:41:06

scarecrow
Member
From: Greece
Registered: 2004-11-18
Posts: 714

Re: problem installing nvidia

Telinit 3 from a root console should bring you to a login terminal with no X running, in any case...
If you have an old nvidia card, you must use the "legacy" nvidia package, and not the ordinary one- plz consult the forum for "nvidia".


Microshaft delenda est

Offline

#13 2005-08-05 06:47:41

paranoos
Member
From: thornhill.on.ca
Registered: 2004-07-22
Posts: 442

Re: problem installing nvidia

Alexo wrote:

-> The file '/tmp/.X0-lock' exists... an X server appears to be running

does that file exist? have you tried deleting it?

Offline

#14 2005-08-05 14:39:51

Alexo
Member
From: near a cup of coffee
Registered: 2005-06-27
Posts: 90

Re: problem installing nvidia

paranoos, the file was there and I turfed it. But I got the same error afterwards.

Offline

#15 2005-08-22 20:30:06

mercy
Member
Registered: 2004-04-24
Posts: 62

Re: problem installing nvidia

do a:
su - root
telinit 3

ps aux
lsmod
lshwd
hwd -e

and post the output of the last four ... that would help to figure out your troubles smile

and copying from xterm is easy.. simply mark all y wanna copy with the mouse (press+hold left key at startpoint... depress it at the finish-point) .. then simply change via ALT+TAB or mouse to the other application .. like firefox... and there hit the middle-mouse button where you wana have it..

Sample:

IDE interface
  ata_piix        : Intel Corp.|82801EB ICH5 IDE (SATA)
  ata_piix        : Intel Corp.|82801EB ICH5 IDE
Ethernet controller
  8139too         : Realtek|RTL-8139
VGA compatible controller
  nv              : nVidia Corporation|NV36 [GeForce FX 5700LE]
Multimedia audio controller
  snd-intel8x0    : Intel Corp.|82801EB AC'97 Audio
Host bridge
  intel-agp       : Intel Corp.|82865G [Springdale-G] Chipset Host Bridge
ISA bridge
  i810-tco        : Intel Corp.|82801EB ISA Bridge (LPC)
PCI bridge
  hw_random       : Intel Corp.|82820 815e (Camino 2) Chipset PCI
  unknown         : Intel Corp.|82865G/PE/P Processor to AGP Controller
USB Controller
  ehci-hcd        : Intel Corp.|USB Enhanced Controller
  uhci_hcd        : Intel Corp.|82801EB USB EHCI Controller #2
  uhci_hcd        : Intel Corp.|USB Controller
  uhci_hcd        : Intel Corp.|USB Controller
  uhci_hcd        : Intel Corp.|USB Controller
SMBus
  i2c-i801        : Intel Corp.|82801EB SMBus
USB Human Interface Devices
  usbhid          : Logitech Inc.|Optical Mouse [/dev/input/mice]
  usbhid          : Microsoft Corp.|SideWinder Joystick
USB Mass Storage
  usb-storage     : USB Storage Device
USB Hub
  hub             : Virtual|Hub
  hub             : Virtual|Hub
Mouse
  msintellips/2   : PS/2 Mouse port [/dev/psaux]

[root@archmage ~]#

Offline

#16 2005-08-22 22:03:58

sputnik
Member
From: Canada
Registered: 2005-06-24
Posts: 98

Re: problem installing nvidia

I had the same problem, i fixed it by upgrading gcc to 4.01

Offline

Board footer

Powered by FluxBB