You are not logged in.

#1 2011-08-28 18:44:41

hussam
Member
Registered: 2006-03-26
Posts: 524
Website

vlc problems. [solved]

using stock archlinux ffmpeg and vlc packages (nothing rebuilt from aur or whatever), I'm getting problems outputing videos. flv videos work find but other videos give "[0x933310c] avcodec decoder error: more than 5 seconds of late video -> dropping frame (computer too slow ?)"
I have a nvidia 430GT card and a /proc/cpu says model name      : Intel(R) Core(TM)2 CPU         E7500  @ 2.93GHz
3GB ram.
so it should at least be able to handle videos.
how can I tell what's wrong?

Last edited by hussam (2012-04-20 16:58:15)

Offline

#2 2011-08-28 20:22:30

doorknob60
Member
From: Oregon
Registered: 2008-09-29
Posts: 401

Re: vlc problems. [solved]

Make sure it's set to use VDPAU accelleration: https://wiki.archlinux.org/index.php/NV … 2FVAAPI.29 (though with that CPU it should be fine either way...oh well). I have a GT430 and when I play any videos they play perfectly smooth with almost no CPU usage sine it uses VDPAU, should be the same for you. Also, you could try using mplayer (or Smplayer if you want a GUI) with its VDPAU output, I find that Mplayer better supports VDPAU than VLC does.

EDIT: Also make sure you have the libvdpau and vdpau-video packages installed, I'm not sure if they come as dependencies or not, better double check.

Last edited by doorknob60 (2011-08-28 20:24:46)

Offline

#3 2011-08-28 20:56:03

hussam
Member
Registered: 2006-03-26
Posts: 524
Website

Re: vlc problems. [solved]

vdpau-video and libvdpau are installed.
I have "Use GPU acceleration" turned on.
BTW, this doesn't happen when I ffplay files. It only fails with vlc.

Offline

#4 2011-08-29 04:30:15

chr0nik
Member
From: Michigan, USA
Registered: 2011-03-13
Posts: 31

Re: vlc problems. [solved]

I lifted this from readthefuckingmanual.net after a quick google so you may have already tried it. If not, you can try increasing vlc's cache size for files as such:

*go to Tools->Preferences
*show settings All
*double click Input / Codecs
*double click Access Modules
*select File and increase the cache size.
*save and restart vlc

Also, what output do you get from vainfo?

Offline

#5 2011-08-29 12:45:27

hussam
Member
Registered: 2006-03-26
Posts: 524
Website

Re: vlc problems. [solved]

chr0nik wrote:

I lifted this from readthefuckingmanual.net after a quick google so you may have already tried it. If not, you can try increasing vlc's cache size for files as such:

*go to Tools->Preferences
*show settings All
*double click Input / Codecs
*double click Access Modules
*select File and increase the cache size.
*save and restart vlc

Hi chr0nik. That seems to have some effect. I increased the cache size to a really huge number. 100000ms. now it plays a full second before it stops again

Also, what output do you get from vainfo?

vainfo
libva: libva version 0.32.0
Xlib:  extension "XFree86-DRI" missing on display ":0.0".
libva: va_getDriverName() returns 0
libva: Trying to open /usr/lib/dri/nvidia_drv_video.so
libva: va_openDriver() returns 0
vainfo: VA API version: 0.32
vainfo: Driver version: Splitted-Desktop Systems VDPAU backend for VA-API - 0.7.3
vainfo: Supported profile and entrypoints
      VAProfileMPEG2Simple            : VAEntrypointVLD
      VAProfileMPEG2Main              : VAEntrypointVLD
      VAProfileMPEG4Simple            : VAEntrypointVLD
      VAProfileMPEG4AdvancedSimple    : VAEntrypointVLD
      VAProfileH264Main               : VAEntrypointVLD
      VAProfileH264High               : VAEntrypointVLD
      VAProfileVC1Simple              : VAEntrypointVLD
      VAProfileVC1Main                : VAEntrypointVLD
      VAProfileVC1Advanced            : VAEntrypointVLD

Offline

#6 2012-04-20 16:52:49

hussam
Member
Registered: 2006-03-26
Posts: 524
Website

Re: vlc problems. [solved]

I finally fixed this.
I recompiled vlc with --disable-libmpeg2 and now it uses ffmpeg to play mpg files instead of libmpeg2 and the problem is gone!

Offline

Board footer

Powered by FluxBB