You are not logged in.

#1 2012-01-03 19:37:26

osmano807
Member
Registered: 2008-10-09
Posts: 21

rtl8192ce intermittent connection.

Does anyone know if the driver was rtl8192ce to work? Here the connection drops all the time, but randomly it remains connected for hours without problems.
I'm using kernel 3.1.5, but I do not think 3.1.6 will improve something (my internet connection is slow, it takes to download, have not updated).

I also tested the realtek driver, but the problem continues.

Offline

#2 2012-04-22 16:19:57

Buggi
Member
Registered: 2012-02-11
Posts: 3

Re: rtl8192ce intermittent connection.

Same issue here on a Thinkpad E525.

05:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter (rev 01)
Any ideas?
It seems that the connection always drops every 10 to 15 minutes regardless of the distance to the router.
Ubuntu seems to have similar problems, but drops connection less often.

Offline

#3 2012-04-23 10:49:13

osmano807
Member
Registered: 2008-10-09
Posts: 21

Re: rtl8192ce intermittent connection.

With the last kernels improved, often does not disconnect. But with kernel 3.3.2-1-ck became more frequent, but stopped recently. Maybe it's something that I modified with power saving and do not remember.

Offline

#4 2012-05-28 07:35:55

Lord_Lizard
Member
From: NJ, USA
Registered: 2012-05-28
Posts: 4

Re: rtl8192ce intermittent connection.

I'm on Kernel 3.4.0-1-ARCH. Maybe it works for you.

After a lot of times trying get it working good finally I did.

This is what I did:

1. Check if rtl8192ce is loaded:

lsmod

2. Get some information about it:

modinfo rtl8192ce

and check the parameters info at the end.

3. Check how are configured those parameters:

systool -v -m rtl8192ce

I got under "Parameters:"

debug   =   "0"
fwlps   =   "Y"
ips   =   "Y"
swnc   =   "N"
swlps   =   "N"

If you already checked the command results at the end in step 2, you saw that some of this parameters are for power saving. So I decided disable.

4. Make a file in /etc/modprobe.d/rtl8192ce.conf and add this:

options rtl8192ce ips=0 fwlps=0

and save it and reboot.
(disable those you are enable)

5. Repeat step 3 to check if the parameters were disable.

6.  Eso es todo! Disfruta!

Last edited by Lord_Lizard (2012-05-28 07:39:19)

Offline

#5 2012-06-12 12:28:25

robcat
Member
From: Fermo
Registered: 2009-02-21
Posts: 19

Re: rtl8192ce intermittent connection.

I had these problems too with linux 3.4.0, and I filed a bug.
Now with linux 3.4.2 I cannot reproduce the problem anymore, can anyone confirm that?

Offline

#6 2012-06-21 16:58:29

jceasless
Member
Registered: 2009-04-20
Posts: 73

Re: rtl8192ce intermittent connection.

I had been avoiding upgrading because everything was working perfectly on my x120e, but going to systemd it seemed like a good reason to do a pacman -Syu.

Well, I have kernel 3.4.3 and am now encountering this problem for the first time. I've disabled PCI-express power saving in the BIOS (as suggested in Arch wiki for wicd) but the problem persists.

I will try adding these module options, though I would be confused if these module options would have an effect considering power saving is shut off in the BIOS.

Last edited by jceasless (2012-06-21 17:06:43)

Offline

#7 2012-07-02 21:09:18

mzanfardino
Member
Registered: 2012-07-02
Posts: 1

Re: rtl8192ce intermittent connection.

Lord_Lizard, thank you for your input! Your suggestion worked perfectly!

Offline

#8 2012-07-08 05:35:19

el_cammello
Member
From: Italy
Registered: 2009-03-20
Posts: 70
Website

Re: rtl8192ce intermittent connection.

Download, make && make install latest rtl8188ce driver from realtek, modprobe -r rtl8192ce && modprobe rtl8192ce.
The connection continues to work intermittently, losing packets.

Eg output of ping :

[~] ping router
PING router (192.168.0.20) 56(84) bytes of data.
64 bytes from router (192.168.0.20): icmp_seq=1 ttl=64 time=433 ms
64 bytes from router (192.168.0.20): icmp_seq=2 ttl=64 time=174 ms
64 bytes from router (192.168.0.20): icmp_seq=3 ttl=64 time=271 ms
64 bytes from router (192.168.0.20): icmp_seq=4 ttl=64 time=93.0 ms
64 bytes from router (192.168.0.20): icmp_seq=5 ttl=64 time=1.47 ms
64 bytes from router (192.168.0.20): icmp_seq=6 ttl=64 time=0.980 ms
64 bytes from router (192.168.0.20): icmp_seq=7 ttl=64 time=0.902 ms
64 bytes from router (192.168.0.20): icmp_seq=8 ttl=64 time=1.09 ms
64 bytes from router (192.168.0.20): icmp_seq=9 ttl=64 time=1.03 ms
64 bytes from router (192.168.0.20): icmp_seq=10 ttl=64 time=3.55 ms
64 bytes from router (192.168.0.20): icmp_seq=11 ttl=64 time=1.01 ms
64 bytes from router (192.168.0.20): icmp_seq=12 ttl=64 time=1.39 ms
64 bytes from router (192.168.0.20): icmp_seq=13 ttl=64 time=1.13 ms
64 bytes from router (192.168.0.20): icmp_seq=14 ttl=64 time=0.954 ms
64 bytes from router (192.168.0.20): icmp_seq=15 ttl=64 time=1.01 ms
64 bytes from router (192.168.0.20): icmp_seq=16 ttl=64 time=1.31 ms
64 bytes from router (192.168.0.20): icmp_seq=17 ttl=64 time=1.07 ms
64 bytes from router (192.168.0.20): icmp_seq=18 ttl=64 time=1.69 ms
64 bytes from router (192.168.0.20): icmp_seq=19 ttl=64 time=2.06 ms
64 bytes from router (192.168.0.20): icmp_seq=34 ttl=64 time=86.4 ms
64 bytes from router (192.168.0.20): icmp_seq=35 ttl=64 time=0.994 ms
^C
--- router ping statistics ---
35 packets transmitted, 21 received, 40% packet loss, time 34023ms
rtt min/avg/max/mdev = 0.902/51.499/433.728/109.765 ms

the parameters of the module,

  Parameters:
    fwlps               = "N"
    ips                 = "N"
    swenc               = "Y"
    swlps               = "N"

I do not know what to do. Now I always use the network cable, fast and no-stress.


Sorry for my bad english :-)

Offline

#9 2012-07-30 14:51:56

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: rtl8192ce intermittent connection.

Lord_Lizard's solution is what I use as well.  I came to those settings on my own after a few days of messing with settings, and that is what seems to work the best.  Every once in a while I will lose my ip, but the association with my netowrk remains.   So a quick reestablishment with dhcpcd of dhclient and I am reconnected.

Offline

#10 2012-08-22 08:04:56

meako
Member
Registered: 2012-04-11
Posts: 6

Re: rtl8192ce intermittent connection.

Thank you, guys, that worked for mee too. I've been struggling with lossy connection like for half of a year, recompiling kernels, downloading realtek's drivers and with no success at all.  This solution with modprobe.d seems to work.

Last edited by meako (2012-08-26 07:50:08)

Offline

#11 2012-09-23 03:02:11

Lord_Lizard
Member
From: NJ, USA
Registered: 2012-05-28
Posts: 4

Re: rtl8192ce intermittent connection.

mzanfardino wrote:

Lord_Lizard, thank you for your input! Your suggestion worked perfectly!

No problem!

Offline

#12 2012-10-01 18:42:58

b_adele
Member
From: Montpellier, France
Registered: 2012-02-03
Posts: 15
Website

Re: rtl8192ce intermittent connection.

Very thank @Lord_Lizard, I had a same story of meako, after you modprobe.d it's work for me also !!

Offline

#13 2012-10-10 22:43:11

eyereader
Member
Registered: 2012-10-10
Posts: 1

Re: rtl8192ce intermittent connection.

Thanks, L_L - a miraculous improvement!

Offline

#14 2012-10-21 00:24:34

Hoek
Member
Registered: 2010-08-27
Posts: 6

Re: rtl8192ce intermittent connection.

Unfortunately, for me, those settings didn't do anything about this problem.

My output of systool -v -m rtl8192ce:

Module = "rtl8192ce"

  Attributes:
    coresize            = "50166"
    initsize            = "0"
    initstate           = "live"
    refcnt              = "0"
    taint               = ""
    uevent              = <store method only>

  Parameters:
    debug               = "5"
    fwlps               = "N"
    ips                 = "N"
    swenc               = "N"
    swlps               = "N"
uname -rv
Linux 3.6.2-1-ARCH #1 SMP PREEMPT Fri Oct 12 23:58:58 CEST 2012

The connection still drops every 1-10 minutes, sometimes (rarely) stays stable for hours. Other devices (Android mobile phone) maintain a constant connection to the router (playing an mp3 live stream, for example) while the laptop repeatedly drops the connection.
This s reproducible with several routers on several locations (home, university)

I've set the debugging level to 5, but where does the module write its debugging output to?

I've set up a connection using wpa_supplicant with -dd parameter, but the debugging output there doesn't print anything indicating a problem or disconnection - the connection just drops silently.

ASPM is also disabled:

lspci -vvv | grep -i aspm
                LnkCap: Port #0, Speed unknown, Width x0, ASPM unknown, Latency L0 <64ns, L1 <1us
                LnkCtl: ASPM Disabled; Disabled- Retrain- CommClk-
                LnkCap: Port #1, Speed 5GT/s, Width x1, ASPM L0s L1, Latency L0 <1us, L1 <16us
                LnkCtl: ASPM Disabled; RCB 64 bytes Disabled- Retrain- CommClk-
                LnkCap: Port #2, Speed 5GT/s, Width x1, ASPM L0s L1, Latency L0 <512ns, L1 <16us
                LnkCtl: ASPM Disabled; RCB 64 bytes Disabled- Retrain- CommClk+
                LnkCap: Port #3, Speed 5GT/s, Width x1, ASPM L0s L1, Latency L0 <512ns, L1 <16us
                LnkCtl: ASPM Disabled; RCB 64 bytes Disabled- Retrain- CommClk+
                LnkCap: Port #5, Speed 5GT/s, Width x1, ASPM L0s L1, Latency L0 <1us, L1 <16us
                LnkCtl: ASPM Disabled; RCB 64 bytes Disabled- Retrain- CommClk-
                LnkCap: Port #0, Speed 5GT/s, Width x1, ASPM L0s L1, Latency L0 <512ns, L1 <64us
                LnkCtl: ASPM Disabled; RCB 64 bytes Disabled- Retrain- CommClk+
                LnkCap: Port #0, Speed 2.5GT/s, Width x1, ASPM L0s L1, Latency L0 <512ns, L1 <64us
                LnkCtl: ASPM Disabled; RCB 64 bytes Disabled- Retrain- CommClk+

Any ideas on how I can debug this further?

Thanks in advance!

Offline

#15 2012-11-05 23:14:36

Vixus
Member
Registered: 2012-11-02
Posts: 60

Re: rtl8192ce intermittent connection.

I'm having the same issues with this card. Looking through dmesg, I see the following right before the connection is lost:

wlan0: deauthenticating from MAC by local choice (reason=3)

The ips and fwlps options don't do a thing and I cannot disable power management as per the wiki instructions because I get the following:

Error for wireless request "Set Power Management" (8B2C) :
    SET failed on device wlan0 ; Operation not supported.

My BIOS (Clevo W170ER laptop) has no options to turn off power management. Is there anything else I can do or am I forever destined to not have working wifi on my laptop?

Offline

#16 2012-11-06 00:09:37

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: rtl8192ce intermittent connection.

You know, the ips fwlps settings mentioned above actually improved my cards functionality quite a bit.  It went from total sh*t to pretty sh*tty.  Eventually, I got so sick of it, I seeked out someone/somewhere that could help me modify my bios to install a different wifi card.

Offline

#17 2012-11-06 01:32:52

Vixus
Member
Registered: 2012-11-02
Posts: 60

Re: rtl8192ce intermittent connection.

I have no idea why this is the only realtek card that seems to have so many problems. I've had tons before that were fixed by either using the vendor drivers or just worked out of the box.

Offline

#18 2013-10-30 04:55:31

ak5
Member
Registered: 2008-06-08
Posts: 4

Re: rtl8192ce intermittent connection.

My fairly new Thinkpad Edge, which I bought in China came with this card. None of the solutions above worked for me, but this little snippet from the Gentoo forums did the trick. I am adding it here for archival purposes.

$ cat /etc/modprobe.d/rtl8192ce.conf
# Disable powersaving
options rtl8192ce ips=0

# WARNING! Do not enable this shit.
#          It causes bugs.
options rtl8192ce fwlps=0

# Use software control instead
options rtl8192ce swlps=1

OP: http://forums.gentoo.org/viewtopic-t-95 … art-0.html

Offline

#19 2013-10-30 08:54:33

Hoek
Member
Registered: 2010-08-27
Posts: 6

Re: rtl8192ce intermittent connection.

ak5, actually, your method was described by Lord_lizard above. A year earlier than the gentoo post you mention smile

Meanwhile, I've observed that the intermittent connection still persists, even if I deactivate the rtl 8192ce adapter and use an external usb wifi adapter. Turns out, I am surrounded by more wifi routers than there are 2.4Ghz channels. It became obvious that my signal had no way of getting a stable connection through that noise.

The solution is either upgrade to 5Ghz (which my wifi card wouldn't support, so I went wioth the other option and bought myself an ethernet over powerline adapter kit)

Offline

Board footer

Powered by FluxBB