You are not logged in.

#1 2012-04-27 13:08:29

markc
Member
From: Gold Coast, Australia
Registered: 2007-05-15
Posts: 496
Website

chromium18.0.1025.162-1 needs libffi5

Just did an update and chromium and firefox won't start because they need libffi.so.5 and it looks like libffi.so.6 just got installed.

/usr/lib/chromium/chromium: error while loading shared libraries: libffi.so.5:

A cheap and quick workaround until these packages are rebuilt is to symlink libffi.so.5 to libffi.so.6. Don't forget to remove the symlink when the packages that depend on the old lib are update to use libff.so.6.

ln -s /usr/lib/libffi.so.6.0.0 /usr/lib/libffi.so.5

Offline

#2 2012-04-28 13:42:32

kjell
Member
From: Norway
Registered: 2012-03-26
Posts: 97

Re: chromium18.0.1025.162-1 needs libffi5

Same problem with some of the gnome updates...

Offline

#3 2012-04-28 16:18:33

KingX
Member
From: Fremont, CA
Registered: 2010-03-24
Posts: 321

Re: chromium18.0.1025.162-1 needs libffi5

Edit: Sorry i didn't realise this was posted in the [testing] forum, you obviously have a testing version installed, while i am on stable. smile Please disregard my post.

What version of libffi are you guys referring to? I have

pacman -Qs libffi
local/lib32-libffi 3.0.10-3
    A portable, high level programming interface to various calling conventions
    (32 bits version)
local/libffi 3.0.11-1
    A portable, high level programming interface to various calling conventions

Firefox and Chrome are working as expected.

Last edited by KingX (2012-04-28 16:46:39)

Offline

#4 2012-04-28 17:17:19

American_Jesus
Member
From: Lisbon/Portugal
Registered: 2011-07-20
Posts: 37

Re: chromium18.0.1025.162-1 needs libffi5

Same problem here with new updates, and some apps stop working after updates

[2012-04-28 17:55] upgraded gobject-introspection (1.32.1-1 -> 1.32.1-2)
[2012-04-28 17:55] gtk-update-icon-cache: error while loading shared libraries: libffi.so.5: cannot open shared object file: No such file or directory
[2012-04-28 17:55] upgraded libpeas (1.4.0-1 -> 1.4.0-2)
[2012-04-28 17:55] gtk-update-icon-cache: error while loading shared libraries: libffi.so.5: cannot open shared object file: No such file or directory
[2012-04-28 17:55] upgraded eog (3.4.1-1 -> 3.4.1-2)
[2012-04-28 17:55] gtk-update-icon-cache: error while loading shared libraries: libffi.so.5: cannot open shared object file: No such file or directory
...
[2012-04-28 17:56] upgraded sushi (0.4.1-1 -> 0.4.1-2)
[2012-04-28 17:56] gtk-update-icon-cache: error while loading shared libraries: libffi.so.5: cannot open shared object file: No such file or directory
[2012-04-28 17:56] upgraded totem (3.4.1-1 -> 3.4.1-2)
[2012-04-28 17:56] upgraded wine (1.5.2-1 -> 1.5.3-1)
[2012-04-28 17:56] gtk-update-icon-cache: error while loading shared libraries: libffi.so.5: cannot open shared object file: No such file or directory

when i try to open terminator or gnome-terminal

#terminator 
You need to install the python bindings for gobject, gtk and pango to run Terminator.
#gnome-terminal 
gnome-terminal: error while loading shared libraries: libffi.so.5: cannot open shared object file: No such file or directory
 pacman -Qs libffi
local/lib32-libffi 3.0.10-3
    A portable, high level programming interface to various calling conventions (32 bits version)
local/libffi 3.0.11-1
    A portable, high level programming interface to various calling conventions

Archlinux X86_64

Offline

#5 2012-04-29 11:00:00

kjell
Member
From: Norway
Registered: 2012-03-26
Posts: 97

Re: chromium18.0.1025.162-1 needs libffi5

Yeah, basically dont install the last gnome updates...nothing works after the fact.  I dont even get any indictators why really..the shell just hangs infinitely.   for the libffi issue you can soft link to the new but that shouldn't be neccessary.......seems to be like a package failure somewhere.

Last edited by kjell (2012-04-29 11:01:35)

Offline

Board footer

Powered by FluxBB