You are not logged in.

#3876 2012-04-25 20:58:14

Unia
Member
From: The Netherlands
Registered: 2010-03-30
Posts: 2,476
Website

Re: The AMD/ATI Bar & Grill

Just build 12.4 myself to test with xorg 1.12. Doesn't work, segfaults. Seems like we still gotta use 1.11 for another while...

OTOH, I don't notice any (performance) issues with 12.4. Not yet, at least.

EDIT: .:B:.: I just played a video with mplayer-xvba, no artifacts for me. I don't know if that means xmbc has them or not, but mplayer at least doesn't.

Last edited by Unia (2012-04-25 20:59:50)


If you can't sit by a cozy fire with your code in hand enjoying its simplicity and clarity, it needs more work. --Carlos Torres

Offline

#3877 2012-04-25 21:53:23

.:B:.
Forum Fellow
Registered: 2006-11-26
Posts: 5,819

Re: The AMD/ATI Bar & Grill

The XvBA build(s) of Xbmc might have issues with 12.4, depending on the branch tested.

Nice to see 1.12 still doesn't work with catalyst... That's two updates already.


Got Leenucks? :: Arch: Power in simplicity :: Get Counted! Registered Linux User #392717 :: Blog thingy

Offline

#3878 2012-04-25 23:25:27

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,335
Website

Re: The AMD/ATI Bar & Grill

catalyst 12.4
yup, still segfault with xserver 1.12...

i'm also concerned about 3.4 kernel support for which there's no patch but just an ugly workaround which is also engaging a patching of kernel's headers, and there's kernel 3.4 rc4 already, guess there could be a problem with it in near future.


and ofcourse info from snack about incoming death of support of my good not-so-oldie tongue 4850... ahhh... hard days for amd's hw users, hard days


anyway catalyst was updated on AUR, i should update repos tomorrow, now gotta sleep Zzz...

Offline

#3879 2012-04-26 08:40:15

andmars
Member
Registered: 2012-03-13
Posts: 158

Re: The AMD/ATI Bar & Grill

hi,

I don't really understand all this rant about AMD.
All they said was that Catalyst 12.5 is going to be the basis for all older cards and there will be updates every three months when nessessary. The reason is that these older cards have reached their limits when it comes to optimization and already have all their features.

If 12.4 doesn't support kernel 3.4 yet so what? Just put it in the ignore updates section and wait 1-2 weeks until 12.5 comes out. That's Arch Linux and we love the latest an greatest. But I don't mind updating the kernel a few weeks later. It's nothing compared to other distros who skip kernel releases entirely.

There are other things that are a much bigger pain than Catalyst 12.4 not supporting x.org 1.12.

With x.org 1.11 flash movies in fullscreen are still laggy and freeze for a couple of seconds. So I'm still on x.org 1.10.

And when it comes to playing games under wine AMD users seem to have graphic glitches that nvidia users just don't have. Here is a screenshot of me playing Aion free2play with GLSL enabled. This white stuff all around is the AMD exclusive feature :-)

http://www-public.rz.uni-duesseldorf.de … on0013.jpg

Offline

#3880 2012-04-26 09:43:40

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,335
Website

Re: The AMD/ATI Bar & Grill

andmars wrote:

hi,

I don't really understand all this rant about AMD.
All they said was that Catalyst 12.5 is going to be the basis for all older cards and there will be updates every three months when nessessary. The reason is that these older cards have reached their limits when it comes to optimization and already have all their features.

If 12.4 doesn't support kernel 3.4 yet so what? Just put it in the ignore updates section and wait 1-2 weeks until 12.5 comes out. That's Arch Linux and we love the latest an greatest. But I don't mind updating the kernel a few weeks later. It's nothing compared to other distros who skip kernel releases entirely.

There are other things that are a much bigger pain than Catalyst 12.4 not supporting x.org 1.12.

With x.org 1.11 flash movies in fullscreen are still laggy and freeze for a couple of seconds. So I'm still on x.org 1.10.

And when it comes to playing games under wine AMD users seem to have graphic glitches that nvidia users just don't have. Here is a screenshot of me playing Aion free2play with GLSL enabled. This white stuff all around is the AMD exclusive feature :-)

http://www-public.rz.uni-duesseldorf.de … on0013.jpg

Yes, from practical point of view you could be right - aspecially when saying that there is bigger pain like ie. mentioned wine bugs.

But... well... imho you are too optimistic smile. i don't believe in amd's support, sorry but they dissapointed me (and i believe not only me) so many times that i really can't believe it. I would really like to think otherwise as there's still a hope in me for AMD, but i just can't.

Why do you think that 3.4 kernel could be supported by catalyst 12.5? I'm 99,999% sure that there won't be such thing, i'm pretty sure that also 12.6 won't support it and maybe we won't see it on 12.7 since AMD isn't working that hard on vacations wink (naah, let's not be such pessimistic ,12.7 should support it!). History already showed us that if community won't provide patches - then we would have to wait for a long time for amd to make driver work. And believe me or not there are people which are waiting for newest kernels because of it's functionality or hardware support.

Updates for every 3 months for hd 2000/3000/4000 _if neccessary_ - time will show how will this work <fingers crossed>
But i must to say that for me (as a maintainer) building and releasing catalyst > 12.7 without possibility of checking/testing is unthinkable.
I'm thinking now about bying ie. hd 7850 which imho really is a good piece of hw, but when i see a better support from nvidia i... i need to think about it ;P

Offline

#3881 2012-04-26 11:04:55

ChemBro
Member
Registered: 2008-10-22
Posts: 691

Re: The AMD/ATI Bar & Grill

Where does it say, there will be a update for older cards every 3 month? I don't think, this will happen for Linux.

Offline

#3882 2012-04-26 11:14:01

andmars
Member
Registered: 2012-03-13
Posts: 158

Re: The AMD/ATI Bar & Grill

ChemBro wrote:

Where does it say, there will be a update for older cards every 3 month? I don't think, this will happen for Linux.

I got this from the german gamesite gamestar.de

http://www.gamestar.de/hardware/news/tr … alyst.html

Offline

#3883 2012-04-26 17:12:27

LeCrayonVert
Member
Registered: 2010-09-01
Posts: 133

Re: The AMD/ATI Bar & Grill

Unia wrote:
LeCrayonVert wrote:

Is there anyone that uses Xorg 1.11, catalyst driver and Gnome 3.4 ? It seems there are some issues after the upgrade ? I've got no more multimedia keys support...
It seems to be related to https://bugzilla.novell.com/show_bug.cgi?id=756563... only solution would be to upgrade to Xorg 1.12....which is not possible right now...

If it is 1.12 you need, then the wait shouldn't be that long. I expect 12.4 to be released somewhat before or after Ubuntu 12.04 wink (which is april 26 fyi)



I was actually running Xorg 1.10 (xorg110) instead of xorg111.... After upgrading to 111, everything works fine wink


I believe in a world I can and do understand. A rational universe, explained through rational means.

Offline

#3884 2012-04-26 17:28:12

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,335
Website

Re: The AMD/ATI Bar & Grill

Funny cuz for me Gnome 3.4 is first stable from 3.x line :-).

Last edited by Vi0L0 (2012-04-26 17:28:52)

Offline

#3885 2012-04-26 18:20:13

Unia
Member
From: The Netherlands
Registered: 2010-03-30
Posts: 2,476
Website

Re: The AMD/ATI Bar & Grill

Vi0L0 wrote:

Funny cuz for me Gnome 3.4 is first stable from 3.x line :-).

So gnome shell is actually working now?


If you can't sit by a cozy fire with your code in hand enjoying its simplicity and clarity, it needs more work. --Carlos Torres

Offline

#3886 2012-04-26 19:41:10

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,335
Website

Offline

#3887 2012-04-26 20:06:09

GERGE
Member
From: Turkey
Registered: 2008-09-29
Posts: 157
Website

Re: The AMD/ATI Bar & Grill

Gnome 3.4 is working very well wtih clutter hack. No problem yet.

Offline

#3888 2012-04-27 07:46:13

xorgx3
Member
From: Poland
Registered: 2011-11-29
Posts: 197

Re: The AMD/ATI Bar & Grill

After upgrade catalyst-utils I have to generate new xorg.conf?

Offline

#3889 2012-04-27 07:57:22

andmars
Member
Registered: 2012-03-13
Posts: 158

Re: The AMD/ATI Bar & Grill

xorgx3 wrote:

After upgrade catalyst-utils I have to generate new xorg.conf?

depends on how you install your catalyst and catalyst-utils. Personally I install the packages from AUR which means they build against that current kernel installed on my system. And then as root I do:

aticonfig --initial --input=/etc/X11/xorg.conf

If everything works fine you can remove the backup file. So, yes you generate a new xorg.conf. Don't know what it's like if you use the repos or other packages from AUR.

Offline

#3890 2012-04-27 09:18:53

mpnordland
Member
Registered: 2011-11-29
Posts: 46

Re: The AMD/ATI Bar & Grill

Vi0L0 wrote:

catalyst 12.4
and ofcourse info from snack about incoming death of support of my good not-so-oldie tongue 4850... ahhh... hard days for amd's hw users, hard days

Yeah, its a shame. My 4650 is only two years old.
Anyway, the Clutter vblank hack doesn't seem to work here for me, I've heard several different places to put it, where is the correct place?

Offline

#3891 2012-04-27 09:32:43

GERGE
Member
From: Turkey
Registered: 2008-09-29
Posts: 157
Website

Re: The AMD/ATI Bar & Grill

I put is to /etc/profile

Also put this there: GDK_NATIVE_WINDOWS=1

Gives some flash improvements on some systems, doesn't hurt anyway.

Offline

#3892 2012-04-28 19:26:03

Squiddles
Member
Registered: 2011-05-31
Posts: 73

Re: The AMD/ATI Bar & Grill

Is anyone else experiencing stuttering with window movement? I can't move windows or scroll in thunar without awful stuttering and choppiness. I'm using AwesomeWM with catalyst 12.4 and xorg 1.11 with kernel 3.3.3-1. Also 1080p video playback is slowed and mildly choppy

I'm using a 5870 if that changes anything.

Just noticed this happening when trying to play some GBA games, and tested again with glxgears. I get this error all of the sudden:

X Error of failed request:  BadRequest (invalid request code or no such operation)
  Major opcode of failed request:  136 (GLX)
  Minor opcode of failed request:  19 (X_GLXQueryServerString)
  Serial number of failed request:  15
  Current serial number in output stream:  15

Not sure if it's related, but I wasn't getting this before 12.4

Last edited by Squiddles (2012-04-28 19:54:56)

Offline

#3893 2012-04-28 21:01:36

ChemBro
Member
Registered: 2008-10-22
Posts: 691

Re: The AMD/ATI Bar & Grill

Squiddles wrote:

Just noticed this happening when trying to play some GBA games, and tested again with glxgears. I get this error all of the sudden:

X Error of failed request:  BadRequest (invalid request code or no such operation)
  Major opcode of failed request:  136 (GLX)
  Minor opcode of failed request:  19 (X_GLXQueryServerString)
  Serial number of failed request:  15
  Current serial number in output stream:  15

Not sure if it's related, but I wasn't getting this before 12.4

That means, your Catalyst update failed. You are on vesa right now.

Offline

#3894 2012-04-28 21:06:19

xsmile
Member
Registered: 2012-03-31
Posts: 21

Re: The AMD/ATI Bar & Grill

I get the same error when upgrading from 12.3 to 12.4.
The only thing I tried was to regenerate a new xorg.conf with 'aticonfig' but it didn't help.
Now I'm back at 12.3.

Offline

#3895 2012-04-28 23:49:30

padster
Member
Registered: 2012-03-14
Posts: 24
Website

Re: The AMD/ATI Bar & Grill

Same here:

Error of failed request:  BadRequest (invalid request code or no such operation)
  Major opcode of failed request:  139 (ATIFGLEXTENSION)
  Minor opcode of failed request:  66 ()
  Serial number of failed request:  13
  Current serial number in output stream:  13

From 12.3 to 12.4, using catalyst-daemon.

Offline

#3896 2012-04-29 00:03:08

Squiddles
Member
Registered: 2011-05-31
Posts: 73

Re: The AMD/ATI Bar & Grill

ChemBro wrote:
Squiddles wrote:

Just noticed this happening when trying to play some GBA games, and tested again with glxgears. I get this error all of the sudden:

X Error of failed request:  BadRequest (invalid request code or no such operation)
  Major opcode of failed request:  136 (GLX)
  Minor opcode of failed request:  19 (X_GLXQueryServerString)
  Serial number of failed request:  15
  Current serial number in output stream:  15

Not sure if it's related, but I wasn't getting this before 12.4

That means, your Catalyst update failed. You are on vesa right now.

Ah, thanks, a quick reinstall and reboot, and it's all fixed. Just posting incase it was a bug.

Offline

#3897 2012-04-29 16:09:31

xorgx3
Member
From: Poland
Registered: 2011-11-29
Posts: 197

Re: The AMD/ATI Bar & Grill

I have this same. Xorg 1.10. Reinstall catalyst-utils didn't help. Only way to fix them is downgrade package?

Offline

#3898 2012-04-29 17:08:54

padster
Member
Registered: 2012-03-14
Posts: 24
Website

Re: The AMD/ATI Bar & Grill

xorgx3 wrote:

I have this same. Xorg 1.10. Reinstall catalyst-utils didn't help. Only way to fix them is downgrade package?

I'm using Xorg 1.11, it was was working with 12.3. Maybe try using Xorg 1.11.

I'm going to try to reinstall the catalyst now, and see if that works...

EDIT: I confirm that it works after a reinstall. I ran "yaourt -Sy catalyst-daemon catalyst-utils lib32-catalyst-utils" then "sudo aticonfig --initial", rebooted, and it works again.

Last edited by padster (2012-04-29 17:18:36)

Offline

#3899 2012-04-29 17:29:38

PhotonX
Member
From: Munich
Registered: 2008-08-10
Posts: 434

Re: The AMD/ATI Bar & Grill

Same problem here. Using catalyst-hook and kernel 3.3.3.  Xorg.0.log reports:

[ 1620.030] (EE) fglrx(0): incompatible kernel module detected - HW accelerated OpenGL will not work
[ 1620.130] (EE) fglrx(0): XMM failed to open CMMQS connection.(EE) fglrx(0):
[ 1620.130] (EE) fglrx(0): XMM failed to initialize

/var/log/catalyst-install.log reports:

--------
2012-04-28 08:13:12
Building fglrx module for 3.3.3-1-ARCH kernel ...
--------
patching file Makefile
Hunk #1 succeeded at 68 (offset 2 lines).
patching file firegl_public.c
Hunk #1 succeeded at 5807 with fuzz 1 (offset 10 lines).
OsVersion says: SMP=1
file /proc/kallsyms says: SMP=1
file /lib/modules/3.3.3-1-ARCH/build/include/generated/autoconf.h says: SMP=1
0
1
file /lib/modules/3.3.3-1-ARCH/build/include/generated/autoconf.h says: MODVERSIONS=1
0
1
file /lib/modules/3.3.3-1-ARCH/build/arch/x86/include/asm/compat.h says: COMPAT_ALLOC_USER_SPACE=arch_compat_alloc_user_space
make: Entering directory `/usr/src/linux-3.3.3-1-ARCH'
CC [M] /tmp/catalyst.0iHIZM/firegl_public.o
CC [M] /tmp/catalyst.0iHIZM/kcl_acpi.o
CC [M] /tmp/catalyst.0iHIZM/kcl_agp.o
CC [M] /tmp/catalyst.0iHIZM/kcl_debug.o
CC [M] /tmp/catalyst.0iHIZM/kcl_ioctl.o
CC [M] /tmp/catalyst.0iHIZM/kcl_io.o
CC [M] /tmp/catalyst.0iHIZM/kcl_pci.o
CC [M] /tmp/catalyst.0iHIZM/kcl_str.o
CC [M] /tmp/catalyst.0iHIZM/kcl_iommu.o
CC [M] /tmp/catalyst.0iHIZM/kcl.o
CC [M] /tmp/catalyst.0iHIZM/kcl_wait.o
LD [M] /tmp/catalyst.0iHIZM/fglrx.o
Building modules, stage 2.
MODPOST 1 modules
CC /tmp/catalyst.0iHIZM/fglrx.mod.o
LD [M] /tmp/catalyst.0iHIZM/fglrx.ko
make: Leaving directory `/usr/src/linux-3.3.3-1-ARCH'
cat: /lib/modules/extramodules-3.2-ARCH/version: No such file or directory
Ok.

Any hints?


Desktop: http://www.sysprofile.de/id15562, Arch Linux    |    Notebook: Thinkpad X200 Tablet, Manjaro

The very worst thing you can do with free software is to download it, see that it doesn't work for some reason, leave it, and tell your friends that it doesn't work.  -  Tuomas Lukka

Offline

#3900 2012-04-29 17:35:00

GERGE
Member
From: Turkey
Registered: 2008-09-29
Posts: 157
Website

Re: The AMD/ATI Bar & Grill

It works well for me. 32 or 64?

Offline

Board footer

Powered by FluxBB