You are not logged in.

#1 2012-05-02 15:56:19

iwan_groznyj
Member
Registered: 2012-04-18
Posts: 3

[SOLVED] Kmail/Kwallet: how to prevent autostart?

Hi, all!


I'm using KDE 4.8 on arch linux.  Recently I switched from thunderbird to kmail.  Since then kwallet asks for my password on every boot because the imap servers request to open the wallet.

When there is no wifi connection present or when I boot into my custom session (dwm window manager), I am not asked for my password.

System Settings > Startup and Shutdown says there is no kwallet/kmail, neither in Autostart nor in Service Manager.  Also KDE starts always with an empty session.  ~/.kde4/Autostart and ~/.kde4/share/autostart are empty.

I'm kinda lost now.  How do I prevent kmail/kwallet from starting on each boot?


Thanks in advance!

Last edited by iwan_groznyj (2012-05-03 09:29:10)

Offline

#2 2012-05-02 21:06:16

framas
Member
Registered: 2009-07-24
Posts: 50

Re: [SOLVED] Kmail/Kwallet: how to prevent autostart?

Hi,

kmail2, which is part of kde since version 4.7 uses akonadi as backend to fetch your emails. Akonadi is started by kde when its starting up. If a network connection is availabe akonadi and not kmail ask for your wallet password to synchronize your imap servers. Maybe you can prevent this issue if you disable the network monitoring service in kde but I don't know if this has not other side effects on other kde programs. I hope this answer could help you a little (even if it doesn't solve your problem).



iwan_groznyj wrote:

Hi, all!


I'm using KDE 4.8 on arch linux.  Recently I switched from thunderbird to kmail.  Since then kwallet asks for my password on every boot because the imap servers request to open the wallet.

When there is no wifi connection present or when I boot into my custom session (dwm window manager), I am not asked for my password.

System Settings > Startup and Shutdown says there is no kwallet/kmail, neither in Autostart nor in Service Manager.  Also KDE starts always with an empty session.  ~/.kde4/Autostart and ~/.kde4/share/autostart are empty.

I'm kinda lost now.  How do I prevent kmail/kwallet from starting on each boot?


Thanks in advance!

Last edited by framas (2012-05-02 21:07:22)

Offline

#3 2012-05-02 23:07:21

iwan_groznyj
Member
Registered: 2012-04-18
Posts: 3

Re: [SOLVED] Kmail/Kwallet: how to prevent autostart?

Hi!

Thank you for your answer.  I disabled the Network Status service, but still kwallet keeps asking the same questions on startup.
The Load-on-Demand Services list also says that the Network Watcher service isn't running.

Where else can I look?

Offline

#4 2012-05-03 07:22:00

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 1,783

Re: [SOLVED] Kmail/Kwallet: how to prevent autostart?

Go to Kmail settings -> accounts, and for each account enable "switch offline when closing kmail" in the drop-down menu

Offline

#5 2012-05-03 09:28:52

iwan_groznyj
Member
Registered: 2012-04-18
Posts: 3

Re: [SOLVED] Kmail/Kwallet: how to prevent autostart?

arojas wrote:

Go to Kmail settings -> accounts, and for each account enable "switch offline when closing kmail" in the drop-down menu

That did the trick.  Thank you very much.

Offline

Board footer

Powered by FluxBB