You are not logged in.

#101 2012-04-10 16:51:43

dodo3773
Member
Registered: 2011-03-17
Posts: 798

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

mr.wizrd wrote:

Just in case any of you are interested, here's a more technical explanation of the problems with the older version.

The last working version for me is:

flashplugin    11.1.102.63-1

In that article it says:

This vulnerability CVE-2012-0769, with another one that my colleague Tavis Ormandy found, were
patched in version 11.1.102.63 [3] released the 05/Mar/2012.
According to Adobe, all versions earlier to 11.1.102.63 are impacted by this vulnerability. Flash
users can check their current version and latest available one at Adobe’s website[4].

So using the older version that works should not be affected by this vulnerability anyways.

Offline

#102 2012-04-10 20:34:38

delacruz
Member
From: /home/houston
Registered: 2007-12-09
Posts: 102

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

If all you need flash is for youtube you can consider switching youtube from flash to html5 via http://www.youtube.com/html5

smile

Offline

#103 2012-04-11 18:52:12

Atmoz
Member
Registered: 2012-04-01
Posts: 4

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

delacruz wrote:

If all you need flash is for youtube you can consider switching youtube from flash to html5 via http://www.youtube.com/html5

smile

Atmoz wrote:

That's not a good solution, because html5 is used only on videos without advertising, they use flash as fallback. Hopefully they will add support for advertising in the html5 player too at some point.

Offline

#104 2012-04-11 20:06:13

Gusar
Member
Registered: 2009-08-25
Posts: 3,466

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

dodo3773 wrote:

So using the older version that works should not be affected by this vulnerability anyways.

Not by this one, but there's CVE-2012-0773 which does affect 11.1.102.63

And the only reason 11.1 works is because it has hardware presentation disabled. Turning off functionality is not my idea of a fix. You can do such turning off even in later, not vulnerable versions.

Online

#105 2012-04-12 15:18:29

fatino
Member
Registered: 2012-04-07
Posts: 9

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

I dont know guys but after last nvidia update it works somehow. Before it was crashing all the time. Now it seems fine. I will test some more.
EDIT: Sorry for spam post... it still doesnt work.

Last edited by fatino (2012-04-12 15:20:17)

Offline

#106 2012-04-13 03:21:43

usuario1986
Member
Registered: 2010-11-26
Posts: 9

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

Not sure if too late, but I had the problem of smurfish people on youtube videos too.
When you install flashplugin from the extra repositories, pacman gives a message:

>> 
 >> If you have an NVIDIA card that supports libvdpau or Broadcom Crystal HD chips,
 >> uncomment EnableLinuxHWVideoDecode=1 from /etc/adobe/mms.cfg.
 >> If you run into problems, please contact nVidia or Broadcom along with your system config info / driver version.
 >> 

I uncommented that line and videos started to play well, without having to turn off hardware acceleration. Hope it helps someone.
Cheers.


EDIT: still have the problem. Update to new version of flashplugin worked with videos of youtube, but out of youtube (videos posted in forums, etc). In the main youtube site, they were still blue. Also, after uncommenting this line, flashplugin crashed frequently. I downgraded flashplugin, and for now, everything seems to work fine. hmm
I hate this flash crap, it always makes navigation uncomfortable.

Last edited by usuario1986 (2012-04-16 00:13:57)

Offline

#107 2012-04-13 07:21:54

mr.wizrd
Member
From: Hull, UK
Registered: 2012-03-31
Posts: 8

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

So, I thought you needed flashplugin installed to use flash in Google Chrome. Apparently it works fine without! If you're using Chrome, try just uninstalling flashplugin and restarting Chrome. No more crashes and super smooth performance big_smile

Offline

#108 2012-04-13 11:37:58

zilverling
Member
From: Utrecht, Netherlands
Registered: 2009-08-19
Posts: 56

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

>>
>> If you have an NVIDIA card that supports libvdpau or Broadcom Crystal HD chips,
>> uncomment EnableLinuxHWVideoDecode=1 from /etc/adobe/mms.cfg.
>> If you run into problems, please contact nVidia or Broadcom along with your system config info / driver version.
>>

This works fine for YouTube clips but on Vimeo I get crashes all the time. When I set EnableLinuxHWVideoDecode=0 Vimeo works fine and YouTube behaves smurfish.

An additional annoyance is that the video frame is always on top: if I move a black background XFCE terminal emulator window over the video frame, the terminal window seems transparent and the video "shows through". The video colours also show up in black text on white background in a window above the video frame.

Checking on the Adobe site it seems there's a newer version of the flashplugin (11.2.202.233) than the one currently provided in the /extra repository (11.2.202.228-1).

Offline

#109 2012-04-13 12:14:39

2Karl
Member
From: Rugby, UK
Registered: 2012-03-26
Posts: 56
Website

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

fast_rizwaan wrote:

this fixed my blue flash video problem on x64 arch and no crashes on youtube:

To fix blue color

cat /etc/adobe/mms.cfg 
#Hardware video decoding
EnableLinuxHWVideoDecode=1
OverrideGPUValidation=true

And to fix crashes after setting the above add "export VDPAU_NVIDIA_NO_OVERLAY=1" to ~/.xinitrc

I can confirm that this solution works perfectly for me, running flashplugin 11.2.202.228-1. I've read that setting VDPAU_NVIDIA_NO_OVERLAY to 1 may cause visual tearing, but as yet I have not observed this. Incidentally, you do not have to export the environment variable in .xinitrc, you could make a script to launch firefox which exports the variable prior to launching FF. something like:

#!/bin/bash
export VDPAU_NVIDIA_NO_OVERLAY=1
/usr/bin/firefox

And then call that script when you want to run the browser.

Seems I spoke too soon; although the vids are fixed in youtube, they still seenm to crash everywhere else.

Further edit: I finally fixed this by installing the package flashplugin_src from the AUR.

Last edited by 2Karl (2012-04-14 13:12:01)


It's affine day for a new sig:
13XQLTXH?R%20GLVHDVB!1046210467104640201045B104731046F02010458104731045902
010450104681045B1046910462104681046F02E0201045A104731045102010458104750201
04780201046F1046A104510201046902010461104671045B1047202010458104671045102E

Offline

#110 2012-04-19 19:37:22

JKAbrams
Member
From: Sweden
Registered: 2011-11-07
Posts: 81

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

Here are two adobe-free alternatives for some video sites.

VLC has got support for playing youtube and vimeo videos.
Use 'Open network stream' and paste the URL.
Bonus features: non-choppy video playback and its possible to have fullscreen on one screen while you do something on the other plus all the other features of VLC like syncing to make all those unsynced youtube videos whatchable. In the latest version they fixed the slider so it wont stop playback if you seek too far.

It is a little bit of an overhead to copy-paste the url, so if anyone has got a one-click solution to open flash videos in VLC from Firefox please share it!

The other application is Piratplayer from AUR, an application made to watch Swedish online television and some more sites. It claims support for (ABF-play, Aftonbladet-TV, Axess-TV, Ceskatelevize, DR NU, Discovery, Elitserien-play, Filmarkivet, Fotbollskanalen, Kanal 5-play, Kanal 9-play, Kanal9-play, NRK nett-TV, PBS, SR, SVT-play, TV3-play, TV4-play, TV6-play, TV8-play, UR-play, VGTV, Vimeo, Youtube) I have tested it for SVT, TV4 and Vimeo, but I was not able to use it for youtube (like VLC you paste the url).
Bonus feature: you're able to download/save the videos.

Perhaps a midterm solution for online video on linux would be a combination of Firefox, VLC and RTMPdump with some glue to make it integrated/seemless. Anyone up for the task?

Last edited by JKAbrams (2012-04-19 19:39:00)

Offline

#111 2012-04-22 19:26:17

toad
Member
From: if only I knew
Registered: 2008-12-22
Posts: 1,775
Website

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

A simple right click on youtube - settings - get rid of the "Enable Hardware Acceleration" gets rid of the blues for me.


never trust a toad...
::Grateful ArchDonor::
::Grateful Wikipedia Donor::

Offline

#112 2012-04-22 20:10:43

Gusar
Member
Registered: 2009-08-25
Posts: 3,466

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

toad wrote:

A simple right click on youtube - settings - get rid of the "Enable Hardware Acceleration" gets rid of the blues for me.

Yes, but it also gets rid of hardware acceleration. If your CPU is fast enough, or if you don't care about battery drain (maybe you're on a desktop, where there isn't a battery to drain), not having hardware accel may not matter. But on a non-fast CPU, flash might not work well without it.

Online

#113 2012-04-22 23:23:04

venomx3
Member
Registered: 2012-04-22
Posts: 1

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

I fixed the blue tint issue by right clicking on youtube video (any flash content should work) -> settings -> making sure "enable hardware acceleration" IS clicked. Turn off firefox, then adding the file /etc/adobe/mms.cfg filled with only
...
#Hardware video decoding
EnableLinuxHWVideoDecode=1
...

That's all I did, problem solved. I am using flash version 11.2.202.233

Last edited by venomx3 (2012-04-22 23:23:23)

Offline

#114 2012-04-24 09:14:21

phoric
Member
From: Seattle, WA
Registered: 2011-10-17
Posts: 21

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

venomx3 wrote:

That's all I did, problem solved. I am using flash version 11.2.202.233


As mentioned previously in this thread, this technique 'fixes' the blue tint issue but causes Flash plugin and browser crashes on video resize and other conditions.

Offline

#115 2012-05-05 20:35:23

korpenkraxar
Member
Registered: 2006-04-02
Posts: 123

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

To be able to play hardware accelerated video on youtube and headweb (Swedish streaming video service) AND have correct colors I had to use Chromium's Pepper version of Flash (which you can find in AUR) as per this recommendation: https://wiki.archlinux.org/index.php/Fl … and_Nvidia

Thanks Adobe for this glorious turd of a retreat from Linux :-/

Offline

#116 2012-05-06 05:05:08

Scotty
Member
From: Canada
Registered: 2010-07-26
Posts: 69

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

mr.wizrd wrote:

So, I thought you needed flashplugin installed to use flash in Google Chrome. Apparently it works fine without! If you're using Chrome, try just uninstalling flashplugin and restarting Chrome. No more crashes and super smooth performance big_smile

I tried this, and this caused every single youtube video to be "unavailable". In addition, flash video of Vimeo did work but required me to right-click on the desktop to get the video to un-freeze, and would re-freeze when the mouse was brought over the video frame. Flash video on other sites was a bit better but had problems going fullscreen and back. But the blue tint was gone. Strangely enough the only place the blue tint was present previously was on youtube videos watched on youtube and not embedded on facebook or whatnot.

This is the first time, too, that I've had ANY sort of trouble with flash video on Linux. The issue is only present on my desktop, too. Thanks Adobe, in your infinite wisdom of putting out such a bad, buggy version for your last Linux release.

Edit: Trying Gnash makes youtube work great, but there is no fullscreen, and flash on every other site does not work

Last edited by Scotty (2012-05-06 05:33:33)

Offline

#117 2012-05-07 02:04:42

japenagosc
Member
Registered: 2012-01-19
Posts: 78

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

Just wanted to ask: Is there a definitive solution for this with flash instead of other alternatives?

Offline

#118 2012-05-07 06:06:07

akspecs
Member
Registered: 2012-02-11
Posts: 169

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

japenagosc wrote:

Just wanted to ask: Is there a definitive solution for this with flash instead of other alternatives?

No just crap workarounds,  I turned off hardware acceleration via the flash GUI.

Offline

#119 2012-05-07 08:36:05

Gusar
Member
Registered: 2009-08-25
Posts: 3,466

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

There's one workaround that isn't crap. This one: http://lists.freedesktop.org/archives/v … 00022.html

It only applies to libvdpau-git, so here's a PKGBUILD for that: http://pastebin.com/fkjZvL49

Online

#120 2012-05-07 12:52:25

Earnestly
Member
Registered: 2011-08-18
Posts: 805

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

Gusar wrote:

There's one workaround that isn't crap. This one: http://lists.freedesktop.org/archives/v … 00022.html

It only applies to libvdpau-git, so here's a PKGBUILD for that: http://pastebin.com/fkjZvL49

Already been done, on page 1 of this thread (and don't have to use -git): https://bbs.archlinux.org/viewtopic.php … 8#p1078368

Offline

#121 2012-05-07 12:58:32

Gusar
Member
Registered: 2009-08-25
Posts: 3,466

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

Kaustic wrote:

Already been done, on page 1 of this thread (and don't have to use -git): https://bbs.archlinux.org/viewtopic.php … 8#p1078368

Nope, you're talking about a different patch that abuses the trace library. This new patch doesn't, it leaves the trace library intact. It also means you don't need any special incantations to launch firefox.

Last edited by Gusar (2012-05-07 12:59:18)

Online

#122 2012-05-07 13:09:00

akspecs
Member
Registered: 2012-02-11
Posts: 169

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

Gusar wrote:

There's one workaround that isn't crap. This one: http://lists.freedesktop.org/archives/v … 00022.html

It only applies to libvdpau-git, so here's a PKGBUILD for that: http://pastebin.com/fkjZvL49

Thanks for this.  Much different than what is on page 1 - and there's nothing wrong with using git wink

No need to disable hardware acceleration - very nice...

Last edited by akspecs (2012-05-07 13:32:17)

Offline

#123 2012-05-07 13:20:20

Kaurin
Member
From: Ireland
Registered: 2011-12-11
Posts: 66

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

Gusar: Can you please make an AUR tarball with flash_hack.patch?
I'm not very familiar with patching. Not very confident about what I have to paste into flash_hack.patch file from that mail archive link.

Offline

#124 2012-05-07 14:24:11

japenagosc
Member
Registered: 2012-01-19
Posts: 78

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

Kaurin wrote:

Gusar: Can you please make an AUR tarball with flash_hack.patch?
I'm not very familiar with patching. Not very confident about what I have to paste into flash_hack.patch file from that mail archive link.

Ditto. Thanks

Offline

#125 2012-05-07 15:44:37

Gusar
Member
Registered: 2009-08-25
Posts: 3,466

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

Jeez folks, this is Arch. Where you're encouraged to learn stuff. There's a md5sum in the PKGBUILD, so you'll know if you got it right. The patch begins with the line that says diff and ends with the line before the --. However, add an empty line at the end of the file.

Last edited by Gusar (2012-05-07 15:47:24)

Online

Board footer

Powered by FluxBB