You are not logged in.

#126 2012-05-07 22:36:38

akspecs
Member
Registered: 2012-02-11
Posts: 169

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

Gusar wrote:

However, add an empty line at the end of the file.

I think that's why I had to input my own md5sum but thanks.

Offline

#127 2012-05-07 23:10:33

JKAbrams
Member
From: Sweden
Registered: 2011-11-07
Posts: 81

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

Gusar wrote:

Jeez folks, this is Arch. Where you're encouraged to learn stuff.

Thanks, I just did (and it was not hard).
Perhaps this lowers the threshold (or saves two minutes of time).
Copy/past into terminal:

mkdir libvdpau-git
cd libvdpau-git
# running code directly from some random site is bad security practice AND kills kittens, sorry for encurageing it.
wget http://hem.bredband.net/jserver/flash_hack.patch
wget http://hem.bredband.net/jserver/PKGBUILD
makepkg
sudo pacman -U libvdpau-git-201?????-1-x86_64.pkg.tar.xz

Now I really hope this patch works smile

edit: typo

Last edited by JKAbrams (2012-05-08 03:03:54)

Offline

#128 2012-05-13 14:13:14

jaymzcampbell
Member
From: london
Registered: 2011-01-10
Posts: 7
Website

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

The above from JKAbrams has fixed this issue for me with no probs, thanks! smile

Offline

#129 2012-05-14 14:06:54

PhatalError
Member
Registered: 2012-05-14
Posts: 5

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

Psykorgasm wrote:
oz wrote:

Something seems really broken with this version.

Oh no, nothing is broken, it's just Adobe's 'Farewell Linux support!' leaving gift.
Take a look at this: Adobe drops Flash for Linux... and the other flash breakage thread has an interesting post seemingly confirming adobe will not fix theese 11.2 issues, here.

Make you wonder how much Microsoft paid them to discontinue Linux support, and to leave us stuck with a broken version. Heh. tongue

Offline

#130 2012-05-14 16:50:57

micer
Member
Registered: 2012-05-14
Posts: 12

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

Solution from JKAbrams helped me, I just had problem with undefined macro: AC_PROG_LIBTOOL, solved by installing package libtool. Thanks!

Offline

#131 2012-05-14 17:37:50

JKAbrams
Member
From: Sweden
Registered: 2011-11-07
Posts: 81

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

PhatalError wrote:
Psykorgasm wrote:
oz wrote:

Something seems really broken with this version.

Oh no, nothing is broken, it's just Adobe's 'Farewell Linux support!' leaving gift.
Take a look at this: Adobe drops Flash for Linux... and the other flash breakage thread has an interesting post seemingly confirming adobe will not fix theese 11.2 issues, here.

Make you wonder how much Microsoft paid them to discontinue Linux support, and to leave us stuck with a broken version. Heh. tongue

I have I hard time imagining that thay could have done anything worse to the linux version if they tried, so parhaps they did...

On topic: I can confirm that the patch solves the blue tint and the new crash bug, after using it for about a week on lots of different sites.
There is now a package in AUR: libvdpau-git-flashpatch 20120510-1

I commented out:

#EnableLinuxHWVideoDecode=1
#OverrideGPUValidation=true

in /etc/adobe/mms.cfg to make it work properly.

Last edited by JKAbrams (2012-05-14 17:38:42)

Offline

#132 2012-05-15 01:04:09

PhatalError
Member
Registered: 2012-05-14
Posts: 5

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

JKAbrams wrote:
PhatalError wrote:
Psykorgasm wrote:

Oh no, nothing is broken, it's just Adobe's 'Farewell Linux support!' leaving gift.
Take a look at this: Adobe drops Flash for Linux... and the other flash breakage thread has an interesting post seemingly confirming adobe will not fix theese 11.2 issues, here.

Make you wonder how much Microsoft paid them to discontinue Linux support, and to leave us stuck with a broken version. Heh. tongue

I have I hard time imagining that thay could have done anything worse to the linux version if they tried, so parhaps they did...

On topic: I can confirm that the patch solves the blue tint and the new crash bug, after using it for about a week on lots of different sites.
There is now a package in AUR: libvdpau-git-flashpatch 20120510-1

I commented out:

#EnableLinuxHWVideoDecode=1
#OverrideGPUValidation=true

in /etc/adobe/mms.cfg to make it work properly.


What I don't get is why the maintainer of the libvdpau in the official repository hasn't patched it yet "officially" though.

Offline

#133 2012-05-15 07:43:26

Gusar
Member
Registered: 2009-08-25
Posts: 3,472

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

PhatalError wrote:

What I don't get is why the maintainer of the libvdpau in the official repository hasn't patched it yet "officially" though.

a) He may not know about it.
b) It's a total hack. Much prettier than the other hacks, but still a hack.

Offline

#134 2012-05-15 16:23:49

kokoko3k
Member
Registered: 2008-11-14
Posts: 1,526

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

I join the voices claiming the variable export workarounds the issue, cpu usage is the same.
Anyway, flash doesn't tears at all, that's strange because mplayer does.
Tested mplayer and firefox with this:
http://www.youtube.com/watch?v=9vZvqNBGagw

-EDIT-
Seems there is tearing (mplayer or flash) only when you play 2 videos at the same time or something other is moving on the screen, definitely acceptable.
Another good thing on using the blit path seems to be the lower X.org cpu consumption when the window manager is forcing vsync, or at least, happens with kwin.

Last edited by kokoko3k (2012-05-15 17:13:28)

Offline

#135 2012-05-17 05:02:50

dodo3773
Member
Registered: 2011-03-17
Posts: 799

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

JKAbrams wrote:

On topic: I can confirm that the patch solves the blue tint and the new crash bug, after using it for about a week on lots of different sites.
There is now a package in AUR: libvdpau-git-flashpatch 20120510-1

Thank you the patch worked perfectly.

Offline

#136 2012-05-23 18:31:04

Convergence
Member
Registered: 2005-07-02
Posts: 370

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

Thanks JKAbrams.  Worked like a charm.


It's a very deadly weapon to know what you're doing
---  William Murderface

Offline

#137 2012-06-02 15:08:21

darkmav
Member
Registered: 2012-01-21
Posts: 73

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

This doesn't work for me. A link to the server cannot be established.

[vivek@krypton libvdpau-git]$ yaourt libvdpau-git-flashpatch
1 aur/libvdpau-git-flashpatch 20120510-1 (31)
    Nvidia VDPAU library from git with patch to fix flash blue tint and bleed 
    through
==> Enter n° of packages to be installed (ex: 1 2 3 or 1-3)
==> -------------------------------------------------------
==> 1


==> Downloading libvdpau-git-flashpatch PKGBUILD from AUR...
x PKGBUILD
x flash_patch.patch


Comment by: Smeagol07 on Thu, 17 May 2012 09:58:54 +0000
make depends on libtool	

Comment by: gulafaran on Thu, 17 May 2012 14:01:25 +0000
libtool is provided by base-devel	

Comment by: mrk3004 on Wed, 23 May 2012 18:25:48 +0000
add in makedepends automake and autoreconf, it does not compile without it	

Comment by: ZekeSulastin on Wed, 23 May 2012 18:59:47 +0000
... which are also provided by base-devel.

You guys might want to read https://wiki.archlinux.org/index.php/AUR ...	

First Submitted: Thu, 10 May 2012 19:05:31 +0000	
libvdpau-git-flashpatch 20120510-1 
( Unsupported package: Potentially dangerous ! )
==> Edit PKGBUILD ? [Y/n] ("A" to abort)
==> ------------------------------------
==> n

==> libvdpau-git-flashpatch dependencies:
 - gcc-libs (already installed)
 - git (already installed)
 - libx11 (already installed)

==> libvdpau-git-flashpatch conflicts:
 - libvdpau-0.4.1-2

==> Continue building libvdpau-git-flashpatch ? [Y/n]
==> -------------------------------------------------
==> 
==> Building and installing package
==> Determining latest git revision...
  -> Version found: 20120602
==> Making package: libvdpau-git-flashpatch 20120602-1 (Sat Jun  2 20:36:03 IST 2012)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving Sources...
  -> Found flash_patch.patch
==> Validating source files with md5sums...
    flash_patch.patch ... Passed
==> Extracting Sources...
==> Starting build()...
==> Connecting to GIT server....
Cloning into 'libvdpau'...
fatal: Unable to look up people.freedesktop.org (port 9418) (Name or service not known)
==> ERROR: A failure occurred in build().
    Aborting...
==> ERROR: Makepkg was unable to build libvdpau-git-flashpatch.
==> Restart building libvdpau-git-flashpatch ? [y/N]
==> ------------------------------------------------
==> 
==> Edit PKGBUILD ? [Y/n] ("A" to abort)
==> ------------------------------------
==> n

==> libvdpau-git-flashpatch dependencies:
 - gcc-libs (already installed)
 - git (already installed)
 - libx11 (already installed)

==> libvdpau-git-flashpatch conflicts:
 - libvdpau-0.4.1-2

==> Continue building libvdpau-git-flashpatch ? [Y/n]
==> -------------------------------------------------
==> 
==> Building and installing package
==> Determining latest git revision...
  -> Version found: 20120602
==> Making package: libvdpau-git-flashpatch 20120602-1 (Sat Jun  2 20:36:47 IST 2012)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving Sources...
  -> Found flash_patch.patch
==> Validating source files with md5sums...
    flash_patch.patch ... Passed
==> Extracting Sources...
==> Removing existing pkg/ directory...
==> Starting build()...
==> Connecting to GIT server....
Cloning into 'libvdpau'...
fatal: Unable to look up people.freedesktop.org (port 9418) (Name or service not known)
==> ERROR: A failure occurred in build().
    Aborting...
==> ERROR: Makepkg was unable to build libvdpau-git-flashpatch.
==> Restart building libvdpau-git-flashpatch ? [y/N]
==> ------------------------------------------------
==> 
[vivek@krypton libvdpau-git]$ 

Offline

#138 2012-06-05 16:54:56

lagagnon
Member
From: an Island in the Pacific...
Registered: 2009-12-10
Posts: 1,077
Website

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

Sorry, solved, ignore.

Last edited by lagagnon (2012-06-05 17:07:16)


Philosophy is looking for a black cat in a dark room. Metaphysics is looking for a black cat in a dark room that isn't there. Religion is looking for a black cat in a dark room that isn't there and shouting "I found it!". Science is looking for a black cat in a dark room with a flashlight.

Offline

#139 2012-06-11 19:23:38

splippity
Member
Registered: 2010-05-25
Posts: 144

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

Used AUR patch and worked like a charm thanks.

Offline

#140 2012-06-15 22:14:27

merilius
Member
Registered: 2012-06-15
Posts: 10

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

patching (library) A to fix a problem in (program) B is an ugly workaround.
But I applied the libvdpau-git-flashpatch patch anyway and it works fine for me.
I hope Adobe fixes the problem or... dies.

Last edited by merilius (2012-06-15 22:28:17)

Offline

#141 2012-06-16 16:24:34

Wilco
Member
Registered: 2008-11-09
Posts: 431

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

I also noticed resizing youtube videos takes about 5 minutes, during which the system is very unresponsive. Could that be related to this problem? Using up-to-date arch x64 system with nvidia binary drivers btw.

Offline

#142 2012-06-16 18:22:32

dodo3773
Member
Registered: 2011-03-17
Posts: 799

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

Wilco wrote:

I also noticed resizing youtube videos takes about 5 minutes, during which the system is very unresponsive. Could that be related to this problem? Using up-to-date arch x64 system with nvidia binary drivers btw.

This is probably related to hardware decoding of videos not the library issue. See post #79 of this thread and pay attention to the /etc/adobe/mms.cfg section.

Offline

#143 2012-06-19 13:20:18

SkyTod
Member
Registered: 2009-09-01
Posts: 214

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

==> Retrieving Sources...
  -> Found flash_patch.patch
==> Validating source files with md5sums...
    flash_patch.patch ... Passed
==> Extracting Sources...
==> Starting build()...
==> Connecting to GIT server....
Cloning into 'libvdpau'...
remote: Counting objects: 207, done.
remote: Compressing objects: 100% (122/122), done.
remote: Total 207 (delta 89), reused 148 (delta 64)
Receiving objects: 100% (207/207), 167.34 KiB | 115 KiB/s, done.
Resolving deltas: 100% (89/89), done.
==> GIT checkout done or server timeout
==> Starting build...
Cloning into '/tmp/yaourt-tmp-root/aur-libvdpau-git-flashpatch/src/libvdpau-build'...
done.
/tmp/yaourt-tmp-root/aur-libvdpau-git-flashpatch/./PKGBUILD: line 38: patch: command not found
==> ERROR: A failure occurred in build().
    Aborting...
==> ERROR: Makepkg was unable to build libvdpau-git-flashpatch.
==> Restart building libvdpau-git-flashpatch ? [y/N]

Offline

#144 2012-06-19 13:25:29

Psykorgasm
Member
From: England, UK
Registered: 2011-11-24
Posts: 158

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

SkyTod wrote:

[...]
Cloning into '/tmp/yaourt-tmp-root/aur-libvdpau-git-flashpatch/src/libvdpau-build'...
done.
/tmp/yaourt-tmp-root/aur-libvdpau-git-flashpatch/./PKGBUILD: line 38: patch: command not found
==> ERROR: A failure occurred in build().
    Aborting...
[...]

Did you try installing that package or what? Or you have patch package installed and there is an issue...?

Edit: Grammar.
/Edit 2: Even better, if you don't have it installed, just go ahead and install the whole "base-devel" group smile

Last edited by Psykorgasm (2012-06-19 13:30:27)

Offline

#145 2012-06-19 13:33:12

SkyTod
Member
Registered: 2009-09-01
Posts: 214

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

Yeah. I reported to AUR. Thanks.

Offline

#146 2012-06-19 13:38:50

Psykorgasm
Member
From: England, UK
Registered: 2011-11-24
Posts: 158

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

Did you mark it out of date and add:

Wiseacre wrote:

Add patch, autoconf, automake to decencies.

?

This is not correct, you (and/or that Wiseacre) should follow the wiki: AUR: Getting Started,
The very first point is important, the package is not out of date and it should not have silly dependencies added because people are too lazy to read while learning the basics. Hopefully you got it built and working though smile

Offline

#147 2012-08-24 17:01:07

Lockheed
Member
Registered: 2010-03-16
Posts: 1,437

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

JKAbrams wrote:
PhatalError wrote:
Psykorgasm wrote:

Oh no, nothing is broken, it's just Adobe's 'Farewell Linux support!' leaving gift.
Take a look at this: Adobe drops Flash for Linux... and the other flash breakage thread has an interesting post seemingly confirming adobe will not fix theese 11.2 issues, here.

Make you wonder how much Microsoft paid them to discontinue Linux support, and to leave us stuck with a broken version. Heh. tongue

I have I hard time imagining that thay could have done anything worse to the linux version if they tried, so parhaps they did...

On topic: I can confirm that the patch solves the blue tint and the new crash bug, after using it for about a week on lots of different sites.
There is now a package in AUR: libvdpau-git-flashpatch 20120510-1

I commented out:

#EnableLinuxHWVideoDecode=1
#OverrideGPUValidation=true

in /etc/adobe/mms.cfg to make it work properly.

After reading this whole thread, I still do not know if this solution disables HW acceleration putting more strain on CPU, or not.


Laptop: ThinkPad W500, C2D P9500, 8GB, Radeon RV635 (HD3650), Arch | Server/fw: Zotac AQ01, A4-5000 Kabini, 4GB, Arch/pfSense VM

Offline

#148 2012-08-24 17:17:49

Gusar
Member
Registered: 2009-08-25
Posts: 3,472

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

Yes it puts more strain on the CPU, as the video is decoded in software. Better higher CPU usage than crashes.

If you absolutely need hardware decoding, try flash 10.3.183.23. Note,  this version (ends in .23) was just released, as there were again a bunch of vulnerabilities found. Get it here: http://www.adobe.com/products/flashplay … tion3.html, the stuff fixed in it is here: http://www.adobe.com/support/security/b … 12-19.html

Offline

#149 2012-08-24 17:20:27

Lockheed
Member
Registered: 2010-03-16
Posts: 1,437

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

Well, I tried the JKAbrams'  solution and it did not make any difference. The blue is orange and the orange is blue.

I am going back to flashplugin 11.1.102.63-1 and adding 'flashplugin' to the ignore list in 'pacman.conf'.

Last edited by Lockheed (2012-08-24 17:22:44)


Laptop: ThinkPad W500, C2D P9500, 8GB, Radeon RV635 (HD3650), Arch | Server/fw: Zotac AQ01, A4-5000 Kabini, 4GB, Arch/pfSense VM

Offline

#150 2012-08-24 17:30:26

Gusar
Member
Registered: 2009-08-25
Posts: 3,472

Re: [SOLVED] Blue tint on youtube videos. (Nvidia or flash problem)

11.1 hasn't been maintained for a while now, which means it's vulnerable to all the stuff that was fixed in 11.2 and 10.3 over the past months. And the only reason it works is because it doesn't do hardware presentation. If you compiled libvdpau with the patch, you should not have screwed up colors.

Offline

Board footer

Powered by FluxBB