You are not logged in.

#1 2012-05-07 09:48:45

tinfoil
Member
Registered: 2012-05-07
Posts: 4

SLiM problems with shutdown

Hello, all.

I've recently set up SLiM while using GNOME, and while I can log in just fine, and can see the "Power Off..." button from the tray, attempting to shut down using it brings me to a frozen SLiM screen, and I cannot power down. I have to hard shutdown or reset to get off of this screen.

I'm starting SLiM using the Daemons array in /etc/rc.conf, rather than inittab, and am launching PolicyKit alongside GNOME in my ~/.xinitrc. The user attempting to log off has the same permissions as root.

If it helps, I'm using Plymouth, but I don't see how that could affect much.

As far as I can see, this should be working fine. =/
Any and all help or suggestions would be appreciated.

I'll post the file outputs of relevant files below in order to keep this post clean and separate.

Offline

#2 2012-05-07 09:51:19

tinfoil
Member
Registered: 2012-05-07
Posts: 4

Re: SLiM problems with shutdown

I'll post any additional files if necessary, but here's /etc/rc.conf, /etc/slim.conf, and ~/.xinitrc:

/etc/rc.conf:

#
# /etc/rc.conf - Main Configuration for Arch Linux
#

# -----------------------------------------------------------------------
# LOCALIZATION
# -----------------------------------------------------------------------
#
# LOCALE: available languages can be listed with the 'locale -a' command
# DAEMON_LOCALE: If set to 'yes', use $LOCALE as the locale during daemon
# startup and during the boot process. If set to 'no', the C locale is used.
# HARDWARECLOCK: set to "", "UTC" or "localtime", any other value will result
#   in the hardware clock being left untouched (useful for virtualization)
#   Note: Using "localtime" is discouraged, using "" makes hwclock fall back
#   to the value in /var/lib/hwclock/adjfile
# TIMEZONE: timezones are found in /usr/share/zoneinfo
#   Note: if unset, the value in /etc/localtime is used unchanged
# KEYMAP: keymaps are found in /usr/share/kbd/keymaps
# CONSOLEFONT: found in /usr/share/kbd/consolefonts (only needed for non-US)
# CONSOLEMAP: found in /usr/share/kbd/consoletrans
# USECOLOR: use ANSI color sequences in startup messages
#
LOCALE="en_US.UTF-8"
DAEMON_LOCALE="no"
HARDWARECLOCK="UTC"
TIMEZONE="America/Denver"
KEYMAP="us"
CONSOLEFONT=
CONSOLEMAP=
USECOLOR="yes"

# -----------------------------------------------------------------------
# HARDWARE
# -----------------------------------------------------------------------
#
# MODULES: Modules to load at boot-up. Blacklisting is no longer supported.
#   Replace every !module by an entry as on the following line in a file in
#   /etc/modprobe.d:
#     blacklist module
#   See "man modprobe.conf" for details.
#
MODULES=()

# Udev settle timeout (default to 30)
UDEV_TIMEOUT=30

# Scan for FakeRAID (dmraid) Volumes at startup
USEDMRAID="no"

# Scan for BTRFS volumes at startup
USEBTRFS="no"

# Scan for LVM volume groups at startup, required if you use LVM
USELVM="no"

# -----------------------------------------------------------------------
# NETWORKING
# -----------------------------------------------------------------------
#
# HOSTNAME: Hostname of machine. Should also be put in /etc/hosts
#
HOSTNAME="fondlebot"

# Use 'ip addr' or 'ls /sys/class/net/' to see all available interfaces.
#
# Wired network setup
#   - interface: name of device (required)
#   - address: IP address (leave blank for DHCP)
#   - netmask: subnet mask (ignored for DHCP) (optional, defaults to 255.255.255.0)
#   - broadcast: broadcast address (ignored for DHCP) (optional)
#   - gateway: default route (ignored for DHCP)
# 
# Static IP example
# interface=eth0
# address=192.168.0.2
# netmask=255.255.255.0
# broadcast=192.168.0.255
# gateway=192.168.0.1
#
# DHCP example
# interface=eth0
# address=
# netmask=
# gateway=

interface=eth0
address=
netmask=
broadcast=
gateway=

# Setting this to "yes" will skip network shutdown.
# This is required if your root device is on NFS.
NETWORK_PERSIST="no"

# Enable these netcfg profiles at boot-up. These are useful if you happen to
# need more advanced network features than the simple network service
# supports, such as multiple network configurations (ie, laptop users)
#   - set to 'menu' to present a menu during boot-up (dialog package required)
#   - prefix an entry with a ! to disable it
#
# Network profiles are found in /etc/network.d
#
# This requires the netcfg package
#
#NETWORKS=(main)

# -----------------------------------------------------------------------
# DAEMONS
# -----------------------------------------------------------------------
#
# Daemons to start at boot-up (in this order)
#   - prefix a daemon with a ! to disable it
#   - prefix a daemon with a @ to start it up in the background
#
# If something other takes care of your hardware clock (ntpd, dual-boot...)
# you should disable 'hwclock' here.
#
DAEMONS=(syslog-ng network netfs crond dbus slim)

/etc/slim.conf:

# Path, X server and arguments (if needed)
# Note: -xauth $authfile is automatically appended
default_path        /bin:/usr/bin:/usr/local/bin
default_xserver     /usr/bin/X
xserver_arguments -nolisten tcp vt07

# Commands for halt, login, etc.
halt_cmd            /sbin/shutdown -h now
reboot_cmd          /sbin/shutdown -r now
console_cmd         /usr/bin/xterm -C -fg white -bg black +sb -T "Console login" -e /bin/sh -c "/bin/cat /etc/issue; exec /bin/login"
#suspend_cmd        /usr/sbin/suspend

# Full path to the xauth binary
xauth_path         /usr/bin/xauth 

# Xauth file for server
authfile           /var/run/slim.auth


# Activate numlock when slim starts. Valid values: on|off
# numlock             on

# Hide the mouse cursor (note: does not work with some WMs).
# Valid values: true|false
 hidecursor          true

# This command is executed after a succesful login.
# you can place the %session and %theme variables
# to handle launching of specific commands in .xinitrc
# depending of chosen session and slim theme
#
# NOTE: if your system does not have bash you need
# to adjust the command according to your preferred shell,
# i.e. for freebsd use:
# login_cmd           exec /bin/sh - ~/.xinitrc %session
login_cmd           exec ck-launch-session /bin/bash -login ~/.xinitrc %session

# Commands executed when starting and exiting a session.
# They can be used for registering a X11 session with
# sessreg. You can use the %user variable
#
# sessionstart_cmd	some command
# sessionstop_cmd	some command

# Start in daemon mode. Valid values: yes | no
# Note that this can be overriden by the command line
# options "-d" and "-nodaemon"
# daemon	yes

# Available sessions (first one is the default).
# The current chosen session name is replaced in the login_cmd
# above, so your login command can handle different sessions.
# see the xinitrc.sample file shipped with slim sources
sessions            xfce4,icewm,wmaker,blackbox

# Executed when pressing F11 (requires imagemagick)
screenshot_cmd      import -window root /slim.png

# welcome message. Available variables: %host, %domain
welcome_msg         Welcome to %host

# Session message. Prepended to the session name when pressing F1
# session_msg         Session: 

# shutdown / reboot messages
shutdown_msg       Halting all fondling...
reboot_msg         Preparing to resume fondling...

# default user, leave blank or remove this line
# for avoid pre-loading the username.
default_user        nico

# Focus the password field on start when default_user is set
# Set to "yes" to enable this feature
focus_password      yes

# Automatically login the default user (without entering
# the password. Set to "yes" to enable this feature
#auto_login          no


# current theme, use comma separated list to specify a set to 
# randomly choose from
current_theme       default

# Lock file
lockfile            /var/lock/slim.lock

# Log file
logfile             /var/log/slim.log


# End of file

~/.xinitrc:

exec ck-launch-session gnome-session

Offline

#3 2012-05-07 11:14:22

Dustbin
Member
From: The Netherlands
Registered: 2011-12-07
Posts: 124

Re: SLiM problems with shutdown

The Wiki says:

If you use Splashy and SLiM, sometimes you can't power-off or reboot from menu in GNOME, Xfce, LXDE or others. Check your /etc/slim.conf and /etc/splash.conf; set the DEFAULT_TTY=7 same as xserver_arguments vt07.

Maybe this problem also occurs with Plymouth?

Just a shot in the dark, but maybe...


If the Matrix was real, it would run on Arch...

Offline

#4 2012-05-07 14:08:11

tinfoil
Member
Registered: 2012-05-07
Posts: 4

Re: SLiM problems with shutdown

That's exactly what I thought as well, but /etc/plymouth/plymouthd.conf, which seems to be Plymouth's main config file, makes no mention of any TTY.
I'm stumped. There seems to be many solutions for people who can't see their shutdown button, but none for people who can see it and it fails.

The wiki mentions a potential fix, but isn't all too helpful.
Does anyone know where in the world the filepath mentioned in the fix would be in GNOME?

Power-off tray icon fails
If your power off tray icon fails, it could be due to not having root privileges. To start a tray icon with root privileges, be sure to have SLiM start the program. Edit /etc/slim.conf as follows:
sessionstart_cmd     /path/to/tray/icon/program &

Offline

#5 2012-05-09 19:25:37

zeroflag
Member
From: Europe
Registered: 2012-05-09
Posts: 17

Re: SLiM problems with shutdown

Same here, except I'm using XFCE4. To be honest, after six years of using linux (2y Gentoo and 4y Arch), I am sick of linux. I migrated from Windows to find a stable operating system, but every week after one of the everyday updates, a bug occurs. I love the freedom linux provides, but I hate the time spent behind the keyboard to correct some backlogs. I confess, I give up, I am gonna buy a Mac as MS Windows are targeted by viruses, worms and other crap.

Anyway, thanks to everyone involved, but this may be a hint for other people to live their normal life and for the programmers to do the work properly or give up the halfway work.

Last edited by zeroflag (2012-05-09 19:31:40)

Offline

#6 2012-05-09 21:14:45

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 12,929

Re: SLiM problems with shutdown

Is this thread related?  I don't use Slim, so I cannot check it.

@zeroflag, Well, good buy and good luck.  Just curious as to why you went to the effort of signing up today to make that post after having been a user for four years.  Without providing feedback and bug reports, how do you expect stability?


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Like you, I have no idea what you are doing, but I am pretty sure it is wrong...Jasonwryan
----
How to Ask Questions the Smart Way

Offline

#7 2012-05-10 05:56:38

zeroflag
Member
From: Europe
Registered: 2012-05-09
Posts: 17

Re: SLiM problems with shutdown

Yes, the Slim is somehow broken after the update and ignores the system setup and user rights. Thus, the user can only log out from X but cannot shut it down, hibernete, etc. The /etc/sudoers setup and ~/.xinitrc is correct, as it was normally working for over half a year (after I completely uninstalled the faulty and crashing Gnome3 with GDM). I installed Ligthdm, but this is not the solution. This is what I was talking about. Too much software which is not working 100 percent.

@ewaller: Stable system = system, where I can update software without any influence on the other software. Like Gnome3, you install some tweaks, and the system becomes completely unstable and faulty (Ooops sumthin happened, blah, blah). Therefore, I do use XFCE4 as a compromise between nice look and stable software. However, it has some things which I don't like but can live with them (the desktop style, for instance). The x64 system is unstable as well (the Flash related stuff even sometimes working and other software). Resolved by the PAE kernel (for 4 GB memory usage) and nVidia drivers for PAE, it is another long story. Yes, I can't be helped, I am fscked.

@ewaller: Yes you're right. I was totally sick yesterday, as the broken slim package was the fifth one in this week. I never posted any debug info. First, I am not the programmer (even I can do the programming, I understand several programming languages, and I made some software for myself). And second, once something has broken, I always find the resolution (after some time, a few hours of googling). Unfortunately, I did not yesterday. I found this thread, and a similar, one year old, thread with no resolution. Feel free to delete my comment as it does not help to resolve the issue itself. But it may help a few people to think about the time they spend behind the keyboard as I did in the last few years.

Last edited by zeroflag (2012-05-10 06:07:09)

Offline

#8 2012-05-10 06:33:07

zeroflag
Member
From: Europe
Registered: 2012-05-09
Posts: 17

Re: SLiM problems with shutdown

An update to close this thread.

@ewaller: Thank you very much for the link you've provided as it contains the resolution.

@everyone interested: The command in ~/.xinitrc needs to be as follows:

exec dbus-launch --exit-with-session startxfce4

The command in /etc/slim.conf can stay as set up by default:

login_cmd           exec /bin/bash -login ~/.xinitrc %session

Do not use the following command anymore.

ck-launch-session

As I was talking about, the numlock stopped working this time. Regardless I use numlockx package or not, regardless the numlock on option is enabled in slim.conf. But I can live with that.

I believe this thread can be tagged as resolved. Thanks everyone for your time and support, esp. ewaller!

Last edited by zeroflag (2012-05-10 06:36:26)

Offline

#9 2012-05-10 07:02:04

tinfoil
Member
Registered: 2012-05-07
Posts: 4

Re: SLiM problems with shutdown

Thank you all very much.
Replacing everything related to xfce for its GNOME equivalent works perfectly.

Offline

#10 2012-05-10 11:33:16

Andrenas
Member
From: Coimbra, Portugal
Registered: 2011-03-14
Posts: 19

Re: SLiM problems with shutdown

I had the same problem (using slim and xfce4). Solved it by removing

ck-launch-session dbus-launch

from the ~ /. xinitrc.

If the ~ /. xinitrc looks like:

exec startxfce4

the problem is solved.

greetings

Offline

#11 2012-05-10 15:57:54

zeroflag
Member
From: Europe
Registered: 2012-05-09
Posts: 17

Re: SLiM problems with shutdown

@Andrenas: removing the

dbus-launch

statement, may cause the extra/xfce4-mount-plugin to stop working (mounting your USB devices).

@linux gurus, correct me if I am wrong please.
Thanks.

Last edited by zeroflag (2012-05-10 16:02:47)

Offline

#12 2012-05-10 17:05:18

biltong
Member
From: South Africa
Registered: 2011-09-01
Posts: 116

Re: SLiM problems with shutdown

zeroflag wrote:

Yes, the Slim is somehow broken after the update and ignores the system setup and user rights. Thus, the user can only log out from X but cannot shut it down, hibernete, etc. The /etc/sudoers setup and ~/.xinitrc is correct, as it was normally working for over half a year

I just hit this issue today. After yesterday's(I think) slim update I can no longer shut down my machine from X - only log out. Not really an issue since networkmanager and all those things are still working and I usually shut down from command line, but eh, just found it very strange today when I booted my machine up.

I use mate if that makes any difference, and my .xinitrc = exec ck-launch-session dbus-launch mate-session.

Offline

#13 2012-05-11 05:11:16

matse
Member
Registered: 2011-04-27
Posts: 276

Re: SLiM problems with shutdown

biltong: but you have read the posts above you? [Hint]#10[/Hint]

Offline

#14 2012-05-11 06:54:48

swanson
Member
From: Sweden
Registered: 2011-02-05
Posts: 759

Re: SLiM problems with shutdown

Slim has a history the last couple of years. A while ago it was considered deprecated since there were no upstream developments. Now there are some updates in the new version 1.3.3, amongst others the inclusion of built-in consolekit support. Which is good, and follows standards, as far as I know. It is NOT a bug. It is development and needs adjustment on the users part. It is interresting to see upwards to 10 threads concering slim and its new functions.

Among all login/display managers. gdm, kdm, xdm amd lightdm, slim is the slimmest and most versatile and easiest to configure. So I'm very glad its development is continuing.

Info here; http://slim.berlios.de/
It's been there all the time.

Offline

#15 2012-06-25 06:03:00

sw2wolf
Member
From: China
Registered: 2009-06-08
Posts: 99
Website

Re: SLiM problems with shutdown

slim cannot use /etc/login.conf ?


e^(π⋅i) + 1 = 0

Offline

#16 2012-06-25 06:23:25

swanson
Member
From: Sweden
Registered: 2011-02-05
Posts: 759

Re: SLiM problems with shutdown

No.

Offline

#17 2012-08-31 15:13:09

nsmathew
Member
From: Asia
Registered: 2012-08-18
Posts: 31

Re: SLiM problems with shutdown

Was a little carless and did not read the wiki for Slim completely. This thread has now resolved my problem witn disabled reboot and shutdown buttons on xfce.


Is man one of God's blunders? Or is God one of man's blunders?
Friedrich Nietzsche

Offline

Board footer

Powered by FluxBB