You are not logged in.

#1 2012-05-12 19:23:58

sandrob
Member
Registered: 2011-10-21
Posts: 16

[SOLVED] No wired internet after fresh arch install

I'm re-installing arch onto a different harddrive after already having installed arch onto a another harddrive flawlessly a couple months ago. So I know that the hardware is fine since I can just boot into that other installation and everything is just peachy. Also the internet worked fine for the installation. It's only now that I'm rebooting.

On this new installation when I log in I don't have internet:

# ping -c 3 www.google.com
ping: unknown host www.google.com

#ping -c 3 8.8.8.8
connect: Network is unreachable

So I followed the guide here: https://wiki.archlinux.org/index.php/Network

#lspci -v
08:00.0 Ethernet Controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 03)
  Subsystem: Giga-byte Technology GA-EP45-DS5 Motherboard
  ...

And no mention of a kernel module. So I assume that's my problem.

A) which module do I need?
B) How do I get it onto my machine that doesn't have internet?
C) Why isn't it working now?

Last edited by sandrob (2012-05-13 06:40:59)

Offline

#2 2012-05-12 19:31:25

Shark
Member
From: /dev/zero
Registered: 2011-02-28
Posts: 663

Re: [SOLVED] No wired internet after fresh arch install


If you have built castles in the air, your work need not be lost; that is where they should be. Now put foundations under them.
Henry David Thoreau

Registered Linux User: #559057

Offline

#3 2012-05-12 19:35:10

sandrob
Member
Registered: 2011-10-21
Posts: 16

Re: [SOLVED] No wired internet after fresh arch install

The connection is wired, not wireless.

But that did make me check my logs and I found this in the /var/log/boot

Error: unknown interface in /etc/rc/conf: `etho'

Offline

#4 2012-05-12 19:58:33

Gcool
Member
Registered: 2011-08-16
Posts: 1,456

Re: [SOLVED] No wired internet after fresh arch install

r8169 is the kernel module you're looking for if I'm not mistaken. Simply try modprobing it and see what happens.


Burninate!

Offline

#5 2012-05-12 20:00:24

sandrob
Member
Registered: 2011-10-21
Posts: 16

Re: [SOLVED] No wired internet after fresh arch install

I ran

modprobe r8169

but nothing happened. The command finished quickly and outputted nothing... what should I do next?

Offline

#6 2012-05-12 20:07:23

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 13,809
Website

Re: [SOLVED] No wired internet after fresh arch install

etho should be eth0 .... zero no the letter O.


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

#7 2012-05-12 20:07:39

dudko
Member
From: Slovakia
Registered: 2010-03-04
Posts: 41
Website

Re: [SOLVED] No wired internet after fresh arch install

sandrob wrote:

The connection is wired, not wireless.

But that did make me check my logs and I found this in the /var/log/boot

Error: unknown interface in /etc/rc/conf: `etho'

Have you checked rc.conf for "etho" typo? It should be "eth0".

B) How do I get it onto my machine that doesn't have internet?

Just download packages on a working machine and install them with pacman (-U) or compile them from source. (./configure & make & sudo make install).

Last edited by dudko (2012-05-13 05:29:01)


"Failure is success if we learn from it."

Offline

#8 2012-05-12 20:09:57

sandrob
Member
Registered: 2011-10-21
Posts: 16

Re: [SOLVED] No wired internet after fresh arch install

Sorry that was a typo when I typed out the message. It actually does say in the log:

Error: unknown interface in /etc/rc.conf: `eth0'

So the issue still exists.

Offline

#9 2012-05-12 20:22:02

Gcool
Member
Registered: 2011-08-16
Posts: 1,456

Re: [SOLVED] No wired internet after fresh arch install

Try running:

# modprobe r8169
# ip link set eth0 up

Once you've done that, post the output of:

# lspci -k
# ip link

Burninate!

Offline

#10 2012-05-12 20:28:07

sandrob
Member
Registered: 2011-10-21
Posts: 16

Re: [SOLVED] No wired internet after fresh arch install

# modprobe r8169
# ip link set eth0 up
Cannot find device "eth0"
# ip link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN mode DEFAULT
  link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00

This seems really bazaar since I had internet for the installation...

Last edited by sandrob (2012-05-12 20:29:08)

Offline

#11 2012-05-13 01:53:46

rnarch
Member
Registered: 2012-03-17
Posts: 292

Re: [SOLVED] No wired internet after fresh arch install

I had similar problem and out of frustration I put the kernel files of working linux installation (/boot/vmlinuz-linux and intramfs-linux.img files) in the new installation and it worked. Later I upgraded the system where mkinitcpio remade those files and everything worked smoothly.

Offline

#12 2012-05-13 02:09:49

sandrob
Member
Registered: 2011-10-21
Posts: 16

Re: [SOLVED] No wired internet after fresh arch install

Arg, even tried that and still nothing!

Offline

#13 2012-05-13 06:25:44

rnarch
Member
Registered: 2012-03-17
Posts: 292

Re: [SOLVED] No wired internet after fresh arch install

You may try including network related packages during installation. While installing Arch, there is a step where the packages to be installed can be selected. Amongst those listed first are some network related packages which are not checked by default. Including them for installation may correct this problem.

Offline

#14 2012-05-13 06:27:30

sandrob
Member
Registered: 2011-10-21
Posts: 16

Re: [SOLVED] No wired internet after fresh arch install

That's exactly how I ended up fixing it. I added dbus and networkmanager, and now things are working well.

Thank you!

Offline

#15 2012-05-13 06:39:05

Gcool
Member
Registered: 2011-08-16
Posts: 1,456

Re: [SOLVED] No wired internet after fresh arch install

Nice to hear you've got it up and running.

Don't forget to mark your thread as [SOLVED].


Burninate!

Offline

#16 2012-05-13 07:29:02

rnarch
Member
Registered: 2012-03-17
Posts: 292

Re: [SOLVED] No wired internet after fresh arch install

I added dbus and networkmanager, and now things are working well.

I don't remember 'networkmanager' to be there on installation cd. Was it networkmanager you included or was it inetutils or net-snmp? Or is it only dbus that did the trick?

Last edited by rnarch (2012-05-13 07:29:32)

Offline

#17 2012-05-13 13:09:33

sandrob
Member
Registered: 2011-10-21
Posts: 16

Re: [SOLVED] No wired internet after fresh arch install

I was doing a netinstall. It was available from there.

Offline

#18 2012-05-23 07:25:27

rnarch
Member
Registered: 2012-03-17
Posts: 292

Re: [SOLVED] No wired internet after fresh arch install

It does mean that, in certain circumstances, the standard packages marked for installation on install CD may not be sufficient for providing a working network immediately after installation.

Offline

#19 2012-05-23 13:35:35

sandrob
Member
Registered: 2011-10-21
Posts: 16

Re: [SOLVED] No wired internet after fresh arch install

Yes that does in fact appear to be the case and at the very center of my confusion.

Offline

Board footer

Powered by FluxBB