You are not logged in.

#1 2012-05-13 04:15:00

oboedad55
Member
From: Baku
Registered: 2011-04-05
Posts: 389

[SOLVED] pulseaudio problems

Hi, after the recent pulseaudio update system notifications and other sounds are experiencing a slight delay. The sound lags, in other words. Seemed OK with the previous version of pulseaudio.

edit: This happens with KDE 4.8.3 and XFCE 4.10.

Last edited by oboedad55 (2012-05-14 19:07:53)


Registered Linux user #436067

Offline

#2 2012-05-13 09:21:28

eNTi
Member
Registered: 2006-04-30
Posts: 107

Re: [SOLVED] pulseaudio problems

well at least it seems to work for you. my pulseaudio stopped working completely!

UPDATE: nm i found a solution here: https://bbs.archlinux.org/viewtopic.php … 5#p1100765

Last edited by eNTi (2012-05-13 09:25:00)

Offline

#3 2012-05-14 03:28:56

sten_gun
Member
From: Italy
Registered: 2012-05-14
Posts: 5

Re: [SOLVED] pulseaudio problems

Hi all there.

oboedad55 wrote:

Hi, after the recent pulseaudio update system notifications and other sounds are experiencing a slight delay. The sound lags, in other words. Seemed OK with the previous version of pulseaudio.

edit: This happens with KDE 4.8.3 and XFCE 4.10.

I have the same problem too, on Gnome 3.4
And I've noticed that when you're playing audio this "lag" completely disappears. I changed pulseaudio configuration with .pacnew when I updated the system.
Starting pavucontrol (starting is enough, no need to touch any setting) also removes lag, so I think is related on opening audio streams (or monitoring devices). Enabling pseudo device for simultaneous output with paprefs and using that as primary device slightly reduces (but not removes) audio lag.
I tried disabling HDMI, but it didn't work.
Any Idea?

Offline

#4 2012-05-14 16:10:18

sten_gun
Member
From: Italy
Registered: 2012-05-14
Posts: 5

Re: [SOLVED] pulseaudio problems

Ok I found the solution:
I noticed that rtkit is the problem, so you must disable it on default.pa:

.ifexists module-udev-detect.so
load-module module-udev-detect tsched=0
.else

And now lag disappeared

Offline

#5 2012-05-14 19:07:09

oboedad55
Member
From: Baku
Registered: 2011-04-05
Posts: 389

Re: [SOLVED] pulseaudio problems

sten_gun wrote:

Ok I found the solution:
I noticed that rtkit is the problem, so you must disable it on default.pa:

.ifexists module-udev-detect.so
load-module module-udev-detect tsched=0
.else

And now lag disappeared

Thanks, this worked.


Registered Linux user #436067

Offline

#6 2012-06-06 06:04:36

evaliauka
Member
Registered: 2011-08-25
Posts: 18

Re: [SOLVED] pulseaudio problems

sten_gun wrote:

Ok I found the solution:
I noticed that rtkit is the problem, so you must disable it on default.pa:

.ifexists module-udev-detect.so
load-module module-udev-detect tsched=0
.else

And now lag disappeared

Thanks a lot, man!

Offline

#7 2012-06-23 20:42:46

dk0r
Member
From: USA
Registered: 2012-06-23
Posts: 7

Re: [SOLVED] pulseaudio problems

I was hoping the solution in this thread would address a system wide 2-3 second hdmi audio delay I've experienced across all ATi's Radeon HD's: 5870, 6670, 6750 and 6770 --Unfortunatelty it did not.

However, I've only tried the xf86-video-ati driver as I'm unable to test catalyst 12.4 due to broken xorg dependencies. Hopefuly catalyst 12.6, which is due to graduate the testing repo this July, will resolve the issue.

As consolation, the integrated hdmi on the DZ77GA-70k ivy-bridge motherboard works properly without any audio delay using the xf86-video-intel 2.19.0-3 drivers. This does not solve my specific issue as I have three displays which the integrated hdmi cannot drive.

#kernel 3.4.3-1, xf86-video-ati 6.14.5-1, pulseaudio 2.0-2 and KDE 4.8.4. ::

Offline

#8 2012-07-02 21:19:49

vassie
Member
Registered: 2006-02-05
Posts: 31

Re: [SOLVED] pulseaudio problems

sten_gun wrote:

Ok I found the solution:
I noticed that rtkit is the problem, so you must disable it on default.pa:

.ifexists module-udev-detect.so
load-module module-udev-detect tsched=0
.else

And now lag disappeared

I already have the following in default.pa

.ifexists module-udev-detect.so
load-module module-udev-detect
.else

Yet I still have lag after logging in, I login via KDM then I have to wait 10-15 seconds before I can use the desktop

Any ideas?

Offline

#9 2012-07-05 13:29:52

LordChaos73
Member
From: .nl
Registered: 2008-11-11
Posts: 118

Re: [SOLVED] pulseaudio problems

vassie wrote:

Yet I still have lag after logging in, I login via KDM then I have to wait 10-15 seconds before I can use the desktop

Any ideas?

Yes, try to move /etc/xdg/autostart/pulseaudio.desktop to your homedir and reboot your computer. Did that help ?

Offline

#10 2012-07-06 22:25:42

vassie
Member
Registered: 2006-02-05
Posts: 31

Re: [SOLVED] pulseaudio problems

LordChaos73 wrote:
vassie wrote:

Yet I still have lag after logging in, I login via KDM then I have to wait 10-15 seconds before I can use the desktop

Any ideas?

Yes, try to move /etc/xdg/autostart/pulseaudio.desktop to your homedir and reboot your computer. Did that help ?

It did, thank you

Do I need to do anything with my default.pa file? I'm running PulseAudio 2.0

Offline

#11 2014-10-13 18:19:42

no1
Member
Registered: 2014-10-13
Posts: 1

Re: [SOLVED] pulseaudio problems

oboedad55 wrote:
sten_gun wrote:

Ok I found the solution:
I noticed that rtkit is the problem, so you must disable it on default.pa:

.ifexists module-udev-detect.so
load-module module-udev-detect tsched=0
.else

And now lag disappeared

Thanks, this worked.


I have an acer aspire one with kde.

This fixed the problem I was having with very choppy audio.

The file to edit is: /etc/pulse/default.pa

Offline

Board footer

Powered by FluxBB