You are not logged in.

#1 2012-05-15 06:17:03

swanson
Member
From: Sweden
Registered: 2011-02-05
Posts: 759

AUR pkgver problem

This concerns the aur package mp3cd which is out-of-date. As pkgver should be the developers version number and the result in this case is that AUR sees an older package as newer? Present PKGBUILD pkger;

pkgname=mp3cd
pkgver=1.026001
pkgrel=1
...
source=("$url/download/$pkgname-$pkgver.tar.gz")
... 

As you can see, pkgver is part of the url, which it should be. But the present dev version is 1.0.27 which leads to the problem that AUR sees version 1.0.26001 as newer than 1.0.27, which it is not.  I've tried to search for this but haven't found anything, just a debate about pkgrel.

I could hardcode the url but then I wouldn't be following standards and maybe the PKGBUILD would lead to an upodate to an older version.

Offline

#2 2012-05-15 06:27:40

ngoonee
Forum Fellow
From: Between Thailand and Singapore
Registered: 2009-03-17
Posts: 6,815

Re: AUR pkgver problem

swanson wrote:

AUR sees version 1.0.26001 as newer than 1.0.27

What is this statement based on?


Allan-Volunteer on the (topic being discussed) mailn lists. You never get the people who matters attention on the forums.
jasonwryan-Installing Arch is a measure of your literacy. Maintaining Arch is a measure of your diligence. Contributing to Arch is a measure of your competence.
Griemak-Bleeding edge, not bleeding flat. Edge denotes falls will occur from time to time. Bring your own parachute.

Offline

#3 2012-05-15 06:50:40

Awebb
Member
Registered: 2010-05-06
Posts: 4,168

Re: AUR pkgver problem

The AUR itself does not "see" package versions. Could you please clarify if pacman thinks that 1.0.26001 is newer than 1.0.27? That could be the case.

Offline

#4 2012-05-15 07:23:22

swanson
Member
From: Sweden
Registered: 2011-02-05
Posts: 759

Re: AUR pkgver problem

Well I edited the present AUR PKGBUILD to reflect the new dev version 1.0.27 like this;

...
pkgname=mp3cd
pkgver=1.027
pkgrel=3
...

And still yaourt/packer want to update it from thenew dev version 1.027 to version 1.026001. Maybe there's some obvius thing I miss?
Since I like this app I'd like to adopt it but must have a functional PKGBUILD first. It does work on my set up locally, of course. Only have to block it in pacman.conf.

:: Starting full aur upgrade...
warning: mp3cd 1.027-3: ignoring package upgrade (1.027-3 => 1.026001-1)

Last edited by swanson (2012-05-15 07:27:24)

Offline

#5 2012-05-15 07:57:55

Awebb
Member
Registered: 2010-05-06
Posts: 4,168

Re: AUR pkgver problem

That's a problem with yaourt and packer, not with the AUR. Go to their places and report the bug.

Offline

#6 2012-05-15 08:20:19

swanson
Member
From: Sweden
Registered: 2011-02-05
Posts: 759

Re: AUR pkgver problem

Are you sure it's a bug?

Offline

#7 2012-05-15 13:02:52

Awebb
Member
Registered: 2010-05-06
Posts: 4,168

Re: AUR pkgver problem

It is a bug. Neither yaourt nor packager can deal with unconventionally structured version numbers. If that thing had another dot, like 1.26.9999 and then 1.27, then they would not fail. You could, on the other hand, report the bug upstream to the mp3cd dev, telling him his numbering sucks.

Offline

#8 2012-05-15 16:12:26

swanson
Member
From: Sweden
Registered: 2011-02-05
Posts: 759

Re: AUR pkgver problem

Well, other options might be to get the present package removed, or upload a new package with the name mp3cd-1.027. But the last alternative isn't ok, as far as I understand.

Offline

#9 2012-05-15 17:26:48

Awebb
Member
Registered: 2010-05-06
Posts: 4,168

Re: AUR pkgver problem

What does pacman say if you install it manually?

Offline

#10 2012-05-15 18:46:37

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: AUR pkgver problem

This problem comes from the weird versioning change. You'll need to use epoch (man PKGBUILd for more info).

Offline

Board footer

Powered by FluxBB