You are not logged in.

#1 2012-05-25 08:12:41

rhadesan
Member
Registered: 2011-05-03
Posts: 11

[SOLVED] lxde - no shutdown and reboot buttons

Hello,

after pacman -Syu I am missing those buttons. I have tried several way, i.e. click on logout button, run lxde-logout command, run lxsession-logout command ... It has been working correctly for several months, until update (maybe 2 weeks ago). I have tried to check for updates several times if it can help, but it doesn't.

In my .xinitrc I have:

exec ck-launch-session dbus-launch startlxde

And I have also run

sudo gpasswd -a <username> power 

There must be something else, can somebody help me?

Last edited by rhadesan (2012-05-25 16:31:42)

Offline

#2 2012-05-25 09:13:05

bnb2235
Member
Registered: 2011-02-13
Posts: 105

Re: [SOLVED] lxde - no shutdown and reboot buttons

You don't say which login manager you use (if any), but I suspect your login manager is now handling the console kit. Please try:
exec startlxde

Offline

#3 2012-05-25 10:02:27

rhadesan
Member
Registered: 2011-05-03
Posts: 11

Re: [SOLVED] lxde - no shutdown and reboot buttons

Hello,
I am using SLIM. Where should I put
exec startlxde
?

Offline

#4 2012-05-25 10:06:00

Gcool
Member
Registered: 2011-08-16
Posts: 1,456

Re: [SOLVED] lxde - no shutdown and reboot buttons

Slim can now handle Consolekit sessions (since version 1.3 iirc). So try just putting "exec startlxde" in your ~/.xinitrc


Burninate!

Offline

#5 2012-05-25 12:03:15

Daimusou
Member
Registered: 2012-05-25
Posts: 20

Re: [SOLVED] lxde - no shutdown and reboot buttons

I have this same problem.   But I am using xfce4, not lxde.   Slim starts up xfce4 just fine, but the shutdown etc buttons are disabled.

Edit: problem fixed by removing the ck-launch-session from the exec command in .xinitrc

Last edited by Daimusou (2012-05-25 12:14:54)

Offline

#6 2012-05-25 13:05:01

mich04
Member
From: Illinois - United States
Registered: 2011-10-25
Posts: 369

Re: [SOLVED] lxde - no shutdown and reboot buttons

Has anyone in this post having the problems checked to see if you can mount a pendrive, or a external usb drive?


I love computers, networking and Arch Linux. Sometimes I might ask a stupid question, but please have grace with me like I would with you.

Offline

#7 2012-05-25 13:09:33

mich04
Member
From: Illinois - United States
Registered: 2011-10-25
Posts: 369

Re: [SOLVED] lxde - no shutdown and reboot buttons

I can now confirm that what Daimusou say's is correct I removed it from

/etc/slim.conf
line

login_cmd exec dbus-launch /bin/bash -login ~/.xinitrc %session

Now everything is working fine. Does this mean that the ck-launch-session command is no longer necessary?

Last edited by mich04 (2012-05-25 13:11:12)


I love computers, networking and Arch Linux. Sometimes I might ask a stupid question, but please have grace with me like I would with you.

Offline

#8 2012-05-25 13:13:47

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 13,696
Website

Re: [SOLVED] lxde - no shutdown and reboot buttons

It means that Slim now handles console kit itself, which is what Gcool said.  This can also be found on well over a dozen other recent threads on the exact same topic.  It has nothing to do with the window manager, it is due to the (fairly) recent update of slim.


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

#9 2012-05-25 13:17:06

mich04
Member
From: Illinois - United States
Registered: 2011-10-25
Posts: 369

Re: [SOLVED] lxde - no shutdown and reboot buttons

Sorry, I took What Gcool said as the method of adding the ck-launch-session command to slim.conf. I understand Gcool's post now that you have stated that.


I love computers, networking and Arch Linux. Sometimes I might ask a stupid question, but please have grace with me like I would with you.

Offline

#10 2012-05-25 16:31:07

rhadesan
Member
Registered: 2011-05-03
Posts: 11

Re: [SOLVED] lxde - no shutdown and reboot buttons

Thanks bnb2235, Gcool. It works now!

Offline

Board footer

Powered by FluxBB