You are not logged in.

#1 2005-09-02 19:56:50

punkandacoke
Member
Registered: 2004-03-09
Posts: 10

archck kernel vesafb/vesafb-tng issue

http://iphitus.loudas.com/archck.php
According to this, the archck patchset uses vesafb-tng.

http://wiki.archlinux.org/index.php/Gensplash
According to this page,

#2.  Even if you are running 32bit x86 I DO NOT recommend vesafb-tng over vesafb, it is slow and requires different configs to vesafb, switching framebuffer types between kernels will cause you grief. If you have previously used vesafb keep using it!

What lead to the decision to use vesafb-tng? What makes the two different?

Second question relates to a gensplash. I have kernel26archck 2.6.13.archck1-1, gensplash from community, as well as the initscripts from community for silent boot. When I try to use vesafb-tng to boot with the splash, it just reverts to the default console...but when I use the vesafb config, it works fine...is there something im missing here.

Just to clarify: I am using kernel26archck that to my knowledge uses vesafb-tng.

grub configs:
This does NOT work. This uses the vesafb-tng format.

# Arch Linux kernel26archck using vesafb-tng
title  Arch Linux with Splash (Verbose) vesafb-tng
root (hd0,0)
kernel (hd0,0)/vmlinuz26archck root=/dev/hda3 ro video=vesafb:ywrap,mtrr,1024x768-32@85 splash=verbose,theme:darch console=tty1
initrd (hd0,0)/fbsplash-darch-1024

This does work. This uses the vesafb format.

# Arch Linux kernel26archck using vesafb 
title  Arch Linux with Splash (Verbose) (Community Kernel)
root (hd0,0)
kernel (hd0,0)/vmlinuz26archck root=/dev/hda3 ro devfs=nomount vga=0x318 splash=verbose,theme:darch console=tty1
initrd (hd0,0)/fbsplash-darch-1024

Just to clarify one last time: I am using kernel26archck which uses vesafb-tng but when I configure grub to boot with vesafb-tng...it doesn't work in the sense that the framebuffer reverts to the default.  However when I configure grub to boot with the vesafb config...it works fine.

WHAT THE HELL?!?!  big_smile


Edit:

And according to vesa-tng's page: http://dev.gentoo.org/~spock/projects/vesafb-tng/  ,what is happening to me...should NOT be happening.

NOTE: After patching the kernel, setting mode via the old vga= way WILL NOT WORK. You'll have to specify the mode you want to set through the video option, for example: video=vesafb:ypan,1024x768-32@85.

Offline

#2 2005-09-02 21:40:01

dtw
Forum Fellow
From: UK
Registered: 2004-08-03
Posts: 4,431
Website

Re: archck kernel vesafb/vesafb-tng issue

It's quite simple - the archck patchset contains the vesa-tng patch but the pkg in [community] does not use the vesa-tng driver the patch enables.  This is because I wrote the gensplash wiki and I don't rate vesa-tng at all smile

So, yeah, you have confused what is available and what is actually include.  Simple smile

Glad I read this thread now...

Offline

#3 2005-09-02 22:11:24

punkandacoke
Member
Registered: 2004-03-09
Posts: 10

Re: archck kernel vesafb/vesafb-tng issue

alright, thanks for the info dibble...I was mainly looking for an anwser from you because you are, as stated, the author of the gensplash wiki. thanks alot man.

Offline

#4 2005-09-02 22:50:22

dtw
Forum Fellow
From: UK
Registered: 2004-08-03
Posts: 4,431
Website

Re: archck kernel vesafb/vesafb-tng issue

You can always pm in future, well, as long as it is something simple big_smile

Offline

Board footer

Powered by FluxBB