You are not logged in.

#1 2012-05-01 14:35:49

ChemBro
Member
Registered: 2008-10-22
Posts: 682

ufoai-data might be missing language files

Wanted to report this as a bug on the bug tracker, but the bug tracker doesn't let me register myself, so here I am.

I have a problem with the new release of UFO: AI (version 2.4). ufoai-data might be missing language files. I don't have (nearly) any text in UFO: AI, no story introduction (besides "introduction_sentence_1"), no Ufopedia entry (it says something like "grenade_launcher_txt") and no mail text (only says "mail_txt"). An ufo: ai dev thinks, that the packager might have forgot to build the language files.

Could someone confirm, that there is a problem and that it is the missing language files? Thanks.

Offline

#2 2012-05-01 15:10:09

Lutey
Member
Registered: 2012-05-01
Posts: 2

Re: ufoai-data might be missing language files

I have exactly the same problem:
ufoai version 2.4-2

Offline

#3 2012-05-01 17:01:39

Todor
Member
From: Bulgaria
Registered: 2011-07-15
Posts: 6

Re: ufoai-data might be missing language files

I have all "usr/share/ufoai/base/i18n" language files (ufoai.mo) but still the same problem as OP. Also all options was gray in 2.4-1. In 2.4-2 green are only English and Russian. In 2.3 all was green and working i think..

Last edited by Todor (2012-05-02 21:00:29)

Offline

#4 2012-05-02 21:13:35

Todor
Member
From: Bulgaria
Registered: 2011-07-15
Posts: 6

Re: ufoai-data might be missing language files

think i found the problem. The language files are there but ufo can't find them. But if
cd /usr/share/ufoai/
and from there:
ufo
there is text

Offline

#5 2012-05-30 09:41:17

ninquitassar
Member
From: Italy
Registered: 2012-05-30
Posts: 29

Re: ufoai-data might be missing language files

Can a more "expert" one report the bug? Nowadays there aren't bug reported. If you want I can do this, but I don't know if I is upstream or arch responsibility...


CPU: AMD Sempron SI-42 - 2.1 Ghz  Video: Nvidia GeForce 8200MG  RAM: 4Gb DR
OS: Arch x86_64 + awesome + GTK+
My DeviantART

Offline

#6 2012-05-30 11:41:14

ninquitassar
Member
From: Italy
Registered: 2012-05-30
Posts: 29

Re: ufoai-data might be missing language files


CPU: AMD Sempron SI-42 - 2.1 Ghz  Video: Nvidia GeForce 8200MG  RAM: 4Gb DR
OS: Arch x86_64 + awesome + GTK+
My DeviantART

Offline

#7 2012-05-31 14:54:01

ninquitassar
Member
From: Italy
Registered: 2012-05-30
Posts: 29

Re: ufoai-data might be missing language files

Solved: add to ~/.ufoai/base/2.4/config.cfg
the line

set fs_i18ndir /usr/share/ufoai/base/i18n/

CPU: AMD Sempron SI-42 - 2.1 Ghz  Video: Nvidia GeForce 8200MG  RAM: 4Gb DR
OS: Arch x86_64 + awesome + GTK+
My DeviantART

Offline

#8 2012-06-02 21:44:42

Lutey
Member
Registered: 2012-05-01
Posts: 2

Re: ufoai-data might be missing language files

Thanx ninquitassar,
this works for me!

Offline

#9 2012-06-03 19:49:29

ninquitassar
Member
From: Italy
Registered: 2012-05-30
Posts: 29

Re: ufoai-data might be missing language files

No, it do not works! Ufo recreates ~/.ufoai/base/2.4/config.cfg every time the game starts. You must run the game with the posted cvar, like this:

/usr/bin/ufo +set fs_i18ndir /usr/share/ufoai/base/i18n/

or, if you want the game to start in a new X session:

xinit /usr/bin/ufo +set fs_i18ndir /usr/share/ufoai/base/i18n/ -- :1

CPU: AMD Sempron SI-42 - 2.1 Ghz  Video: Nvidia GeForce 8200MG  RAM: 4Gb DR
OS: Arch x86_64 + awesome + GTK+
My DeviantART

Offline

#10 2013-03-23 18:50:55

spottedgeckgo
Member
Registered: 2013-02-08
Posts: 31
Website

Re: ufoai-data might be missing language files

Just in case anyone is still having this issue running ufoai, also make sure to check in your in-game settings that language is set to "English" or whatever language you like.  My was set to "No Language" by default, and changing the exec line is absolutely neccessary even if you select a language.

In XFCE, I went to /usr/share/applications directory and edit ufoai.desktop as root.
Change the line "Exec=ufo" to "Exec=/usr/bin/ufo +set fs_i18ndir /usr/share/ufoai/base/i18n/"
Then restart from your menu and set your language.  You are good to go.

Thought this might be helpful, sometimes ingame settings are easy to overlook.

Offline

Board footer

Powered by FluxBB