You are not logged in.

#1 2012-05-30 12:48:29

mtbrooks33
Member
Registered: 2011-06-08
Posts: 52

[Solved]Can't change MATE icon theme

I can't seem to find any way to change the MATE icon theme to Faience or Faenza, my two favorites. I have tried to change the icon theme through appearance settings and mateconf-editor. In appearance settings I customized the theme I'm using and selected Faience as my icon theme - it did nothing. In mateconf-editor I set /desktop/mate/interface/icon_theme to Faience - also did nothing.

Any ideas? Thanks.

Last edited by mtbrooks33 (2012-05-30 16:21:55)

Offline

#2 2012-05-30 12:53:30

DSpider
Member
From: Romania
Registered: 2009-08-23
Posts: 2,273

Re: [Solved]Can't change MATE icon theme

Restart X.


"How to Succeed with Linux"

I have made a personal commitment not to reply in topics that start with a lowercase letter. Proper grammar and punctuation is a sign of respect, and if you do not show any, you will NOT receive any help (at least not from me).

Offline

#3 2012-05-30 12:58:18

mtbrooks33
Member
Registered: 2011-06-08
Posts: 52

Re: [Solved]Can't change MATE icon theme

I have tried that. I think it might have something to do with my previous use of KDE (many things on my desktop have inherited QT style, maybe some kde setting is controlling my icons?)

Offline

#4 2012-05-30 13:38:06

DSpider
Member
From: Romania
Registered: 2009-08-23
Posts: 2,273

Re: [Solved]Can't change MATE icon theme

MATE is a GTK2 fork, so using mateconf-editor would only change GTK-based apps. For Qt apps (KDE) you'll need to run systemsettings and go to Application Appearance - Icons.

Last edited by DSpider (2012-05-30 13:40:14)


"How to Succeed with Linux"

I have made a personal commitment not to reply in topics that start with a lowercase letter. Proper grammar and punctuation is a sign of respect, and if you do not show any, you will NOT receive any help (at least not from me).

Offline

#5 2012-05-30 14:33:56

mtbrooks33
Member
Registered: 2011-06-08
Posts: 52

Re: [Solved]Can't change MATE icon theme

when I run systemsettings I get "command not found"

Offline

#6 2012-05-30 15:00:39

DSpider
Member
From: Romania
Registered: 2009-08-23
Posts: 2,273

Re: [Solved]Can't change MATE icon theme

Well, pacman says:

$ pacman -Qo systemsettings
/usr/bin/systemsettings is owned by kdebase-workspace 4.8.3-2

So you'll need:

# pacman -S kdebase-workspace

Kinda odd, though... It's installed as a dependency for gtk-kde4. You should probably read the "Uniform Look for Qt and GTK Applications" article.


"How to Succeed with Linux"

I have made a personal commitment not to reply in topics that start with a lowercase letter. Proper grammar and punctuation is a sign of respect, and if you do not show any, you will NOT receive any help (at least not from me).

Offline

#7 2012-05-30 15:54:56

mtbrooks33
Member
Registered: 2011-06-08
Posts: 52

Re: [Solved]Can't change MATE icon theme

Thank you for your responses! I changed the icon theme successfully with systemsettings. Just one question though - why doesn't changing the icon theme in appearance settings work? I didn't expect kde settings to change my MATE desktop..

Offline

#8 2012-05-30 16:15:06

DSpider
Member
From: Romania
Registered: 2009-08-23
Posts: 2,273

Re: [Solved]Can't change MATE icon theme

Because by default GTK apps use a theme and Qt apps use a different theme. Read the above article.

Qt and GTK+ based programs both use a different widget toolkit to render the graphical user interface. Each come with different themes, styles and icon sets by default, among other things, so the "look and feel" differ significantly. This article will help you make your Qt and GTK+ applications look similar for a more streamlined and "integrated" desktop experience.

Oh, and don't forget to mark it as solved. wink

Last edited by DSpider (2012-05-30 16:15:38)


"How to Succeed with Linux"

I have made a personal commitment not to reply in topics that start with a lowercase letter. Proper grammar and punctuation is a sign of respect, and if you do not show any, you will NOT receive any help (at least not from me).

Offline

#9 2012-05-30 16:19:21

mtbrooks33
Member
Registered: 2011-06-08
Posts: 52

Re: [Solved]Can't change MATE icon theme

Thanks Dspider. I was under the impression that icon theme was independent for some reason. Thread will be marked solved.

Offline

#10 2013-02-24 14:00:40

Archer1X
Member
From: Astral World
Registered: 2013-01-31
Posts: 27
Website

Re: [Solved]Can't change MATE icon theme

This solution is the best for now..I have installed kde-meta and have removed it, because I'd like to try everything that I can when I'm using Arch..so then I installed qtwebkit and kdebase-workspace (just a tips for those who having the same problem like this..)..changed the system icons using KDE System Settings and wal-lah..kudos to Dspider for his idea..

Last edited by Archer1X (2013-02-24 14:02:02)


Arch Linux all the way..

Offline

Board footer

Powered by FluxBB