You are not logged in.

#3926 2012-05-09 18:39:37

Unia
Member
From: The Netherlands
Registered: 2010-03-30
Posts: 2,476
Website

Re: The AMD/ATI Bar & Grill

xsmile wrote:

It performed quite well on my netbook with an AMD E-350 / Radeon 6320 chipset.
You will probably need to set 'export CLUTTER_VBLANK=none' in your profile for better performance though.

Thanks, it indeed runs good. Way better than with the older drivers and it can actually be used now tongue

Still, it's not my DE. I'll be sticking with DWM!


If you can't sit by a cozy fire with your code in hand enjoying its simplicity and clarity, it needs more work. --Carlos Torres

Offline

#3927 2012-05-13 19:40:42

namtsui
Member
Registered: 2012-05-13
Posts: 3

Re: The AMD/ATI Bar & Grill

I'm getting artifacts from scrolling in a terminal. I thought it was because i updated xf86-video-ati-6.14.4.2 --> 6.14.4.4 recently. Downgrading didn't fix the problem. Everything is a little laggy when I scroll in a terminal.

Offline

#3928 2012-05-13 19:55:24

namtsui
Member
Registered: 2012-05-13
Posts: 3

Re: The AMD/ATI Bar & Grill

namtsui wrote:

I'm getting artifacts from scrolling in a terminal. I thought it was because i updated xf86-video-ati-6.14.4.2 --> 6.14.4.4 recently. Downgrading didn't fix the problem. Everything is a little laggy when I scroll in a terminal.

Resolved by downgrading xorg-server 1.12.1-2 --> 1.12.1-1.

Offline

#3929 2012-05-23 19:51:05

zanardi84
Member
Registered: 2011-08-23
Posts: 10

Re: The AMD/ATI Bar & Grill

Hi, I have some problem with my 5770. Just installed Arch on my i5 750 and Radeon 5770. I'm using catalyst taken from Arch repo.
Poor performances, only 700 - 850 fps, vsync off. Youtube playback is slow when enabling full screen. kwin (kde) effects are fine. I had the same behavior when using Chakra. Ubuntu is ok (but I don't like it smile )
What can I do? Tried to follow wiki page, flashplugin section, but it didn't solve.

Offline

#3930 2012-05-26 09:32:23

dgcoffman
Member
Registered: 2012-05-18
Posts: 4

Re: The AMD/ATI Bar & Grill

I'm trying to downgrade xorg-server from 1.12 to 1.11, but can't get the db file from the x111 repo.

/etc/pacman.conf contains

[#x111]
#Server = http://catalyst.apocalypsus.net/repo/xorg111/$arch
$ sudo pacman -Syu                                                                                  ~
warning: database file for 'x111' does not exist
:: Synchronizing package databases...
error: failed retrieving file 'x111.db' from catalyst.apocalypsus.net : The requested URL returned error: 404
error: failed to update x111 (download library error)

How can I do this?

Offline

#3931 2012-05-26 10:24:33

foutrelis
Developer/TU
From: Athens, Greece
Registered: 2008-07-28
Posts: 675
Website

Re: The AMD/ATI Bar & Grill

dgcoffman wrote:
[#x111]
#Server = http://catalyst.apocalypsus.net/repo/xorg111/$arch

Compare what you have to what's in the wiki:

https://wiki.archlinux.org/index.php/AT … positories

Offline

#3932 2012-05-26 14:54:50

arctos
Member
Registered: 2010-12-19
Posts: 13

Re: The AMD/ATI Bar & Grill

dgcoffman wrote:

I'm trying to downgrade xorg-server from 1.12 to 1.11, but can't get the db file from the x111 repo.

/etc/pacman.conf contains

[#x111]
#Server = http://catalyst.apocalypsus.net/repo/xorg111/$arch

Change it to look exactly like this

[xorg111]
Server = http://catalyst.apocalypsus.net/repo/xorg111/$arch

Offline

#3933 2012-05-27 10:01:08

mpnordland
Member
Registered: 2011-11-29
Posts: 46

Re: The AMD/ATI Bar & Grill

Digital Paint (http://www.digitalpaint.org/) doesn't work on fglrx, it gives "Received Signal 11..." Using the opensource drivers works just fine.

Offline

#3934 2012-05-28 09:47:29

achilleas.k
Member
From: Sol 3
Registered: 2011-10-30
Posts: 115

Re: The AMD/ATI Bar & Grill

I just realised last night that I have full-screen YouTube video problems. I kept seeing this problem mentioned in the thread but I was fine until recently. Must be the latest driver.

EDIT: HTML5 video on YouTube works fine (which I thought I had enabled, but for some reason I had to rejoin the trial).

Last edited by achilleas.k (2012-05-28 09:49:47)

Offline

#3935 2012-05-28 15:40:51

Undeterminant
Member
Registered: 2011-12-20
Posts: 4

Re: The AMD/ATI Bar & Grill

It seems that the latest udev in [testing] causes problems with xorg-server in [xorg111]; I had to downgrade to get xorg-server to start. I haven't tried creating new symlinks, but I don't think that that's a good idea, considering how they probably bumped from version 0 to 1 for a good reason.

Is this easily fixed by rebuilding the packages, or does the old version of udev need to be included in this repo alongside xorg-server?

Offline

#3936 2012-05-29 08:47:00

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,336
Website

Re: The AMD/ATI Bar & Grill

fresh udev
Some good people informed me/us about solutions:
- 3V0LU710N @ AUR
- prettyvanilla who sends me an e-mails.
I'm very gratefull for those infos, thank you.

The best way is to recompile xorg-server 1.11 while having fresh udev installed. I will compile it and add to the repo but unfortunatelly i am afk now and i guess that most possible term when i would be able to perform this is saturday, 2nd of june.

fresh udev is still in [testing], hope it won't land in [extra] till i recompile it, but if it would then you can always go through easy (though not so clean...) way:

3V0LU710N wrote:

If someone already experienced this problem, just do the following in the terminal:

"sudo ln -sf /usr/lib/libudev.so.1 /usr/lib/libudev.so.0".

The output should be something like this:

-------------------------------------------------------------------------------------------
ls -l /usr/lib/ | grep -i udev

-rw-r--r-- 1 root root 82644 Mai 27 01:47 libgudev-1.0.a
lrwxrwxrwx 1 root root 21 Mai 27 01:47 libgudev-1.0.so -> libgudev-1.0.so.0.1.1
lrwxrwxrwx 1 root root 21 Mai 27 01:47 libgudev-1.0.so.0 -> libgudev-1.0.so.0.1.1
-rwxr-xr-x 1 root root 39824 Mai 27 01:47 libgudev-1.0.so.0.1.1
-rw-r--r-- 1 root root 649756 Mai 27 01:47 libudev.a
lrwxrwxrwx 1 root root 16 Mai 27 01:47 libudev.so -> libudev.so.1.0.0
lrwxrwxrwx 1 root root 21 Mai 28 00:17 libudev.so.0 -> /usr/lib/libudev.so.1
lrwxrwxrwx 1 root root 16 Mai 27 01:47 libudev.so.1 -> libudev.so.1.0.0
-rwxr-xr-x 1 root root 68408 Mai 27 01:47 libudev.so.1.0.0
drwxr-xr-x 5 root root 4096 Mai 26 18:57 udev
-------------------------------------------------------------------------------------------

Offline

#3937 2012-05-29 10:15:43

Unia
Member
From: The Netherlands
Registered: 2010-03-30
Posts: 2,476
Website

Re: The AMD/ATI Bar & Grill

Shouldn't 12.5 come soon? I guess that should work with Xorg 1.12, which in turn will work with the new udev?

Correct me if I'm wrong, though.


If you can't sit by a cozy fire with your code in hand enjoying its simplicity and clarity, it needs more work. --Carlos Torres

Offline

#3938 2012-05-29 17:18:43

ChemBro
Member
Registered: 2008-10-22
Posts: 691

Re: The AMD/ATI Bar & Grill

Unia wrote:

Shouldn't 12.5 come soon? I guess that should work with Xorg 1.12, which in turn will work with the new udev?

Man, you're optimistic.

Offline

#3939 2012-05-29 17:47:30

Unia
Member
From: The Netherlands
Registered: 2010-03-30
Posts: 2,476
Website

Re: The AMD/ATI Bar & Grill

ChemBro wrote:
Unia wrote:

Shouldn't 12.5 come soon? I guess that should work with Xorg 1.12, which in turn will work with the new udev?

Man, you're optimistic.

big_smile always have been


If you can't sit by a cozy fire with your code in hand enjoying its simplicity and clarity, it needs more work. --Carlos Torres

Offline

#3940 2012-05-31 08:08:11

zanardi84
Member
Registered: 2011-08-23
Posts: 10

Re: The AMD/ATI Bar & Grill

achilleas.k wrote:

I just realised last night that I have full-screen YouTube video problems. I kept seeing this problem mentioned in the thread but I was fine until recently. Must be the latest driver.

EDIT: HTML5 video on YouTube works fine (which I thought I had enabled, but for some reason I had to rejoin the trial).

I can't understand why, after fresh install, everything seems to be ok, and then not.
After new install and pacman -Su ---> fgl_glxgears ok, at least 1800 fps, full-screen youtube playback ok.
After some time --> fgl_glxgears 800 fps max, full-screen youtube playback problems.

On Chakra I had theese problems after new install, but if i start live cd loading amd drivers everything seems to work fine.

I'm thinking about power saving issues, but I can't read gpu freq from catalyst interface... and also I can't believe that my vga is not able to play full screen youtube video (360p or 1080, no difference) while its clock is at the powersave freq.

Offline

#3941 2012-05-31 20:34:32

Weegee
Member
Registered: 2010-08-06
Posts: 62

Re: The AMD/ATI Bar & Grill

Unia wrote:

Shouldn't 12.5 come soon?

http://www.phoronix.com/scan.php?page=n … px=MTExMTA

Yeah, no.


~

Offline

#3942 2012-05-31 21:37:05

ChemBro
Member
Registered: 2008-10-22
Posts: 691

Re: The AMD/ATI Bar & Grill

No 12.5, and 12.6 already has no support for HD 4xxx and less. Also no more monthly releases, only when there are "big windows games", or so.

Offline

#3943 2012-05-31 23:09:30

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,336
Website

Re: The AMD/ATI Bar & Grill

huh... what a sucky sucky phoronix news, darn!

Because of the fact that we know actually nothing about catalyst 12.5  - soon (tommorow or so, now i gotta sleep, then job, etc) i will recompile udev package in [xorg111]...



outside of this !@#$% news well...

[catalyst 12.6 beta]

I just get back from my little job journey, i've used catalyst 11.6 beta driver (found by 3V0LU710N, you can find this driver @ AUR) against my freshly bought hd 7850.
Here's what it's offer:
- xserver 1.12 support;
- kde's direct rendering is finally working well, no errors, no flickering at all (!)  --- well just found that chromium is working even slower than without dir render - which is not so good, though i used to use opera lately, still - looks like amd is finally doing something with this

3V0LU710N said that it doesn't support radeons hd < 5xxx, i cannot test it but i believe his words, and this fact rly rly sux!!!


BTW: i believe that leaving monthly cycle is actually a good idea, i just don't like this "windows games" words

Last edited by Vi0L0 (2012-05-31 23:11:24)

Offline

#3944 2012-06-01 07:57:56

xorgx3
Member
From: Poland
Registered: 2011-11-29
Posts: 197

Re: The AMD/ATI Bar & Grill

Is it normal if I have this output of glxgears (graphic card: Mobility Radeon HD 5400 Series):

303 frames in 5.0 seconds = 60.413 FPS
301 frames in 5.0 seconds = 60.063 FPS
301 frames in 5.0 seconds = 60.064 FPS
301 frames in 5.0 seconds = 60.062 FPS
301 frames in 5.0 seconds = 60.066 FPS
301 frames in 5.0 seconds = 60.066 FPS
300 frames in 5.0 seconds = 59.864 FPS
301 frames in 5.0 seconds = 60.063 FPS
301 frames in 5.0 seconds = 60.066 FPS
301 frames in 5.0 seconds = 60.065 FPS
299 frames in 5.0 seconds = 59.664 FPS
301 frames in 5.0 seconds = 60.064 FPS
301 frames in 5.0 seconds = 60.064 FPS
301 frames in 5.0 seconds = 60.065 FPS

I saw people who FPS were more than 1000.

I am using xorg 1.10.

Offline

#3945 2012-06-01 09:26:29

ChemBro
Member
Registered: 2008-10-22
Posts: 691

Re: The AMD/ATI Bar & Grill

xorgx3 wrote:

Is it normal if I have this output of glxgears (graphic card: Mobility Radeon HD 5400 Series):

303 frames in 5.0 seconds = 60.413 FPS
301 frames in 5.0 seconds = 60.063 FPS
(and so on)

I saw people who FPS were more than 1000.

I am using xorg 1.10.

A) glxgears is really not a benchmark.

B) vsync caps the fps to your monitor frequence, which is 60 Hz. This is normal behaviour.

Offline

#3946 2012-06-01 11:49:43

achilleas.k
Member
From: Sol 3
Registered: 2011-10-30
Posts: 115

Re: The AMD/ATI Bar & Grill

Vi0L0 wrote:

3V0LU710N said that it doesn't support radeons hd < 5xxx, i cannot test it but i believe his words, and this fact rly rly sux!!!

Wow! That really fucking sucks! I'm using a 5 series so this doesn't affect me immediately but how old is  the 4 series? 4 years old according to wikipedia.
4 years is nowhere near old enough to drop support. They should just stop pretending that they care about Linux at all, so people know to stay away from AMD if they're not running Windows.

I have heard occasionally that nVidia drivers aren't that awesome on Linux either, but my 6 year old 8800 is supported by the latest driver (and runs amazingly well) and from the compatibility list it seems they support as far back as 2003 (FX series, remember those?)!!!

I know this is nothing new, I'm just in a "ranty" mood right now. But I'm not reading this wrong, am I? I mean, it's not like we shouldn't be expecting that > 5 year old hardware should be supported.

Offline

#3947 2012-06-01 12:52:01

Weegee
Member
Registered: 2010-08-06
Posts: 62

Re: The AMD/ATI Bar & Grill

achilleas.k wrote:

4 years is nowhere near old enough to drop support. They should just stop pretending that they care about Linux at all, so people know to stay away from AMD if they're not running Windows.

The funny thing is that not only Linux users are affected, everyone having a 4xxx card using Windows is in the same situation right now. My next graphics card will be from NVIDIA, since AMD drivers for high-end cards are a huge mess on Windows (bluescreens, bluescreens everywhere!) - and the closed source nvidia-driver on Linux seems to perform very well. The only sad thing is that NVIDIA doesn't officially support the development of the free nouveau driver, at least as far as I know.


~

Offline

#3948 2012-06-01 12:59:42

achilleas.k
Member
From: Sol 3
Registered: 2011-10-30
Posts: 115

Re: The AMD/ATI Bar & Grill

@Weegee: I was under the impression that the decision was for Linux drivers only. Googling around I'm seeing much confusion. A lot of articles claim that this is for both Win and Linux, but commenters keep pointing out that the announcement is Linux only. Others say the announcement is Linux only but that they suspect the same will go for Windows.

Either way, it's a really bad move.

Offline

#3949 2012-06-01 15:52:30

szorti
Member
From: Cracow, Poland
Registered: 2010-06-23
Posts: 21

Re: The AMD/ATI Bar & Grill

Is Radeon HD 4xxx the same as Radeon Mobility HD 4xxx? I'm using Mobility HD 4550 on my laptop and it's only 3 years old...

Offline

#3950 2012-06-01 16:34:13

agapito
Member
From: Spain
Registered: 2008-11-13
Posts: 499

Re: The AMD/ATI Bar & Grill

12.6 works fine with kernel 3.3.7 and xorg-server 1.12.

HD6790.


Excuse my poor English.

Offline

Board footer

Powered by FluxBB