You are not logged in.

#1 2012-06-02 15:30:14

From: Midwest USA
Registered: 2012-05-31
Posts: 7

[SOLVED]Cannot mount partitions with PCMANFM --no longer an issue

I have searched and searched and pulling my hair out on this issue. I am using PCMANFM .9.10 on an LXDE install using the Arch x86 iso.  My HD contains several linux partitions and a FAT32 partition.

I am not able to mount these partitions in PCMANFM.  I am able to mount my usb flash drive

When trying to mount a partition in PCMANFM I get a "not authorized to perform operation" error message.

Today, June 11 I partially rewrote this due to the lack of response I am getting on this problem.

1. did a reinstall of Arch & LXDE today.  I've done two or three installs. dbus is in daemons in /etc/rc.conf
2. initially the partition icons did not show up
3. then, I installed gvfs and added 55-my-conf.pkla in /etc/polkit-1/localauthority/50-local.d/
4. With that the partition icons show up in PCMANFM
5. But I still get the "not authorized to perform operation" message

The 55-my-conf.pkla has this content:

 [Storage Permissions]

contents of .xinitrc

# ~/.xinitrc
# Executed by startx (run your window manager from here)

if [ -d /etc/X11/xinit/xinitrc.d ]; then
  for f in /etc/X11/xinit/xinitrc.d/*; do
    [ -x "$f" ] && . "$f"
  unset f

# exec gnome-session
# exec startkde
 #exec startxfce4
  exec startlxde
# ...or the Window Manager of your choice

At /usr/share/polkit-1/actions/org.freedesktop.udisks.policy

I changed <action id="org.freedesktop.udisks.filesystem-mount-system-internal">
mount a system-internal disk at <allow_active> from "auth_admin_keep" to "yes".

Still didn't work!

Either this is a bug or I have a permission problem somewhere.

Can you please advise how to do this or point me to a recent tutorial to be able to  auto mount other partitions not using /etc/fstab?  Some of the older posts refer to hal or other package that have been deprecated. 


Edit: latest. It seems that I must mount the desired partition from the terminal. example: $sudo mount /dev/sda5 /mnt
then can edit it from PCMANFM by going to / and then /mnt. Apparently I do not have to manually unmount.

Last edited by linuxloverjerry1 (2012-06-13 04:25:37)


Board footer

Powered by FluxBB