You are not logged in.

#1 2012-06-02 16:37:05

punkeroso
Member
From: Rome, Italy
Registered: 2007-01-19
Posts: 104

linux-3.4 breaks backlight

Hi,
I've just upgraded the kernel and the folder /sys/class/backlight which I used to control the screen brightness is just empty...
Someone knows how to help me?
Thanks

Offline

#2 2012-06-02 18:37:14

punkeroso
Member
From: Rome, Italy
Registered: 2007-01-19
Posts: 104

Re: linux-3.4 breaks backlight

punkeroso wrote:

Hi,
I've just upgraded the kernel and the folder /sys/class/backlight which I used to control the screen brightness is just empty...
Someone knows how to help me?
Thanks

Appending acpi_backlight=vendor to the kernel boot line in menu.lst solved the problem!

Offline

#3 2012-06-16 14:51:40

zag
Member
From: Ukraine, Kiev
Registered: 2012-06-16
Posts: 3

Re: linux-3.4 breaks backlight

After update to linux-3.4.2 I was unable to control backlight via Fn+... keys, hovever /sys/class/backlight/* still were present. Downgrade to 3.3.8 solved the problem. How do I fix it with new kernel?

Offline

#4 2012-06-16 15:37:07

progandy
Member
Registered: 2012-05-17
Posts: 2,151

Re: linux-3.4 breaks backlight

zag wrote:

After update to linux-3.4.2 I was unable to control backlight via Fn+... keys, hovever /sys/class/backlight/* still were present. Downgrade to 3.3.8 solved the problem. How do I fix it with new kernel?

I have the same problem, acpi_backlight=vendor did not help. Did it solve the problem for you?
Currently I am compiling the arch kernel with this patch. Let's wait a few hours for makepkg to finish and see if it helps.

Reporting back after a reboot: The bug is fixed for me.

Last edited by progandy (2012-06-16 17:48:10)

Offline

#5 2012-06-16 20:30:51

zag
Member
From: Ukraine, Kiev
Registered: 2012-06-16
Posts: 3

Re: linux-3.4 breaks backlight

progandy wrote:

acpi_backlight=vendor did not help. Did it solve the problem for you?

I tried, but it didn't help me neither.

progandy wrote:

this patch

The bug seems relevant, I use Toshiba Satellite R630; so I'm going to stay with downgraded kernel until they fix it.

Offline

#6 2012-06-23 17:51:39

Aesthetikx
Member
Registered: 2012-06-23
Posts: 1

Re: linux-3.4 breaks backlight

This happened to me with a fresh install with gnome3, sony vaio f11, nvidia.   Adding

acpi_backlight=vendor

fixed it for me.

Offline

#7 2012-06-26 18:20:42

jackjackk
Member
Registered: 2010-07-21
Posts: 34

Re: linux-3.4 breaks backlight

same problem here, with linux 3.4.4-2 on a Clevo notebook. Backlight Fn keys weren't working anymore, /sys/class/backlight was empty, and brightness at its maximum was stabbing my eyes!
Differently from the above suggestions, adding

acpi_osi=Linux acpi_backlight=legacy

in my /boot/grub/menu.lst as suggested in the wiki fortunately fixed the problem for me.

Offline

#8 2012-06-26 20:37:53

graysky
Member
From: /run/user/1000
Registered: 2008-12-01
Posts: 8,614
Website

Re: linux-3.4 breaks backlight

Probably best to open up a flyspray, jackj... doubtful one of the devs will read this.

EDIT: the kernel line fixes the backlight problem on my Acer AS4830T-6678 as well!

Last edited by graysky (2012-07-06 20:24:13)


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

#9 2012-07-23 21:49:33

ujohnny
Member
Registered: 2012-06-30
Posts: 2

Re: linux-3.4 breaks backlight

I've got this problem again after upgrading to kernel 3.4.6 from 3.4.4, and now option

acpi_backlight=vendor

didn't help for me (it helped some weeks ago when I installed 3.4.4).
If I add

acpi_osi=Linux acpi_backlight=legacy

backlight changing works, but only with Fn+<left | right> buttons. It's a temporary solution, cause in this way there is no backlight level changing, if I turned AC adapter off, for example.

I have Acer 3820TG with ati-intel switchable graphics. Have anybody got this bug after upgrade?

Offline

#10 2012-08-01 19:50:17

zag
Member
From: Ukraine, Kiev
Registered: 2012-06-16
Posts: 3

Re: linux-3.4 breaks backlight

After trial-and-error session I discovered that blacklisting toshiba_acpi module solves problem for me. However if acpi_backlight=vendor is set, Fn buttons still don't affect backlight brightness even with the module blacklisted, despite they generate ACPI events. If acpi_backlight is not set or acpi_backlight=legacy, it works fine.

Offline

#11 2012-08-18 18:58:23

ujohnny
Member
Registered: 2012-06-30
Posts: 2

Re: linux-3.4 breaks backlight

Hi,

I found solution for my problem described here some time ago. It wasn't a bug after updating kernel, it's just a strange behaviour of intel xorg driver.
If I put  to /etc/x11/xorg.conf in device section for intel card

Option      "AccelMethod"  "sna"

the backlight regulation with Fn+<left|right> doesnt working.
With UXA acceleration method it works. Maybe, it was broken here
So, solution is replace SNA by UXA in xorg.conf

Option      "AccelMethod"  "uxa"

Last edited by ujohnny (2012-08-18 18:58:43)

Offline

Board footer

Powered by FluxBB