You are not logged in.

#1 2012-06-03 00:12:40

Registered: 2008-12-15
Posts: 80

Setting default sound card to card 0


After following Arch Wiki for configuring Alsa I added the following to my /etc/asound.conf:

efaults.pcm.card 0
defaults.pcm.device 0
defaults.ctl.card 0

This works on my current session. However, sometimes when I reboot my computer, my primary sound card that my speakers are connected to, becomes card 1 and I have to update this setting to get my sound card working. Also, noticed that Chromium always look for card 0. That is, if my primary sound card is detected as card 1, I won't be able to play videos on youtube, neither using Flash or HTML 5.

Any idea how I can dictate my system to set my primary sound card as card 0?

Last edited by mohtasham1983 (2012-06-03 00:13:04)


#2 2012-06-03 18:38:19

Registered: 2010-01-30
Posts: 40

Re: Setting default sound card to card 0

If both soundcards use different modules you can use e.g.

options snd slots=snd-hda-intel,snd-cmipci


options snd-hda-intel index=0
options snd-cmipci index=1

which both do the same.
If both soundcards use the same module you have to do something like

options snd-hda-intel index=0,1 id=SB,HDMI

(See modinfo of your sound module for suitable parameters like id, vid, pid, etc)


Board footer

Powered by FluxBB