You are not logged in.

#1 2012-06-04 18:07:37

Jindur
Member
Registered: 2011-09-29
Posts: 184

Accessibility's "Slow Keys" always turns on on its own [SOLVED](kinda)

The "Slow Keys" feature always turns on randomly when I for example just try to mark something with the mouse, holding down the shift key, this is on XFCE4.
In Applications Menu -> Accessories -> Accessiblity I already unchecked ALL boxes to try and disable it, but it doesn't work. What's more, when it turns on again (I notice this because it gives a little popup message) it's even still shown as "disabled" (ie check box is unchecked) in the AM->Acc->Acc config dialogue! I have to actually click it twice there (check + uncheck again) to disable it.
I tried to just uninstall 'atk' which seemed to provide Accessibility, but that didn't work out because gtk2/gtk3 depended on it.
Help please, how can I get rid of SlowKeys popping up once and for all?

Last edited by Jindur (2012-06-07 11:15:43)

Offline

#2 2012-06-06 20:25:39

Jindur
Member
Registered: 2011-09-29
Posts: 184

Re: Accessibility's "Slow Keys" always turns on on its own [SOLVED](kinda)

hm, is it ok to bump my question? ^^ no solution yet, but I can't believe I'm the only one with that problem? And a pretty annoying problem actually.

Last edited by Jindur (2012-06-06 20:26:18)

Offline

#3 2012-06-06 20:47:04

ConnorBehan
Trusted User (TU)
From: Long Island NY
Registered: 2007-07-05
Posts: 1,356
Website

Re: Accessibility's "Slow Keys" always turns on on its own [SOLVED](kinda)

If settings you apply aren't taking effect, I would try clearing ~/.cache/xfce4 and ~/.cache/sessions. You're running the accessibility settings dialog and the main xfce processes as the same user right?


6EA3 F3F3 B908 2632 A9CB E931 D53A 0445 B47A 0DAB
Great things come in tar.xz packages.

Offline

#4 2012-06-07 05:56:14

Jindur
Member
Registered: 2011-09-29
Posts: 184

Re: Accessibility's "Slow Keys" always turns on on its own [SOLVED](kinda)

1) Thanks, but that didn't help.
2) I'm always logged in on my one user account, so I think the answer is yes.

Is there a way to just uninstall some package with pacman that provides the accessibility stuff? Is "atk" really the correct package or is it just some additional lib? I did a "pacman -Ss accessibility" to no avail. I just want to delete the broken accessibility feature from my system, to keep it simple.

To reproduce the problem: Hold down SHIFT key. Hold down left mouse button. Move mouse around for about 6 seconds eg to mark some text.

Last edited by Jindur (2012-06-07 06:08:56)

Offline

#5 2012-06-07 07:50:39

ConnorBehan
Trusted User (TU)
From: Long Island NY
Registered: 2007-07-05
Posts: 1,356
Website

Re: Accessibility's "Slow Keys" always turns on on its own [SOLVED](kinda)

You're probably out of luck there. The accessibility dialog is part of xfce4-settings but the actual functions that xfce uses to change keyboard behaviour are part of libx11. Have you tried different ways of starting xfce? Some one said that this problem appeared to be caused by xfce and was actually caused by GDM: http://forums.fedoraforum.org/showthread.php?t=277298


6EA3 F3F3 B908 2632 A9CB E931 D53A 0445 B47A 0DAB
Great things come in tar.xz packages.

Offline

#6 2012-06-07 10:27:52

Jindur
Member
Registered: 2011-09-29
Posts: 184

Re: Accessibility's "Slow Keys" always turns on on its own [SOLVED](kinda)

Interesting, I actually do use gdm for logging in.
When I set up my Arch system I wanted to not install any gnome/kde stuff but only xfce, however, if I didn't use gdm for login manager but Slim (I think it was called, I followed the instructions on the archlinux page for that one actually) then I wouldn't have any sound in my xfce session. I was unable to find out why, alsamixer and everything seemed completely fine, yet there was not a single sound coming out, so I just went with gdm which seemed to do something magic to audio (or maybe Slim did something anti-magic).

I just searched in /etc for "accessibility" and got several results in these files:
1) /etc/gconf/gconf.xml.defaults/%gconf-tree.xml
2) /etc/dconf/db/gdm.d/00-upstream-settings
3) /etc/dconf/db/gdm.d/locks/00-upstream-settings-locks

as well as these two whose filenames seem unlikely to be involved in the problem:
4) /etc/xdg/menus/xfce-applications.menu
5) /etc/xdg/menus/arch-applications.menu

1) only seems to contain a menu structure in XML format, although it also has an entry "exec_ats" under "accessibility"->"startup"..
2) contains this:
  [org/gnome/desktop/interface]
  toolkit-accessibility=true
3) this, but since it's apparently a  "lock" file, I guess it is just created from 2)?:
  /org/gnome/desktop/interface/toolkit-accessibility
4) and 5) are XML menu structures again, which just mention "xfce-accessories.directory" and "Arch-Accessibility.directory". Seem unlikely to be a cause I guess.

I tried setting 2) to =false and commenting out the line in 3) but it didn't help.
I noticed however, that it seemed to take 10s rather than just 6s until slowkeys triggered, but might just be my nerves wink.

Last edited by Jindur (2012-06-07 10:44:16)

Offline

#7 2012-06-07 10:58:09

Jindur
Member
Registered: 2011-09-29
Posts: 184

Re: Accessibility's "Slow Keys" always turns on on its own [SOLVED](kinda)

New approach: I tried to use gconftool-2:
  gconftool-2 -a /desktop/gnome/accessibility/keyboard
shows every accessibility option set to "false" though.
  gconftool-2 -a /desktop/gnome/accessibility/startup
shows just "exec_ats = []" whatever that means.

  gconftool-2 -a /apps/gdm/simple-greeter/accessibility
is just empty.

  gconftool-2 -a /schemas/desktop/gnome/accessibility/keyboard
and
gconftool-2 -a /schemas/desktop/gnome/accessibility/startup
seem to be just unrelated menu structure things.

-> out of ideas.


Edit: It definitely seems to be caused by the underlying gdm.
Jim Minter wrote a hack yesterday for execution in your xfce-session, to disable slowkeys activation:
https://bugzilla.redhat.com/attachment.cgi?id=589953
so far it worked for me! smile  Uh I guess this counts as SOLVED..probably.

Last edited by Jindur (2012-06-07 11:15:15)

Offline

#8 2013-04-24 03:49:43

wlmeng11
Member
Registered: 2012-11-17
Posts: 6

Re: Accessibility's "Slow Keys" always turns on on its own [SOLVED](kinda)

Another solution is here:
http://ubuntuforums.org/showthread.php? … st12090504

Run in XFCE autostart:
xkbset -a

Offline

Board footer

Powered by FluxBB