You are not logged in.

#101 2012-06-11 11:02:16

aksr
Member
Registered: 2011-03-16
Posts: 11

Re: [Official] broadcom-wl thread

broadcom-wl isn't working after latest update(linux-headers). I'm unable to set it up

Offline

#102 2012-06-12 11:44:48

greenfuse
Member
Registered: 2008-02-14
Posts: 57

Re: [Official] broadcom-wl thread

I have also just had broadcom-wl fail with my 14e4:4315 after pacman -Syu. Rebuilding/reinstalling did not help. Loading the module wl succeeds without error but:

# iwlist wlan1 scan
wlan1     Interface doesn't support scanning.

Anyone else have this?

Offline

#103 2012-06-12 11:52:23

greenfuse
Member
Registered: 2008-02-14
Posts: 57

Re: [Official] broadcom-wl thread

Never mind, 'rfkill unblock all' cleared it up

Offline

#104 2012-06-13 06:47:45

kostett
Member
From: Archangelsk, Russia
Registered: 2012-04-14
Posts: 34

Re: [Official] broadcom-wl thread

oh.. i can't build broadcom-wl since i update my kernel to 3.4 (linux-pf, but i builded on 3.3, i think problem not here)

[kostett@lenovo-sielab ~]$ yaourt -S broadcom-wl

==> Downloading broadcom-wl PKGBUILD from AUR...
x PKGBUILD
x install
x license.patch
x linux3.patch
x modprobe.d
x multicast.patch
x semaphore.patch

Comment by: aksr on Mon, 11 Jun 2012 10:58:05 +0000
Wireless stopped working after latest update.., what can be done?	

Comment by: QuimaxW on Mon, 11 Jun 2012 11:12:46 +0000
To aksr...usually if this breaks after an update, rebuilding the package seems to do the trick. I simply keep around the tarball from this page and any other files I'd have to download so I can rebuild the module withouth a connection. Just clean out the folder, then re-run makepkg and reinstall with pacman.

To whomever marked this out-of-date: it's not. The package ver on broadcom's site is the same as here, 5.100.82.112.	

Comment by: aksr on Mon, 11 Jun 2012 11:15:14 +0000
@QuimaxW: Yes, I know, but this isn't the case with the latest update, I tried rebuilding it.., nothing.	

Comment by: andreyv on Mon, 11 Jun 2012 11:21:14 +0000
@aksr: Then you'll have to define stopped working. Does the module not load? Does it fail to connect? (What are the errors in dmesg?)	

Comment by: vesath on Mon, 11 Jun 2012 14:43:18 +0000
aksr: Do not flag packages out-of-date just to get attention; whatever the reason, you'll only succeed in pissing maintainers off.
And next time you try to report an issue, define your terms: Wireless stopped working after latest update... What update? What wireless card? How is it not working? Because right now nobody here has a clue what you are talking about...	

Comment by: aksr on Mon, 11 Jun 2012 15:45:35 +0000
vesath: I didn't flag package out-of-date just to get attention, that would be foolish; I had this problem earlier and I always solved it by rebuilding the package. Now, that isn't the case. I didn't mess with settings, it just stopped after latest kernel headers update (I think). All info is here: http://nopaste.info/2c30f6f798.html . If you need something else, please say. It's strange that only I have this problem.	

First Submitted: Mon, 01 Sep 2008 18:22:27 +0000	
broadcom-wl 5.100.82.112-3 
( Unsupported package: Potentially dangerous ! )
==> Edit PKGBUILD ? [Y/n] ("A" to abort)
==> ------------------------------------
==> y

Please add $EDITOR to your environment variables
for example:
export EDITOR="vim" (in ~/.bashrc)
(replace vim with your favorite editor)

==> Edit PKGBUILD with:  nano

==> broadcom-wl dependencies:
 - linux-pf (already installed)
 - linux-headers (already installed)


==> Edit PKGBUILD ? [Y/n] ("A" to abort)
==> ------------------------------------
==> n

==> Edit install ? [Y/n] ("A" to abort)
==> -----------------------------------
==> n

==> Continue building broadcom-wl ? [Y/n]
==> -------------------------------------
==> 
==> Building and installing package
==> Сборка пакета: broadcom-wl 5.100.82.112-3 (Ср. июня 13 10:17:20 MSK 2012) //en: Building package: ...
==> Проверяю необходимые для запуска зависимости... //en: Checking dependencies to start
==> Проверяю необходимые для сборки зависимости... //en: Checking dependencies to build
==> Получение исходных файлов... //en: Downloading sources
  -> Загрузка hybrid-portsrc_x86_32-v5_100_82_112.tar.gz... //en Downloading ...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 1112k  100 1112k    0     0   3657      0  0:05:11  0:05:11 --:--:--  3386
  -> Найден modprobe.d //en: Found ..
  -> Найден linux3.patch //en: Found ..
  -> Найден license.patch
  -> Найден multicast.patch
  -> Найден semaphore.patch
==> Проверка исходных файлов с помощью sha1sums... //en: Checking sources with use ...
    hybrid-portsrc_x86_32-v5_100_82_112.tar.gz ... Готово //en: Done
    modprobe.d ... Готово //en: Done
    linux3.patch ... Готово
    license.patch ... Готово
    multicast.patch ... Готово
    semaphore.patch ... Готово
==> Распаковка исходных файлов... //en: Extracting sources
  -> Извлечение hybrid-portsrc_x86_32-v5_100_82_112.tar.gz с помощью bsdtar //en: Extracting ... with use ...
==> Запускается build()... //en: Starting ...
patching file Makefile
patching file src/wl/sys/wl_linux.c
Hunk #1 succeeded at 245 (offset 5 lines).
patching file src/wl/sys/wl_linux.c
Hunk #1 succeeded at 386 (offset 1 line).
patching file src/wl/sys/wl_iw.h
make: Вход в каталог `/usr/src/linux-3.4-pf' //en: Entering to directory ...
CFG80211 API is prefered for this kernel version
Using CFG80211 API
  LD      /tmp/yaourt-tmp-kostett/aur-broadcom-wl/src/built-in.o
  CC [M]  /tmp/yaourt-tmp-kostett/aur-broadcom-wl/src/src/shared/linux_osl.o
  CC [M]  /tmp/yaourt-tmp-kostett/aur-broadcom-wl/src/src/wl/sys/wl_linux.o
/tmp/yaourt-tmp-kostett/aur-broadcom-wl/src/src/wl/sys/wl_linux.c:43:24: фатальная ошибка: asm/system.h: Нет такого файла или каталога //en: Fatal error: ...: No such file or directory
компиляция прервана. //en: Compilation aborted
make[1]: *** [/tmp/yaourt-tmp-kostett/aur-broadcom-wl/src/src/wl/sys/wl_linux.o] Ошибка 1 //en: Error 1
make: *** [_module_/tmp/yaourt-tmp-kostett/aur-broadcom-wl/src] Ошибка 2 //en: Error 2
make: Выход из каталога `/usr/src/linux-3.4-pf' //en: Exit from directory..
==> ОШИБКА: Произошел сбой в build(). //en: ERROR: in build() shit happens
    Преждевременный выход... //en: pretime exit
==> ERROR: Makepkg was unable to build broadcom-wl.
==> Restart building broadcom-wl ? [y/N]
==> ------------------------------------
==> 

i tryed to translate the console output
how can i install broadcom-wl on that kernel version?

Offline

#105 2012-06-13 18:35:06

kostett
Member
From: Archangelsk, Russia
Registered: 2012-04-14
Posts: 34

Re: [Official] broadcom-wl thread

i'm update headers and kernel to 3.4.1 and nothings changed, asm/system.h isn't there..
i must to wait an update from Broadcom? or I can to make it work by another method?
//sorry for my english..

Offline

#106 2012-06-13 18:51:17

guibou
Member
Registered: 2012-05-13
Posts: 20

Re: [Official] broadcom-wl thread

There is an updated PKGBUILD in the the aur page.

Offline

#107 2012-06-14 04:26:35

kostett
Member
From: Archangelsk, Russia
Registered: 2012-04-14
Posts: 34

Re: [Official] broadcom-wl thread

guibou wrote:

There is an updated PKGBUILD in the the aur page.

i was trying to install it by yaourt -S broadcom-wl and i get same result, as yesterday - no file asm/system.h

Offline

#108 2012-06-14 05:32:36

guibou
Member
Registered: 2012-05-13
Posts: 20

Re: [Official] broadcom-wl thread

Sorry, I was not precise. The updated PKGBUILD is on the comments of the aur page.

Offline

#109 2012-06-14 10:09:27

Gusar
Member
Registered: 2009-08-25
Posts: 3,500

Re: [Official] broadcom-wl thread

kostett, post the output of lspci -nn, so we'll know which wireless card you have. All of them are now supported by open-source drivers, so you can probably use those and don't need to bother with broadcom-wl.

Offline

#110 2012-06-14 11:39:13

ijanos
Member
From: Budapest, Hungary
Registered: 2008-03-30
Posts: 441
Website

Re: [Official] broadcom-wl thread

Hi,

I have a

Broadcom Corporation BCM4312 802.11b/g LP-PHY [14e4:4315] (rev 01)

card. The -wl driver works well and the only annoying thing is the rebuild after kernel upgrades (and of course the fear that some day it will not build with the current kernel)

Last time I tried the b43 driver (~ a year ago) it could not connect to anything. The Arch Wiki mentions problems with b43 with this card, is it up to date? Anyone using b43 with this card?

Last edited by ijanos (2012-06-14 11:41:22)

Offline

#111 2012-06-14 16:48:59

kostett
Member
From: Archangelsk, Russia
Registered: 2012-04-14
Posts: 34

Re: [Official] broadcom-wl thread

guibou wrote:

Sorry, I was not precise. The updated PKGBUILD is on the comments of the aur page.

it crashed my lbkmod, thanks

Gusar wrote:

kostett, post the output of lspci -nn, so we'll know which wireless card you have. All of them are now supported by open-source drivers, so you can probably use those and don't need to bother with broadcom-wl.

[kostett@lenovo-sielab ~]$ sudo lspci -nn
Пароль: 
00:00.0 Host bridge [0600]: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub [8086:2a40] (rev 09)
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 09)
00:02.1 Display controller [0380]: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a43] (rev 09)
00:1a.0 USB controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 [8086:2937] (rev 03)
00:1a.1 USB controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 [8086:2938] (rev 03)
00:1a.2 USB controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 [8086:2939] (rev 03)
00:1a.7 USB controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 [8086:293c] (rev 03)
00:1b.0 Audio device [0403]: Intel Corporation 82801I (ICH9 Family) HD Audio Controller [8086:293e] (rev 03)
00:1c.0 PCI bridge [0604]: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 [8086:2940] (rev 03)
00:1c.1 PCI bridge [0604]: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 [8086:2942] (rev 03)
00:1c.2 PCI bridge [0604]: Intel Corporation 82801I (ICH9 Family) PCI Express Port 3 [8086:2944] (rev 03)
00:1c.3 PCI bridge [0604]: Intel Corporation 82801I (ICH9 Family) PCI Express Port 4 [8086:2946] (rev 03)
00:1c.5 PCI bridge [0604]: Intel Corporation 82801I (ICH9 Family) PCI Express Port 6 [8086:294a] (rev 03)
00:1d.0 USB controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 [8086:2934] (rev 03)
00:1d.1 USB controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 [8086:2935] (rev 03)
00:1d.2 USB controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 [8086:2936] (rev 03)
00:1d.7 USB controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 [8086:293a] (rev 03)
00:1e.0 PCI bridge [0604]: Intel Corporation 82801 Mobile PCI Bridge [8086:2448] (rev 93)
00:1f.0 ISA bridge [0601]: Intel Corporation ICH9M LPC Interface Controller [8086:2919] (rev 03)
00:1f.2 SATA controller [0106]: Intel Corporation 82801IBM/IEM (ICH9M/ICH9M-E) 4 port SATA Controller [AHCI mode] [8086:2929] (rev 03)
00:1f.3 SMBus [0c05]: Intel Corporation 82801I (ICH9 Family) SMBus Controller [8086:2930] (rev 03)
04:00.0 Network controller [0280]: Broadcom Corporation BCM4312 802.11b/g LP-PHY [14e4:4315] (rev 01)
07:00.0 Ethernet controller [0200]: Broadcom Corporation NetLink BCM5906M Fast Ethernet PCI Express [14e4:1713] (rev 02)
[kostett@lenovo-sielab ~]$ 

my laptop is lenovo 3000 G530 or also named lenovo G530 6KS-B

Offline

#112 2012-06-15 08:10:21

Gusar
Member
Registered: 2009-08-25
Posts: 3,500

Re: [Official] broadcom-wl thread

Same card as ijamos has. Try the b43 driver. Just install b43-firmware from AUR and the driver should work.

Last edited by Gusar (2012-06-15 08:10:57)

Offline

#113 2012-06-15 09:20:38

kostett
Member
From: Archangelsk, Russia
Registered: 2012-04-14
Posts: 34

Re: [Official] broadcom-wl thread

Gusar, ok, i will try when hot-spot will be near me..

Offline

#114 2012-06-15 14:02:20

Koven
Member
Registered: 2006-06-13
Posts: 151

Re: [Official] broadcom-wl thread

Today I updated kernel from 3.3.8 to 3.4.2.  My broadcom chip es

0c:00.0 Network controller: Broadcom Corporation BCM4322 802.11a/b/g/n Wireless LAN Controller (rev 01)

I changed this line in PKGBUILD

from

_extramodules=extramodules-3.3-ARCH

to

_extramodules=extramodules-3.4-ARCH

because it wasn't even downloading broadcom driver. Once i did it I tried to compile again and I get this error.

==> Validating source files with sha1sums...
    hybrid-portsrc_x86_64-v5_100_82_112.tar.gz ... Passed
    modprobe.d ... Passed
    linux3.patch ... Passed
    license.patch ... Passed
    multicast.patch ... Passed
    semaphore.patch ... Passed
==> Extracting Sources...
  -> Extracting hybrid-portsrc_x86_64-v5_100_82_112.tar.gz with bsdtar
==> Starting build()...
patching file Makefile
patching file src/wl/sys/wl_linux.c
Hunk #1 succeeded at 245 (offset 5 lines).
patching file src/wl/sys/wl_linux.c
Hunk #1 succeeded at 386 (offset 1 line).
patching file src/wl/sys/wl_iw.h
make: Entering directory `/usr/src/linux-3.4.2-2-ARCH'
CFG80211 API is prefered for this kernel version
Using CFG80211 API
  LD      /tmp/yaourt-tmp-koven/aur-broadcom-wl/src/built-in.o
  CC [M]  /tmp/yaourt-tmp-koven/aur-broadcom-wl/src/src/shared/linux_osl.o
  CC [M]  /tmp/yaourt-tmp-koven/aur-broadcom-wl/src/src/wl/sys/wl_linux.o
/tmp/yaourt-tmp-koven/aur-broadcom-wl/src/src/wl/sys/wl_linux.c:43:24: fatal error: asm/system.h: No such file or directory
compilation terminated.
make[1]: *** [/tmp/yaourt-tmp-koven/aur-broadcom-wl/src/src/wl/sys/wl_linux.o] Error 1
make: *** [_module_/tmp/yaourt-tmp-koven/aur-broadcom-wl/src] Error 2
make: Leaving directory `/usr/src/linux-3.4.2-2-ARCH'
==> ERROR: A failure occurred in build().
    Aborting...
==> ERROR: Makepkg was unable to build broadcom-wl

b43-firmware didn't work for me so I don't know what else to do. The PKGBUILD in aur didn't work either becacuse it's for 3.4.0.

BR

Last edited by Koven (2012-06-15 14:11:41)

Offline

#115 2012-06-15 14:26:38

Koven
Member
Registered: 2006-06-13
Posts: 151

Re: [Official] broadcom-wl thread

Now working with last update of vesath. Great Work!!

Offline

#116 2012-06-15 16:11:24

Gusar
Member
Registered: 2009-08-25
Posts: 3,500

Re: [Official] broadcom-wl thread

Koven wrote:

b43-firmware didn't work for me so I don't know what else to do. The PKGBUILD in aur didn't work either becacuse it's for 3.4.0

Err, the firmware is for 3.2 and up and is marked as such in the PKGBUILD. Or are you talking here about the broadcom-wl PKGBUILD?

In this case "didn't work" is not a useful report. Even if you have broadcom-wl working now, I'd still be interested what exactly is wrong with the b43 driver.

Last edited by Gusar (2012-06-15 16:15:40)

Offline

#117 2012-06-16 13:23:00

moggux
Member
Registered: 2009-01-06
Posts: 3

Re: [Official] broadcom-wl thread

Just in case someone else out there is experiencing a kernel panic (freeze on boot with flashing capslock) on a hpdm1 (bcm4313) laptop after the kernel upgrade to 3.4.2-2 and reinstalling the broadcom-wl driver. I found adding cfg80211 to the MODULES array in rc.conf gets it working again.

Offline

#118 2012-06-18 10:17:49

kostett
Member
From: Archangelsk, Russia
Registered: 2012-04-14
Posts: 34

Re: [Official] broadcom-wl thread

bcm4312 - all works now after updating b43-firmware and broadcom-wl, tested on 3.4.2-1-pf and 3.4.2-2-ARCH
thanks

Offline

#119 2012-07-19 23:04:22

djyoung4
Member
Registered: 2012-05-03
Posts: 22

Re: [Official] broadcom-wl thread

Just upgraded to 3.4.5-1 and am having problems with broadcom.  any ideas when it could be upgraded.

Offline

#120 2012-07-19 23:25:05

skunktrader
Member
From: Brisbane, Australia
Registered: 2010-02-14
Posts: 1,323

Re: [Official] broadcom-wl thread

djyoung4 wrote:

Just upgraded to 3.4.5-1 and am having problems with broadcom.  any ideas when it could be upgraded.

broadcom-wl working fine for me with 3.4.5-1

Offline

#121 2012-07-20 00:22:06

djyoung4
Member
Registered: 2012-05-03
Posts: 22

Re: [Official] broadcom-wl thread

Odd I can't seem to figure out what is wrong with mine.   heres my lspci -nn

[djyoung4@arch ~]$ lspci -nn
00:00.0 Host bridge [0600]: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub [8086:2a40] (rev 07)
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07)
00:02.1 Display controller [0380]: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a43] (rev 07)
00:1a.0 USB controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 [8086:2937] (rev 03)
00:1a.1 USB controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 [8086:2938] (rev 03)
00:1a.7 USB controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 [8086:293c] (rev 03)
00:1b.0 Audio device [0403]: Intel Corporation 82801I (ICH9 Family) HD Audio Controller [8086:293e] (rev 03)
00:1c.0 PCI bridge [0604]: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 [8086:2940] (rev 03)
00:1c.2 PCI bridge [0604]: Intel Corporation 82801I (ICH9 Family) PCI Express Port 3 [8086:2944] (rev 03)
00:1c.3 PCI bridge [0604]: Intel Corporation 82801I (ICH9 Family) PCI Express Port 4 [8086:2946] (rev 03)
00:1c.4 PCI bridge [0604]: Intel Corporation 82801I (ICH9 Family) PCI Express Port 5 [8086:2948] (rev 03)
00:1c.5 PCI bridge [0604]: Intel Corporation 82801I (ICH9 Family) PCI Express Port 6 [8086:294a] (rev 03)
00:1d.0 USB controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 [8086:2934] (rev 03)
00:1d.1 USB controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 [8086:2935] (rev 03)
00:1d.2 USB controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 [8086:2936] (rev 03)
00:1d.7 USB controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 [8086:293a] (rev 03)
00:1e.0 PCI bridge [0604]: Intel Corporation 82801 Mobile PCI Bridge [8086:2448] (rev 93)
00:1f.0 ISA bridge [0601]: Intel Corporation ICH9M LPC Interface Controller [8086:2919] (rev 03)
00:1f.2 SATA controller [0106]: Intel Corporation 82801IBM/IEM (ICH9M/ICH9M-E) 4 port SATA Controller [AHCI mode] [8086:2929] (rev 03)
00:1f.3 SMBus [0c05]: Intel Corporation 82801I (ICH9 Family) SMBus Controller [8086:2930] (rev 03)
02:00.0 Network controller [0280]: Broadcom Corporation BCM4312 802.11b/g LP-PHY [14e4:4315] (rev 01)
03:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller [10ec:8136] (rev 02)
04:00.0 System peripheral [0880]: JMicron Technology Corp. SD/MMC Host Controller [197b:2382]
04:00.2 SD Host controller [0805]: JMicron Technology Corp. Standard SD Host Controller [197b:2381]
04:00.3 System peripheral [0880]: JMicron Technology Corp. MS Host Controller [197b:2383]
04:00.4 System peripheral [0880]: JMicron Technology Corp. xD Host Controller [197b:2384]

Offline

#122 2012-08-14 18:30:20

mhtrinh
Member
Registered: 2010-10-06
Posts: 19

Re: [Official] broadcom-wl thread

ijanos wrote:

Hi,

I have a

Broadcom Corporation BCM4312 802.11b/g LP-PHY [14e4:4315] (rev 01)

card. The -wl driver works well and the only annoying thing is the rebuild after kernel upgrades (and of course the fear that some day it will not build with the current kernel)

Last time I tried the b43 driver (~ a year ago) it could not connect to anything. The Arch Wiki mentions problems with b43 with this card, is it up to date? Anyone using b43 with this card?

I tested b43 driver around kernel 3.2.1  and using updated source from http://linuxwireless.org/en/users/Download
It works for me (on OpenSuse). I even managed to crack WEP with it :-p ... for learning purpose. Anyway, no one use WEP anymore :-(

The only problem is that when using b43, bluetooth don't work !

Offline

#123 2012-08-14 18:36:54

ijanos
Member
From: Budapest, Hungary
Registered: 2008-03-30
Posts: 441
Website

Re: [Official] broadcom-wl thread

ijanos wrote:

Hi,

I have a

Broadcom Corporation BCM4312 802.11b/g LP-PHY [14e4:4315] (rev 01)

card. The -wl driver works well and the only annoying thing is the rebuild after kernel upgrades (and of course the fear that some day it will not build with the current kernel)

Last time I tried the b43 driver (~ a year ago) it could not connect to anything. The Arch Wiki mentions problems with b43 with this card, is it up to date? Anyone using b43 with this card?

I've successfully switched to the b43 driver. Everything works fine. Including bluetooth.

Offline

#124 2012-08-15 20:43:33

mhtrinh
Member
Registered: 2010-10-06
Posts: 19

Re: [Official] broadcom-wl thread

I installed the latest compat-wireless driver. I cannot make wifi and bluetooth work together.
More precisely, at boot, I blacklist b43 and btusb.
If I enable bluetooth (modprobe btusb) first (without b43, wifi). Bluetooth work. I can pair and play audio with my bt headset (MW600). But then if I load wifi (mordprob b43), bluetooth disconnect and won't reconnect, even after unloading b43. I see the device but cannot connect/pair with it. Meanwhile, wifi works.
If I load wifi then bluetooth, the later never connect.
I used a custom kernel 3.4.6, BCM4312 802.11b/g LP-PHY [14e4:4315] (rev 01). I tested compat-wireless-2012-07-03

Offline

#125 2012-09-06 19:36:02

xorgx3
Member
From: Poland
Registered: 2011-11-29
Posts: 197

Re: [Official] broadcom-wl thread

Since yesterday something is wrong with my broadcom-wl. Still error:

Sep  6 21:25:17 localhost kernel: [   24.093047] ERROR @__wl_cfg80211_scan : WLC_SCAN error (-22)
Sep  6 21:25:22 localhost kernel: [   29.086896] ERROR @__wl_cfg80211_scan : WLC_SCAN error (-22)
Sep  6 21:25:28 localhost dhcpcd[1246]: dhcpcd not running
Sep  6 21:25:28 localhost dhcpcd[1252]: dhcpcd not running
Sep  6 21:25:28 localhost dhcpcd[1260]: dhcpcd not running
Sep  6 21:25:30 localhost dhcpcd[1273]: eth0: sendmsg: Cannot assign requested address

Not working only wirelles connection, cable internet is fine.

b43 and b43 legacy not work for me and I have to use wl.


I've got:

$ lspci -vnn | grep 14e4
04:00.0 Network controller [0280]: Broadcom Corporation BCM4312 802.11b/g LP-PHY [14e4:4315] (rev 01)
#ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether b8:ac:6f:70:ba:71 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.3/24 brd 192.168.1.255 scope global eth0
    inet6 fe80::baac:6fff:fe70:ba71/64 scope link 
       valid_lft forever preferred_lft forever
3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN qlen 1000
    link/ether 78:e4:00:45:3d:80 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::7ae4:ff:fe45:3d80/64 scope link 
       valid_lft forever preferred_lft forever
# iwconfig
eth0      no wireless extensions.

eth1      IEEE 802.11abg  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=200 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:on
          
lo        no wireless extensions.

This broken suddenly, i didn't nothing special(even not upgrade, i think so).

Anyone can help me?

Offline

Board footer

Powered by FluxBB