You are not logged in.

#1 2012-06-17 09:13:50

cm100
Member
Registered: 2010-01-23
Posts: 16

Boots to "(none) login:" after upgrade

After my last

pacman -Syu

my system boots into

Arch Linux 3.3.7-1-ARCH (tty1)
(none) login:

So I cannot login anymore. Any idea how I can fix this?

Offline

#2 2012-06-17 09:22:34

Gcool
Member
Registered: 2011-08-16
Posts: 1,456

Re: Boots to "(none) login:" after upgrade

I'm not sure I fully understand the issue. That looks like a normal login prompt to me.

What happens if you try to login there (tty output, logging,...)?


Burninate!

Offline

#3 2012-06-17 09:24:20

DSpider
Member
From: Romania
Registered: 2009-08-23
Posts: 2,273

Re: Boots to "(none) login:" after upgrade

(none) login:

It should say "your_hostname login:"

So I'm thinking you don't have a proper /etc/rc.conf. Here's mine:

LOCALE="en_US.UTF-8"
HARDWARECLOCK="localtime"
TIMEZONE="Europe/Bucharest"
USECOLOR="yes"
HOSTNAME="arch"

MODULES=(vboxdrv)

DAEMONS=(syslog-ng dbus ufw crond alsa networkmanager)

Post your /etc/inittab and /etc/fstab.


"How to Succeed with Linux"

I have made a personal commitment not to reply in topics that start with a lowercase letter. Proper grammar and punctuation is a sign of respect, and if you do not show any, you will NOT receive any help (at least not from me).

Offline

#4 2012-06-17 09:37:53

cm100
Member
Registered: 2010-01-23
Posts: 16

Re: Boots to "(none) login:" after upgrade

Gcool wrote:

I'm not sure I fully understand the issue. That looks like a normal login prompt to me.

What happens if you try to login there (tty output, logging,...)?

If I type in my loginname and press enter instead of asking the password it just changes to a fresh loginscreen as posted above. If I press then

Ctrl+Alt+Enter

it displays

/bin/bash: error while loading shared libraries: libreadline.so.6: cannot open shared object file: No such file or directory

and

shutdown: warning: cannot open /var/run/shutdown.pid
 fstab
# 
# /etc/fstab: static file system information
#
# <file system>        <dir>         <type>    <options>          <dump> <pass>
devpts                 /dev/pts      devpts    defaults            0      0
shm                    /dev/shm      tmpfs     nodev,nosuid        0      0

#/dev/cdrom             /media/cd   auto    ro,user,noauto,unhide   0      0
#/dev/dvd               /media/dvd  auto    ro,user,noauto,unhide   0      0
#/dev/fd0               /media/fl   auto    user,noauto             0      0

UUID=280a8721-3e78-4910-af7f-875d3d553877 /home ext4 defaults,noatime 0 1
UUID=4bcc61c2-ad4c-41e4-bf5e-fb505599e748 /opt ext4 defaults,noatime 0 1
UUID=7db71d4f-0ee6-4c61-a124-8be6e39438e0 /var reiserfs defaults,notail 0 1
UUID=965b4303-e912-4555-8d92-893bca489a0e /usr ext4 defaults,noatime 0 1
UUID=d0023b70-4375-41de-add2-4a9acf19dddf / ext2 defaults 0 1
UUID=b253dbf4-cdc6-43b2-9ecc-9ed50b2fc84c /home/myuser/backup ext4
defaults,noatime 0 1
UUID=f8a0b36f-f007-42cc-b492-272692a8ee58 swap swap defaults 0 0
defaults,noatime 0 1
/etc/rc.conf
#
# /etc/rc.conf - Main Configuration for Arch Linux
#

# -----------------------------------------------------------------------
# LOCALIZATION
# -----------------------------------------------------------------------
#
# LOCALE: available languages can be listed with the 'locale -a' command
# HARDWARECLOCK: set to "UTC" or "localtime", any other value will result
#   in the hardware clock being left untouched (useful for virtualization)
# TIMEZONE: timezones are found in /usr/share/zoneinfo
# KEYMAP: keymaps are found in /usr/share/kbd/keymaps
# CONSOLEFONT: found in /usr/share/kbd/consolefonts (only needed for non-US)
# CONSOLEMAP: found in /usr/share/kbd/consoletrans
# USECOLOR: use ANSI color sequences in startup messages
#
LOCALE="de_DE.UTF-8"
HARDWARECLOCK="UTC"
TIMEZONE="Europe/Berlin"
KEYMAP="de-latin1"
CONSOLEFONT=
CONSOLEMAP=
USECOLOR="yes"

# -----------------------------------------------------------------------
# HARDWARE
# -----------------------------------------------------------------------
#
# MOD_AUTOLOAD: Allow autoloading of modules at boot and when needed
# MOD_BLACKLIST: Prevent udev from loading these modules
# MODULES: Modules to load at boot-up. Prefix with a ! to blacklist.
#
# NOTE: Use of 'MOD_BLACKLIST' is deprecated. Please use ! in the MODULES array.
#
MOD_AUTOLOAD="yes"
#MOD_BLACKLIST=() #deprecated
MODULES=(powernow-k7 cpufreq_ondemand)

# Scan for LVM volume groups at startup, required if you use LVM
USELVM="no"

# -----------------------------------------------------------------------
# NETWORKING
# -----------------------------------------------------------------------
#
# HOSTNAME: Hostname of machine. Should also be put in /etc/hosts
#
HOSTNAME="arch"

# Use 'ifconfig -a' or 'ls /sys/class/net/' to see all available interfaces.
#
# Interfaces to start at boot-up (in this order)
# Declare each interface then list in INTERFACES
#   - prefix an entry in INTERFACES with a ! to disable it
#   - no hyphens in your interface names - Bash doesn't like it
# 
# DHCP:     Set your interface to "dhcp" (eth0="dhcp")
# Wireless: See network profiles below
#

#Static IP example
#eth0="eth0 192.168.0.2 netmask 255.255.255.0 broadcast 192.168.0.255"
eth0="dhcp"
INTERFACES=(eth0)

# Routes to start at boot-up (in this order)
# Declare each route then list in ROUTES
#   - prefix an entry in ROUTES with a ! to disable it
#
gateway="default gw 192.168.0.1"
ROUTES=(!gateway)
 
# Enable these network profiles at boot-up.  These are only useful
# if you happen to need multiple network configurations (ie, laptop users)
#   - set to 'menu' to present a menu during boot-up (dialog package required)
#   - prefix an entry with a ! to disable it
#
# Network profiles are found in /etc/network.d
#
# This now requires the netcfg package
#
#NETWORKS=(main)

# -----------------------------------------------------------------------
# DAEMONS
# -----------------------------------------------------------------------
#
# Daemons to start at boot-up (in this order)
#   - prefix a daemon with a ! to disable it
#   - prefix a daemon with a @ to start it up in the background
#
DAEMONS=(syslog-ng network netfs crond cpufreq hal gdm)

Last edited by cm100 (2012-06-17 10:08:21)

Offline

#5 2012-06-17 09:56:51

DarkCerberus
Member
From: Holsworthy, Devon
Registered: 2011-12-31
Posts: 252

Re: Boots to "(none) login:" after upgrade

Try seeing if the rc.conf has been moved, if it defaults to the console logon screen then usually it means that something has changed the rc.conf file - like for example lxdm or gdm was removed in the Daemons section after upgrade.

If it has been upgrade you might be using the new kmod - the rc.conf file might be located at /etc/rc.conf.pacnew or /etc/rc.conf.pacsave  if so move /etc/rc.conf.pacnew to /etc/rc.conf


Our enemies are your enemies, Nick. Disorder, war. It's just a matter of time before a dirty bomb goes off in Moscow, or an EMP fries Chicago.  ---  Alexander Pierce, Captain America: Winter Soldier
Access Denied! De-cryption failed, override denied all files sealed! --- Triskelion, Shield OS
-----
How to ask questions the smart way

Offline

#6 2012-06-17 09:59:11

DSpider
Member
From: Romania
Registered: 2009-08-23
Posts: 2,273

Re: Boots to "(none) login:" after upgrade

/bin/bash: error while loading shared libraries: libreadline.so.6: cannot open shared object file: No such file or directory

Readline... -__-

NEVER use pacman -Syuf or pacman -Sy foo ! If you did this before, stop it.

https://bbs.archlinux.org/viewtopic.php … 61#p802661

Incidentally, Firefox was updated recently, EXACTLY like in the story. The correct way to install shit is using:

# pacman -Syu
# pacman -S foo

Or just:

# pacman -Syu foo

"How to Succeed with Linux"

I have made a personal commitment not to reply in topics that start with a lowercase letter. Proper grammar and punctuation is a sign of respect, and if you do not show any, you will NOT receive any help (at least not from me).

Offline

#7 2012-06-17 10:09:03

cm100
Member
Registered: 2010-01-23
Posts: 16

Re: Boots to "(none) login:" after upgrade

DSpider wrote:

/bin/bash: error while loading shared libraries: libreadline.so.6: cannot open shared object file: No such file or directory

Readline... -__-

NEVER use pacman -Syuf or pacman -Sy foo ! If you did this before, stop it.

I didn't do this.

Offline

#8 2012-06-17 10:11:06

DSpider
Member
From: Romania
Registered: 2009-08-23
Posts: 2,273

Re: Boots to "(none) login:" after upgrade

I still think it's PEBKAC. It's just too similar.

Chroot and update your system.

Last edited by DSpider (2012-06-17 10:12:58)


"How to Succeed with Linux"

I have made a personal commitment not to reply in topics that start with a lowercase letter. Proper grammar and punctuation is a sign of respect, and if you do not show any, you will NOT receive any help (at least not from me).

Offline

#9 2012-06-17 11:54:07

cm100
Member
Registered: 2010-01-23
Posts: 16

Re: Boots to "(none) login:" after upgrade

Ok, I did Chroot and try to update the system via

pacman -Syu

.

First message

Replace notify-sharp-svn with community/notify-sharp? [Y/n]
Replace sqlite3 with extra/sqlite? [Y/n]

Just did Enter in each case.

Then I get error messages about GPGME Bad file descriptor and missing required signatures.

Offline

#10 2012-06-17 11:55:54

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 15,830
Website

Re: Boots to "(none) login:" after upgrade

Have you merged pacnew files?  Have you ever merged pacnew files??  That rc.conf looks *very* old.  A recent change will give you problems without DAEMON_LOCALE="yes", but this would be a minor issue.  Is there a reason you are still using hal?

Offline

#11 2012-06-17 12:12:50

cm100
Member
Registered: 2010-01-23
Posts: 16

Re: Boots to "(none) login:" after upgrade

Trilby wrote:

Have you merged pacnew files?  Have you ever merged pacnew files??  That rc.conf looks *very* old.  A recent change will give you problems without DAEMON_LOCALE="yes", but this would be a minor issue.  Is there a reason you are still using hal?

Oh, I don't know what it means to merge pacnew files. The arch system is just a test system: Currently I am using ubuntu on my main system, however I got the impression that archlinux might be better :-). However arch is rolling release whereas ubuntu is not. If I need a new application in ubuntu I just install it. In arch I often must update lots of packages before I can do this. So I wanted to test arch first before switching and installed it on my old laptop just for testing, playing around and using it as a second machine for surfing the web etc. I didn't invest much time in that archlinux system, just updated packages every few month. That might be the reason why rc.conf looks very old.

Offline

#12 2012-06-17 12:23:26

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 15,830
Website

Re: Boots to "(none) login:" after upgrade

And that would be why you are now having problems.  Arch users are responsible for maintaining their own system.  Your system has - essentially - been unmaintained.

I can't say whether arch or ubuntu would be better for you, but if you chose arch, you'll need to take a more active role in understanding what's happening.  For the present issue properly merging pacnew files in /etc/ will get you on your way to solving the problem - but I suspect there were other interventions that were missed and there will be many steps to catch up on.

Ideally in arch one should update regularly.  Some people leave an arch install for quite a long time without updating.  This makes updates a good bit of work, but things can usually be sorted out.  Updating without paying attention to what is happening, however, will cause serious problems.

Offline

#13 2012-06-17 13:23:08

falconindy
Developer
From: New York, USA
Registered: 2009-10-22
Posts: 4,100
Website

Re: Boots to "(none) login:" after upgrade

You're missing the usr hook from your initramfs like so many other posters who didn't read the post_upgrade message from pacman.

Offline

#14 2012-06-24 14:31:34

gabx
Member
From: Geneva, Switzerland
Registered: 2011-11-20
Posts: 91
Website

Re: Boots to "(none) login:" after upgrade

falconindy wrote:

You're missing the usr hook from your initramfs like so many other posters who didn't read the post_upgrade message from pacman.

I do think you are right, as I had exactly same issue than OP with /usr on a separated partiton. The filesystem of OP is not mounted.
Could get rid of this issue when chrooting. Need to add usr shutdown in the /etc/mkinitcpio.conf, then rebuild the image

$mkinitcpio -p linux

Offline

#15 2012-07-01 06:54:19

cesarramsan
Member
Registered: 2012-06-20
Posts: 5

Re: Boots to "(none) login:" after upgrade

Thank you! I adding 'usr' and 'shutdown' to my HOOKS fixed the problem for me.

Offline

Board footer

Powered by FluxBB