You are not logged in.

#1 2012-06-21 07:27:44

yupeng820921
Member
Registered: 2012-06-21
Posts: 2

lyx has error prompt: Missing prerequisites: enumitem.sty

I install lyx:

# pacman -S lyx

Then run lyx, but I can't export any document, and when I open an exist lyx file, such as the Help->User's Guide, I will get this error:


LyX: Package not available
The module enumitem requries a package that is not
available in your LaTeX istallation, or a conerter that
you have not installed. LaTeX output may not be possible.
Missing prerequisties:
        enumitem.sty
See section 3.1.2.3 (Modules) of the User's Guide for more information.

Offline

#2 2012-06-21 07:28:36

yupeng820921
Member
Registered: 2012-06-21
Posts: 2

Re: lyx has error prompt: Missing prerequisites: enumitem.sty

Could anyone give me some suggestion?

Offline

#3 2012-11-19 22:44:06

wilmerhenao
Member
From: Ann Arbor, MI
Registered: 2012-10-15
Posts: 26
Website

Re: lyx has error prompt: Missing prerequisites: enumitem.sty

Hi.  I'm sure this is too late for you but other users might need a solution.  I had the same problem and installing texlive-latexextra solved it.

Offline

#4 2012-11-19 22:51:01

kevin89
Arch Linux f@h Team Member
From: Netherlands
Registered: 2007-03-14
Posts: 218

Re: lyx has error prompt: Missing prerequisites: enumitem.sty

You can always use pkgfile to see which package provides a certain file, e.g. 'pkgfile enumitem.sty'.

Offline

#5 2012-11-19 22:52:38

masteryod
Member
Registered: 2010-05-19
Posts: 429

Re: lyx has error prompt: Missing prerequisites: enumitem.sty

yupeng820921 wrote:

Missing prerequisties:
        enumitem.sty
See section 3.1.2.3 (Modules) of the User's Guide for more information.

Everything you need to know is here. (La)TeX is modular, you're using module that your system cannot find (which is either bad configuration or simply you didn't installed extra packages - almost always issue is this second thing). All you need to do is type "enumitem archlinux" into google and see what package contain it: texlive-latexextra. Install texlive-latexextra and carry on smile

[edit] Sorry for necrobumping, didn't notice date. But it might help someone in the future.

Last edited by masteryod (2012-11-19 22:53:28)

Offline

Board footer

Powered by FluxBB