You are not logged in.

#26 2012-01-21 11:11:03

karol
Archivist
Registered: 2009-05-06
Posts: 25,423

Re: [SOLVED] [pacman] My 'pacman-key --init' issue

teratomata, conf files never "get updated". You were explicitly reminded to merge pacnew files.

Offline

#27 2012-06-21 22:23:20

senorsmile
Member
Registered: 2010-12-12
Posts: 67

Re: [SOLVED] [pacman] My 'pacman-key --init' issue

karol wrote:
T-u-N-i-X wrote:

Hey There,

I have an Arch box inside a VM which doesn't even have a DE. I just start it via VBoxHeadless -s VMNAME and do ssh into it. When I initiate pacman-key --init and it asks me for more entrophy, I type things, start another gnu screen session and do cat /dev/urandom in it but it never continues to create keys.

Can someone please help me on this?

So you didn't solve it with

When I ran rngd -f -r /dev/urandom and ran pacman-key --init, it completed
in seconds. Issue solved. This is probably about being inside a VM which
limits the entropy level somehow.

?

I am having this same problem running a vm on a debian box under Linux KVM.  I ran cat /dev/urandom for a long time and in another window had pacman-key --init going.  The key init never finished.  I do not have a rngd command, nor is it found in the repositories.

Offline

#28 2012-06-21 22:58:09

senorsmile
Member
Registered: 2010-12-12
Posts: 67

Re: [SOLVED] [pacman] My 'pacman-key --init' issue

senorsmile wrote:
karol wrote:
T-u-N-i-X wrote:

Hey There,

I have an Arch box inside a VM which doesn't even have a DE. I just start it via VBoxHeadless -s VMNAME and do ssh into it. When I initiate pacman-key --init and it asks me for more entrophy, I type things, start another gnu screen session and do cat /dev/urandom in it but it never continues to create keys.

Can someone please help me on this?

So you didn't solve it with

When I ran rngd -f -r /dev/urandom and ran pacman-key --init, it completed
in seconds. Issue solved. This is probably about being inside a VM which
limits the entropy level somehow.

?

I am having this same problem running a vm on a debian box under Linux KVM.  I ran cat /dev/urandom for a long time and in another window had pacman-key --init going.  The key init never finished.  I do not have a rngd command, nor is it found in the repositories.

I have found the rngd in aur.  However, since I can't run pacman yet, I can't install anything.  The wiki says to run haveged before, but I can't install that either until I run the key init.

Offline

#29 2012-06-21 23:40:46

2ManyDogs
Member
Registered: 2012-01-15
Posts: 1,637

Re: [SOLVED] [pacman] My 'pacman-key --init' issue

senorsmile wrote:

I have found the rngd in aur.  However, since I can't run pacman yet, I can't install anything.  The wiki says to run haveged before, but I can't install that either until I run the key init.

Arch wiki wrote:

Initializing the keyring
To set up the pacman keyring use:

pacman-key --init

For this initialization entropy is required. Moving your mouse around, pressing random characters at the keyboard or running some disk-based activity (for example in another console running ls -R / or find / -name foo) should generate entropy. If your system does not already have sufficient entropy, this step may take hours; if you actively generate entropy it will complete much more quickly.

You should have ls and find, right?

Last edited by 2ManyDogs (2012-06-21 23:44:11)

Offline

#30 2012-06-22 00:37:31

senorsmile
Member
Registered: 2010-12-12
Posts: 67

Re: [SOLVED] [pacman] My 'pacman-key --init' issue

2ManyDogs wrote:
senorsmile wrote:

I have found the rngd in aur.  However, since I can't run pacman yet, I can't install anything.  The wiki says to run haveged before, but I can't install that either until I run the key init.

Arch wiki wrote:

Initializing the keyring
To set up the pacman keyring use:

pacman-key --init

For this initialization entropy is required. Moving your mouse around, pressing random characters at the keyboard or running some disk-based activity (for example in another console running ls -R / or find / -name foo) should generate entropy. If your system does not already have sufficient entropy, this step may take hours; if you actively generate entropy it will complete much more quickly.

You should have ls and find, right?

I forgot to mention I tried that as well.  I tried a ls -R / in both an ssh session and on the console several times over and over.  20 minutes later it was still just sitting there.  Is there any way to completely disable gpg signing in pacman 4 in order to download a few things?  I have SigLevel = Never, but I still get GPG errors when trying to use pacman.

Offline

#31 2012-06-22 03:40:00

2ManyDogs
Member
Registered: 2012-01-15
Posts: 1,637

Re: [SOLVED] [pacman] My 'pacman-key --init' issue

senorsmile wrote:

Is there any way to completely disable gpg signing in pacman 4 in order to download a few things?  I have SigLevel = Never, but I still get GPG errors when trying to use pacman.

I don't know why you are still getting errors, unless you still have "repository-specific SigLevel settings" too.

Archwiki wrote:

Disabling signature checking
Warning: Use with caution. Disabling package signing will allow pacman to install untrusted packages automatically.
If you are not concerned about package signing, you can disable PGP signature checking completely. Edit /etc/pacman.conf and uncomment the following line under

[options]:
SigLevel = Never

You need to comment out any repository-specific SigLevel settings too because they override the global settings. This will result in no signature checking, which was the behavior before pacman 4. If you decide to do this, you do not need to set up a keyring with pacman-key. You can change this option later if you decide to enable package verification.

Last edited by 2ManyDogs (2012-06-22 03:42:55)

Offline

Board footer

Powered by FluxBB