You are not logged in.

#1 2012-03-28 14:58:04

jlacroix
Member
Registered: 2009-08-16
Posts: 576

KDE4: DPMS Re-Enables Itself After File Transfer

Here is a very strange (and frustrating) problem. It seems that lately, my screen goes blank when not active. In KDE settings, I have screen energy saving disabled. This problem seems very random. I can go 15 minutes without this problem, and then later, it just starts happening.

When I say turning the screen off after inactivity, I mean turning it off after 2 seconds of inactivity. Literally. When this happens, I have to keep moving the mouse at all times. If I stop moving the mouse for 2 seconds, the screen goes blank, then I have to wake it up again. This happens on my laptops built in screen, and the screen on the dock. I've tried setting screen energy setting to 360 minutes, and that doesn't help either.

I'm hoping this is a known issue...

Last edited by jlacroix (2012-09-22 18:19:14)

Offline

#2 2012-03-28 15:02:00

Shark
Member
From: /dev/zero
Registered: 2011-02-28
Posts: 663

Re: KDE4: DPMS Re-Enables Itself After File Transfer

Post the output of "xset -q".


If you have built castles in the air, your work need not be lost; that is where they should be. Now put foundations under them.
Henry David Thoreau

Registered Linux User: #559057

Offline

#3 2012-03-28 18:36:25

jlacroix
Member
Registered: 2009-08-16
Posts: 576

Re: KDE4: DPMS Re-Enables Itself After File Transfer

Here is the output:

Keyboard Control:
  auto repeat:  on    key click percent:  0    LED mask:  00000002
  XKB indicators:
    00: Caps Lock:   off    01: Num Lock:    on     02: Scroll Lock: off
    03: Compose:     off    04: Kana:        off    05: Sleep:       off
    06: Suspend:     off    07: Mute:        off    08: Misc:        off
    09: Mail:        off    10: Charging:    off    11: Shift Lock:  off
    12: Group 2:     off    13: Mouse Keys:  off
  auto repeat delay:  660    repeat rate:  25
  auto repeating keys:  00ffffffdffffbbf
                        fadfffefffedffff
                        9fffffffffffffff
                        fff7ffffffffffff
  bell percent:  50    bell pitch:  400    bell duration:  100
Pointer Control:
  acceleration:  20/10    threshold:  4
Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  0    cycle:  600
Colors:
  default colormap:  0x20    BlackPixel:  0x0    WhitePixel:  0xffffff
Font Path:
  /usr/share/fonts/misc/,/usr/share/fonts/TTF/,/usr/share/fonts/Type1/,built-ins
DPMS (Energy Star):
  Standby: 81    Suspend: 121    Off: 162
  DPMS is Enabled
  Monitor is On

Offline

#4 2012-03-28 18:42:05

Shark
Member
From: /dev/zero
Registered: 2011-02-28
Posts: 663

Re: KDE4: DPMS Re-Enables Itself After File Transfer

You can se that your computer will go in standby mode in 82 seconds, in suspend in 121 seconds. you could try to change standby value to something like 1200.
Try this:

xset dpms 1200 1500 1800

If you have built castles in the air, your work need not be lost; that is where they should be. Now put foundations under them.
Henry David Thoreau

Registered Linux User: #559057

Offline

#5 2012-03-28 19:05:41

jlacroix
Member
Registered: 2009-08-16
Posts: 576

Re: KDE4: DPMS Re-Enables Itself After File Transfer

Shark wrote:

You can se that your computer will go in standby mode in 82 seconds, in suspend in 121 seconds. you could try to change standby value to something like 1200.
Try this:

xset dpms 1200 1500 1800

That's very strange, but it seems to go along with what you're saying (I timed it). However, sometimes it does start turning the LCD off after 2 seconds. I prefer to have the LCD never turn off, and the laptop never sleep unless I close the lid. Those are the settings I have chosen in System Settings for all tabs (AC, no-AC, etc). I wonder if there is a reason why the settings I chose in System Settings isn't jiving with the command you had me run?

Offline

#6 2012-03-29 08:20:48

Shark
Member
From: /dev/zero
Registered: 2011-02-28
Posts: 663

Re: KDE4: DPMS Re-Enables Itself After File Transfer

Turn the LCD off with the xset command.
Try:

xset s noblank && xset s off 

If you have built castles in the air, your work need not be lost; that is where they should be. Now put foundations under them.
Henry David Thoreau

Registered Linux User: #559057

Offline

#7 2012-03-29 21:49:24

jlacroix
Member
Registered: 2009-08-16
Posts: 576

Re: KDE4: DPMS Re-Enables Itself After File Transfer

Thanks everyone. I think I have at least the symptoms sorted out by doing:

xset -dpms

It seems to work so far, but does that have any other side effects I may need to know about?

However, the remaining question is this, shouldn't KDE's power management setting sync with the dpms command I'm doing? Meaning, if I disabled LCD blanking in KDE, shouldn't that have worked? Perhaps it's a bug?

Offline

#8 2012-03-30 10:05:53

Shark
Member
From: /dev/zero
Registered: 2011-02-28
Posts: 663

Re: KDE4: DPMS Re-Enables Itself After File Transfer

I think KDE power management should be in sync with X server. I suggest you, because of my limited knowledge, to go to KDE forums and they will help you out.

You can check wiki too: https://wiki.archlinux.org/index.php/Di … _Signaling

Please report if you will find any new findings.


If you have built castles in the air, your work need not be lost; that is where they should be. Now put foundations under them.
Henry David Thoreau

Registered Linux User: #559057

Offline

#9 2012-03-31 15:25:01

jlacroix
Member
Registered: 2009-08-16
Posts: 576

Re: KDE4: DPMS Re-Enables Itself After File Transfer

I'm marking this soved because xset -dpms seems to work fine, and with KDE it's probably just an upstream problem.

Offline

#10 2012-04-18 21:33:54

jlacroix
Member
Registered: 2009-08-16
Posts: 576

Re: KDE4: DPMS Re-Enables Itself After File Transfer

I am unmarking as solved, because this problem still keeps happening. Running xset -dpms does disable screen blanking, but it keeps re-enabling itself. I even tried adding xset -dpms to KDE startup, and it will show disabled when I run xset -q, but then later, it will be turned back on. Even worse, the number of seconds until the monitor turns off is seemingly random. One boot, dpms shows that standby is 600 seconds. The next, it was 300 seconds. And today when I started my laptop, dpms is set to turn the monitor off after 33 seconds. This is driving me nuts.

No matter what I do, dpms seems to turn itself back on. Is there a way to take dpms out back, shoot it, and permanently get rid of it?

Offline

#11 2012-04-19 17:26:44

Shark
Member
From: /dev/zero
Registered: 2011-02-28
Posts: 663

Re: KDE4: DPMS Re-Enables Itself After File Transfer

Check this:
http://askubuntu.com/questions/61291/ho … mmand-line
But in this thread the guy suggests to use cron job. I hope you are familiar with it.


If you have built castles in the air, your work need not be lost; that is where they should be. Now put foundations under them.
Henry David Thoreau

Registered Linux User: #559057

Offline

#12 2012-04-19 21:40:09

jlacroix
Member
Registered: 2009-08-16
Posts: 576

Re: KDE4: DPMS Re-Enables Itself After File Transfer

Shark wrote:

Check this:
http://askubuntu.com/questions/61291/ho … mmand-line
But in this thread the guy suggests to use cron job. I hope you are familiar with it.

I'm familiar with Cron, that's no issue. But, is there no way to just remove dpms altogether?

Offline

#13 2012-06-16 04:20:10

jlacroix
Member
Registered: 2009-08-16
Posts: 576

Re: KDE4: DPMS Re-Enables Itself After File Transfer

Hello again, I'm still needing help with this. I can't seem to get DPMS to be permanently disabled.

For the past few months, adding the following to /etc/X11/xorg.conf.d/10-monitor.conf fixed it:

Option         "DPMS" "false"

However, about a week ago, DPMS started enabling itself again:

xset -q
...
DPMS (Energy Star):
  Standby: 600    Suspend: 600    Off: 600
  DPMS is Enabled
  Monitor is On

So I went into the KDE settings, and enabled screen blanking, then disabled it again. After doing that dpms showed itself as disabled. Great, I thought, until I rebooted. Then it enabled itself again.

Finally, I found this note in the Arch WIKI:

Alternatively you can disable console blanking permanently using the following command:
# echo -ne "\033[9;0]" >> /etc/issue

So I did that, and rebooted, and dpms still showed disabled when running xset -q. Awesome! Well, that's what I thought until a half hour later, and my screen started blanking again. Then I found out that DPMS enabled itself again!!!

GRRRR!!!

I don't understand why this is so hard, is there no way to reasonably permanently kill screen blanking? Can dpms just be uninstalled altogether? I'm not accustomed to things like this in Linux, usually things are fairly easy to enable or disable. dpms is acting like some sort of Malware, forcing itself to be turned on against my will.

Maybe one of you have been successful (permanently) killing dpms?

Offline

#14 2012-06-17 00:41:47

ElderSnake
Member
From: Australia
Registered: 2010-12-09
Posts: 93

Re: KDE4: DPMS Re-Enables Itself After File Transfer

It is frustrating.

It was interfering with my watching shows in XBMC (non fullscreen) because it would black unless I touched the mouse every so often so to fix that I had to run XBMC in a short script like this:

#!/bin/bash

xset -dpms s off
xbmc
xset +dpms s on

exit 0

So it disables dpms everytime I run the program then reenables once I'm done watching. I disabled KDE's screen blanking entirely because at the moment it's useless and not in sync with X's settings (and sometimes reenables dpms when I don't want it to). dpms still enables at startup but I figure that's normal.

Could one perhaps disable all the screen power management in KDE's settings and put "xset -dpms s off" in /etc/rc.local or something? That way it should disable it everytime you boot, if that's what one desires.


Arch Linux - Intel E5200 Desktop (Cinnamon 2.0) - Debian Testing - Netbook EeePC AMD C-50 (Xfce)

Offline

#15 2012-06-17 01:34:56

jlacroix
Member
Registered: 2009-08-16
Posts: 576

Re: KDE4: DPMS Re-Enables Itself After File Transfer

ElderSnake wrote:

It is frustrating.

It was interfering with my watching shows in XBMC (non fullscreen) because it would black unless I touched the mouse every so often so to fix that I had to run XBMC in a short script like this:

#!/bin/bash

xset -dpms s off
xbmc
xset +dpms s on

exit 0

So it disables dpms everytime I run the program then reenables once I'm done watching. I disabled KDE's screen blanking entirely because at the moment it's useless and not in sync with X's settings (and sometimes reenables dpms when I don't want it to). dpms still enables at startup but I figure that's normal.

Could one perhaps disable all the screen power management in KDE's settings and put "xset -dpms s off" in /etc/rc.local or something? That way it should disable it everytime you boot, if that's what one desires.

I've tried the rc.local thing, and it does indeed make dpms disabled when you boot. But eventually, something triggers it to turn on again. I wish this was a package that could be completely removed. Even disabling it in KDE will make it disabled on boot, but then later on it will turn itself on again.

Like I said before, I consider this malware. It's something on my machine I don't want, providing a feature that I don't want, it turns itself on at will, and there's apparently no way to get rid of it.

Last edited by jlacroix (2012-06-17 01:38:21)

Offline

#16 2012-06-17 04:42:20

ElderSnake
Member
From: Australia
Registered: 2010-12-09
Posts: 93

Re: KDE4: DPMS Re-Enables Itself After File Transfer

Hmm I have no idea. It sounds like you've done pretty much everything and yet it or something... is turning it back on again.

With the

 Option         "DPMS" "false"

part, have you instead maybe tried

Option          "NODPMS"

That might be an obsolete option though, I'm unsure.

Last edited by ElderSnake (2012-06-17 04:43:42)


Arch Linux - Intel E5200 Desktop (Cinnamon 2.0) - Debian Testing - Netbook EeePC AMD C-50 (Xfce)

Offline

#17 2012-06-17 13:57:26

jlacroix
Member
Registered: 2009-08-16
Posts: 576

Re: KDE4: DPMS Re-Enables Itself After File Transfer

ElderSnake wrote:

Hmm I have no idea. It sounds like you've done pretty much everything and yet it or something... is turning it back on again.

With the

 Option         "DPMS" "false"

part, have you instead maybe tried

Option          "NODPMS"

That might be an obsolete option though, I'm unsure.

I'll try it! I'll report back when I find out if it works or not. Thanks!

Offline

#18 2012-06-21 03:23:28

jlacroix
Member
Registered: 2009-08-16
Posts: 576

Re: KDE4: DPMS Re-Enables Itself After File Transfer

It seems like that is working. Then again, all the other tricks I've used worked for a while too. Hopefully this one sticks. Thanks again!

Offline

#19 2012-06-26 01:57:54

jlacroix
Member
Registered: 2009-08-16
Posts: 576

Re: KDE4: DPMS Re-Enables Itself After File Transfer

jlacroix wrote:

It seems like that is working. Then again, all the other tricks I've used worked for a while too. Hopefully this one sticks. Thanks again!

I am un-marking this as solved. DPMS just re-enabled itself just now. What the heck?!!!

Offline

#20 2012-06-26 02:07:59

ElderSnake
Member
From: Australia
Registered: 2010-12-09
Posts: 93

Re: KDE4: DPMS Re-Enables Itself After File Transfer

That is insane.

The inconsistencies at desktop level are bad enough, but even when disabled in Xorg's own config files??

I'm sorry, I'm out of ideas sad


Arch Linux - Intel E5200 Desktop (Cinnamon 2.0) - Debian Testing - Netbook EeePC AMD C-50 (Xfce)

Offline

#21 2012-06-26 02:10:19

jlacroix
Member
Registered: 2009-08-16
Posts: 576

Re: KDE4: DPMS Re-Enables Itself After File Transfer

ElderSnake wrote:

That is insane.

The inconsistencies at desktop level are bad enough, but even when disabled in Xorg's own config files??

I'm sorry, I'm out of ideas sad

The only thing I can think of is a KDE bug. That in itself is hard to believe, because my other laptop doesn't have this issue. They literally use the same image. However, my other laptop has Intel graphics and this one has Nvidia. But perhaps it is an issue with KDE? Who knows.

Thanks for your help regardless.

Offline

#22 2012-06-26 02:22:14

ElderSnake
Member
From: Australia
Registered: 2010-12-09
Posts: 93

Re: KDE4: DPMS Re-Enables Itself After File Transfer

I might keep digging around anyway as I get time, because I agree dpms just shouldn't be this hard to get rid of.

You've probably already done this, but I noticed an example in the wiki page https://wiki.archlinux.org/index.php/Di … _Signaling

this part (specifically the ServerLayout section)

Section "Monitor"
    Identifier "LVDS0"
    Option "DPMS" "false"
EndSection

Section "ServerLayout"
    Identifier "ServerLayout0"
    Option "BlankTime"  "0"
    Option "StandbyTime" "0"
    Option "SuspendTime" "0"
    Option "OffTime" "0"
EndSection

I wonder if setting these values to 0, even if dpms like the bugger that it is re-enabled itself, if the effects of it would simply be cancelled out (i.e no screen blanking etc) due to these hard values. But I'm not sure. It may just as well reset them hmm

To be honest I only ever noticed dpms since I switched to KDE too. Gnome, whatever it does, somehow seems to keep it in check.


Arch Linux - Intel E5200 Desktop (Cinnamon 2.0) - Debian Testing - Netbook EeePC AMD C-50 (Xfce)

Offline

#23 2012-06-26 15:28:18

jlacroix
Member
Registered: 2009-08-16
Posts: 576

Re: KDE4: DPMS Re-Enables Itself After File Transfer

ElderSnake wrote:

I might keep digging around anyway as I get time, because I agree dpms just shouldn't be this hard to get rid of.

You've probably already done this, but I noticed an example in the wiki page https://wiki.archlinux.org/index.php/Di … _Signaling

this part (specifically the ServerLayout section)

Section "Monitor"
    Identifier "LVDS0"
    Option "DPMS" "false"
EndSection

Section "ServerLayout"
    Identifier "ServerLayout0"
    Option "BlankTime"  "0"
    Option "StandbyTime" "0"
    Option "SuspendTime" "0"
    Option "OffTime" "0"
EndSection

I wonder if setting these values to 0, even if dpms like the bugger that it is re-enabled itself, if the effects of it would simply be cancelled out (i.e no screen blanking etc) due to these hard values. But I'm not sure. It may just as well reset them hmm

To be honest I only ever noticed dpms since I switched to KDE too. Gnome, whatever it does, somehow seems to keep it in check.

Thank you, I'll try that later on today. I'll mark this as solved for now, because I found an upstream bug report:

https://bugs.kde.org/show_bug.cgi?id=295164

I'll continue my fight there.

Thanks again!

Offline

#24 2012-08-05 19:16:06

h_hettema
Member
Registered: 2011-10-11
Posts: 1

Re: KDE4: DPMS Re-Enables Itself After File Transfer

Re-opening the discussion: i have the same problem here. Looking today in my Xorg.0.log I see the following:

[...]
[    23.344] (II) intel(0): DPMS capabilities: Off
[...]
[    23.735] (==) intel(0): DPMS enabled
[...]

It seems the intel-driver automagically enables DPMS, even if in the "Monitor" section of xorg.conf I have disabled DPMS (which is reflected by the first log-entry). This is only at start-up, but perhaps also later the driver can automagically decides it wants to use DPMS?

Offline

#25 2012-08-09 15:51:09

matt.garriott
Member
Registered: 2012-08-09
Posts: 1

Re: KDE4: DPMS Re-Enables Itself After File Transfer

I'm not sure if this will help anyone, but I recently switched desktop managers from XFCE to KDE and I was experiencing some very similar problems.

  • Switching the "Screen Energy Saving" setting in "Power Management" wouldn't change the output of 'xset -q'.

  • The amount of time the before the screen would shut off would randomly change / disable on restart.

This morning I switched login managers from SLiM to KDM (no-daemon), and suddenly it all seems to be working. I'm not sure why using SLiM would cause problems like this (if in-fact that was the problem), but I thought I would share my experience in the hopes of helping others.

Offline

Board footer

Powered by FluxBB