You are not logged in.

#1 2012-06-24 10:28:07

mfncl
Member
Registered: 2012-06-24
Posts: 9

[SOLVED] ath9k_htc wi-fi connection drops (dmesg reasons 7 & 3) on

Hi all,

Before I get started I should mention this is my first post, I've (hopefully) done my best to describe the problem and collect relevant data, but if there's anything missing just let me know and I'll be more than happy to get it.

Here we go:

All is working well since a new install / config of archlinux netboot on my laptop (used ethernet) using the great wikis available, bar the external wireless N adaptor.

At first, there was a lock on the card, so I used rfkill to remove it.

Then I was able to set the device to an "up" state and use wpa_supplicant to authenticate with my WPA2 network.
Assigning an IP address with dhcpcd was also fine, so I went ahead and installed NetworkManager along with its kde4 plasma configuration widget.
Not wanting to have a seperate boot time configuration outside of rc.conf, I added networkmanager-dispatcher-net_daemons from the AUR so I could have samba start only when NetworkManager had taken care of the connection.

I found after around 10-15 minutes of uptime on wlan0, the wireless connection dropped for a minute or so and reconnected. This behaviour recurs sporadically every so often.

I should state at this stage the laptop has an old internal wireless adaptor I don't need (not wireless N compliant)

Checking dmesg for wireless error notifications, there are two types of error:

[ 2315.131446] wlan0: deauthenticated from a0:21:b7:4d:dd:a0 (Reason: 7)

[ 2345.106119] wlan0: disassociating from a0:21:b7:4d:dd:a0 by local choice (reason=3)
[ 2345.211674] cfg80211: Calling CRDA to update world regulatory domain
[ 2345.278700] wlan0: deauthenticating from a0:21:b7:4d:dd:a0 by local choice (reason=3)I 

These errors recur frequently, see this dmesg output: http://pastebin.com/dg5ZpR95

Running recursive ping tests highlights the frequent drops: http://pastebin.com/tnyf9GME

After googling the errors, as per the suggestions collected some data.

Here are some connection details with NetworkManager managing the connection:

The latest kernel / software versions (pacman -Syu completed following wireless configuration):

[root@houseserver networkmanager-dispatcher-net_daemons]# uname -a
Linux houseserver 3.4.3-1-ARCH #1 SMP PREEMPT Mon Jun 18 08:28:29 CEST 2012 x86_64 GNU/Linux

No wireless hardware locks are on from "rfkill".

Here's lsusb and iwconfig (whilst connected with NetworkManager) - Power management on the wireless adaptor is disabled (ran iwconfig wlan0 power off)

[root@houseserver networkmanager-dispatcher-net_daemons]# lsusb
Bus 001 Device 002: ID 0c45:62c0 Microdia Sonix USB 2.0 Camera
Bus 001 Device 003: ID 0cf3:7015 Atheros Communications, Inc. TP-Link TL-WN821N v3 802.11n [Atheros AR7010+AR9287]
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

[root@houseserver networkmanager-dispatcher-net_daemons]# iwconfig
wlan1     IEEE 802.11bg  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          
eth0      no wireless extensions.

lo        no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:"smokie the bandit"  
          Mode:Managed  Frequency:2.462 GHz  Access Point: A0:21:B7:4D:DD:A0   
          Bit Rate=130 Mb/s   Tx-Power=20 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=69/70  Signal level=-41 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:2   Missed beacon:0

[root@houseserver networkmanager-dispatcher-net_daemons]# ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN qlen 1000
    link/ether 00:1e:68:98:fe:a7 brd ff:ff:ff:ff:ff:ff
3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP qlen 1000
    link/ether 90:f6:52:08:11:8f brd ff:ff:ff:ff:ff:ff
    inet 192.168.0.3/24 brd 192.168.0.255 scope global wlan0
    inet6 fe80::92f6:52ff:fe08:118f/64 scope link 
       valid_lft forever preferred_lft forever
4: wlan1: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN qlen 1000
    link/ether 00:1f:e2:ca:35:c1 brd ff:ff:ff:ff:ff:ff
[root@houseserver networkmanager-dispatcher-net_daemons]# 

dmesg showing the loading / configuration of ath9k_htc driver/firmware at boot:

[    5.841763] usb 1-6: ath9k_htc: Firmware htc_7010.fw requested
[    5.842509] usbcore: registered new interface driver ath9k_htc
[    5.881031] mmcblk0: mmc0:8fe4 SU02G 1.84 GiB 
[    5.883866]  mmcblk0: p1
[    6.007365] input: HDA Digital PCBeep as /devices/pci0000:00/0000:00:07.0/input/input9
[    6.074663] usb 1-6: ath9k_htc: Transferred FW: htc_7010.fw, size: 72992
[    6.114588] psmouse serio1: synaptics: Touchpad model: 1, fw: 6.3, id: 0x1a0b1, caps: 0xa04711/0xa00000/0x0
[    6.136651] ath9k_htc 1-6:1.0: ath9k_htc: HTC initialized with 45 credits
[    6.195404] input: SynPS/2 Synaptics TouchPad as /devices/platform/i8042/serio1/input/input10
[    6.207021] firewire_core 0000:07:05.0: created device fw0: GUID 00241b001d531601, S400
[    6.218675] nouveau 0000:05:00.0: power state changed by ACPI to D0
[    6.218704] nouveau 0000:05:00.0: power state changed by ACPI to D0
[    6.220380] ACPI: PCI Interrupt Link [LK4E] enabled at IRQ 19
[    6.223793] [drm] nouveau 0000:05:00.0: Detected an NV50 generation card (0x086700a2)
[    6.228296] ath: EEPROM regdomain: 0x67
[    6.228301] ath: EEPROM indicates we should expect a direct regpair map
[    6.228315] ath: Country alpha2 being used: 00
[    6.228319] ath: Regpair used: 0x67
[    6.238774] [drm] nouveau 0000:05:00.0: Checking PRAMIN for VBIOS
[    6.265530] ath9k_htc 1-6:1.0: ath9k_htc: FW Version: 1.3
[    6.265540] ath: EEPROM regdomain: 0x809c
[    6.265545] ath: EEPROM indicates we should expect a country code
[    6.265552] ath: doing EEPROM country->regdmn map search
[    6.265557] ath: country maps to regdmn code: 0x52
[    6.265562] ath: Country alpha2 being used: CN
[    6.265566] ath: Regpair used: 0x52

It seems ath9k_htc is the correct driver to load -  "lsusb" shows my wireless USB device as an TP-Link TL-WN821N v3 802.11n device - this shows on the hardware compatibility for the ath9k_htc driver ok with matching hardware / device IDs as shown by lsusb.

http://wireless.kernel.org/en/users/Dri … tc/devices

For troubleshooting purposes I cleared "networkmanager" from DAEMONS in /etc/rc.conf and rebooted, then established a connection with wpa_supplicant (debugging enabled).

[root@houseserver networkmanager-dispatcher-net_daemons]# ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN qlen 1000
    link/ether 00:1e:68:98:fe:a7 brd ff:ff:ff:ff:ff:ff
3: wlan0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether 00:1f:e2:ca:35:c1 brd ff:ff:ff:ff:ff:ff
4: wlan1: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether 90:f6:52:08:11:8f brd ff:ff:ff:ff:ff:ff

Here, it seems the internal Wi-Fi adaptor has swapped interface names with the external device after the reboot, so I used wlan1 for the correct corresponding mac address.

ip link set wlan1 up
wpa_supplicant -d -Dwext -i wlan1 -c /etc/wpa_supplicant.conf
dhcpcd wlan1

See here for the full wpa_supplicant / dhcpcd log: http://pastebin.com/jhXzSFFF
As well as a new ping test: http://pastebin.com/MQLLX6Be

The new dmesg display the same errors when compared to the NetworkManager connection (full log here: http://pastebin.com/8mSNTNLU )

[ 2331.271162] wlan1: deauthenticated from a0:21:b7:4d:dd:a0 (Reason: 7)
[ 2331.396499] cfg80211: Calling CRDA to update world regulatory domain
[ 2344.204092] wlan1: authenticate with a0:21:b7:4d:dd:a0
[ 2344.366641] wlan1: send auth to a0:21:b7:4d:dd:a0 (try 1/3)
[ 2344.370918] wlan1: authenticated
[ 2344.423155] wlan1: associate with a0:21:b7:4d:dd:a0 (try 1/3)
[ 2344.428178] wlan1: RX AssocResp from a0:21:b7:4d:dd:a0 (capab=0x411 status=0 aid=1)
[ 2344.428192] wlan1: associated
[ 2354.485511] wlan1: deauthenticating from a0:21:b7:4d:dd:a0 by local choice (reason=3)
[ 2354.585510] cfg80211: Calling CRDA to update world regulatory domain
[ 2355.490997] wlan1: authenticate with a0:21:b7:4d:dd:a0
[ 2355.645507] wlan1: send auth to a0:21:b7:4d:dd:a0 (try 1/3)
[ 2355.846466] wlan1: send auth to a0:21:b7:4d:dd:a0 (try 2/3)
[ 2355.922164] wlan1: authenticated
[ 2355.973149] wlan1: associate with a0:21:b7:4d:dd:a0 (try 1/3)
[ 2355.978766] wlan1: RX AssocResp from a0:21:b7:4d:dd:a0 (capab=0x411 status=0 aid=1)
[ 2355.978776] wlan1: associated

dhcpcd looked OK.

Does anybody have any suggestions at this stage - would it be worth disabling hw encryption on the wireless adaptor (nohwcrypt) on bootup or trying another network manager (possibly wicd)?

Anything else I could try so that I get a consistent connection on the wireless N card without drops - maybe there are two issues here based on the two different types of error?

Many thanks for your help smile


Mark

Last edited by mfncl (2012-06-27 06:49:40)

Offline

#2 2012-06-24 11:35:21

Strike0
Member
From: Germany
Registered: 2011-09-05
Posts: 1,277

Re: [SOLVED] ath9k_htc wi-fi connection drops (dmesg reasons 7 & 3) on

Trying "nohwcrypt =1" seemed to help in a lot of cases, not a big issue to try it.

However, "deauthentication for Reason 7" ("Class 3 frame received from nonassociated station") in your logs might mean that another device in your region disturbs the connection . Could that be?

If yes, try using different channels - keep in mind that for wifi-N a number of channels are used .. that might make it harder to find a setting which does not disturb others (for everyone;)

Offline

#3 2012-06-24 17:26:48

sliposk
Member
Registered: 2010-08-19
Posts: 46

Re: [SOLVED] ath9k_htc wi-fi connection drops (dmesg reasons 7 & 3) on

I have the same dongle , Works with Wicd on 4 diff machines. As of todays date.

Offline

#4 2012-06-25 06:54:52

mfncl
Member
Registered: 2012-06-24
Posts: 9

Re: [SOLVED] ath9k_htc wi-fi connection drops (dmesg reasons 7 & 3) on

Thanks for the tips guys, I'll give these a go later on today. Good to hear the device is working well for you sliposk, this gives some reassurance I should be able to get my issue fixed. What kernel are you running, did you need any special configuration to get the device working or was it good OOTB?

From my end the card worked correctly under Windows with no connection drops before, also my other Wi-Fi enabled devices (two phones and a tablet) have never seen connection drops to the best of my knowledge, although there are a few of the same ISP provided hybrid cable modems / wireless routers installed in my area based on some using the factory standard SSIDs so there's a possibility these other devices are using the same channels and causing interference.

I will try adding a ath9k_htc.conf file to /etc/modprobe.d containing nohwcrypt=1 and use wicd and do some further tests, if the problem persists I will try tweaking the wireless channels the router is using - perhaps placing it in 5 GHz mode might help.

Offline

#5 2012-06-25 20:35:57

mfncl
Member
Registered: 2012-06-24
Posts: 9

Re: [SOLVED] ath9k_htc wi-fi connection drops (dmesg reasons 7 & 3) on

As suggested, I played around with the wireless channel settings of my router - the router was set to channel 11. A Wi-Fi scan from my Windows box showed little interference, most space used by other networks is on 1-7.
Strangely enough, after switching the router to channel 13 wpa_supplicant was no longer able to see my wireless network SSID, yet when the same external Wi-Fi device is plugged into the Windows box the scanner is able to pick up channel 13 with no issues, as are other Wi-Fi devices. Also, the laptops built in wireless was also able to pick up channel 13 as well. Setting nohwcrypt=1 and rebooting made no difference.

I then changed the Wi-Fi channel to 9, wpa_supplicant was able to see the network again. Ping tests reveal the connection is now much more stable, no disconnects have occurred yet and transfer speeds over samba are more consistent at around 10 MB/s with fewer speed dips.

It would seem the linux driver/firmware doesn't perform well on the upper 2.3 GHz channels for some reason? As the wifi device performs as expected under windows I'd say its safe to rule out the hardware from being the issue, as well as the router.

The only issue I can still see is that ping response times continue to be uneven - one packet will be received with 20-25ms latency, the next packet with latency in the 100s:

[mark@houseserver wicd-kde]$ ping google.co.uk
PING google.co.uk (173.194.66.94) 56(84) bytes of data.
64 bytes from we-in-f94.1e100.net (173.194.66.94): icmp_req=1 ttl=47 time=29.4 ms
64 bytes from we-in-f94.1e100.net (173.194.66.94): icmp_req=2 ttl=48 time=90.9 ms
64 bytes from we-in-f94.1e100.net (173.194.66.94): icmp_req=3 ttl=48 time=62.1 ms
64 bytes from we-in-f94.1e100.net (173.194.66.94): icmp_req=4 ttl=48 time=89.2 ms
64 bytes from we-in-f94.1e100.net (173.194.66.94): icmp_req=5 ttl=47 time=29.7 ms
64 bytes from we-in-f94.1e100.net (173.194.66.94): icmp_req=6 ttl=48 time=86.5 ms
64 bytes from we-in-f94.1e100.net (173.194.66.94): icmp_req=7 ttl=46 time=25.6 ms
64 bytes from we-in-f94.1e100.net (173.194.66.94): icmp_req=8 ttl=46 time=182 ms
64 bytes from we-in-f94.1e100.net (173.194.66.94): icmp_req=9 ttl=46 time=49.1 ms
64 bytes from we-in-f94.1e100.net (173.194.66.94): icmp_req=10 ttl=47 time=182 ms
64 bytes from we-in-f94.1e100.net (173.194.66.94): icmp_req=11 ttl=46 time=26.1 ms
64 bytes from we-in-f94.1e100.net (173.194.66.94): icmp_req=12 ttl=48 time=176 ms
64 bytes from we-in-f94.1e100.net (173.194.66.94): icmp_req=13 ttl=48 time=26.0 ms
64 bytes from we-in-f94.1e100.net (173.194.66.94): icmp_req=14 ttl=47 time=179 ms
64 bytes from we-in-f94.1e100.net (173.194.66.94): icmp_req=15 ttl=46 time=45.6 ms
64 bytes from we-in-f94.1e100.net (173.194.66.94): icmp_req=16 ttl=48 time=192 ms
64 bytes from we-in-f94.1e100.net (173.194.66.94): icmp_req=17 ttl=48 time=47.8 ms
^Z
[1]+  Stopped                 ping google.co.uk
[mark@houseserver wicd-kde]$ ^C
[mark@houseserver wicd-kde]$ ping bbc.co.uk
PING bbc.co.uk (212.58.241.131) 56(84) bytes of data.
64 bytes from 212.58.241.131: icmp_req=1 ttl=241 time=50.9 ms
64 bytes from 212.58.241.131: icmp_req=2 ttl=241 time=199 ms
64 bytes from 212.58.241.131: icmp_req=3 ttl=241 time=20.7 ms
64 bytes from 212.58.241.131: icmp_req=4 ttl=241 time=197 ms
64 bytes from 212.58.241.131: icmp_req=5 ttl=241 time=24.2 ms
64 bytes from 212.58.241.131: icmp_req=6 ttl=241 time=194 ms
64 bytes from 212.58.241.131: icmp_req=7 ttl=241 time=22.5 ms
64 bytes from 212.58.241.131: icmp_req=8 ttl=241 time=192 ms
64 bytes from 212.58.241.131: icmp_req=9 ttl=241 time=53.9 ms
64 bytes from 212.58.241.131: icmp_req=10 ttl=241 time=190 ms
64 bytes from 212.58.241.131: icmp_req=11 ttl=241 time=20.3 ms
64 bytes from 212.58.241.131: icmp_req=12 ttl=241 time=209 ms
64 bytes from 212.58.241.131: icmp_req=13 ttl=241 time=22.4 ms
^Z
[2]+  Stopped                 ping bbc.co.uk

When using the internal wireless I get regular ping times:

[root@houseserver mark]# ping bbc.co.uk
PING bbc.co.uk (212.58.241.131) 56(84) bytes of data.
64 bytes from 212.58.241.131: icmp_req=1 ttl=241 time=19.9 ms
64 bytes from 212.58.241.131: icmp_req=2 ttl=241 time=62.8 ms
64 bytes from 212.58.241.131: icmp_req=3 ttl=241 time=19.5 ms
64 bytes from 212.58.241.131: icmp_req=4 ttl=241 time=21.4 ms
64 bytes from 212.58.241.131: icmp_req=5 ttl=241 time=19.1 ms
64 bytes from 212.58.241.131: icmp_req=6 ttl=241 time=19.2 ms
64 bytes from 212.58.241.131: icmp_req=7 ttl=241 time=25.8 ms
64 bytes from 212.58.241.131: icmp_req=8 ttl=241 time=31.6 ms
64 bytes from 212.58.241.131: icmp_req=9 ttl=241 time=20.3 ms
64 bytes from 212.58.241.131: icmp_req=10 ttl=241 time=42.2 ms
64 bytes from 212.58.241.131: icmp_req=11 ttl=241 time=19.4 ms
64 bytes from 212.58.241.131: icmp_req=12 ttl=241 time=19.0 ms
64 bytes from 212.58.241.131: icmp_req=13 ttl=241 time=19.3 ms
64 bytes from 212.58.241.131: icmp_req=14 ttl=241 time=44.0 ms
64 bytes from 212.58.241.131: icmp_req=15 ttl=241 time=22.9 ms
64 bytes from 212.58.241.131: icmp_req=16 ttl=241 time=21.4 ms
64 bytes from 212.58.241.131: icmp_req=17 ttl=241 time=21.6 ms
64 bytes from 212.58.241.131: icmp_req=18 ttl=241 time=19.3 ms
64 bytes from 212.58.241.131: icmp_req=19 ttl=241 time=46.3 ms
64 bytes from 212.58.241.131: icmp_req=20 ttl=241 time=22.1 ms
64 bytes from 212.58.241.131: icmp_req=21 ttl=241 time=24.7 ms
64 bytes from 212.58.241.131: icmp_req=22 ttl=241 time=21.7 ms
64 bytes from 212.58.241.131: icmp_req=23 ttl=241 time=23.3 ms
64 bytes from 212.58.241.131: icmp_req=24 ttl=241 time=19.7 ms
64 bytes from 212.58.241.131: icmp_req=25 ttl=241 time=36.6 ms
64 bytes from 212.58.241.131: icmp_req=26 ttl=241 time=22.7 ms
64 bytes from 212.58.241.131: icmp_req=27 ttl=241 time=21.6 ms
64 bytes from 212.58.241.131: icmp_req=28 ttl=241 time=20.4 ms
64 bytes from 212.58.241.131: icmp_req=29 ttl=241 time=22.6 ms
64 bytes from 212.58.241.131: icmp_req=30 ttl=241 time=19.1 ms
64 bytes from 212.58.241.131: icmp_req=31 ttl=241 time=20.1 ms
64 bytes from 212.58.241.131: icmp_req=32 ttl=241 time=20.1 ms
64 bytes from 212.58.241.131: icmp_req=33 ttl=241 time=20.5 ms
64 bytes from 212.58.241.131: icmp_req=34 ttl=241 time=21.2 ms
64 bytes from 212.58.241.131: icmp_req=35 ttl=241 time=23.0 ms

Any possible reason for this? /etc/hosts, /etc/resolv.conf and /etc/rc.conf all seem correct - reviewing the data in the original post  the erratic pings can be seen there too.

I should mention the router is located in the same room as the laptop, so signal strength isn't an issue.

Offline

#6 2012-06-25 22:16:27

Gusar
Member
Registered: 2009-08-25
Posts: 3,466

Re: [SOLVED] ath9k_htc wi-fi connection drops (dmesg reasons 7 & 3) on

mfncl wrote:

one packet will be received with 20-25ms latency, the next packet with latency in the 100s:

That's a bug in the driver. The patch is here, so if you're game for compiling your own kernel, you can fix it. There's also compat-wireless, possibly easier if you've never compiled a kernel before. Or the lts kernel.

Offline

#7 2012-06-26 07:36:07

mfncl
Member
Registered: 2012-06-24
Posts: 9

Re: [SOLVED] ath9k_htc wi-fi connection drops (dmesg reasons 7 & 3) on

Gusar wrote:

That's a bug in the driver. The patch is here, so if you're game for compiling your own kernel, you can fix it. There's also compat-wireless, possibly easier if you've never compiled a kernel before. Or the lts kernel.

Thanks for the info Gusar. I've not compiled a kernel before - whilst I would enjoy learning about this I would prefer a quicker solution so I can start configuring my applications on the system and get it productive.

I've been looking into compat-wireless, according to the wiki the ath9k_htc driver that's included in the compat-wireless package is already included in the archlinux kernel:

https://wiki.archlinux.org/index.php/Wi … #ath9k_htc

ath9k_htc

ath9k_htc is Atheros' officially supported driver for 802.11n USB devices. Station and Ad-Hoc modes are supported. Since 2.6.35, the driver has been included in the kernel. For more information, see http://wireless.kernel.org/en/users/Drivers/ath9k_htc .

Is the compat-wireless driver not the same driver that's included in the arch kernel? I'm thinking if the driver is the same, then surely the problem would also exist in the compat-wireless driver version.

If the issue is not present in the compat-wireless packaged driver, would installing the version from the AUR (compat-wireless-patched 3.3_2_n-3) be recent enough to contain the fix?

The package has been flagged out of date: https://aur.archlinux.org/packages.php? … mments=all

According to one of the earlier threads to the link you suggested with the patch, the issue seems to be kernel version specific:

http://www.spinics.net/lists/linux-wire … 92518.html

> > > Please note the additional delay of ~1000ms every 2nd packet. This
> > > is Kernel 3.4.3, have seen it in 3.4.2 also. Does NOT happen in
> > > 3.3.1.

Hence I assume why the LTS kernel doesn't contain the defect. Is there any chance this patch will be included at some point into the official arch kernel in the near future?

Thanks

Offline

#8 2012-06-26 09:43:46

Gusar
Member
Registered: 2009-08-25
Posts: 3,466

Re: [SOLVED] ath9k_htc wi-fi connection drops (dmesg reasons 7 & 3) on

compat-wireless contains *the very latest* of wireless stuff. There's tarballs that contain what's in specific kernels (compat-wireless-3.2, compat-wireless-3.3), but there's also a daily tarball containing the very latest. That's the point of it - provide the very latest no matter what kernel you're using.

Offline

#9 2012-06-26 10:36:57

agapito
Member
From: Spain
Registered: 2008-11-13
Posts: 495

Re: [SOLVED] ath9k_htc wi-fi connection drops (dmesg reasons 7 & 3) on

I have the same dongle, never worked fine in linux, always suffering random disconnections.

In windows works, but is not the best wifi usb to be honest. Only 4 or 5 networks are detected and the link quality is low. Don´t buy it.


Excuse my poor English.

Offline

#10 2012-06-26 10:43:22

Gusar
Member
Registered: 2009-08-25
Posts: 3,466

Re: [SOLVED] ath9k_htc wi-fi connection drops (dmesg reasons 7 & 3) on

I have a similar one, the 721N, uses the same driver. Always worked great. There's this current bug I mentioned, but beyond that never had any problems.

Atheros is a great FOSS citizen. For an old chip that they didn't care about anymore, they released full docs and even the firmware under the GPL, so the community could write a driver (carl9170). For current chips, they themselves work on the open drivers (ath9k and ath9k_htc, ath6kl), there's tons of commits every kernel. Only ath5k is kinda abandoned, it's in "maintenance mode", but it doesn't need work anyway, my netbook with ath5k wireless works great.

Last edited by Gusar (2012-06-26 10:51:00)

Offline

#11 2012-06-26 15:01:39

mfncl
Member
Registered: 2012-06-24
Posts: 9

Re: [SOLVED] ath9k_htc wi-fi connection drops (dmesg reasons 7 & 3) on

Thanks for the pointers Gusar. I'll try the latest daily compat-wireless out tonight.

Offline

#12 2012-06-26 17:48:52

mfncl
Member
Registered: 2012-06-24
Posts: 9

Re: [SOLVED] ath9k_htc wi-fi connection drops (dmesg reasons 7 & 3) on

So I ran pacman -Syu to update the system prior to installing linux-headers, it updated the kernel to 3.4.4.2.

Rebooting the system for the new kernel, I downloaded and untarred the latest daily compat-wireless and followed the make instructions.

It ran through and completed correctly:

[mark@houseserver compat-wireless]$ ./scripts/driver-select
Usage: ./scripts/driver-select [ <driver-name> | <driver-group-name> | restore ]
Supported 802.11 drivers:
        ath5k
        ath9k
        ath9k_ap
        ath9k_htc
        carl9170
        ath6kl
        b43
        zd1211rw
        rt2x00
        wl1251
        wl12xx
        brcmsmac
        brcmfmac

Supported Ethernet drivers:
        atl1
        atl2
        atl1e
        atl1c
        alx

Supported group drivers:
        atheros <  ath5k ath9k carl9170 zd1211rw ath6kl >
        ath <  ath5k ath9k carl9170 ath6kl >
        brcm80211 <  brcmsmac brcmfmac >
        intel <  iwlwifi, iwlegacy >
        rtl818x <  rtl8180 rtl8187 >
        rtlwifi <  rtl8192ce >
        ti <  wl1251 wl12xx (SPI and SDIO)>

Supported group drivers: Bluetooth & Ethernet:
        atlxx <  atl1 atl2 atl1e alx>
        bt <  Linux bluetooth drivers >
Restoring compat-wireless:
        restore: you can use this option to restore compat-wireless to the original state
[mark@houseserver compat-wireless]$ ./scripts/driver-select atheros
Processing new driver-select request...
Backing up makefile: Makefile.bk
Backing up makefile: drivers/net/wireless/Makefile.bk
Backup exists: Makefile.bk
Backup exists: Makefile.bk
Backup exists: Makefile.bk
Backup exists: Makefile.bk
Backing up makefile: net/wireless/Makefile.bk
Backing up makefile: drivers/ssb/Makefile.bk
Backing up makefile: drivers/bcma/Makefile.bk
Backing up makefile: drivers/misc/eeprom/Makefile.bk
Backup exists: Makefile.bk
[mark@houseserver compat-wireless]$ make
./scripts/gen-compat-autoconf.sh /home/mark/aur/compat-wireless/.config /home/mark/aur/compat-wireless/config.mk > include/linux/compat_autoconf.h
make -C /lib/modules/3.4.4-2-ARCH/build M=/home/mark/aur/compat-wireless modules
make[1]: Entering directory `/usr/src/linux-3.4.4-2-ARCH'
  CC [M]  /home/mark/aur/compat-wireless/compat/main.o
  CC [M]  /home/mark/aur/compat-wireless/compat/compat-3.5.o
  LD [M]  /home/mark/aur/compat-wireless/compat/compat.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/main.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/regd.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/hw.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/key.o
  LD [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath5k/caps.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath5k/initvals.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath5k/eeprom.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath5k/gpio.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath5k/desc.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath5k/dma.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath5k/qcu.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath5k/pcu.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath5k/phy.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath5k/reset.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath5k/attach.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath5k/base.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath5k/led.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath5k/rfkill.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath5k/ani.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath5k/sysfs.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath5k/mac80211-ops.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath5k/pci.o
  LD [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath5k/ath5k.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath6kl/debug.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath6kl/hif.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath6kl/htc_mbox.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath6kl/htc_pipe.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath6kl/bmi.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath6kl/cfg80211.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath6kl/init.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath6kl/main.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath6kl/txrx.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath6kl/wmi.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath6kl/core.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath6kl/testmode.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath6kl/sdio.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath6kl/usb.o
  LD [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath6kl/ath6kl_core.o
  LD [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath6kl/ath6kl_sdio.o
  LD [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath6kl/ath6kl_usb.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath9k/beacon.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath9k/gpio.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath9k/init.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath9k/main.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath9k/recv.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath9k/xmit.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath9k/mci.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath9k/rc.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath9k/pci.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath9k/ahb.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath9k/common.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath9k/htc_hst.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath9k/hif_usb.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath9k/wmi.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath9k/htc_drv_txrx.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath9k/htc_drv_main.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath9k/htc_drv_beacon.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath9k/htc_drv_init.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath9k/htc_drv_gpio.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath9k/ar9002_hw.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath9k/ar9003_hw.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath9k/hw.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath9k/ar9003_phy.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath9k/ar9002_phy.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath9k/ar5008_phy.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath9k/ar9002_calib.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath9k/ar9003_calib.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath9k/ar9003_rtt.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath9k/calib.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath9k/eeprom.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath9k/eeprom_def.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath9k/eeprom_4k.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath9k/eeprom_9287.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath9k/ani.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath9k/mac.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath9k/ar9002_mac.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath9k/ar9003_mac.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath9k/ar9003_eeprom.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath9k/ar9003_paprd.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath9k/btcoex.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath9k/ar9003_mci.o
  LD [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath9k/ath9k.o
  LD [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath9k/ath9k_hw.o
  LD [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath9k/ath9k_common.o
  LD [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath9k/ath9k_htc.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/carl9170/main.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/carl9170/usb.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/carl9170/cmd.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/carl9170/mac.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/carl9170/phy.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/carl9170/led.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/carl9170/fw.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/carl9170/tx.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/carl9170/rx.o
  LD [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/carl9170/carl9170.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/zd1211rw/zd_chip.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/zd1211rw/zd_mac.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/zd1211rw/zd_rf_al2230.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/zd1211rw/zd_rf_rf2959.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/zd1211rw/zd_rf_al7230b.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/zd1211rw/zd_rf_uw2453.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/zd1211rw/zd_rf.o
  CC [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/zd1211rw/zd_usb.o
  LD [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/zd1211rw/zd1211rw.o
  CC [M]  /home/mark/aur/compat-wireless/net/mac80211/main.o
  CC [M]  /home/mark/aur/compat-wireless/net/mac80211/status.o
  CC [M]  /home/mark/aur/compat-wireless/net/mac80211/sta_info.o
  CC [M]  /home/mark/aur/compat-wireless/net/mac80211/wep.o
  CC [M]  /home/mark/aur/compat-wireless/net/mac80211/wpa.o
  CC [M]  /home/mark/aur/compat-wireless/net/mac80211/scan.o
  CC [M]  /home/mark/aur/compat-wireless/net/mac80211/offchannel.o
  CC [M]  /home/mark/aur/compat-wireless/net/mac80211/ht.o
  CC [M]  /home/mark/aur/compat-wireless/net/mac80211/agg-tx.o
  CC [M]  /home/mark/aur/compat-wireless/net/mac80211/agg-rx.o
  CC [M]  /home/mark/aur/compat-wireless/net/mac80211/ibss.o
  CC [M]  /home/mark/aur/compat-wireless/net/mac80211/work.o
  CC [M]  /home/mark/aur/compat-wireless/net/mac80211/iface.o
  CC [M]  /home/mark/aur/compat-wireless/net/mac80211/rate.o
  CC [M]  /home/mark/aur/compat-wireless/net/mac80211/michael.o
  CC [M]  /home/mark/aur/compat-wireless/net/mac80211/tkip.o
  CC [M]  /home/mark/aur/compat-wireless/net/mac80211/aes_ccm.o
  CC [M]  /home/mark/aur/compat-wireless/net/mac80211/aes_cmac.o
  CC [M]  /home/mark/aur/compat-wireless/net/mac80211/cfg.o
  CC [M]  /home/mark/aur/compat-wireless/net/mac80211/rx.o
  CC [M]  /home/mark/aur/compat-wireless/net/mac80211/spectmgmt.o
  CC [M]  /home/mark/aur/compat-wireless/net/mac80211/tx.o
  CC [M]  /home/mark/aur/compat-wireless/net/mac80211/key.o
  CC [M]  /home/mark/aur/compat-wireless/net/mac80211/util.o
  CC [M]  /home/mark/aur/compat-wireless/net/mac80211/wme.o
  CC [M]  /home/mark/aur/compat-wireless/net/mac80211/event.o
  CC [M]  /home/mark/aur/compat-wireless/net/mac80211/chan.o
  CC [M]  /home/mark/aur/compat-wireless/net/mac80211/mlme.o
  CC [M]  /home/mark/aur/compat-wireless/net/mac80211/driver-trace.o
  CC [M]  /home/mark/aur/compat-wireless/net/mac80211/led.o
  CC [M]  /home/mark/aur/compat-wireless/net/mac80211/mesh.o
  CC [M]  /home/mark/aur/compat-wireless/net/mac80211/mesh_pathtbl.o
  CC [M]  /home/mark/aur/compat-wireless/net/mac80211/mesh_plink.o
  CC [M]  /home/mark/aur/compat-wireless/net/mac80211/mesh_hwmp.o
  CC [M]  /home/mark/aur/compat-wireless/net/mac80211/mesh_sync.o
  CC [M]  /home/mark/aur/compat-wireless/net/mac80211/pm.o
  CC [M]  /home/mark/aur/compat-wireless/net/mac80211/rc80211_pid_algo.o
  CC [M]  /home/mark/aur/compat-wireless/net/mac80211/rc80211_minstrel.o
  CC [M]  /home/mark/aur/compat-wireless/net/mac80211/rc80211_minstrel_ht.o
  LD [M]  /home/mark/aur/compat-wireless/net/mac80211/mac80211.o
  CC [M]  /home/mark/aur/compat-wireless/net/wireless/core.o
  CC [M]  /home/mark/aur/compat-wireless/net/wireless/sysfs.o
  CC [M]  /home/mark/aur/compat-wireless/net/wireless/radiotap.o
  CC [M]  /home/mark/aur/compat-wireless/net/wireless/util.o
  CC [M]  /home/mark/aur/compat-wireless/net/wireless/reg.o
  CC [M]  /home/mark/aur/compat-wireless/net/wireless/scan.o
  CC [M]  /home/mark/aur/compat-wireless/net/wireless/nl80211.o
  CC [M]  /home/mark/aur/compat-wireless/net/wireless/mlme.o
  CC [M]  /home/mark/aur/compat-wireless/net/wireless/ibss.o
  CC [M]  /home/mark/aur/compat-wireless/net/wireless/sme.o
  CC [M]  /home/mark/aur/compat-wireless/net/wireless/chan.o
  CC [M]  /home/mark/aur/compat-wireless/net/wireless/ethtool.o
  CC [M]  /home/mark/aur/compat-wireless/net/wireless/mesh.o
  CC [M]  /home/mark/aur/compat-wireless/net/wireless/wext-compat.o
  CC [M]  /home/mark/aur/compat-wireless/net/wireless/wext-sme.o
  LD [M]  /home/mark/aur/compat-wireless/net/wireless/cfg80211.o
  Building modules, stage 2.
  MODPOST 14 modules
WARNING: /home/mark/aur/compat-wireless/compat/compat: 'simple_open' exported twice. Previous export was in vmlinux
  CC      /home/mark/aur/compat-wireless/compat/compat.mod.o
  LD [M]  /home/mark/aur/compat-wireless/compat/compat.ko
  CC      /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath.mod.o
  LD [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath.ko
  CC      /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath5k/ath5k.mod.o
  LD [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath5k/ath5k.ko
  CC      /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath6kl/ath6kl_core.mod.o
  LD [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath6kl/ath6kl_core.ko
  CC      /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath6kl/ath6kl_sdio.mod.o
  LD [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath6kl/ath6kl_sdio.ko
  CC      /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath6kl/ath6kl_usb.mod.o
  LD [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath6kl/ath6kl_usb.ko
  CC      /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath9k/ath9k.mod.o
  LD [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath9k/ath9k.ko
  CC      /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath9k/ath9k_common.mod.o
  LD [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath9k/ath9k_common.ko
  CC      /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath9k/ath9k_htc.mod.o
  LD [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath9k/ath9k_htc.ko
  CC      /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath9k/ath9k_hw.mod.o
  LD [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath9k/ath9k_hw.ko
  CC      /home/mark/aur/compat-wireless/drivers/net/wireless/ath/carl9170/carl9170.mod.o
  LD [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/ath/carl9170/carl9170.ko
  CC      /home/mark/aur/compat-wireless/drivers/net/wireless/zd1211rw/zd1211rw.mod.o
  LD [M]  /home/mark/aur/compat-wireless/drivers/net/wireless/zd1211rw/zd1211rw.ko
  CC      /home/mark/aur/compat-wireless/net/mac80211/mac80211.mod.o
  LD [M]  /home/mark/aur/compat-wireless/net/mac80211/mac80211.ko
  CC      /home/mark/aur/compat-wireless/net/wireless/cfg80211.mod.o
  LD [M]  /home/mark/aur/compat-wireless/net/wireless/cfg80211.ko
make[1]: Leaving directory `/usr/src/linux-3.4.4-2-ARCH'
[mark@houseserver compat-wireless]$ sudo make install

make -C /lib/modules/3.4.4-2-ARCH/build M=/home/mark/aur/compat-wireless modules
make[1]: Entering directory `/usr/src/linux-3.4.4-2-ARCH'
  Building modules, stage 2.
  MODPOST 14 modules
WARNING: /home/mark/aur/compat-wireless/compat/compat: 'simple_open' exported twice. Previous export was in vmlinux
make[1]: Leaving directory `/usr/src/linux-3.4.4-2-ARCH'
make -C /lib/modules/3.4.4-2-ARCH/build M=/home/mark/aur/compat-wireless "INSTALL_MOD_DIR=updates"  \
        modules_install
make[1]: Entering directory `/usr/src/linux-3.4.4-2-ARCH'
  INSTALL /home/mark/aur/compat-wireless/compat/compat.ko
  INSTALL /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath.ko
  INSTALL /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath5k/ath5k.ko
  INSTALL /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath6kl/ath6kl_core.ko
  INSTALL /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath6kl/ath6kl_sdio.ko
  INSTALL /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath6kl/ath6kl_usb.ko
  INSTALL /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath9k/ath9k.ko
  INSTALL /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath9k/ath9k_common.ko
  INSTALL /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath9k/ath9k_htc.ko
  INSTALL /home/mark/aur/compat-wireless/drivers/net/wireless/ath/ath9k/ath9k_hw.ko
  INSTALL /home/mark/aur/compat-wireless/drivers/net/wireless/ath/carl9170/carl9170.ko
  INSTALL /home/mark/aur/compat-wireless/drivers/net/wireless/zd1211rw/zd1211rw.ko
  INSTALL /home/mark/aur/compat-wireless/net/mac80211/mac80211.ko
  INSTALL /home/mark/aur/compat-wireless/net/wireless/cfg80211.ko
  DEPMOD  3.4.4-2-ARCH
make[1]: Leaving directory `/usr/src/linux-3.4.4-2-ARCH'

Note: iwl4965 detected, we're going to disable it. If you would like to enable it later you can run:
    sudo iwl-load iwl4965

Running iwl-enable iwlagn...
modprobe: invalid option -- 'l'
Module iwl4965 not detected -- this is fine

Note: iwlagn detected, we're going to disable it. If you would like to enable it later you can run:
    sudo iwl-load iwlagn

Running iwl-enable iwlwifi...
modprobe: invalid option -- 'l'
Module iwl4965 not detected -- this is fine
modprobe: invalid option -- 'l'
Module iwlagn not detected -- this is fine

Note: atl1c detected, we're going to disable it. If you would like to enable it later you can run:
    sudo alx-load atl1c

Running alx-enable alx...
modprobe: invalid option -- 'l'
Module atl1c not detected -- this is fine
modprobe: invalid option -- 'l'
depmod will prefer updates/ over kernel/ -- OK!

Now run:

sudo make unload to unload all: wireless, bluetooth and ethernet modules
sudo make wlunload to unload wireless modules
sudo make btunload to unload bluetooth modules

Run sudo modprobe driver-name to load your desired driver.
If unsure reboot.

[mark@houseserver compat-wireless]$ sudo make unload
Stoping bluetooth service..
./scripts/unload.sh: line 41: /etc/init.d/bluetooth: No such file or directory
./scripts/unload.sh: line 42: /etc/init.d/bluetooth: No such file or directory
Unloading ath9k...
Unloading ath9k_htc...
[mark@houseserver compat-wireless]$ sudo modprobe ath9k_htc
ERROR: could not insert 'ath9k_htc': Exec format error

Now it seems the new driver doesn't want to load after unloading the old one:

[mark@houseserver compat-wireless]$ sudo modprobe ath9k_htc
ERROR: could not insert 'ath9k_htc': Exec format error

Googling the error, I can't see any way around this.. any suggestions? Should I run any of the iwl-load / alx-load options that were disabled by the make install script?

Edit: the iwl-load and alx-load options didn't help:

[mark@houseserver compat-wireless]$ sudo iwl-load iwl4965
modprobe: invalid option -- 'l'
modprobe: invalid option -- 'l'
Module iwlagn not detected -- this is fine
ERROR: could not insert 'iwl4965': Exec format error
modprobe: invalid option -- 'l'
[mark@houseserver compat-wireless]$ sudo iwl-load iwlagn
modprobe: invalid option -- 'l'
Module iwl4965 not detected -- this is fine
ERROR: could not insert 'iwlwifi': Exec format error
modprobe: invalid option -- 'l'
[mark@houseserver compat-wireless]$ sudo iwl-load iwlagn
modprobe: invalid option -- 'l'
Module iwl4965 not detected -- this is fine
ERROR: could not insert 'iwlwifi': Exec format error
modprobe: invalid option -- 'l'
[mark@houseserver compat-wireless]$ sudo modprobe ath9k_htc
ERROR: could not insert 'ath9k_htc': Exec format error
[mark@houseserver compat-wireless]$ 

Edit#2: Here is the line from dmesg when the new driver tried to load:

[ 2836.486408] compat: exports duplicate symbol simple_open (owned by kernel)

Last edited by mfncl (2012-06-26 17:59:27)

Offline

#13 2012-06-26 19:58:09

mfncl
Member
Registered: 2012-06-24
Posts: 9

Re: [SOLVED] ath9k_htc wi-fi connection drops (dmesg reasons 7 & 3) on

Solved the duplicate symbol errors by removing "EXPORT_SYMBOL_GPL(simple_open);" from ./compact/compat-3.5.c and recompiling.

Ping problem persists sad

--- bbc.co.uk ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 4004ms
rtt min/avg/max/mdev = 19.699/21.822/26.585/2.515 ms
[mark@houseserver compat-wireless]$ ping -c 10 bbc.co.uk
PING bbc.co.uk (212.58.241.131) 56(84) bytes of data.
64 bytes from 212.58.241.131: icmp_req=1 ttl=241 time=310 ms
64 bytes from 212.58.241.131: icmp_req=2 ttl=241 time=21.3 ms
64 bytes from 212.58.241.131: icmp_req=3 ttl=241 time=200 ms
64 bytes from 212.58.241.131: icmp_req=4 ttl=241 time=19.9 ms
64 bytes from 212.58.241.131: icmp_req=5 ttl=241 time=197 ms
64 bytes from 212.58.241.131: icmp_req=6 ttl=241 time=20.3 ms
64 bytes from 212.58.241.131: icmp_req=7 ttl=241 time=194 ms
64 bytes from 212.58.241.131: icmp_req=8 ttl=241 time=21.6 ms
64 bytes from 212.58.241.131: icmp_req=9 ttl=241 time=191 ms
64 bytes from 212.58.241.131: icmp_req=10 ttl=241 time=20.0 ms

--- bbc.co.uk ping statistics ---
10 packets transmitted, 10 received, 0% packet loss, time 9012ms
rtt min/avg/max/mdev = 19.917/119.740/310.474/104.264 ms
[mark@houseserver compat-wireless]$ ping -c 10 bbc.co.uk
PING bbc.co.uk (212.58.241.131) 56(84) bytes of data.
64 bytes from 212.58.241.131: icmp_req=1 ttl=241 time=20.5 ms
64 bytes from 212.58.241.131: icmp_req=2 ttl=241 time=20.1 ms
64 bytes from 212.58.241.131: icmp_req=3 ttl=241 time=194 ms
64 bytes from 212.58.241.131: icmp_req=4 ttl=241 time=21.1 ms
64 bytes from 212.58.241.131: icmp_req=5 ttl=241 time=191 ms
64 bytes from 212.58.241.131: icmp_req=6 ttl=241 time=21.3 ms
64 bytes from 212.58.241.131: icmp_req=7 ttl=241 time=195 ms
64 bytes from 212.58.241.131: icmp_req=8 ttl=241 time=20.6 ms
64 bytes from 212.58.241.131: icmp_req=9 ttl=241 time=187 ms
64 bytes from 212.58.241.131: icmp_req=10 ttl=241 time=20.4 ms

I noticed the latest compat_wireless daily build seems to be dated May 10th but timestamped June 25th..

http://linuxwireless.org/download/compat-wireless-2.6/

compat-wireless-2012-05-08-p.tar.bz2    2012-May-08 22:51:51    4.2M    application/octet-stream
compat-wireless-2012-05-08-pc.tar.bz2    2012-May-08 22:51:52    4.2M    application/octet-stream
compat-wireless-2012-05-08.tar.bz2    2012-May-08 22:51:53    4.1M    application/octet-stream
compat-wireless-2012-05-09-p.tar.bz2    2012-May-09 22:49:19    4.2M    application/octet-stream
compat-wireless-2012-05-09-pc.tar.bz2    2012-May-09 22:49:20    4.2M    application/octet-stream
compat-wireless-2012-05-09.tar.bz2    2012-May-09 22:49:21    4.1M    application/octet-stream
compat-wireless-2012-05-10-p.tar.bz2    2012-Jun-25 22:43:51    4.2M    application/octet-stream
compat-wireless-2012-05-10-pc.tar.bz2    2012-Jun-25 22:43:51    4.2M    application/octet-stream
compat-wireless-2012-05-10.tar.bz2    2012-Jun-25 22:43:51    4.1M    application/octet-stream

The files in compat-wireless-2.6.tar.bz2 are stamped May 10th.

Also on the historic mirror the folder for June is empty:

http://www.orbit-lab.org/kernel/compat- … s/2012/06/

Anybody have any idea why the daily builds don't seem to be being maintained?

Offline

#14 2012-06-26 20:16:31

mfncl
Member
Registered: 2012-06-24
Posts: 9

Re: [SOLVED] ath9k_htc wi-fi connection drops (dmesg reasons 7 & 3) on

Went ahead and patched the code in compat_wireless myself and recompiled, now problem solved!!! smile

[mark@houseserver compat-wireless]$ ping -c 10 bbc.co.uk
ping: unknown host bbc.co.uk
[mark@houseserver compat-wireless]$ ping -c 10 bbc.co.uk
PING bbc.co.uk (212.58.241.131) 56(84) bytes of data.
64 bytes from 212.58.241.131: icmp_req=1 ttl=241 time=20.0 ms
64 bytes from 212.58.241.131: icmp_req=2 ttl=241 time=28.8 ms
64 bytes from 212.58.241.131: icmp_req=3 ttl=241 time=32.3 ms
64 bytes from 212.58.241.131: icmp_req=4 ttl=241 time=21.6 ms
64 bytes from 212.58.241.131: icmp_req=5 ttl=241 time=34.7 ms
64 bytes from 212.58.241.131: icmp_req=6 ttl=241 time=21.4 ms
64 bytes from 212.58.241.131: icmp_req=7 ttl=241 time=23.5 ms
64 bytes from 212.58.241.131: icmp_req=8 ttl=241 time=20.4 ms
64 bytes from 212.58.241.131: icmp_req=9 ttl=241 time=22.3 ms
64 bytes from 212.58.241.131: icmp_req=10 ttl=241 time=23.8 ms

--- bbc.co.uk ping statistics ---
10 packets transmitted, 10 received, 0% packet loss, time 9014ms
rtt min/avg/max/mdev = 20.097/24.934/34.713/4.909 ms
[mark@houseserver compat-wireless]$ ping -c 10 bbc.co.uk
PING bbc.co.uk (212.58.241.131) 56(84) bytes of data.
64 bytes from 212.58.241.131: icmp_req=1 ttl=241 time=20.5 ms
64 bytes from 212.58.241.131: icmp_req=2 ttl=241 time=21.4 ms
64 bytes from 212.58.241.131: icmp_req=3 ttl=241 time=24.7 ms
64 bytes from 212.58.241.131: icmp_req=4 ttl=241 time=21.8 ms
64 bytes from 212.58.241.131: icmp_req=5 ttl=241 time=22.4 ms
64 bytes from 212.58.241.131: icmp_req=6 ttl=241 time=21.8 ms
64 bytes from 212.58.241.131: icmp_req=7 ttl=241 time=21.2 ms
64 bytes from 212.58.241.131: icmp_req=8 ttl=241 time=20.0 ms
64 bytes from 212.58.241.131: icmp_req=9 ttl=241 time=20.4 ms
64 bytes from 212.58.241.131: icmp_req=10 ttl=241 time=20.4 ms

--- bbc.co.uk ping statistics ---
10 packets transmitted, 10 received, 0% packet loss, time 9013ms
rtt min/avg/max/mdev = 20.085/21.509/24.725/1.306 ms
[mark@houseserver compat-wireless]$ 

Thanks for the pointers in the right direction, was able to get there with a bit of diligence and have learned a great deal in the process.

Offline

#15 2012-06-27 00:12:51

doorknob60
Member
From: Oregon
Registered: 2008-09-29
Posts: 402

Re: [SOLVED] ath9k_htc wi-fi connection drops (dmesg reasons 7 & 3) on

I'm getting random connection drop as well on my "Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter (rev 01)" (which as far as I can tell uses the rtl8192ce module), with similar dmesg output:

[21479.595798] [21478.260381] wlan0: authenticate with bc:ae:c5:a7:51:af
[21478.280348] wlan0: send auth to bc:ae:c5:a7:51:af (try 1/3)
[21478.282216] wlan0: authenticated
[21478.293252] wlan0: associate with bc:ae:c5:a7:51:af (try 1/3)
[21478.297072] wlan0: RX AssocResp from bc:ae:c5:a7:51:af (capab=0x411 status=0 aid=6)
[21478.297080] wlan0: associated
[21479.595798] wlan0: deauthenticating from bc:ae:c5:a7:51:af by local choice (reason=3)
[21479.616965] cfg80211: Calling CRDA to update world regulatory domain
[21479.969142] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[21480.064538] r8169 0000:03:00.0: eth0: link down
[21480.065737] ADDRCONF(NETDEV_UP): eth0: link is not ready
[21484.807254] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[21486.223648] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[21486.269069] r8169 0000:03:00.0: eth0: link down
[21486.269590] ADDRCONF(NETDEV_UP): eth0: link is not ready
[21486.640143] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[21489.202513] wlan0: authenticate with bc:ae:c5:a7:51:af
[21489.212667] wlan0: send auth to bc:ae:c5:a7:51:af (try 1/3)
[21489.214759] wlan0: authenticated
[21489.225359] wlan0: associate with bc:ae:c5:a7:51:af (try 1/3)
[21489.227740] wlan0: RX AssocResp from bc:ae:c5:a7:51:af (capab=0x411 status=0 aid=6)
[21489.227748] wlan0: associated
[21489.229085] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready

I assume this is where the problem is:

[21479.595798] wlan0: deauthenticating from bc:ae:c5:a7:51:af by local choice (reason=3)

I don't know what it means by "local choice", I obviously didn't tell it to disconnect or anything, so not sure...

This only started recently, so I haven't had a lot of time to debug and mess around with router settings, but this problem recently popped up for me to.

Oh, and by the way, I'm using Wicd.

Last edited by doorknob60 (2012-06-27 00:16:09)

Offline

#16 2012-06-27 06:48:28

mfncl
Member
Registered: 2012-06-24
Posts: 9

Re: [SOLVED] ath9k_htc wi-fi connection drops (dmesg reasons 7 & 3) on

Hmm.. based on your output I would say you have a different issue with another root cause - you Wi-Fi adaptor disconnects straight after its connected with reason 3, I got reason 7 (followed by reason 3 as a knock on effect) at random intervals a time period after the connection was established. Reason 7 from what was suggested above is down to wireless interference which you shouldn't have (otherwise the connection would have been established and the error appeared afterwards). Also, your hardware and driver are from a different vendor, the driver/firmware might behave differently under different problem scenarios.

Based on what I learned I would start by troubleshooting the linux driver and Wi-Fi adaptor configuration rather than your router.

Did you try connecting manually using wpa_supplicant -d / dhcpcd? Check rfkill / power management on the device? Is the right module being loaded for your hardware (check linuxwireless.org)? Does the wiki state if any additional instructions are needed to configure the wireless adaptor? Are there any switches for the adaptor you could specify in modprobe.d that might help (a common suggestion for ath9k users is to try nohwcrypt=1)

As a suggestion, it may be better raising this in a new thread with an appropriate title so that you have a better chance of people with similar hardware being able to help out that have had similar issues.

I'm marking this thread as resolved, the original issues I raised are now fixed.

Offline

#17 2012-06-27 16:45:30

doorknob60
Member
From: Oregon
Registered: 2008-09-29
Posts: 402

Re: [SOLVED] ath9k_htc wi-fi connection drops (dmesg reasons 7 & 3) on

mfncl wrote:

Hmm.. based on your output I would say you have a different issue with another root cause - you Wi-Fi adaptor disconnects straight after its connected with reason 3, I got reason 7 (followed by reason 3 as a knock on effect) at random intervals a time period after the connection was established. Reason 7 from what was suggested above is down to wireless interference which you shouldn't have (otherwise the connection would have been established and the error appeared afterwards). Also, your hardware and driver are from a different vendor, the driver/firmware might behave differently under different problem scenarios.

Based on what I learned I would start by troubleshooting the linux driver and Wi-Fi adaptor configuration rather than your router.

Did you try connecting manually using wpa_supplicant -d / dhcpcd? Check rfkill / power management on the device? Is the right module being loaded for your hardware (check linuxwireless.org)? Does the wiki state if any additional instructions are needed to configure the wireless adaptor? Are there any switches for the adaptor you could specify in modprobe.d that might help (a common suggestion for ath9k users is to try nohwcrypt=1)

As a suggestion, it may be better raising this in a new thread with an appropriate title so that you have a better chance of people with similar hardware being able to help out that have had similar issues.

I'm marking this thread as resolved, the original issues I raised are now fixed.

Alright thank you for the tips. I will mess around with it some more, and if I can't figure it out, I'll start a new thread, but not until I try some things first smile

Offline

Board footer

Powered by FluxBB