You are not logged in.

#101 2012-06-26 09:50:06

MrZYX
Member
From: Hannover, Germany
Registered: 2011-12-14
Posts: 6
Website

Re: Wayland on Arch Linux?

I too get no cursor. I could get rid of the xcb-xkb warning by recompiling libxcd with --enable-xkd and then recompiling wayland/weston but that didn't change anything about the cursor.

Offline

#102 2012-06-26 21:57:59

Giselher
Member
From: Austria
Registered: 2010-02-02
Posts: 150
Website

Re: Wayland on Arch Linux?

Sorry, but I don't really know why I have a cursor in weston, but I don't even have the environment variable XCURSOR

Offline

#103 2012-06-27 06:28:43

Cdh
Member
Registered: 2009-02-03
Posts: 1,098

Re: Wayland on Arch Linux?

I'm pretty sure that KDE set it.

Maybe it doesn't work with some drivers? Radeon here, what do you have?


฿ 18PRsqbZCrwPUrVnJe1BZvza7bwSDbpxZz

Offline

#104 2012-06-27 06:31:27

Giselher
Member
From: Austria
Registered: 2010-02-02
Posts: 150
Website

Re: Wayland on Arch Linux?

Radeon here too. Do you have the config file in place (~/.config/weston.ini)?

Offline

#105 2012-06-27 06:50:00

Giselher
Member
From: Austria
Registered: 2010-02-02
Posts: 150
Website

Re: Wayland on Arch Linux?

I think I found the cursor magic, maybe it helps.

#ifndef ICONDIR
#define ICONDIR "/usr/X11R6/lib/X11/icons"
#endif

#ifndef XCURSORPATH
#define XCURSORPATH "~/.icons:/usr/share/icons:/usr/share/pixmaps:"ICONDIR
#endif

static const char *
XcursorLibraryPath (void)
{
    static const char	*path;

    if (!path)
    {
	path = getenv ("XCURSOR_PATH");
	if (!path)
	    path = XCURSORPATH;
    }
    return path;
}

EDIT: From the code I read you probably need a default directory in ~/.icons or a directory for your XCURSOR theme there.
EDIT2: Weston currently only recognizes a default theme and doesn't use the XCURSOR environment variable.
EDIT3: It looks like only XCURSOR_PATH is specified: http://www.x.org/archive/X11R7.5/doc/ma … html#toc14
Final EDIT: I have a simple patch that makes it work with the XCURSOR variable, but like I said above only XCURSOR_PATH seems to be specified and you just need an index.theme file in ~/.icons/default . (Example content below)

index.theme

# This file is written by LXAppearance. Do not edit.[Icon Theme]
Name=Default
Comment=Default Cursor Theme
Inherits=ComixCursors-Green-Small-Slim

Last edited by Giselher (2012-06-27 07:24:36)

Offline

#106 2012-06-27 08:04:57

Cdh
Member
Registered: 2009-02-03
Posts: 1,098

Re: Wayland on Arch Linux?

Giselher wrote:

you just need an index.theme file in ~/.icons/default . (Example content below)
index.theme

# This file is written by LXAppearance. Do not edit.[Icon Theme]
Name=Default
Comment=Default Cursor Theme
Inherits=ComixCursors-Green-Small-Slim

Many, many thanks for your investigation. This is the solution. Should definitely go to the wiki.
(And wayland/weston should definitely implement a fallback smile)

Last edited by Cdh (2012-06-27 08:06:07)


฿ 18PRsqbZCrwPUrVnJe1BZvza7bwSDbpxZz

Offline

#107 2012-06-27 09:28:44

Giselher
Member
From: Austria
Registered: 2010-02-02
Posts: 150
Website

Re: Wayland on Arch Linux?

Cdh wrote:
Giselher wrote:

you just need an index.theme file in ~/.icons/default . (Example content below)
index.theme

# This file is written by LXAppearance. Do not edit.[Icon Theme]
Name=Default
Comment=Default Cursor Theme
Inherits=ComixCursors-Green-Small-Slim

Many, many thanks for your investigation. This is the solution. Should definitely go to the wiki.
(And wayland/weston should definitely implement a fallback smile)

You're welcome, but is a cursor theme really that important wink.

Offline

#108 2012-06-27 10:07:20

Cdh
Member
Registered: 2009-02-03
Posts: 1,098

Re: Wayland on Arch Linux?

If the alternative is a cursor without a theme (= invisible), yes.


฿ 18PRsqbZCrwPUrVnJe1BZvza7bwSDbpxZz

Offline

#109 2012-06-28 07:09:01

Giselher
Member
From: Austria
Registered: 2010-02-02
Posts: 150
Website

Re: Wayland on Arch Linux?

I updated the wiki with a troubleshooting section, but it would be better if you submit a bug report. https://wiki.archlinux.org/index.php/Wayland

By the way, here is a link to the Wayland Documentation: http://wayland.freedesktop.org/docs/html/

Offline

#110 2012-06-30 00:10:53

Saxcore
Member
From: London
Registered: 2012-06-29
Posts: 2
Website

Re: Wayland on Arch Linux?

Giselher -- Thanks for this! I was having the same issue with an invisible cursor, and creating an index.theme file fixed it. Good find!

Offline

#111 2012-07-02 09:36:17

Saxcore
Member
From: London
Registered: 2012-06-29
Posts: 2
Website

Re: Wayland on Arch Linux?

I've submitted a bug report for the cursor issue. Hopefully this covers it!
https://bugs.freedesktop.org/show_bug.cgi?id=51647

jukkan wrote:

Not working here either. I can only ran Wayland under X but without mouse cursor (mouse still working though). Trying 'weston' or 'weston-launch' in a TTY always results in total crash after which a reboot is needed.

Can I ask if anyone has managed to get Weston running on the KMS console with intel graphics? I'm having the issue Jukkan was having above .. I get a total graphics lock up. I can remotely log into the machine, but as far as I can tell there are no processes I can kill to revive it, so have to reboot.

Offline

#112 2012-07-02 10:46:24

Giselher
Member
From: Austria
Registered: 2010-02-02
Posts: 150
Website

Re: Wayland on Arch Linux?

Saxcore wrote:

I've submitted a bug report for the cursor issue. Hopefully this covers it!
https://bugs.freedesktop.org/show_bug.cgi?id=51647

Thanks for reporting this issue.

Btw: I am currently trying to port mplayer2 to wayland. https://github.com/giselher/mplayer2-wayland

It renders a video but rendering FullHD Videos is too slow with my implementation.

Offline

#113 2012-07-24 20:33:06

cryptix
Member
From: Hamburg, Germany
Registered: 2008-02-15
Posts: 10
Website

Re: Wayland on Arch Linux?

Hi,

i'm having problems starting up weston-* from a KMS console as well.

Running my normal user i get

[cryptix@oObsi ~]$ weston
Date: 2012-07-25 CEST
[00:22:45.565] weston 0.94.90
               http://wayland.freedesktop.org/
               Bug reports to: https://bugs.freedesktop.org/enter_bug.cgi?product=weston
               Build: d1936b9 desktop-shell: Break command lines into env vars, executable and arguments (2012-07-23 22:59:33 -0400)
[00:22:45.565] OS: Linux, 3.4.6-1-ARCH, #1 SMP PREEMPT Fri Jul 20 07:24:45 UTC 2012, i686
[00:22:45.586] warning: XDG_RUNTIME_DIR "/home/cryptix/.config/runtime" is not configured
correctly.  Unix access mode must be 0700 but is 755,
and XDG_RUNTIME_DIR must be owned by the user, but is
owned by UID 1000.
Refer to your distribution on how to get it, or
http://www.freedesktop.org/wiki/Specifications/basedir-spec
on how to implement it.
[00:22:45.586] Loading module '/usr/lib/weston/drm-backend.so'
[00:22:45.587] initializing drm backend
[00:22:45.587] could not open tty0: Permission denied
[00:22:45.587] failed to open tty: Permission denied
[00:22:45.587] failed to initialize tty
[00:22:45.587] failed to create compositor

So i tried as root which gives me:

[root@oObsi ~]# weston
Date: 2012-07-25 CEST
[00:22:16.494] weston 0.94.90
               http://wayland.freedesktop.org/
               Bug reports to: https://bugs.freedesktop.org/enter_bug.cgi?product=weston
               Build: d1936b9 desktop-shell: Break command lines into env vars, executable and arguments (2012-07-23 22:59:33 -0400)
[00:22:16.494] OS: Linux, 3.4.6-1-ARCH, #1 SMP PREEMPT Fri Jul 20 07:24:45 UTC 2012, i686
[00:22:16.494] warning: XDG_RUNTIME_DIR "westonRuntime" is not configured
correctly.  Unix access mode must be 0700 but is 755,
and XDG_RUNTIME_DIR must be owned by the user, but is
owned by UID 0.
Refer to your distribution on how to get it, or
http://www.freedesktop.org/wiki/Specifications/basedir-spec
on how to implement it.
couldn't open /root/.config/weston.ini
[00:22:16.495] Loading module '/usr/lib/weston/drm-backend.so'
[00:22:16.496] initializing drm backend
couldn't open /root/.config/weston.ini
[00:22:16.496] compositor: using new vt /dev/tty8
[00:22:16.498] using /dev/dri/card0
[00:22:16.506] EGL version: 1.4 (DRI2)
[00:22:16.506] EGL vendor: Mesa Project
[00:22:16.506] EGL client APIs: OpenGL OpenGL_ES OpenGL_ES2 
[00:22:16.506] EGL extensions: EGL_MESA_drm_image EGL_WL_bind_wayland_display
               EGL_KHR_image_base EGL_KHR_gl_renderbuffer_image
               EGL_KHR_surfaceless_gles1 EGL_KHR_surfaceless_gles2
               EGL_KHR_surfaceless_opengl
[00:22:16.506] GL version: OpenGL ES 2.0 Mesa 8.1-devel (git-881bb4a)
[00:22:16.506] GLSL version: OpenGL ES GLSL ES 1.0.16
[00:22:16.506] GL vendor: X.Org
[00:22:16.506] GL renderer: Gallium 0.4 on AMD RV710
[00:22:16.506] GL extensions: GL_EXT_blend_minmax GL_EXT_multi_draw_arrays
               GL_EXT_texture_filter_anisotropic
               GL_EXT_texture_format_BGRA8888 GL_OES_depth24
               GL_OES_element_index_uint GL_OES_fbo_render_mipmap
               GL_OES_mapbuffer GL_OES_rgb8_rgba8 GL_OES_standard_derivatives
               GL_OES_stencil8 GL_OES_texture_3D GL_OES_texture_npot
               GL_OES_EGL_image GL_OES_depth_texture
               GL_OES_packed_depth_stencil GL_EXT_texture_type_2_10_10_10_REV
               GL_EXT_read_format_bgra GL_NV_fbo_color_attachments
               GL_OES_EGL_image_external GL_EXT_texture_rg
               GL_EXT_unpack_subimage GL_NV_draw_buffers GL_NV_read_buffer
[00:22:16.558] kms connector 13, crtc 10
  mode 1680x1050@60.0, preferred, current
  mode 1280x1024@75.0
  mode 1280x1024@60.0
  mode 1440x900@75.0
  mode 1440x900@59.9
  mode 1280x960@60.0
  mode 1280x800@59.8
  mode 1152x864@75.0
  mode 1152x720@60.0
  mode 1024x768@75.1
  mode 1024x768@60.0
  mode 832x624@74.6
  mode 800x600@75.0
  mode 800x600@60.3
  mode 640x480@75.0
  mode 640x480@60.0
  mode 720x400@70.1
Error:         could not find "evdev" rules in XKB path
Error:         0 include paths searched:
Error:         failed to generate XKB components from rules "evdev"
[00:22:16.599] failed to compile global XKB keymap
[00:22:16.599]   tried rules evdev, model pc105, layout us, variant (null), options (null)[root@oObsi ~]# 

I searched for the XKB Error: but couldn't find anything.

ps.: Both tries lock up my screen which seems to be what jukkan and saxcore experience as well.

edit: small typo.

Last edited by cryptix (2012-07-24 20:34:37)

Offline

#114 2012-07-24 20:48:22

Cdh
Member
Registered: 2009-02-03
Posts: 1,098

Re: Wayland on Arch Linux?

I don't know about the error when running as root, but for running as user:

cryptix wrote:
[cryptix@oObsi ~]$ weston

[...]

[00:22:45.587] could not open tty0: Permission denied
[00:22:45.587] failed to open tty: Permission denied

you can try weston-launch, it's a script with setuid so it automatically starts as root but then drops its privilegues to run as your user again.


฿ 18PRsqbZCrwPUrVnJe1BZvza7bwSDbpxZz

Offline

#115 2012-07-24 21:40:47

cryptix
Member
From: Hamburg, Germany
Registered: 2008-02-15
Posts: 10
Website

Re: Wayland on Arch Linux?

Cdh wrote:

you can try weston-launch, it's a script with setuid so it automatically starts as root but then drops its privilegues to run as your user again.

Thanks for the suggestion, much better approach, but it quits with the same error as when running as root.

edit: i ran it with 'EGL_LOG_LEVEL=debug'.

[cryptix@oObsi ~]$ EGL_LOG_LEVEL=debug weston-launch 
Date: 2012-07-24 CEST
[23:43:35.276] weston 0.94.90
               http://wayland.freedesktop.org/
               Bug reports to: https://bugs.freedesktop.org/enter_bug.cgi?product=weston
               Build: d1936b9 desktop-shell: Break command lines into env vars, executable and arguments (2012-07-23 22:59:33 -0400)
[23:43:35.276] OS: Linux, 3.4.6-1-ARCH, #1 SMP PREEMPT Fri Jul 20 07:24:45 UTC 2012, i686
[23:43:35.293] Loading module '/usr/lib/weston/drm-backend.so'
[23:43:35.651] initializing drm backend
[23:43:35.668] using /dev/dri/card0
libEGL debug: Native platform type: drm (autodetected)
libEGL debug: EGL search path is /usr/lib/egl
libEGL debug: added /usr/lib/egl/egl_gallium.so to module array
libEGL debug: added egl_dri2 to module array
libEGL debug: added egl_glx to module array
libEGL debug: dlopen(/usr/lib/egl/egl_gallium.so)
libEGL info: use DRM for display 0x899c9f8
libEGL debug: EGL user error 0x3001 (EGL_NOT_INITIALIZED) in eglInitialize(no usable display)

libEGL debug: the best driver is DRI2
[23:43:36.585] EGL version: 1.4 (DRI2)
[23:43:36.585] EGL vendor: Mesa Project
[23:43:36.585] EGL client APIs: OpenGL OpenGL_ES OpenGL_ES2 
[23:43:36.585] EGL extensions: EGL_MESA_drm_image EGL_WL_bind_wayland_display
               EGL_KHR_image_base EGL_KHR_gl_renderbuffer_image
               EGL_KHR_surfaceless_gles1 EGL_KHR_surfaceless_gles2
               EGL_KHR_surfaceless_opengl
[23:43:36.585] GL version: OpenGL ES 2.0 Mesa 8.1-devel (git-881bb4a)
[23:43:36.585] GLSL version: OpenGL ES GLSL ES 1.0.16
[23:43:36.585] GL vendor: X.Org
[23:43:36.585] GL renderer: Gallium 0.4 on AMD RV710
[23:43:36.585] GL extensions: GL_EXT_blend_minmax GL_EXT_multi_draw_arrays
               GL_EXT_texture_filter_anisotropic
               GL_EXT_texture_format_BGRA8888 GL_OES_depth24
               GL_OES_element_index_uint GL_OES_fbo_render_mipmap
               GL_OES_mapbuffer GL_OES_rgb8_rgba8 GL_OES_standard_derivatives
               GL_OES_stencil8 GL_OES_texture_3D GL_OES_texture_npot
               GL_OES_EGL_image GL_OES_depth_texture
               GL_OES_packed_depth_stencil GL_EXT_texture_type_2_10_10_10_REV
               GL_EXT_read_format_bgra GL_NV_fbo_color_attachments
               GL_OES_EGL_image_external GL_EXT_texture_rg
               GL_EXT_unpack_subimage GL_NV_draw_buffers GL_NV_read_buffer
[23:43:36.640] kms connector 13, crtc 10
			     mode 1680x1050@60.0, preferred, current
			     mode 1280x1024@75.0
			     mode 1280x1024@60.0
			     mode 1440x900@75.0
			     mode 1440x900@59.9
			     mode 1280x960@60.0
			     mode 1280x800@59.8
			     mode 1152x864@75.0
			     mode 1152x720@60.0
			     mode 1024x768@75.1
			     mode 1024x768@60.0
			     mode 832x624@74.6
			     mode 800x600@75.0
			     mode 800x600@60.3
			     mode 640x480@75.0
			     mode 640x480@60.0
			     mode 720x400@70.1
			   Error:         could not find "evdev" rules in XKB path
			   Error:         0 include paths searched:
			   Error:         failed to generate XKB components from rules "evdev"
			   [23:43:36.679] failed to compile global XKB keymap
			   [23:43:36.679]   tried rules evdev, model pc105, layout us, variant (null), options (null)libEGL debug: Display 0x89a3da0 is destroyed with resources
[cryptix@oObsi ~]$ echo $?
1

edit2: i noticed that Cdh also had "libEGL debug: EGL user error 0x3001 (EGL_NOT_INITIALIZED) in eglInitialize(no usable display)" error and while building mesa with --disable-gallium-egl removes that error, it doesn't help with the evdev/xkb stuff..

Last edited by cryptix (2012-07-24 22:13:43)

Offline

#116 2012-07-25 09:07:19

cryptix
Member
From: Hamburg, Germany
Registered: 2008-02-15
Posts: 10
Website

Re: Wayland on Arch Linux?

Small bump: i got the hint from #wayland to install xkeyboard-config and xorg-xkbcomp.
I installed a fresh system and wanted to go with the least amount of X i can. Looks like this bit me here but i also feel that xkeyboard-config should be a dependency somewhere.

I'm now at a different error that is know to the irc guys already but no fix yet.. Seems to be related to a bug in wayland or mesa..

[cryptix@oObsi ~]$ EGL_LOG_LEVEL=debug weston-launch
Date: 2012-07-25 CEST
[10:50:16.720] weston 0.94.90
               http://wayland.freedesktop.org/
               Bug reports to: https://bugs.freedesktop.org/enter_bug.cgi?product=weston
               Build: d1936b9 desktop-shell: Break command lines into env vars, executable and arguments (2012-07-23 22:59:33 -0400)
[10:50:16.720] OS: Linux, 3.4.6-1-ARCH, #1 SMP PREEMPT Fri Jul 20 07:24:45 UTC 2012, i686
[10:50:16.720] Loading module '/usr/lib/weston/drm-backend.so'
[10:50:16.722] initializing drm backend
[10:50:16.730] using /dev/dri/card0
libEGL debug: Native platform type: drm (autodetected)
libEGL debug: EGL search path is /usr/lib/egl
libEGL debug: added egl_dri2 to module array
libEGL debug: added egl_glx to module array
libEGL debug: the best driver is DRI2
[10:50:16.736] EGL version: 1.4 (DRI2)
[10:50:16.736] EGL vendor: Mesa Project
[10:50:16.737] EGL client APIs: OpenGL OpenGL_ES OpenGL_ES2 
[10:50:16.737] EGL extensions: EGL_MESA_drm_image EGL_WL_bind_wayland_display
               EGL_KHR_image_base EGL_KHR_gl_renderbuffer_image
               EGL_KHR_surfaceless_gles1 EGL_KHR_surfaceless_gles2
               EGL_KHR_surfaceless_opengl
[10:50:16.737] GL version: OpenGL ES 2.0 Mesa 8.1-devel (git-f35e380)[10:50:16.737] GLSL version: OpenGL ES GLSL ES 1.0.16
[10:50:16.737] GL vendor: X.Org[10:50:16.737] GL renderer: Gallium 0.4 on AMD RV710
[10:50:16.737] GL extensions: GL_EXT_blend_minmax GL_EXT_multi_draw_arrays
               GL_EXT_texture_filter_anisotropic
               GL_EXT_texture_format_BGRA8888 GL_OES_depth24               GL_OES_element_index_uint GL_OES_fbo_render_mipmap
               GL_OES_mapbuffer GL_OES_rgb8_rgba8 GL_OES_standard_derivatives
               GL_OES_stencil8 GL_OES_texture_3D GL_OES_texture_npot
               GL_OES_EGL_image GL_OES_depth_texture
               GL_OES_packed_depth_stencil GL_EXT_texture_type_2_10_10_10_REV
               GL_EXT_read_format_bgra GL_NV_fbo_color_attachments
               GL_OES_EGL_image_external GL_EXT_texture_rg
               GL_EXT_unpack_subimage GL_NV_draw_buffers GL_NV_read_buffer
[10:50:16.790] kms connector 13, crtc 10
  mode 1680x1050@60.0, preferred, current
  mode 1280x1024@75.0
  mode 1280x1024@60.0
  mode 1440x900@75.0
  mode 1440x900@59.9
  mode 1280x960@60.0
  mode 1280x800@59.8
  mode 1152x864@75.0
  mode 1152x720@60.0
  mode 1024x768@75.1
  mode 1024x768@60.0
  mode 832x624@74.6
  mode 800x600@75.0
  mode 800x600@60.3  mode 640x480@75.0
  mode 640x480@60.0  mode 720x400@70.1
[10:50:16.847] Loading module '/usr/lib/weston/desktop-shell.so'
[10:50:16.847] libwayland: using socket /run/user/1000/wayland-0
libEGL debug: Native platform type: wayland (autodetected)
libEGL debug: EGL search path is /usr/lib/egl
libEGL debug: added egl_dri2 to module array
libEGL debug: added egl_glx to module array
libEGL debug: pci id for 5: 1002:954f, driver r600
libEGL debug: DRI2: dlopen(/usr/lib/xorg/modules/dri/r600_dri.so)
libEGL debug: DRI2: found extension `DRI_Core'
libEGL info: DRI2: found extension DRI_Core version 1
libEGL debug: DRI2: found extension `DRI_DRI2'libEGL info: DRI2: found extension DRI_DRI2 version 3
libEGL debug: DRI2: found extension `DRI_TexBuffer'libEGL info: DRI2: found extension DRI_TexBuffer version 2
libEGL debug: DRI2: found extension `DRI2_Flush'
libEGL info: DRI2: found extension DRI2_Flush version 3
libEGL debug: DRI2: found extension `DRI_IMAGE'libEGL info: DRI2: found extension DRI_IMAGE version 1
libEGL debug: DRI2: found extension `DRI_CONFIG_QUERY'
libEGL debug: DRI2: found extension `DRI2_Throttle'
libEGL debug: the best driver is DRI2
[10:50:16.939] libwayland: disconnect from client 0x91a0d48
wl_drm@11: error 2: invalid name
[10:50:16.942] weston-desktop-shell died, respawning...
libEGL debug: Native platform type: wayland (autodetected)
libEGL debug: EGL search path is /usr/lib/egl
libEGL debug: added egl_dri2 to module array
libEGL debug: added egl_glx to module array
libEGL debug: pci id for 5: 1002:954f, driver r600
libEGL debug: DRI2: dlopen(/usr/lib/xorg/modules/dri/r600_dri.so)
libEGL debug: DRI2: found extension `DRI_Core'
libEGL info: DRI2: found extension DRI_Core version 1
libEGL debug: DRI2: found extension `DRI_DRI2'
libEGL info: DRI2: found extension DRI_DRI2 version 3
libEGL debug: DRI2: found extension `DRI_TexBuffer'
libEGL info: DRI2: found extension DRI_TexBuffer version 2
libEGL debug: DRI2: found extension `DRI2_Flush'
libEGL info: DRI2: found extension DRI2_Flush version 3
libEGL debug: DRI2: found extension `DRI_IMAGE'
libEGL info: DRI2: found extension DRI_IMAGE version 1
libEGL debug: DRI2: found extension `DRI_CONFIG_QUERY'
libEGL debug: DRI2: found extension `DRI2_Throttle'
libEGL debug: the best driver is DRI2
[10:50:17.008] libwayland: disconnect from client 0x9197f60
wl_drm@11: error 2: invalid name
[10:50:17.009] weston-desktop-shell died, giving up.

edit: log for the curious.
edit2: users of ati or nvidia cards who experience this should track this bug: https://bugs.freedesktop.org/show_bug.cgi?id=52267

Last edited by cryptix (2012-07-26 12:31:12)

Offline

#117 2012-11-01 09:37:13

zAo
Member
Registered: 2012-11-01
Posts: 26

Re: Wayland on Arch Linux?

On a fresh system, without X, but with the following, it ran fine on radeon. Both on X or standalone wayland. With a cursor.
* wayland-git 20121023-1
* weston-git
* cairo-gl-git
* glu
* libxcursor
* libxkbcommon-git
* mesa-full-wayland
* mtdev pixman
* poppler-glib

Did anyone build WebKitGTK+ for wayland? I'm really looking forward to try a browser on Wayland.

Offline

#118 2012-11-01 16:14:12

taylorchu
Member
Registered: 2010-08-09
Posts: 405

Re: Wayland on Arch Linux?

does any dev want to open another repo called [wayland-unstable]?
i am too lazy to compile mesa, gtk, qt, wayland... it simply takes a long time...


"After you do enough distro research, you will choose Arch."

Offline

#119 2012-11-01 16:23:03

Giselher
Member
From: Austria
Registered: 2010-02-02
Posts: 150
Website

Re: Wayland on Arch Linux?

taylorchu wrote:

does any dev want to open another repo called [wayland-unstable]?
i am too lazy to compile mesa, gtk, qt, wayland... it simply takes a long time...

If you have multiple cores then just add -j3 or -j5 to MAKEFLAGS in your makepkg.conf. This speeds up compiling stuff.

Offline

#120 2012-11-09 11:33:59

zAo
Member
Registered: 2012-11-01
Posts: 26

Re: Wayland on Arch Linux?

Anyone working on an AUR for the new xwayland?

Offline

#121 2012-11-09 14:56:41

karol
Archivist
Registered: 2009-05-06
Posts: 25,430

Re: Wayland on Arch Linux?

zAo wrote:

Anyone working on an AUR for the new xwayland?

What do you mean by 'new'? wayland-git should be always up to date https://aur.archlinux.org/packages/wayland-git/

Offline

#122 2012-11-10 23:21:14

adirat
Member
Registered: 2012-11-03
Posts: 27

Re: Wayland on Arch Linux?

karol wrote:
zAo wrote:

Anyone working on an AUR for the new xwayland?

What do you mean by 'new'? wayland-git should be always up to date https://aur.archlinux.org/packages/wayland-git/

XWayland is a branch from xserver, it contains patches needed to make xserver act as a wayland client.
Between Wayland 0.95 and 1.0 the API was broken and a few days ago a series of patches was proposed to make XWayland work with the new api.

More details here http://www.phoronix.com/scan.php?page=n … px=MTIyMzE

Offline

#123 2012-11-18 21:47:08

blackout23
Member
Registered: 2011-11-16
Posts: 780

Re: Wayland on Arch Linux?

So would it be possible to run a 3D game through Weston in Fullscreen at this stage? Of course with the nouveau driver you won't get much 3D performance anyway but I'd like to bench it against nouveau with raw X server or some compositors like Mutter, KWin, XFWM4, xcompmgr.

Offline

#124 2012-11-18 21:51:57

Giselher
Member
From: Austria
Registered: 2010-02-02
Posts: 150
Website

Re: Wayland on Arch Linux?

blackout23 wrote:

So would it be possible to run a 3D game through Weston in Fullscreen at this stage? Of course with the nouveau driver you won't get much 3D performance anyway but I'd like to bench it against nouveau with raw X server or some compositors like Mutter, KWin, XFWM4, xcompmgr.

Yes it is possible, but you first have to find a game that uses EGL to create a GL context.

Offline

#125 2012-11-19 00:28:30

ArcRaven
Member
From: Germany
Registered: 2012-11-19
Posts: 2
Website

Re: Wayland on Arch Linux?

Hey Guys,

I am currently working on XWayland, maybe I get it compiled till tomorrow. smile

cheers,

Michi

Offline

Board footer

Powered by FluxBB