You are not logged in.

#1 2005-09-12 16:49:34

vacant
Member
From: downstairs
Registered: 2004-11-05
Posts: 797

Kernel 2.4 mouse and sound

A quick one I hope. I copied my Arch Linux partition (2.6.13 kernel) onto my daughter's PC. She has a Kyro II video card and the powerVR drivers only work with a 2.4 kernel, so after getting everything working I'm just left with a couple of lines I put in rc.local because the mouse didn't work and she had no sound:

mknod /dev/psaux c 10 1
chmod a+rw /dev/sound/dsp

All works just fine but there's probably a better place to set these up, anyone know? devfs or something?

TIA
Paul

Offline

#2 2005-09-12 16:56:38

Dusty
Schwag Merchant
From: Medicine Hat, Alberta, Canada
Registered: 2004-01-18
Posts: 5,986
Website

Re: Kernel 2.4 mouse and sound

maybe you should use /dev/input/mice in your xorg.conf instead of /dev/psaux. Also, possible /dev/misc/psaux exists on her system? Finally, the 'better way' to create the device, if that is necessary is to use some sort of udev rule.

As for the second one, add the user to group 'audio' instead. taht group already has rw permissions on /dev/sound/dsp

Dusty

Offline

#3 2005-09-12 18:33:50

vacant
Member
From: downstairs
Registered: 2004-11-05
Posts: 797

Re: Kernel 2.4 mouse and sound

/dev/input/mice is 13 63 (unified mouse according to the docs)

Ah, there it is /dev/misc/psaux! Thanks.

/dev/sound/dsp has owner=root and group=root and she's in the audio group anyway as she had been set up on my PC.

I wonder if I have to reinstate "devfs=nomount" in /boot/grub/menu.lst to force udev on an Arch 2.4 kernel? I compiled my own 2.6 so I didn't need that option. I'll probably complie her a 2.4 in the next few days.

Offline

#4 2005-09-12 22:52:52

brain0
Developer
From: Aachen - Germany
Registered: 2005-01-03
Posts: 1,382

Re: Kernel 2.4 mouse and sound

Dusty wrote:

Finally, the 'better way' to create the device, if that is necessary is to use some sort of udev rule.

So you are suggesting that he uses udev with Linux 2.4. I think I'll just remind you that udev requires /sys.

Offline

Board footer

Powered by FluxBB