You are not logged in.

#1 2012-07-05 16:29:59

I am Gianluca
Member
From: London, UK
Registered: 2011-05-22
Posts: 195

CDM bug with new pam authentification login file

I simply replace the /etc/pam.d/login file with the new /etc/pam.d/login.pacnew but I've encountered a login problem.
My current login file is as reported:

#%PAM-1.0

auth       required     pam_securetty.so
auth       requisite    pam_nologin.so
auth       include      system-local-login
account    include      system-local-login
session    include      system-local-login

I use CDM (AUR) as login manager. After having typed my username and password, and having pressed enter for select to start XFCE as DM, I return to the login screen. If I repeat the login a second or third time happen the same.
The only way to access the DM seem to be selecting 'Console' in CDM and manually type the command:

$ startxfce4

It isn't a big problem, but a bit annoying. Would I restore some lines in the login file or it is a bug of CDM?
CDM seems to be not maintained since a while, the website is down and is available only the GitHub page.

The command that I use in CDM to start XFCE is:

# List all WM binary names
wmbinlist=(startxfce4)

I suppose it's not the cause of the problem.

Thank you for your time,

Gianluca


Laptop: Acer Aspire S3 | Linux Mint Cinnamon 64-bit

Offline

#2 2012-07-05 23:18:02

bashnev
Member
Registered: 2012-06-11
Posts: 19

Re: CDM bug with new pam authentification login file

I have the same problem. I use CDM to choose between XFCE and WMFS. Neither option works and I just get returned to the login. If I choose the console option and use

 xinit 

or

 startxfce4 --with-ck-launch 

then everything works as normal.


Workaround
I found if I log in from tty2 (Crtl-Alt-F2) then everything works as before but starts up slower.

I believe the problem is connected to the updated util-linux package and consolekit. The issue reported here says something about ttys being "mixed up". Sounds connected.

I also found that if I added

 sleep 20 

to the end of /usr/bin/cdm  then XFCE would start up but once the sleep timed out XFCE would get closed and I would be back at the login console. Hopefully that helps someone more knowledgeable work out whats going on.

Offline

#3 2012-07-05 23:35:29

Nepherte
Member
From: Belgium
Registered: 2008-09-09
Posts: 427
Website

Re: CDM bug with new pam authentification login file

It is definitely related to consolekit.

Launching my session fails with

exec ck-launch-session xmonad

Launching my session works with

exec xmonad

Offline

#4 2012-07-08 19:10:15

Nepherte
Member
From: Belgium
Registered: 2008-09-09
Posts: 427
Website

Re: CDM bug with new pam authentification login file

I found a way to get things back to work, thanks to this thread: https://bbs.archlinux.org/viewtopic.php?id=144569.

Change the following line in /usr/bin/cdm from

nohup startx $wm_bin -- ${serverargs} &> /dev/null

to

setsid startx $wm_bin -- ${serverargs} &> /dev/null

If you have loginshell enabled, change that corresponding line instead. FYI, setsid is part of util-linux.

Offline

#5 2012-07-09 11:24:00

bashnev
Member
Registered: 2012-06-11
Posts: 19

Re: CDM bug with new pam authentification login file

Works for me! Thanks Nepherte smile

Offline

#6 2012-07-09 13:24:30

I am Gianluca
Member
From: London, UK
Registered: 2011-05-22
Posts: 195

Re: CDM bug with new pam authentification login file

Works in my machine too. Thanks Nepherte smile


Laptop: Acer Aspire S3 | Linux Mint Cinnamon 64-bit

Offline

#7 2012-07-16 19:56:13

Teyras
Member
Registered: 2010-07-14
Posts: 40

Re: CDM bug with new pam authentification login file

This should definitely be fixed in CDM itself...

Offline

#8 2012-07-31 19:54:38

ElkMonster
Member
Registered: 2008-11-24
Posts: 27

Re: CDM bug with new pam authentification login file

The setsid fix doesn't work for me.

Offline

Board footer

Powered by FluxBB