You are not logged in.

#1 2012-07-14 03:55:16

bergersau
Member
Registered: 2012-01-19
Posts: 48

[SOLVED] makepkg fails when building libdivecomputer-git from AUR.

I'm not sure where to start debugging this failure as I'm a newb when it comes to compiling packages.
Can anyone point me in the right direction?

[dan@arch libdivecomputer-git]$ makepkg -s PKGBUILD 
==> Determining latest git revision...
  -> Version found: 20120714
==> Making package: libdivecomputer-git 20120714-1 (Sat Jul 14 13:43:22 EST 2012)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving Sources...
==> Extracting Sources...
==> Starting build()...
==> Connecting to GIT server....
Cloning into 'libdivecomputer'...
remote: Counting objects: 3995, done.
remote: Compressing objects: 100% (1563/1563), done.
remote: Total 3995 (delta 3240), reused 2983 (delta 2429)
Receiving objects: 100% (3995/3995), 739.19 KiB | 59 KiB/s, done.
Resolving deltas: 100% (3240/3240), done.
==> GIT checkout done or server timeout
==> Starting make...
Cloning into '/home/dan/libdivecomputer-git/src/libdivecomputer-build'...
done.
libtoolize: putting auxiliary files in `.'.
libtoolize: copying file `./ltmain.sh'
libtoolize: putting macros in AC_CONFIG_MACRO_DIR, `m4'.
libtoolize: copying file `m4/libtool.m4'
libtoolize: copying file `m4/ltoptions.m4'
libtoolize: copying file `m4/ltsugar.m4'
libtoolize: copying file `m4/ltversion.m4'
libtoolize: copying file `m4/lt~obsolete.m4'
configure.ac:25: installing './config.guess'
configure.ac:25: installing './config.sub'
configure.ac:21: installing './install-sh'
configure.ac:21: installing './missing'
examples/Makefile.am: installing './depcomp'
automake: warnings are treated as errors
/usr/share/automake-1.12/am/ltlibrary.am: warning: 'libdivecomputer.la': linking libtool libraries using a non-POSIX
/usr/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
src/Makefile.am:4:   while processing Libtool library 'libdivecomputer.la'
autoreconf: automake failed with exit status: 1
==> ERROR: A failure occurred in build().
    Aborting...

Last edited by bergersau (2012-07-18 03:57:09)

Offline

#2 2012-07-14 11:37:36

karol
Archivist
Registered: 2009-05-06
Posts: 25,427

Re: [SOLVED] makepkg fails when building libdivecomputer-git from AUR.

You may want to notify the maintainer by posting a comment on https://aur.archlinux.org/packages.php?ID=52648

Offline

#3 2012-07-14 11:40:21

hesse
Member
Registered: 2011-12-08
Posts: 88

Re: [SOLVED] makepkg fails when building libdivecomputer-git from AUR.

Do you have the whole base-devel group installed? pacman -Sy base-devel

Offline

#4 2012-07-15 06:17:01

bergersau
Member
Registered: 2012-01-19
Posts: 48

Re: [SOLVED] makepkg fails when building libdivecomputer-git from AUR.

@hesse -Yes base-devel is properly installed.

@karol - I'll try that and see where it takes me.

Thanks

Offline

#5 2012-07-16 03:28:40

bergersau
Member
Registered: 2012-01-19
Posts: 48

Re: [SOLVED] makepkg fails when building libdivecomputer-git from AUR.

The package maintainer is aware of this issue and is working to resolve it.

Marking thread solved.

Offline

Board footer

Powered by FluxBB