You are not logged in.

#1 2012-04-15 13:23:15

awayand
Member
Registered: 2009-09-25
Posts: 396

sogo compile problems

so I have tried to update sogo, it is in the aur (rc1), however I keep getting compile errors.

/usr/bin/ld: cannot find -lSOGo
../../SOPE/GDLContentStore/obj//libGDLContentStore.so: file not recognized: File format not recognized
collect2: error: ld returned 1 exit status
make[3]: *** [Appointments.SOGo/./Appointments] Error 1
make[2]: *** [Appointments.all.wobundle.variables] Error 2
make[1]: *** [internal-all] Error 2
make: *** [internal-all] Error 2
==> ERROR: A failure occurred in build().

I am completely stumped, any help appreciated.

Offline

#2 2012-07-16 21:38:35

kwirkie
Member
Registered: 2010-01-09
Posts: 15

Re: sogo compile problems

I've been using sogo for some time, but just tried to rebuild (rc4) post the glibc update and I'm getting the following errors:

Making all for library libGDLContentStore...
 Linking library libGDLContentStore ...
/usr/bin/ld: cannot find -lGDLAccess
/usr/bin/ld: cannot find -lNGExtensions
/usr/bin/ld: cannot find -lEOControl
/usr/bin/ld: cannot find -lDOM
/usr/bin/ld: cannot find -lSaxObjC
collect2: error: ld returned 1 exit status
make[4]: *** [obj/libGDLContentStore.so.4.9.0] Error 1
make[3]: *** [internal-library-all_] Error 2
make[2]: *** [libGDLContentStore.all.library.variables] Error 2
make[1]: *** [internal-all] Error 2
make: *** [internal-all] Error 2

I'm also stumped sad

Offline

#3 2012-07-16 22:23:30

kwirkie
Member
Registered: 2010-01-09
Posts: 15

Re: sogo compile problems

Seems to be an issue with the "lib" folders reshuffle with glibc 2.6.0-2, as sope/sogo are putting libs in "/usr/lib64" rather than "/usr/lib". First rebuild sope, then sogo with the following patches (2.0.0rc4) to "configure"
sope: http://pastebin.com/LsjEhfhe
sogo: http://pastebin.com/xP73uPg5

I've commented on the AUR for anyone else who comes across it.

I've now got sogo 2.0.0rc4 running with no issues smile

Offline

#4 2013-11-19 03:24:18

jimbeam
Member
From: philly
Registered: 2004-02-25
Posts: 16

Re: sogo compile problems

The latest version of Sogo is out, v2.1.0.  I tried putting this into the AUR comments, but can't login there.  Odd.

SOPE has dependencies not in the pkbuild, BTW, for gnustep-base and icu.

new md5s:

01DC8172DD26E91EBCE6EE1887617942  SOPE-2.1.0.tar.gz
145813F897B52C45B4AFB6811BE6EEBC  SOGo-2.1.0.tar.gz

Offline

#5 2013-11-19 03:28:36

karol
Archivist
Registered: 2009-05-06
Posts: 25,423

Re: sogo compile problems

jimbeam wrote:

The latest version of Sogo is out, v2.1.0.  I tried putting this into the AUR comments, but can't login there.  Odd.

You need to register a separate account for the AUR (and the wiki, the bugtracker ...). Your forum login and password won't work.

Offline

#6 2013-11-27 08:19:07

kwirkie
Member
Registered: 2010-01-09
Posts: 15

Re: sogo compile problems

jimbeam wrote:

The latest version of Sogo is out, v2.1.0.  I tried putting this into the AUR comments, but can't login there.  Odd.

SOPE has dependencies not in the pkbuild, BTW, for gnustep-base and icu.

new md5s:

01DC8172DD26E91EBCE6EE1887617942  SOPE-2.1.0.tar.gz
145813F897B52C45B4AFB6811BE6EEBC  SOGo-2.1.0.tar.gz

I've now updated the packages on AUR to v2.1.1a. Unfortunately the Mailer element of the web interface is still not functioning. If anyone's got any ideas on how to fix this, that would be great. Appears to be caused by the difference in the version of gnustep compared to what upstream support.

Also, icu and gunstep-make are dependencies of gnustep-base, so don't also need to be explicitly added as dependencies of the sope/sogo packages as well.

Offline

#7 2013-11-27 08:23:14

jasonwryan
Forum & Wiki Admin
From: .nz
Registered: 2009-05-09
Posts: 18,330
Website

Re: sogo compile problems

Moving to AUR Issues...


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Online

#8 2013-11-30 12:32:12

kwirkie
Member
Registered: 2010-01-09
Posts: 15

Re: sogo compile problems

Package update on AUR and now Mailer element is working.

Offline

Board footer

Powered by FluxBB