You are not logged in.

#1 2012-06-17 15:11:37

sliposk
Member
Registered: 2010-08-19
Posts: 45

Solved Nvidia 304.37-1 Problems 6 Series Using XBMC,Assaultcube,OpenGL

Ever since I updated to 302.17 . The previous driver 295.53 was working fine .  Problems Using XBMC , Wine , Assaultcube or anything with uses Open GL .  The two machines that are affected have the same hardware ( Nvidia 6200 pci) . Let me know if any of you are having similar issues .  Thanks .

Last edited by sliposk (2012-10-31 16:59:44)

Offline

#2 2012-06-17 18:30:50

dimitrov
Member
From: Sofia, Bulgaria
Registered: 2012-01-23
Posts: 6

Re: Solved Nvidia 304.37-1 Problems 6 Series Using XBMC,Assaultcube,OpenGL

You never said what issues you have, so I will blindly send you to this topic.

Offline

#3 2012-06-17 19:17:17

sliposk
Member
Registered: 2010-08-19
Posts: 45

Re: Solved Nvidia 304.37-1 Problems 6 Series Using XBMC,Assaultcube,OpenGL

All problems with Open GL programs working slowly or not at all on 6 and 7 series cards , have been solved by installing 295.59 . Looks like a nvidia bug to me .

Offline

#4 2012-06-17 19:43:39

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: Solved Nvidia 304.37-1 Problems 6 Series Using XBMC,Assaultcube,OpenGL

sliposk wrote:

All problems with Open GL programs working slowly or not at all on 6 and 7 series cards , have been solved by installing 295.59 . Looks like a nvidia bug to me .

so reported it.

http://www.nvnews.net/vbulletin/forumdisplay.php?f=14


Give what you have. To someone, it may be better than you dare to think.
Blog

Offline

#5 2012-06-18 15:10:09

sliposk
Member
Registered: 2010-08-19
Posts: 45

Re: Solved Nvidia 304.37-1 Problems 6 Series Using XBMC,Assaultcube,OpenGL

wonder wrote:
sliposk wrote:

All problems with Open GL programs working slowly or not at all on 6 and 7 series cards , have been solved by installing 295.59 . Looks like a nvidia bug to me .

so reported it.

http://www.nvnews.net/vbulletin/forumdisplay.php?f=14

http://www.nvnews.net/vbulletin/showthr … ost2564988

Offline

#6 2012-06-19 12:12:49

syms
Member
Registered: 2008-12-25
Posts: 292

Re: Solved Nvidia 304.37-1 Problems 6 Series Using XBMC,Assaultcube,OpenGL

I downgraded nvidia, nvidia-utils and opencl-nvidia and the games work fine again, but kwin starts to crash sometimes. It crashes compositing.

Offline

#7 2012-06-23 12:46:10

ronnylov
Member
Registered: 2010-12-21
Posts: 55

Re: Solved Nvidia 304.37-1 Problems 6 Series Using XBMC,Assaultcube,OpenGL

I have the same (or maybe a simlar) problem with my 8400GS PCI card.
xbmc-pvr-git AUR package compiled and installed OK but xorg crached at boot into xbmc.
Downgraded to nvidia and nvidia-utils 295.53 and xbmc-pvr-git works again.

Offline

#8 2012-06-30 13:33:04

Dehir
Member
From: Finland
Registered: 2009-11-08
Posts: 25

Re: Solved Nvidia 304.37-1 Problems 6 Series Using XBMC,Assaultcube,OpenGL

Im facing also slowdowns/hangs with my en460gtx with 302.17 earlier  295.59-1 wprks fine. Using wine mainly  so its not related only to 6xxx 7xxx series but also fermi are buggy i guess.

Last edited by Dehir (2012-06-30 13:33:37)

Offline

#9 2012-06-30 19:18:37

finale
Member
Registered: 2012-01-16
Posts: 18

Re: Solved Nvidia 304.37-1 Problems 6 Series Using XBMC,Assaultcube,OpenGL

I had the same problem. After finding this I was able to fix it: http://www.nvnews.net/vbulletin/showthr … f&t=176815

This may work for you too:

1. Use the nvidia-settings GUI to uncheck both "Sync to VBlank" values under "OpenGL Settings" and "X Server XVideo Settings."
("SyncToVBlank" and "XVideoTextureSyncToVBlank" will be set to to 0 in ~/.nvidia-settings-rc)

2. Have this command run right after Xorg is started, before any other programs such as your window manager start:

nvidia-settings --load-config-only

You can put it in your desktop environment's autostart or into one of the Xorg scripts that may be run; KDM and GDM source ~/.xprofile.

Last edited by finale (2012-06-30 20:56:56)

Offline

#10 2012-07-22 10:22:54

Kinux
Member
Registered: 2010-06-05
Posts: 42

Re: Solved Nvidia 304.37-1 Problems 6 Series Using XBMC,Assaultcube,OpenGL

I have the same problems with my systems running on GeForce 6200 cards. The first time I upgraded to Nvidia 302.17 my system running with Compiz broke and couldn't see anything on screen.

Downgrading to Nvidia 295.59 fixed my problem. Glxgears shows 2.4 FPS on Nvidia 302 and 973 FPS with Nvidia 295 on another system that does not use Compiz. This one has no problems as long as not using anything with Open GL.

Today I updated my system and the Kernel has been updated to Linux 3.4.6. This kernel breaks the Nvidia 295 and gives "Failed to load module "nvidia" (module-specific error, 0)" in Xorg.0.log.

Now, I downgraded Kernel to 3.4.5 to make it work again.

I am searching now for some advice. What should I do with my systems? Should I also abandon Compiz?
I have 4 systems with GeForce 6200 graphics cards in their AGP slot, having no way changing these cards as AGP is no more an option with newer cards.

Offline

#11 2012-07-22 22:23:17

sliposk
Member
Registered: 2010-08-19
Posts: 45

Re: Solved Nvidia 304.37-1 Problems 6 Series Using XBMC,Assaultcube,OpenGL

This is the only work around at the moment ... Fully update your system , then check out ......nvidia-173xx 173.14.35-3  , in the Aur .   It works on 3 machines Running 6200 Pci cards at this time . Big Thank You  to (natrio) .

Offline

#12 2012-07-23 08:54:52

Kinux
Member
Registered: 2010-06-05
Posts: 42

Re: Solved Nvidia 304.37-1 Problems 6 Series Using XBMC,Assaultcube,OpenGL

Thanks for reply.

I didn't know the nvidia-173xx works with GeForce 6 GPUs.
Everywhere I checked says this driver is for Legacy cards with GPUs up to GeForce 5. Can you please confirm that it works with GeForce 6200 ?

Even Nvidia site proposes the version 295.59 for this card as the latest Certified driver.
I think also there is something in Linux 3.4.6 that prevents the certified version to work correctly, so that we could keep the official driver until the next certified release.

OTOH, I wonder how the Nvidia 302.17 is current in Arch Repos as Nvidia does not propose it on their site !

Offline

#13 2012-07-23 09:36:32

sliposk
Member
Registered: 2010-08-19
Posts: 45

Re: Solved Nvidia 304.37-1 Problems 6 Series Using XBMC,Assaultcube,OpenGL

Read .. http://www.nvidia.com/object/linux-disp … river.html   Get it here ....  http://aur.archlinux.org/packages.php?ID=56776

Last edited by sliposk (2012-07-23 09:37:37)

Offline

#14 2012-07-23 10:10:30

Gusar
Member
Registered: 2009-08-25
Posts: 3,398

Re: Solved Nvidia 304.37-1 Problems 6 Series Using XBMC,Assaultcube,OpenGL

295.59 is the "long-lived branch", while 302.17 is the mainline driver. Then there's also 304.22 beta. Even though 302.17 is mainline and Arch packages it, I wouldn't recommend it. Go either with 295.59 or 304.22

173xx is indeed for Geforce 5. Though it seems it works for all cards that were out at the time it was first released.

Last edited by Gusar (2012-07-23 10:12:40)

Offline

#15 2012-07-24 13:11:04

Kinux
Member
Registered: 2010-06-05
Posts: 42

Re: Solved Nvidia 304.37-1 Problems 6 Series Using XBMC,Assaultcube,OpenGL

@Sliposk, Thanks a lot for the links. Indeed via these links Nvidia says the 173.14.35 works also with GeForce 6200.

@Gusar, I think I'll follow your advice for now. I'll stick to Linux-3.4.5 and wait until the Nvidia 304.22 hits the normal repos to test it. If it didn't work, then I will have to compile and test the 173xx one.

Any Idea why the Nvidia 173.14.35 driver is not in normal repositories as it seems to be also an official certified driver from Nvidia?
Seems it's getting harder and harder having a consistent stable driver without being left out of a rolling release distro !

Offline

#16 2012-07-24 13:37:55

Gusar
Member
Registered: 2009-08-25
Posts: 3,398

Re: Solved Nvidia 304.37-1 Problems 6 Series Using XBMC,Assaultcube,OpenGL

Kinux wrote:

Any Idea why the Nvidia 173.14.35 driver is not in normal repositories as it seems to be also an official certified driver from Nvidia?

Because it often lags behind in it's support for latest X or kernels. Arch is rolling release as you've noted, and the devs don't want to hold back packaging the latest X just because of a legacy branch of a proprietary driver.

Offline

#17 2012-07-30 04:07:28

brando56894
Member
From: New Jersey, USA
Registered: 2008-08-03
Posts: 613
Website

Re: Solved Nvidia 304.37-1 Problems 6 Series Using XBMC,Assaultcube,OpenGL

I've been having this problem too for about the past week or so and it was really pissing me off. A lof of movements in XBMC would be noticeably slower on my Core i7 Quadcore with 12GB DDR3, and 8600GTS than it was on my Zotax Z-Box AD02 which has the AMD E-350 APU and 4GB of ram (it's also running OpenELEC to be fair).

I just found this thread over at the XBMC forums that says that Compositioning will cause tearing on Nvidia drivers and I've been experiencing horizontal tearing recently. The post is from 2011 and refers to Ubuntu and Compiz so I didn't know who relevant it was since I use the compositioning in KDE. Sure enough right after I disabled compositioning XBMC was back to full speed, I have yet to see if it still crashes and hard-locks everything though. Hopefully it doesn't....

Offline

#18 2012-08-07 11:00:06

Kinux
Member
Registered: 2010-06-05
Posts: 42

Re: Solved Nvidia 304.37-1 Problems 6 Series Using XBMC,Assaultcube,OpenGL

Update:

Today after seeing availability of new Nvidia drivers in normal repos, I updated my system to nvidia 304.32-1.

Unfortunately this one still has the same problem with OpenGL and Compiz with my GeForce 6200 cards.
I have temporary disabled Compiz to try going the other route and compile the Aur 173.14.35 version to see if it works.

I really enjoy using Compiz and this is why I noticed this problem and am trying to find a solution to this.
I have still no idea what they removed from 295.59 version that breaks this graphics card to this point.

Offline

#19 2012-08-07 12:49:09

Gusar
Member
Registered: 2009-08-25
Posts: 3,398

Re: Solved Nvidia 304.37-1 Problems 6 Series Using XBMC,Assaultcube,OpenGL

Kinux wrote:

I have still no idea what they removed from 295.59 version that breaks this graphics card to this point.

This is Arch. You know, rolling release and such. If you want to use the long-lived branch, it's now at 295.71 and contains the security fix.

Offline

#20 2012-08-08 13:30:06

Kinux
Member
Registered: 2010-06-05
Posts: 42

Re: Solved Nvidia 304.37-1 Problems 6 Series Using XBMC,Assaultcube,OpenGL

Update 2 :

As suggested previously, I downloaded the PKGBUILD of nvidia-173xx and nvidia-173xx-utils and compiled them. [makepkg -s]
I had to put a comment sign in the nvidia-173xx file where it checked for nvidia-173xx-utils for dependency to make it compile as I couldn't install the later first.

The compiling also downloaded the linux-headers 3.4.7-1 file as it is my actual kernel. I guess with the next kernel update the driver will fail to start and I have to recompile the drivers again. (I would appreciate a confirmation on this)

After both packages where made, I removed the old driver with "pacman -Rdd nvidia nvidia-utils", as -R showed a lot of other programs as dependency.
Then installed my compiled packages and after a reboot I was back again to my beloved Compiz desktop !

Checking the "glxgears" showed a surprising 1237.484 FPS compared to about 973 FPS with 295.59 drivers. (2.4 FPS with actual 304.32-1)
Am going to check all other programs to see if there is no hidden problems. I hope this goes well and Nvidia do not abandon supporting its old cards.

Oh, great thanks to Natrio for maintaining this driver in AUR.

Offline

#21 2012-08-15 16:57:42

sliposk
Member
Registered: 2010-08-19
Posts: 45

Re: Solved Nvidia 304.37-1 Problems 6 Series Using XBMC,Assaultcube,OpenGL

The same problem with 304.37-1 . I will keep using Nvidia-173xx for my 6200's from the Aur....  https://aur.archlinux.org/packages.php?ID=56776  Big Thank You To Natrio .

Offline

#22 2012-09-21 04:23:58

twarkie
Member
Registered: 2007-09-16
Posts: 24

Re: Solved Nvidia 304.37-1 Problems 6 Series Using XBMC,Assaultcube,OpenGL

I might have the same problem with my ION2 system. Even since I updated to 304.17, I'm not able to use XBMC because of too much stutter/lag. The log file is spammed with "CDVDPlayerAudio:: Discontinuity". Downgrading the driver completely removes the problem.

Anyone came up with a good solution for this problem?

Offline

#23 2012-10-31 16:59:02

sliposk
Member
Registered: 2010-08-19
Posts: 45

Re: Solved Nvidia 304.37-1 Problems 6 Series Using XBMC,Assaultcube,OpenGL

This issue has been solved by the new driver 304.60 , Thanks.

Offline

Board footer

Powered by FluxBB