You are not logged in.

#1 2012-07-23 03:28:07

seniorsassycat
Member
Registered: 2011-08-27
Posts: 76

How do you compensate for overscanning in linux?

The virtual screen area is larger than the actual size, and the edges of the screen are off the display. In windows I was  able to fix this using the overscan compensation in the nvidia control panel, but that option isn't there is linux.

Offline

#2 2012-07-23 05:58:43

PhotonX
Member
From: Munich
Registered: 2008-08-10
Posts: 430

Re: How do you compensate for overscanning in linux?

Hi,

which video card and video driver are you using? In my case by installing the proper driver the problem got solved automatically.


Desktop: http://www.sysprofile.de/id15562, Arch Linux    |    Notebook: Thinkpad X200 Tablet, Manjaro

The very worst thing you can do with free software is to download it, see that it doesn't work for some reason, leave it, and tell your friends that it doesn't work.  -  Tuomas Lukka

Offline

#3 2012-07-23 06:33:15

MisterAnderson
Member
Registered: 2011-09-04
Posts: 284

Re: How do you compensate for overscanning in linux?

Also are you using a TV or dedicated monitor? TV's seem to have problems with over-and-underscanning, but I've not heard of a monitor doing so.


D:

Offline

#4 2012-07-23 13:09:03

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 4,205

Re: How do you compensate for overscanning in linux?

I've seen the same thing happen on a laptop with nvidia card.
With the nouveau driver everything was automagically correct, with the nvidia driver it wasn't .
I looked into this then, and found nvidia driver seems to choose modelines that they think work, but may not be the best one for that resolution.

On a CRT a different modeline would solve this, but I found no way to override that setting on LCD screens.
(that laptop now uses the nouveau driver permanently)

http://us.download.nvidia.com/XFree86/L … index.html has info about all options you can use in an xorg config file .
Good luck.


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#5 2012-07-23 17:57:11

desaparecido
Member
From: Liège, Belgium
Registered: 2010-03-14
Posts: 137

Re: How do you compensate for overscanning in linux?

I use nvidia card with nouveau drivers in HDMI port and Samsung TV.  Before upgrade to latest 30x series drivers of nvidia the overscan option was there, now this option was disable sad and even I tried a lot I never has success to make works fine.  I tried with nouveau driver and was really easy, in my case I add this to my /usr/share/config/kdm/Xsetup file:

xrandr --output HDMI-1 --set underscan on &
xrandr --output HDMI-1 --set "underscan hborder" 40 --set "underscan vborder" 25

and now all is fine.  I needed test differents values to finally find the right for hborder and vborder, you can test from a console (konsole in my case).

my kwin works really fine, i can use kwin_GLES option and i'm happy big_smile..


KF5 & Plasma5 (git versions) - Awesome WM
ASUS Sabertooth 990FX - AMD FX8350 - ATI Radeon HD 7970
[testing] repo

Offline

#6 2012-07-24 00:10:09

seniorsassycat
Member
Registered: 2011-08-27
Posts: 76

Re: How do you compensate for overscanning in linux?

Sorry for the late response. This is a nvidia 670 with propitiatory drivers, open source drivers had more issues. 
I'm using a hdtv as a second monitor, for movies and such, the lcd monitor has no problems.
I'm using nvidia-settings to adjust the monitors, and it reports the monitor as DFP-1, but xrandr reports it as HDMI-0, both are able to adjust the resolutions.

xrandr --output HDMI-0 --set underscan on

fails with

X Error of failed request:  BadName (named color or font does not exist)
  Major opcode of failed request:  153 (RANDR)
  Minor opcode of failed request:  11 (RRQueryOutputProperty)
  Serial number of failed request:  43
  Current serial number in output stream:  43

Last edited by seniorsassycat (2012-07-24 00:19:02)

Offline

#7 2012-07-24 09:59:19

MisterAnderson
Member
Registered: 2011-09-04
Posts: 284

Re: How do you compensate for overscanning in linux?

What is the native resolution of the HDTV? I've found that on my 1080p screen that it will underscan automatically (from my windows computer, Radeon 6850) and I have to go to catalyst to turn underscanning compensation off, however when using 1366x768 it works perfectly (even looks good, better than a non-native res on a monitor). If you can survive a lower resolution you can try 1366x768, 1280x720 etc.


D:

Offline

#8 2012-10-11 04:28:15

anatolik
Developer
Registered: 2012-09-27
Posts: 385

Re: How do you compensate for overscanning in linux?

I have this overscan problem as well.

My configuration: main monitor DELL 1920x1200, second monitor - Panasonic Viera S1 TV connected via HDMI. Videocard - NVidia GeForce 210. I tried both nouveau and proprietary video drivers. And with both drivers my TV has overscan problem - some parts of the screen is outside of visible TV area.

I googled and found this helpful article http://b.wardje.eu/2012/08/nvidia-linux-overscan.html I followed it and found that for proprietary driver I have to run

$ nvidia-settings -a CurrentMetaMode="DFP-0: 1920x1200+0+0, DFP-1: 1920x1080+1920+0 { ViewPortOut=1820x1022+50+29 }"

This works for me and now I want to make this fix permanent. I want to put it under /etc/X11 and I guess I need to add

Option	"metamodes"	"DFP-0: 1920x1200+0+0, DFP-1: 1920x1080+1920+0 { ViewPortOut=1820x1022+50+29 }"

to 'Section "Device"'. But do not have such section for NVidia anywhere under /etc/X11/

$  ls -R /etc/X11/
/etc/X11/:
twm  xinit  xorg.conf.d

/etc/X11/twm:
system.twmrc

/etc/X11/xinit:
xinitrc  xinitrc.d  xserverrc

/etc/X11/xinit/xinitrc.d:
30-dbus  40-libcanberra-gtk-module  pulseaudio  xdg-user-dirs

/etc/X11/xorg.conf.d:
10-evdev.conf  10-quirks.conf


So my question how to add the "metamodes" to X11 configuration? Is there better way to fix the overscan issue?

Offline

#9 2012-10-11 06:25:45

moetunes
Member
From: A comfortable couch
Registered: 2010-10-09
Posts: 1,017

Re: How do you compensate for overscanning in linux?

anatolik wrote:

I have this overscan problem as well.

My configuration: main monitor DELL 1920x1200, second monitor - Panasonic Viera S1 TV connected via HDMI. Videocard - NVidia GeForce 210. I tried both nouveau and proprietary video drivers. And with both drivers my TV has overscan problem - some parts of the screen is outside of visible TV area.

I googled and found this helpful article http://b.wardje.eu/2012/08/nvidia-linux-overscan.html I followed it and found that for proprietary driver I have to run

$ nvidia-settings -a CurrentMetaMode="DFP-0: 1920x1200+0+0, DFP-1: 1920x1080+1920+0 { ViewPortOut=1820x1022+50+29 }"

This works for me and now I want to make this fix permanent. I want to put it under /etc/X11 and I guess I need to add

Option	"metamodes"	"DFP-0: 1920x1200+0+0, DFP-1: 1920x1080+1920+0 { ViewPortOut=1820x1022+50+29 }"

to 'Section "Device"'. But do not have such section for NVidia anywhere under /etc/X11/

$  ls -R /etc/X11/
/etc/X11/:
twm  xinit  xorg.conf.d

/etc/X11/twm:
system.twmrc

/etc/X11/xinit:
xinitrc  xinitrc.d  xserverrc

/etc/X11/xinit/xinitrc.d:
30-dbus  40-libcanberra-gtk-module  pulseaudio  xdg-user-dirs

/etc/X11/xorg.conf.d:
10-evdev.conf  10-quirks.conf


So my question how to add the "metamodes" to X11 configuration? Is there better way to fix the overscan issue?

Make a file named /etc/X11/xorg.conf.d/20-nvidia.conf and add the lines

Section "Device"
    Option	"metamodes"	"DFP-0: 1920x1200+0+0, DFP-1: 1920x1080+1920+0 { ViewPortOut=1820x1022+50+29 }"
EndSection

and restart X.
HTH


You're just jealous because the voices only talk to me.

Offline

#10 2012-10-12 05:21:11

anatolik
Developer
Registered: 2012-09-27
Posts: 385

Re: How do you compensate for overscanning in linux?

Make a file named /etc/X11/xorg.conf.d/20-nvidia.conf and add the lines

No, this does not work. X fails to start. Here is a part of Xorg.0.log

[    11.655] (==) Log file: "/var/log/Xorg.0.log", Time: Thu Oct 11 22:16:01 2012
[    11.680] (==) Using config directory: "/etc/X11/xorg.conf.d"
[    11.688] Parse error on line 3 of section Device in file /etc/X11/xorg.conf.d/20-nvidia.conf
        This section must have an Identifier line.
[    11.688] (EE) Problem parsing the config file
[    11.688] (EE) Error parsing the config file
[    11.688]
Fatal server error:
[    11.688] no screens found
[    11.688]

Offline

#11 2012-10-12 07:16:21

skunktrader
Member
From: Brisbane, Australia
Registered: 2010-02-14
Posts: 1,319

Re: How do you compensate for overscanning in linux?

anatolik wrote:

Make a file named /etc/X11/xorg.conf.d/20-nvidia.conf and add the lines

No, this does not work. X fails to start. Here is a part of Xorg.0.log

So try

Section "Device"
        Identifier "Default nvidia Device"
.
.
.

You might also need to add

        Driver "nvidia"

but try without first

Offline

#12 2012-10-12 11:46:16

drcouzelis
Member
From: Connecticut, USA
Registered: 2009-11-09
Posts: 3,437
Website

Re: How do you compensate for overscanning in linux?

desaparecido wrote:
xrandr --output HDMI-1 --set underscan on
xrandr --output HDMI-1 --set "underscan hborder" 40 --set "underscan vborder" 25

Thanks for the tip! Now I can finally see all of my computer output on my TV. smile

I only ended up needing to use the first line. Xrandr read the size of the overscan from the TV and automatically applied it.

Offline

#13 2012-10-12 18:05:05

johni
Member
Registered: 2012-02-03
Posts: 102

Re: How do you compensate for overscanning in linux?

Another, possibly simpler solution is some TV's offer a setting in their setup menu that will turn off the overscan for some HDMI ports.
My panasonic LCD TV allows me to set a port to "PC Mode".  When I configure an hdmi port in that mode, I get the full resolution with no overscan.

You should search your TV setup menu to see if you have such an option.

Offline

#14 2012-10-14 06:15:42

anatolik
Developer
Registered: 2012-09-27
Posts: 385

Re: How do you compensate for overscanning in linux?

johni wrote:

Another, possibly simpler solution is some TV's offer a setting in their setup menu that will turn off the overscan for some HDMI ports.
My panasonic LCD TV allows me to set a port to "PC Mode".  When I configure an hdmi port in that mode, I get the full resolution with no overscan.

You should search your TV setup menu to see if you have such an option.

D'oh, indeed my TV has such option. I spent several weeks of trying to fix this issue in linux just to discover that this is a problem with TV. I feel stupid sad

For the future readers: if you have PANASONIC VIERA S1 then overscan is enabled by default. To turn it off you need to go to "Menu > Picture > Advanced picture > HD size" and change this option to "Size 2". This will allow you watching movies over HDMI without any problems. And yeah, Panasonic company should hire UX designer.

Offline

#15 2014-04-09 20:56:03

Pednick
Member
Registered: 2014-04-09
Posts: 22

Re: How do you compensate for overscanning in linux?

Thank you very much, I'm with a TV that doesn't have the settings to fix overscan so it's very much appreciated, thank you again, I've waited so long for this. smile

desaparecido wrote:

I

xrandr --output HDMI-1 --set underscan on &
xrandr --output HDMI-1 --set "underscan hborder" 40 --set "underscan vborder" 25

and now all is fine.  I needed test differents values to finally find the right for hborder and vborder, you can test from a console (konsole in my case).

my kwin works really fine, i can use kwin_GLES option and i'm happy big_smile..

Last edited by Pednick (2014-04-09 21:07:06)


"An it harm none, do what thou wilt"

Offline

#16 2014-04-09 21:10:40

jasonwryan
Forum & Wiki Admin
From: .nz
Registered: 2009-05-09
Posts: 18,524
Website

Re: How do you compensate for overscanning in linux?

Please don't necrobump https://wiki.archlinux.org/index.php/Fo … Bumping.27 especially with an empty post.



Closing


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

Board footer

Powered by FluxBB