You are not logged in.

#1 2012-07-15 14:27:05

Raffo
Member
Registered: 2007-07-13
Posts: 37

Cannot upgrade libcanberra and pyqt

Hi guys,
I left my computer without doing updates for a while and when I tried to do

pacman -Syu --ignore glibc

what I get is:


looking for inter-conflicts...
error: failed to prepare transaction (could not satisfy dependencies)
:: libcanberra-pulse: requires libcanberra=0.28-4
:: pyqt: requires python-sip


I don't know how to fix this problem since it seems I cannot remove libcanberra. Can you help me or at least give me an hint for a procedure to solve this issue?
Thanks!


P.S. It has been a long time since I used archlinux and I'm starting to forget things, so please don't be mad at me if I'm missing something very stupid.

Offline

#2 2012-07-15 14:29:52

popso
Member
Registered: 2012-07-15
Posts: 16

Re: Cannot upgrade libcanberra and pyqt

Hi,
Maybe you didn't read the news ? http://www.archlinux.org/news/the-lib-d … a-symlink/

edit : Did you read this guide ? https://wiki.archlinux.org/index.php/De … iki:usrlib

Last edited by popso (2012-07-15 14:34:35)

Offline

#3 2012-07-25 14:49:48

GogglesGuy
Member
From: Rocket City
Registered: 2005-03-29
Posts: 605
Website

Re: Cannot upgrade libcanberra and pyqt

popso wrote:

That doesn't exactly help...

Offline

#4 2012-07-25 14:57:46

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 5,557

Re: Cannot upgrade libcanberra and pyqt

Have you listed any hold packages in pacman.conf?

If not, try switching to a different pacman mirror, then using

pacman -Syyu --ignore glibc

Sakura:-
Mobo: ASUS P8Z77-V PRO // Processor: Intel Core i7-3770K 3.4GHz // GFX: nVidia GeForce GTX 970 Ti // RAM: 32GB (4x 8GB) Corsair DDR3 (@ 2133MHz) // Storage: 1x 3TB Seagate SATAII 5x 1TB Samsung SATAII, 2x 120GB Corsair SSD

Offline

#5 2012-07-28 08:29:36

flowie
Member
Registered: 2012-07-27
Posts: 9

Re: Cannot upgrade libcanberra and pyqt

I have the same problem with pyqt and python-sip. The post #145186 doesn't help for me and http://allanmcrae.com/ either. The curious thing is that python-sip isn't install. If installing python-sip, the outcome is this:

python-sip: /usr/include/python3.2mu/sip.h existiert im Dateisystem
python-sip: /usr/lib/python3.2/site-packages/sip.so existiert im Dateisystem
python-sip: /usr/lib/python3.2/site-packages/sipconfig.py existiert im Dateisystem
python-sip: /usr/lib/python3.2/site-packages/sipdistutils.py existiert im Dateisystem
Fehler sind aufgetreten, keine Pakete wurden aktualisiert.

Is there any other solution?

Offline

#6 2012-07-28 09:44:06

Terminator
Member
From: Belgium
Registered: 2012-05-07
Posts: 265

Re: Cannot upgrade libcanberra and pyqt

https://wiki.archlinux.org/index.php/Pa … stem.22.21

Btw, you can temporarily set your output to english by running export LC_MESSAGES=C.

Offline

#7 2012-07-28 10:15:13

flowie
Member
Registered: 2012-07-27
Posts: 9

Re: Cannot upgrade libcanberra and pyqt

Thanks Terminator !

The package is additional owned by sip:

(e.g.)

/usr/lib/python3.2/site-packages/sipdistutils.py is owned by sip 4.13.2-1

Offline

#8 2012-07-28 10:29:09

flowie
Member
Registered: 2012-07-27
Posts: 9

Re: Cannot upgrade libcanberra and pyqt

The "sip"-package seems for me a little bit weird:

The sip-package is a base package for python2-sip and python-sip (see here). Also this post connects to this problem. There is a bug-report but no further informations.

I'm absolutely confused what to do.

Last edited by flowie (2012-07-28 10:33:59)

Offline

#9 2012-07-28 11:02:17

Terminator
Member
From: Belgium
Registered: 2012-05-07
Posts: 265

Re: Cannot upgrade libcanberra and pyqt

It seems your system is not up to date. I can install sip, python-sip and pyqt at the same time.

Offline

#10 2012-07-28 12:22:15

flowie
Member
Registered: 2012-07-27
Posts: 9

Re: Cannot upgrade libcanberra and pyqt

You're absolutely right - it's the glibc-problem I'm confronted with. But wether "pacman -Syu --ignore glibc" nor the solution from Allan's blog worked for me. So I have to try another way, but don't know what way. I'm stucked at this python-sip/sip-what-so-ever-conflict.

Offline

#11 2012-07-28 14:16:10

Terminator
Member
From: Belgium
Registered: 2012-05-07
Posts: 265

Re: Cannot upgrade libcanberra and pyqt

Can't you temporarily uninstall sip/python-sip, upgrade and install it again?

Offline

#12 2012-07-28 14:56:30

flowie
Member
Registered: 2012-07-27
Posts: 9

Re: Cannot upgrade libcanberra and pyqt

This I exactly did - and everything worked well, so for me the problem is solved!

Many thanks for your kindly support, Terminator!

Offline

#13 2012-07-28 17:53:43

Terminator
Member
From: Belgium
Registered: 2012-05-07
Posts: 265

Re: Cannot upgrade libcanberra and pyqt

Don't forget to add [Solved] to the title of this topic.

Offline

#14 2012-07-28 18:01:07

flowie
Member
Registered: 2012-07-27
Posts: 9

Re: Cannot upgrade libcanberra and pyqt

Sorry, I can't do it because I haven't opened this thread.

Offline

#15 2012-08-01 21:49:24

wasperen
Member
Registered: 2012-02-03
Posts: 16

Re: Cannot upgrade libcanberra and pyqt

well... I am still having this issue. Funny thing is that pacman reports that it will ignore the upgrade of pyqt....

:: The following packages cannot be upgraded due to unresolvable dependencies:
      akonadi  ati-dri  attica  avogadro  binutils  boost-libs  cryptsetup  cups  cups-filters  dbus  dbus-core  dbus-glib  device-mapper  digikam  ffmpeg  firefox  gcc  gcc-libs  gegl  glew  glib2  gnutls  grep  gtk2  gtk3  icu  initscripts  intel-dri
      kdebase-runtime  kdebase-workspace  kdebindings-python2  kdeedu-kig  kdeedu-rocs  kdelibs  kdemultimedia-dragonplayer  kdemultimedia-ffmpegthumbs  kdemultimedia-juk  kdemultimedia-kioslave  kdemultimedia-kmix  kdemultimedia-kscd
      kdemultimedia-mplayerthumbs  kdeplasma-addons-applets-bball  kdeplasma-addons-applets-binary-clock  kdeplasma-addons-applets-blackboard  kdeplasma-addons-applets-bookmarks  kdeplasma-addons-applets-bubblemon  kdeplasma-addons-applets-calculator
      kdeplasma-addons-applets-charselect  kdeplasma-addons-applets-comic  kdeplasma-addons-applets-community  kdeplasma-addons-applets-dict  kdeplasma-addons-applets-eyes  kdeplasma-addons-applets-fifteenpuzzle  kdeplasma-addons-applets-filewatcher
      kdeplasma-addons-applets-frame  kdeplasma-addons-applets-fuzzy-clock  kdeplasma-addons-applets-icontasks  kdeplasma-addons-applets-incomingmsg  kdeplasma-addons-applets-kdeobservatory  kdeplasma-addons-applets-kimpanel
      kdeplasma-addons-applets-knowledgebase  kdeplasma-addons-applets-kolourpicker  kdeplasma-addons-applets-konqprofiles  kdeplasma-addons-applets-konsoleprofiles  kdeplasma-addons-applets-lancelot  kdeplasma-addons-applets-leavenote
      kdeplasma-addons-applets-life  kdeplasma-addons-applets-luna  kdeplasma-addons-applets-magnifique  kdeplasma-addons-applets-mediaplayer  kdeplasma-addons-applets-microblog  kdeplasma-addons-applets-news  kdeplasma-addons-applets-notes
      kdeplasma-addons-applets-nowplaying  kdeplasma-addons-applets-paste  kdeplasma-addons-applets-pastebin  kdeplasma-addons-applets-plasmaboard  kdeplasma-addons-applets-previewer  kdeplasma-addons-applets-qalculate
      kdeplasma-addons-applets-rememberthemilk  kdeplasma-addons-applets-rssnow  kdeplasma-addons-applets-showdashboard  kdeplasma-addons-applets-showdesktop  kdeplasma-addons-applets-social-news  kdeplasma-addons-applets-spellcheck
      kdeplasma-addons-applets-systemloadviewer  kdeplasma-addons-applets-timer  kdeplasma-addons-applets-unitconverter  kdeplasma-addons-applets-weather  kdeplasma-addons-applets-weatherstation  kdeplasma-addons-applets-webslice
      kdeplasma-addons-containments  kdeplasma-addons-libs  kdeplasma-addons-runners-audioplayercontrol  kdeplasma-addons-runners-browserhistory  kdeplasma-addons-runners-characters  kdeplasma-addons-runners-contacts  kdeplasma-addons-runners-converter
      kdeplasma-addons-runners-datetime  kdeplasma-addons-runners-events  kdeplasma-addons-runners-katesessions  kdeplasma-addons-runners-konquerorsessions  kdeplasma-addons-runners-konsolesessions  kdeplasma-addons-runners-kopete
      kdeplasma-addons-runners-mediawiki  kdeplasma-addons-runners-spellchecker  kdeplasma-addons-wallpapers-mandelbrot  kdeplasma-addons-wallpapers-marble  kdeplasma-addons-wallpapers-pattern  kdeplasma-addons-wallpapers-potd
      kdeplasma-addons-wallpapers-virus  kdeplasma-addons-wallpapers-weather  kipi-plugins  libcups  libegl  libgl  libimobiledevice  libkface  libkgeomap  libktorrent  libkvkontakte  libmp4v2  libpulse  libreoffice-base  libreoffice-calc
      libreoffice-common  libreoffice-draw  libreoffice-extension-nlpsolver  libreoffice-extension-pdfimport  libreoffice-extension-presentation-minimizer  libreoffice-extension-presenter-screen  libreoffice-extension-report-builder
      libreoffice-extension-scripting-python  libreoffice-extension-wiki-publisher  libreoffice-gnome  libreoffice-impress  libreoffice-kde4  libreoffice-math  libreoffice-sdk  libreoffice-sdk-doc  libreoffice-writer  libtool  linux  lvm2  mediastreamer
      mesa  mkinitcpio  mplayer  mythtv  opencv  pcre  poppler  poppler-glib  poppler-qt  pyqt  python-dbus  python2-dbus  python2-pyqt  qscintilla  qt  raptor  soprano  svga-dri  syslog-ng  systemd-tools  taglib  thunderbird  upower  wpa_supplicant
      xf86-video-ati  xf86-video-intel  xf86-video-nouveau  xine-lib  xorg-server

Do you want to skip the above packages for this upgrade? [y/N] y
looking for inter-conflicts...

But then complains about pyqt...

error: failed to prepare transaction (could not satisfy dependencies)
:: pyqt: requires python-sip

I though you just said you where going to ignore it?

Adding it to the --ignore list does not help either: --ignore pyqt, glibc

I tried to remove pyqt but that is required by kdebindings-python and python2-pyqt. python2-pyqt is required by kdebindings-python2, which is required by a whole load of kde packages:
:: kdeadmin-system-config-printer-kde: requires kdebindings-python2
:: kdegames-kajongg: requires kdebindings-python2
:: kdesdk-lokalize: requires kdebindings-python2
:: kdeutils-printer-applet: requires kdebindings-python2

I feel this is not the way to go...

Offline

#16 2012-08-01 21:59:26

SS4
Member
From: !Rochford, Essex
Registered: 2010-12-05
Posts: 699

Re: Cannot upgrade libcanberra and pyqt

Adding it to the --ignore list does not help either: --ignore pyqt, glibc

The ignore list is spaced so there shouldn't be a comma there.

@wasperen - what command are you telling pacman to do?


Rauchen verboten

Offline

#17 2012-08-01 23:45:55

wasperen
Member
Registered: 2012-02-03
Posts: 16

Re: Cannot upgrade libcanberra and pyqt

Hi.

From the pacman man page:

--ignore <package>
           Directs pacman to ignore upgrades of package even if there is one available. Multiple packages can be specified by separating them with a comma.

using space as delimiter does not work.

I am trying:

 pacman -Su --ignore glibc 

and

 pacman -Su --ignore pyqt,glibc 

then saying No to:

:: Replace libdrm-nouveau with extra/libdrm? [Y/n] n

and Yes to:

The following packages cannot be upgraded due to unresolvable dependencies:
      akonadi  ati-dri  attica  avogadro  binutils  boost-libs  cryptsetup  cups  cups-filters  dbus  dbus-core  dbus-glib  device-mapper  digikam  ffmpeg  firefox  gcc  gcc-libs  gegl  glew  glib2  gnutls  grep  gtk2  gtk3  icu  initscripts  intel-dri
      kdebase-runtime  kdebase-workspace  kdebindings-python2  kdeedu-kig  kdeedu-rocs  kdelibs  kdemultimedia-dragonplayer  kdemultimedia-ffmpegthumbs  kdemultimedia-juk  kdemultimedia-kioslave  kdemultimedia-kmix  kdemultimedia-kscd
      kdemultimedia-mplayerthumbs  kdeplasma-addons-applets-bball  kdeplasma-addons-applets-binary-clock  kdeplasma-addons-applets-blackboard  kdeplasma-addons-applets-bookmarks  kdeplasma-addons-applets-bubblemon  kdeplasma-addons-applets-calculator
      kdeplasma-addons-applets-charselect  kdeplasma-addons-applets-comic  kdeplasma-addons-applets-community  kdeplasma-addons-applets-dict  kdeplasma-addons-applets-eyes  kdeplasma-addons-applets-fifteenpuzzle  kdeplasma-addons-applets-filewatcher
      kdeplasma-addons-applets-frame  kdeplasma-addons-applets-fuzzy-clock  kdeplasma-addons-applets-icontasks  kdeplasma-addons-applets-incomingmsg  kdeplasma-addons-applets-kdeobservatory  kdeplasma-addons-applets-kimpanel
      kdeplasma-addons-applets-knowledgebase  kdeplasma-addons-applets-kolourpicker  kdeplasma-addons-applets-konqprofiles  kdeplasma-addons-applets-konsoleprofiles  kdeplasma-addons-applets-lancelot  kdeplasma-addons-applets-leavenote
      kdeplasma-addons-applets-life  kdeplasma-addons-applets-luna  kdeplasma-addons-applets-magnifique  kdeplasma-addons-applets-mediaplayer  kdeplasma-addons-applets-microblog  kdeplasma-addons-applets-news  kdeplasma-addons-applets-notes
      kdeplasma-addons-applets-nowplaying  kdeplasma-addons-applets-paste  kdeplasma-addons-applets-pastebin  kdeplasma-addons-applets-plasmaboard  kdeplasma-addons-applets-previewer  kdeplasma-addons-applets-qalculate
      kdeplasma-addons-applets-rememberthemilk  kdeplasma-addons-applets-rssnow  kdeplasma-addons-applets-showdashboard  kdeplasma-addons-applets-showdesktop  kdeplasma-addons-applets-social-news  kdeplasma-addons-applets-spellcheck
      kdeplasma-addons-applets-systemloadviewer  kdeplasma-addons-applets-timer  kdeplasma-addons-applets-unitconverter  kdeplasma-addons-applets-weather  kdeplasma-addons-applets-weatherstation  kdeplasma-addons-applets-webslice
      kdeplasma-addons-containments  kdeplasma-addons-libs  kdeplasma-addons-runners-audioplayercontrol  kdeplasma-addons-runners-browserhistory  kdeplasma-addons-runners-characters  kdeplasma-addons-runners-contacts  kdeplasma-addons-runners-converter
      kdeplasma-addons-runners-datetime  kdeplasma-addons-runners-events  kdeplasma-addons-runners-katesessions  kdeplasma-addons-runners-konquerorsessions  kdeplasma-addons-runners-konsolesessions  kdeplasma-addons-runners-kopete
      kdeplasma-addons-runners-mediawiki  kdeplasma-addons-runners-spellchecker  kdeplasma-addons-wallpapers-mandelbrot  kdeplasma-addons-wallpapers-marble  kdeplasma-addons-wallpapers-pattern  kdeplasma-addons-wallpapers-potd
      kdeplasma-addons-wallpapers-virus  kdeplasma-addons-wallpapers-weather  kipi-plugins  libcups  libegl  libgl  libimobiledevice  libkface  libkgeomap  libktorrent  libkvkontakte  libmp4v2  libpulse  libreoffice-base  libreoffice-calc
      libreoffice-common  libreoffice-draw  libreoffice-extension-nlpsolver  libreoffice-extension-pdfimport  libreoffice-extension-presentation-minimizer  libreoffice-extension-presenter-screen  libreoffice-extension-report-builder
      libreoffice-extension-scripting-python  libreoffice-extension-wiki-publisher  libreoffice-gnome  libreoffice-impress  libreoffice-kde4  libreoffice-math  libreoffice-sdk  libreoffice-sdk-doc  libreoffice-writer  libtool  linux  lvm2  mediastreamer
      mesa  mkinitcpio  mplayer  mythtv  opencv  pcre  poppler  poppler-glib  poppler-qt  pyqt  python-dbus  python2-dbus  python2-pyqt  qscintilla  qt  raptor  soprano  svga-dri  syslog-ng  systemd-tools  taglib  thunderbird  upower  wpa_supplicant
      xf86-video-ati  xf86-video-intel  xf86-video-nouveau  xine-lib  xorg-server

 Do you want to skip the above packages for this upgrade? [y/N] y 

Then I get:

looking for inter-conflicts...
error: failed to prepare transaction (could not satisfy dependencies)
:: pyqt: requires python-sip

Last edited by wasperen (2012-08-01 23:47:44)

Offline

#18 2012-08-02 00:03:56

wasperen
Member
Registered: 2012-02-03
Posts: 16

Re: Cannot upgrade libcanberra and pyqt

This is what happens with space delimiting the ignores:

sudo pacman -Su --ignore pyqt glibc
Password: 
:: Starting full system upgrade...
:: Replace libdrm-nouveau with extra/libdrm? [Y/n] n
warning: pyqt: ignoring package upgrade (4.9.1-2 => 4.9.4-2)
resolving dependencies...
looking for inter-conflicts...
error: failed to prepare transaction (could not satisfy dependencies)
:: pyqt: requires python-sip

Offline

#19 2012-08-02 00:06:31

wasperen
Member
Registered: 2012-02-03
Posts: 16

Re: Cannot upgrade libcanberra and pyqt

funny... I upgraded pyqt first:

sudo pacman -S pyqt
resolving dependencies...
looking for inter-conflicts...

Targets (2): pyqt-common-4.9.4-2  pyqt-4.9.4-2

Total Installed Size:   16.52 MiB
Net Upgrade Size:       -1.23 MiB

Proceed with installation? [Y/n] 
(2/2) checking package integrity                                                                                                                           [###############################################################################################] 100%
(2/2) loading package files                                                                                                                                [###############################################################################################] 100%
(2/2) checking for file conflicts                                                                                                                          [###############################################################################################] 100%
(2/2) checking available disk space                                                                                                                        [###############################################################################################] 100%
(1/2) installing pyqt-common                                                                                                                               [###############################################################################################] 100%
(2/2) upgrading pyqt                          

But then I get exactly the same issue when doing

pacman -Su --ignore glibc

Offline

#20 2012-08-02 00:11:21

wasperen
Member
Registered: 2012-02-03
Posts: 16

Re: Cannot upgrade libcanberra and pyqt

installing xf86-video-nouveau then removing libdrm-nouveau removes the Replace libdrm-nouveau with extra/libdrm? question, but still the pyqt issue remains...

Last edited by wasperen (2012-08-02 00:12:29)

Offline

#21 2012-08-04 14:59:05

mivaho
Member
Registered: 2011-05-04
Posts: 7

Re: Cannot upgrade libcanberra and pyqt

I had to do the install of xf86-video-nouveau and removal of libdrm-nouveau also and still got stuck with the pyqt python-sip message.

Then I tried:

pacman -Su --ignore glibc python-sip

and that worked for me.

But don't forget to copy the packages names  you are skipping, because if you haven't update for while you won't find them back and end up like me, reinstalling Arch for the first time since I installed it smile

You need them after the first update proces. I forgot to do that. It's been running without reinstall for several years now so I don't mind.  It's far less then in my Fedora/Opensuse days smile

Offline

#22 2012-08-04 21:19:26

wasperen
Member
Registered: 2012-02-03
Posts: 16

Re: Cannot upgrade libcanberra and pyqt

Thanks for the tip. The upgrade went through... but... when I now try to use pacman at all it gives me

pacman: /lib/libc.so.6: version `GLIBC_2.16' not found (required by /usr/lib/libcurl.so.4)

Seems like I am just minutes away from re-installing the whole box... sad

Offline

#23 2012-08-04 21:37:31

wasperen
Member
Registered: 2012-02-03
Posts: 16

Re: Cannot upgrade libcanberra and pyqt

Yep. This officially broke it. The box does not see it's network card anymore, does not boot into X and looks in a good mess... Oh well...

Offline

#24 2012-08-05 01:28:48

fsckd
Forum Moderator
Registered: 2009-06-15
Posts: 3,575

Re: Cannot upgrade libcanberra and pyqt

@wasperen: see the solutions in this thread: https://bbs.archlinux.org/viewtopic.php?id=146308


aur S & M :: forum rules :: Community Ethos
Resources for Women, POC, LGBT*, and allies

Offline

#25 2012-08-05 18:09:05

wasperen
Member
Registered: 2012-02-03
Posts: 16

Re: Cannot upgrade libcanberra and pyqt

Mwha... Seemed simpler just to re-install the box and keep my /home partition in place. Worked perfectly although I do miss the (now) classic arch installer.

Thanks for all advice, though.

Offline

Board footer

Powered by FluxBB