You are not logged in.

#1 2012-07-30 17:33:58

From: Northern Germany
Registered: 2012-07-29
Posts: 2

kdelibs3 doesn't build anymore

Hi there!

I tried to build the package "kdelibs3" from ABS on my x86_64 Arch-machine (+ testing repo), but it fails :

The build was done inside a clean chroot (created using pacstrap + arch-chroot + testing repo).
I think it's caused by a newer version of automake/autoconf, but I'm not an expert in this.

How to fix this?
Thanks in advance!

Alex :-)

Off topic: Before you write "Why do you try to build this old crap anyway?", I'm trying to rebuild kdemod3. And it's "kdelibs" build fails too -> same problem. :-(

EDIT: I installed another chroot, this time using the "Arch Rollback Machine - ARM". I've set the date to the 10th Feb. 2012.
Everything worked fine :
This was just for testing. Of course it has to work with current automake/-conf too.

EDIT2 : I downgraded automake and autoconf on my chroot (the current one), but the build fails too :-(
So I guess it's probably not caused by automake nor autoconf.
warning: downgrading package autoconf (2.69-1 => 2.68-2)
warning: downgrading package automake (1.12.2-1 => 1.11.3-1)
resolving dependencies...
looking for inter-conflicts...
Targets (2): autoconf-2.68-2  automake-1.11.3-1

EDIT 3 :
Filled a bug report :

Last edited by schreiberstein (2012-07-31 15:16:04)

Kde3 Ftw! :-)


Board footer

Powered by FluxBB