You are not logged in.

#1 2012-07-30 19:40:24

Marcus27
Member
From: Hamburgo
Registered: 2012-07-05
Posts: 11

Unknown directive in cupsd.conf

I just updated and got following message:

* check your config with cupsd -t
  and fix all Browsing related settings

I did check that:

# cupsd -t

Unknown directive BrowseOrder on line 22.
Unknown directive BrowseAllow on line 23.
Unknown directive DefaultAuthType on line 27.
/etc/cups/cupsd.conf is OK

22      BrowseOrder allow,deny
23      BrowseAllow all
27      DefaultAuthType Basic

But after having a look at http://www.cups.org/documentation.php/d … DIRECTIVES these lines seem to be okay.

Can somebody perhaps explain that to me?

Last edited by Marcus27 (2012-07-30 19:43:21)

Offline

#2 2012-07-30 19:55:57

toothandnail
Member
From: Oxfordshire, UK
Registered: 2012-05-05
Posts: 49

Re: Unknown directive in cupsd.conf

I'm getting the same errors. My printer is hung off a small server and shared by CUPS/Samba on the server. In the past, it was autodetected by CUPs, but this time I had to reconfigure it manually.

I've got avahi-daemon installed, but I'm not sure if there is any special configuration necessary for it. Searching hasn't done me much good so far....

smile Hope somebody can provide fuller information.

Paul.

Offline

#3 2012-07-30 21:10:57

Minsc
Member
Registered: 2012-07-16
Posts: 78

Re: Unknown directive in cupsd.conf

Looks like those options have disappeared since the update. If you check the latest documentation (1.6 instead of 1.5) the directives you listed have gone...

Offline

#4 2012-07-30 23:05:03

mrman
Member
Registered: 2010-02-05
Posts: 26

Re: Unknown directive in cupsd.conf

Minsc wrote:

Looks like those options have disappeared since the update. If you check the latest documentation (1.6 instead of 1.5) the directives you listed have gone...

DefaultAuthType Basic

is still listed in the latest documentation.

Offline

#5 2012-07-31 05:38:20

Marcus27
Member
From: Hamburgo
Registered: 2012-07-05
Posts: 11

Re: Unknown directive in cupsd.conf

Minsc wrote:

Looks like those options have disappeared since the update. If you check the latest documentation (1.6 instead of 1.5) the directives you listed have gone...

In man 5 cupsd.conf, too. Sorry, my fault...

But I still haven't found an answer. Were they replaced? Or can those lines be deleted?

Offline

#6 2012-07-31 08:08:23

Minsc
Member
Registered: 2012-07-16
Posts: 78

Re: Unknown directive in cupsd.conf

Not sure.. I presume the DefaultAuthType is failing because of the previous two directives. I haven't got time to setup cups and test for myself but I would just comment them out for now.

Offline

#7 2012-08-04 14:40:53

1LordAnubis
Member
Registered: 2008-10-10
Posts: 250
Website

Re: Unknown directive in cupsd.conf

The same thing here...
Have the printer on a cups server, and now its NO LONGER autodetected by cups on this machine....
However, if I goto the "Add Printer" area, it is listed under the Network Discovered Printers, but if I add it from there, and try to print something, I get the error message "Unable to locate printer .local"

The only way I've been able to get it to work is by adding the ipp address manually, e.g. ipp://192.168.1.121:631/printers/iP2600-series


Any society that would give up a little liberty to gain a little security will deserve neither and lose both.
-Benjamin Franklin
The reasonable man adapts himself to the world; the unreasonable one persists in trying to adapt the world to himself. Therefore all progress depends on the unreasonable man.
-George Bernard Shaw

Offline

#8 2012-08-05 12:22:39

bwat47
Member
Registered: 2009-10-07
Posts: 637

Re: Unknown directive in cupsd.conf

I'm getting this too. I merged the new cupsd.conf.pacnew and it removed the other two unknown directive errors, but I still get this one: "Unknown directive DefaultAuthType on line 25". Its set to "Basic" which is still shown as supported in the manpage...

Last edited by bwat47 (2012-08-05 12:27:02)

Offline

#9 2012-11-01 01:52:49

walterjwhite
Member
Registered: 2011-05-01
Posts: 207

Re: Unknown directive in cupsd.conf

Hi guys,

I had this same problem, I merged an existing config with a new one.  The problem for me was the Listen directive.  I had:

Listen 631

It needs to be:

Listen *:631

If that doesn't do it, try a new config, then make iterative changes.  Also, if you are running systemd, make sure avahi is running.

systemctl enable avahi-daemon.service
systemctl start avahi-daemon.service

Avahi is only needed though if you have cups listening on a port that other machines can get to.  With the default config, you won't get this error because it is listening locally.

Walter

Last edited by walterjwhite (2012-11-01 02:08:25)

Offline

Board footer

Powered by FluxBB