You are not logged in.

#1 2005-09-10 01:18:51

syamajala
Member
From: here, there, everywhere
Registered: 2005-01-25
Posts: 604
Website

Wireless woes!

This has been driving so fscking crazy. I have never had so many problems with wireless before in my short short life. What happens is i set everything, essid, wep key, channel, ... and i do dhcpcd ath0 (using madwifi) and it never gets an address. The logs just say dhcpcd timed out waiting for a valid dhcp server response. I have reset everything (wireless access point, restarted dhcp on the firewall, rebooted the client), but still get the same error. Wireless was working fine before, with 2.6.12-cko. I upgraded to 2.6.13 and patched the kernel with fbsplash, dynamic tick, and software suspend 2 patches and rebuilt madwifi. Now it doesn't seem to work. I have no idea whats wrong because wireless seems to work on my powerbook which i am typing this from right now. Also, I am using the initscripts package from testing.

Offline

#2 2005-09-11 23:30:05

jskier
Member
From: Minnesota, USA
Registered: 2003-07-30
Posts: 356
Website

Re: Wireless woes!

What version of madwifi are you using? Are you able to set a static IP?


--
JSkier

Offline

#3 2005-09-11 23:35:28

syamajala
Member
From: here, there, everywhere
Registered: 2005-01-25
Posts: 604
Website

Re: Wireless woes!

i built madwifi today. i haven't tried a static ip or anything. i'll try it tomorrow or something i am bored right now.

Offline

#4 2005-09-12 19:30:02

syamajala
Member
From: here, there, everywhere
Registered: 2005-01-25
Posts: 604
Website

Re: Wireless woes!

ok, i tried setting a static ip. It doesn't seem to work when i ping external addresses. When i ping internal address it says Destination host unreachable.

Offline

#5 2005-09-20 12:18:50

sven
Member
Registered: 2005-02-01
Posts: 311

Re: Wireless woes!

I have just the same problem - in my case it seems only to be wep-related somehow. Whenever I'l try to set wep key with iwconfig, I'll get an error about unknown operation. And dhcpcd fails always with that "timed out" message.

When there is no wep protection, everything is just fine. dhcpcd gives ip in an instant.

Offline

#6 2005-09-22 23:41:00

syamajala
Member
From: here, there, everywhere
Registered: 2005-01-25
Posts: 604
Website

Re: Wireless woes!

it just randomly started working for me. don't know what i did.

Offline

#7 2005-09-26 21:49:38

_alexmyself
Member
From: france
Registered: 2005-09-18
Posts: 89

Re: Wireless woes!

hello,
i've got this problem too : dhcpcd fail at boot whith ath0 wifi.
some others have problem with no ath0 interfaces.
there are two solutions, for two problems.
one answer a problem the second just turn around

1) in /etc/rc.d/network, in the ifdown() part :
comment that line :

#/bin/kill `cat /etc/dhcpc/dhcpcd-${1}.pid`

put this one just under to replace :

/usr/sbin/dhcpcd -k ${1}

it makes the dhcpcd quit cleanly, it said to server that don't need the ip longer.
go to /etc/rc.d/, and then : ./network start  until it run normaly.
from here it will run at next reboot (if network isn't properly started it won't)

if don't change anything :

2) still in /etc/rc.d/network but in ifup() part :
add the lines :

/usr/sbin/dhcpcd -k ${1}
/bin/sleep 2

just before the line :

/usr/sbin/dhcpcd $DHCPCD_ARGS ${1}

and don't try under 10 in your /etc/conf.d/dhcpcd (-t 30...)

this was the solution for me with ath0.
the problem is that two dhcpcd try run on ath0 at boot and the first still fail.
i don't know why but i know it makes very strange things.
oh, i forgot, i don't use the wireless script, just put ath0/dhcp in rc.conf, it means no security in wifi, no wep or others.
the essid is found by dhcpcd(certainly not itself, but when it start it goal).

if you have more than ath0 in dhcp it certainly make an error at boot, but work fine.

bye everyone....

Offline

Board footer

Powered by FluxBB