You are not logged in.

#1 2012-08-01 04:08:08

Smirking Turtle
Member
Registered: 2012-06-03
Posts: 5

[Solved] No text/fonts while using Steam

While preparing to install steam (installing wine & winetricks + fonts) everything seemed to go smoothly. Unfortunatley when starting steam for the first time after it's updates, I discovered there was no visible text. The window is still interactive, but there is no text and I have no Idea what to do. To make it worse this is my first time actualy using steam.

Here is a screenshot of the starting menu. I'm guessing this has probably been causes by me not have installing the correct fonts or any fonts at that? I have ran the command "winetricks allfonts" (for fonts), if that helps, but has anyone else had this problem or have any suggestions?

nEf7v.png

help would be much appreciated, thanks.

Last edited by Smirking Turtle (2012-08-01 17:09:10)

Offline

#2 2012-08-01 06:45:46

rLy
Member
From: Hungary
Registered: 2011-06-01
Posts: 7

Re: [Solved] No text/fonts while using Steam

Hi! There is a bugreport with solution at http://bugs.winehq.org/show_bug.cgi?id=31374

Offline

#3 2012-08-01 16:48:56

Smirking Turtle
Member
Registered: 2012-06-03
Posts: 5

Re: [Solved] No text/fonts while using Steam

rLy wrote:

Hi! There is a bugreport with solution at http://bugs.winehq.org/show_bug.cgi?id=31374

Thank you, I'll try it.

Offline

#4 2012-08-04 16:01:55

HalJordan
Member
Registered: 2010-11-17
Posts: 57

Re: [Solved] No text/fonts while using Steam

For the lazy, on your alias/start script for steam, at the end of the line that calls steam add -no-dwrite, so for mine it was ::

#!/bin/bash
export WINEPREFIX=$HOME/.steam
export WINEDEBUG=-all
nice -n 19 wine "C:\Program Files\Steam\Steam.exe" -no-dwrite

Offline

#5 2012-08-21 02:23:15

nadman10
Member
From: Erie, PA
Registered: 2005-10-15
Posts: 200

Re: [Solved] No text/fonts while using Steam

Same problem. Fixed me too. Thanks.

Offline

#6 2012-08-24 22:58:41

bobwya
Member
Registered: 2012-01-09
Posts: 36

Re: [Solved] No text/fonts while using Steam

Hi,

I know the thread is resolved however can I draw folks attention to:
WineHQ Steam Client AppDB

Where I mention that the recent dwrite.dll stubbing (>=Wine 1.5.10) is a current, known issue with Wine+Steam !!

Ahhhh, sometimes I don't why I bother maintaining the page... yikes

Bob

Offline

#7 2012-08-24 23:08:03

HalJordan
Member
Registered: 2010-11-17
Posts: 57

Re: [Solved] No text/fonts while using Steam

This came up before wine hit 1.5.10 and I didn't notice anything about dwrite.dll in the output. I just saw that no text was rendered.

Offline

Board footer

Powered by FluxBB